Subject: Re: [precis] (More) Belated WGLC Comments on draft-ietf-precis-saslprepbis-13

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Mon, 02 Mar 2015 09:21:25 -0700

On 2/27/15 2:35 PM, ⌘ Matt Miller wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA512
>
> My apologies for the tardiness of these comments.
>
> Overall, I think this document is ready for publication.  I agree with
> the comments that Ben Campbell sent earlier (and Peter's responses).
> My only outstanding concern:
>
> * [MINOR] - The reference to UNICODE in this document is to version
> 6.3, while precis-framework references version 7.0 and text in section
> 6.1 mentions version 7.0.  Is the difference intentional here, or a
> case of missing a reference update?  I'm guessing it's a missed
> reference ...

Hi Matt, thanks for the feedback.

We had some discussion months ago (IIRC occasioned by comments from John 
Klensin) about citing a particular version when necessary (e.g., 3.2 or 
6.3 or 7.0) but otherwise having a generic pointer to the Unicode 
Standard when we're talking about the technology in general, rather than 
a particular version.

Let me send a note to the RFC Editor about this and see what they might 
recommend.

Peter

-- 
Peter Saint-Andre
https://andyet.com/

---

From: John C Klensin <[email-masked]>
Date: Mon, 02 Mar 2015 14:20:29 -0500

--On Monday, March 02, 2015 09:21 -0700 Peter Saint-Andre - &yet
<[email-masked]> wrote:

>> * [MINOR] - The reference to UNICODE in this document is to
>> version 6.3, while precis-framework references version 7.0
>> and text in section 6.1 mentions version 7.0.  Is the
>> difference intentional here, or a case of missing a reference
>> update?  I'm guessing it's a missed reference ...
> 

In fairness to Peter and other PRECIS doc authors, this process
has dragged out for a rather long time, with Unicode evolving
from, IIR, 6.0 to 7.0 during that period.  To complicate things
further (and again IIR -- I don't have time to spend on this),
references to sections of 6.3 are meaningless because the core
spec wasn't reissued for 6.3 -- it was the 6.2 core spec plus
code point changes.

Section numbers do periodically change when moving from one
version to another, so Section N.M of 6.0 may not have the same
number (or, in a few cases, even the same structure within the
Section) in 7.0.   To make this more exciting, the final
formatted version of the 7.0 Core spec was not published until
December; at least in theory, section numbers could have changed
up to that time.

On the other hand, if any of the statements normatively
referenced by any PRECIS spec have actually changed
substantively, regardless of how they are phrased and the
numbered sections in which they appear, then we are in big
trouble that goes far beyond any discussions of just what should
be referenced.

> We had some discussion months ago (IIRC occasioned by comments
> from John Klensin) about citing a particular version when
> necessary (e.g., 3.2 or 6.3 or 7.0) but otherwise having a
> generic pointer to the Unicode Standard when we're talking
> about the technology in general, rather than a particular
> version.

Yes.  And the above, and the hope that the index to the Unicode
Standard is adequate, are the reasons for that.   All things
being equal, I'd prefer that all of the PRECIS specs reference
the same version of Unicode, but that is just to make things
more convenient for readers.

> Let me send a note to the RFC Editor about this and see what
> they might recommend.

Good plan.  Trying to tune it on this list is probably
sub-optimal and it is their job to spot things like this and
sort them out.  Obviously, feel free to share the above with
them and/or to pull me into the conversation if I can help.

best,
    john

---

From: Peter Saint-Andre - &yet <[email-masked]>
Date: Mon, 02 Mar 2015 14:53:08 -0700

> them and/or to pull me into the conversation if I can help.

I have heard back from the RFC Editor and they note that several recent 
RFCs use this as a citation:

    [UNICODE]  The Unicode Consortium, "The Unicode Standard",
               <http://www.unicode.org/versions/latest/>.

I think that works fine in most instances.

I do have a question about how to handle pointers to particular 
chapters, such as:

        using Unicode Default Case Folding as defined in Chapter 3
        of the Unicode Standard [UNICODE]

As John notes, chapter numbers might change. If we want to provide a 
pointer to a particular chapter, we could modify such text like so:

        using Unicode Default Case Folding as defined in the Unicode
        Standard [UNICODE] (at the time of this writing, the algorithm
        is specified in Chapter 3 of [UNICODE7.0])

However, I'm not sure if we really need to point to a particular chapter 
in a particular version.

Peter

---

From: "Martin J. Dürst" <[email-masked]>
Date: Tue, 03 Mar 2015 11:52:52 +0900

>>> about the technology in general, rather than a particular

This is of course exactly the right thing to do. W3C does the same, and 
it's even called out in the Character Model spec (see 
http://www.w3.org/TR/charmod/#C063).

> I think that works fine in most instances.

Yes indeed.

> However, I'm not sure if we really need to point to a particular chapter

Yes. If we do, I suggest two things:

- Make the section number more specific, if possible (in the case at 
hand, it would be section 3.13).

- Make the text shorter, if possible:
          using Unicode Default Case Folding as defined in the Unicode
          Standard [UNICODE] (e.g. Chapter 3.13 of [UNICODE7.0])

But in many cases, it is necessary to look at more than one chapter, so 
it may be better to not give just one exact pointer.

Regards,    Martin.

---

From: John C Klensin <[email-masked]>
Date: Mon, 02 Mar 2015 23:53:46 -0500

--On Monday, March 02, 2015 14:53 -0700 Peter Saint-Andre - &yet
<[email-masked]> wrote:

>...
> I have heard back from the RFC Editor and they note that
> several recent RFCs use this as a citation:
> 

The condition for its working fine is that we be confident that
whatever text we are referring to be stable, at least in
substance and to the extent to which we need it.  IIR, formal
stability rules apply to code tables, properties, and
relationships, not sections of text, so it is hard to be
confident about any very specific statements.  If one does not
have that confidence and does not have a high level of skill in
predicting the future, one is probably better off referencing a
version and making statements about likely stability, not using
"latest".

> I do have a question about how to handle pointers to
> particular chapters, such as:
> 
> As John notes, chapter numbers might change. If we want to
> provide a pointer to a particular chapter, we could modify
> such text like so:
> 

That is more or less what I've done in other places.
 
> However, I'm not sure if we really need to point to a
> particular chapter in a particular version.

With additional qualifications about being able to predict the
future, if the need granularity is that of a Chapter, one might
use the chapter name and let the reader find the TOC or Index in
a particular version.  At the risk of introducing an immediate
counterexample to illustrate why one needs to be careful about
this, TUS 5.0 has
   [...]
   7 European Alphabetic Scripts
   8 Middle Eastern Scripts
   9 South Asian Scripts-1
   10 South Asian Scripts-2
   11 Southeast Asian Scripts
   [...]

while TUS 7.0 has
   [...]
   7 Europe-I: Modern and Liturgical Scripts
   8 Europe-II: Ancient and Other Scripts
   9 Middle East-I: Modern and Liturgical Scripts
   10 Middle East-II Ancient Scripts
   11 Cuneiform and Hieroglyphs
   12 South and Central Asia-I: Official Scripts of India
   13 South and Central Asia-II: Other Modern Scripts
   14 South and Central Asia-III: Ancient Scripts
   15 South and Central Asia-IV: Other Historic Scripts
   16 Southeast Asia
   [...]

These new category breakdowns are not just subdivisions of
existing material with renumbering but required moving some
material around.  There are also some new chapters that have no
obvious correspondence to chapters or parts of chapters in
earlier versions.  I won't try to guess at future Unicode plans,
but note, for example, that the new Chapter 12 is unstable
because shifting political tides in India have resulted in
gradual increases in the number of official languages.

    john