Subject: PMP> Printer MIB draft posted

From: [email-masked]
Date: Fri, 5 May 2000 16:20:27 -0600

Today I posted a draft of the Printer MIB intended for last or (at least)
penultimate internal call before sending to the IETF. Section 4 contains a
list of updates. I'd like some time on the NYC agenda to not necessarily
review this in detail but at least take comments. Of course, please
comment on the reflector!

There are a couple "issues" remaining.

1. That Top 25 alert table (Apdx E) is horrible in terms of formatting and
I think it's useless in it's current condition. I'd like to remove it!
2. There's the issues I posted earlier to day about mailto: etc. for
Service and Operator contact info
3. I'm not sure I've got the correct references to IPP standards docs. in
the channel info for the IPP channel

Otherwise, I (hope) think, it's in pretty good shape!

ftp://ftp.pwg.org/pub/pwg/pmp/drafts/draft-ietf-printmib-info-05.txt

Harry Lewis
IBM Printing Systems

---

From: [email-masked]
Date: Fri, 5 May 2000 21:51:30 -0600

Yes, I'm all for highlighting it on the PWG web site and even putting a
reference to it in the MIB draft (if that's "allowed"). I agree the "Top
25" was a valuable exercise. It's just the lack of usability in the
current text format that I don't like.

Harry Lewis
IBM Printing Systems

Jay Martin <[email-masked]>
05/05/00 04:25 PM

        To:     Harry Lewis/Boulder/IBM@IBMUS
        cc:     [email-masked]
        Subject:        Re: PMP> Printer MIB draft posted

> I think it's useless in it's current condition. I'd like to remove it!

Generating that Top 25 table turned out to be the *only* way the group
could narrow its focus to determine what was truly important with respect
to alerts and associated usage scenarios, IMHO.

I certainly understand how hard it is to put such a big table in such a
small format, but this table should be retained *someplace* that everyone
can access.  How's about putting it on the PWG website in a
well-advertised
location?

        ...jay

---

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 17 May 2000 11:37:02 -0700

Hi Harry,

I picked up this file yesterday from the PWG site and used
SMICng 'mstrip' tool to extract the MIB source.  It compiles
after fixing three one-line typos (all commas that are missing
or present when they shouldn't be):

1)  chNDPS(43),  -- Ira - added comma
2)  chIPP(44)    -- Ira - removed comma
3)  mediaPathcannotDuplexMediaSelected(1304), -- Ira - added comma
    [the word 'cannot' should also be capitalized in the above]

Also, your entire file is still set at 65 columns of text (as
Randy Turner had done) and not 72 columns (as required by RFC
Editor for I-Ds and RFCs).  This causes some additional havoc
with some tables.

I haven't reviewed the text updates and clarifications yet.
Will do so shortly.

Cheers,
- Ira McDonald, consulting architect at Xerox and Sharp
  High North Inc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 05, 2000 8:52 PM
To: Jay Martin
Cc: [email-masked]
Subject: Re: PMP> Printer MIB draft posted

Harry Lewis
IBM Printing Systems

        ...jay

---

From: [email-masked]
Date: Fri, 19 May 2000 10:12:39 -0600

Thanks, Ira. A couple of these were caught by one of the Xerox guys who
ran it through a compiler, too. I'll make the changes (I don't really
understand why there IS a comma in (1) and NOT a comma in (2)). I'm
working on moving to 72 columns, replacing the goofed up stick figures and
replacing the top-25 chart with a reference.

Harry Lewis
IBM Printing Systems

"McDonald, Ira" <[email-masked]>
05/17/00 12:37 PM

        To:     Harry Lewis/Boulder/IBM@IBMUS, Jay Martin
<[email-masked]>
        cc:     [email-masked]
        Subject:        RE: PMP> Printer MIB draft posted

Hi Harry,

Cheers,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 05, 2000 8:52 PM
To: Jay Martin
Cc: [email-masked]
Subject: Re: PMP> Printer MIB draft posted

Harry Lewis
IBM Printing Systems

        ...jay

---

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 19 May 2000 17:01:16 -0700

Hi Harry,

There needs to be a comma in (1) because it's NOT the last
member of an enum and there need to NOT be a comma in (2)
because it IS the last member of an enum definition.

Remember NOT to make the reference to the Top-25 normative
(a shall or must) in the Printer MIB v2 text or it will
NOT be permitted to be published on the IETF 'standards
track' - because all normative references must be to
stable official standards (IETF, ISO, W3C, ITU-T, IEEE, or
whatever).

Cheers,
- Ira

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 19, 2000 9:13 AM
To: McDonald, Ira
Cc: [email-masked]; [email-masked]
Subject: RE: PMP> Printer MIB draft posted

Harry Lewis
IBM Printing Systems

Hi Harry,

Cheers,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, May 05, 2000 8:52 PM
To: Jay Martin
Cc: [email-masked]
Subject: Re: PMP> Printer MIB draft posted

Harry Lewis
IBM Printing Systems

        ...jay