Subject: PMP> e-mail print Channel definition

From: "Harry Lewis" <[email-masked]>
Date: Wed, 10 Apr 2002 16:51:45 -0600

Some printers have implemented printing of e-mail attachments. It would be 
benificial to enumrate a seperate channel for this behavior. Even though 
we have not standardized the implementation I would like to propose an 
additional to PrtChannelTypeTC along the lines of :

chSMTP(45) -- Print job submission via SMTP.
           --   Keyword:      Mailto
           --   Syntax:       Name
           --   Status:       Mandatory
           --   Multiplicity: Single
           --   Default:      not applicable
           --   Description:  E-mail sent to this address will be printed

What do others think about this idea?

---

From: "McDonald, Ira" <[email-masked]>
Date: Thu, 11 Apr 2002 09:49:33 -0700

Hi Harry,

Agreed - we should have defined an email (specifically SMTP) job 
submission channel long ago.  Many printers have this feature.
Using 'other(1)' is _bad_.

I suspect a few parameters (like the IPP three musketeers) about
authentication and security modes to use would be appropriate
(like listing SASL, S/MIME, PGP, XML Digital Signatures, etc.).

Cheers,
- Ira McDonald
  High North Inc