Subject: RE: PWG-ANNOUNCE> IESG approved Printer MIB v2 and Finisher MIB f or RFCs

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 23 May 2003 23:55:25 +0200

Hi all... not sure where Ira retrieved the "announcement" from.
But for all I know, the documents are on the IESG agenda for
coming Thursday and Have NOT yet been approved.

So pls excercise a bot more patience. 
Sorry to spoil the party.

Thanks,
Bert Wijnen, co-AD for the IETF Operations and Management Area

> -----Original Message-----
> From: McDonald, Ira [mailto:[email-masked]]
> Sent: vrijdag 23 mei 2003 22:37
> To: [email-masked]
> Cc: [email-masked]; [email-masked]'; 
> [email-masked]'
> Subject: PWG-ANNOUNCE> IESG approved Printer MIB v2 and 
> Finisher MIB for
> RFCs
> 
> 
> Hi folks,                                           Friday 
> (23 May 2003)
> 
> Great news!
> 
> After seven years of effort, the IESG has approved the Printer MIB v2
> (Proposed Standard), Finisher MIB (Informational), and IANA 
> Charset MIB
> (Informational).
> 
> Copies of the IESG approval notes to the RFC Editor are appended below
> (copied from the IETF Data Tracker search engine).
> 
> Thanks to the MIB experts, Bert Wijnen (IETF Ops & Mgmt Area 
> Director),
> Dave Harrington, and Juergen Schoenwaelder, for significant technical
> improvements and clarifications to these MIBs over the last two years.
> Thanks to Ned Freed (IETF Applications Area Director) for shepherding
> these MIBs through the recent IETF 'last call'.
> 
> Thanks to Ron Bergman (Hitachi) and Harry Lewis (IBM) for their years
> of patient effort as principal editors.  Thanks also to Ray Casterline
> (Lighthouse Solutions), Gary Gocek (Veramark), and Randy 
> Turner (2wire)
> for their significant contributions in the past as 
> co-editors.  Lastly,
> thanks to all the many PWG members who contributed so much over the
> years to the Printer MIB v2 and Finisher MIB.  Well done!
> 
> Cheers,
> - Ira McDonald, co-editor of Printer MIB v2 and Finisher MIB
>   High North Inc
> 
> 
> PS - Next steps - The RFC Editor will (in several months) 
> work on these
> MIBs.  At that time, the current MIB editors will be contacted for a
> final review for typographic or formatting errors.  There is a good
> chance that these MIBs will be published as RFCs before the end of
> calendar 2003!
> 
> PPS - So it turns out that the XML Schema translations of these MIBs
> that I posted yesterday (part of the PWG WBMM project) are in 
> fact based
> on the final form of the MIBs.  Good timing, huh?
> 
> 
> --------------------------------------------------------------
> ----------
> To: IETF-Announce:;
> Dcc: *******
> Cc: RFC Editor <[email-masked]>,
>  Internet Architecture Board <[email-masked]>,
> From: The IESG <[email-masked]>
> Subject: Protocol Action: Printer MIB v2 to Proposed Standard
> -------------
> 
> The IESG has approved the Internet-Draft 'Printer MIB v2'
> <draft-ietf-printmib-mib-info-15.txt> as a Proposed Standard.
> This has been reviewed in the IETF but is not the product of an IETF
> Working Group. The IESG contact persons are Ned Freed and Ted Hardie.
>  
> Technical Summary
>  
>     This document provides definitions of models and 
> manageable objects
>     for printing environments. The objects included in this 
> MIB apply to
>     physical, as well as logical entities within a printing 
> device. This
>     document obsoletes RFC 1759.
> 
>     The task of managing the production of printed documents 
> can be divided
>     into two overlapping pieces, the management of printing and the
>     management of the printer. Printing encompasses the 
> entire process of
>     producing a printed document from generation of the file to be
>     printed, selection of a printer, choosing printing properties,
>     routing, queuing, resource management, scheduling, and 
> final printing
>     including notifying the user. Most of the printing process is
>     outside the scope of the model presented here; only the 
> management of
>     the printer itself is covered in this document.
>  
> Working Group Summary
>  
>     This document was reviewed by the Internet Print Protocol 
> Working Group
>     but is not a product of that group.
>  
> Protocol Quality
>  
>     Bert Wijnen and Ned Freed reviewed the document for the IESG.
> 
> --------------------------------------------------------------
> ----------
> To: IETF-Announce:;
> Dcc: *******
> Cc: RFC Editor <[email-masked]>,
>  Internet Architecture Board <[email-masked]>,
> From: The IESG <[email-masked]>
> Subject: Document Action: Printer Finishing MIB to Informational
> -------------
> 
> The IESG has approved the Internet-Draft 'Printer Finishing MIB'
> <draft-ietf-printmib-finishing-16.txt> as an Informational RFC.
> This has been reviewed in the IETF but is not the product of an IETF
> Working Group. The IESG contact persons are Ned Freed and Ted Hardie.
>  
> Technical Summary
>  
>   This document defines a MIB module for the management of printer
>   finishing device subunits. The finishing device subunits applicable
>   to this MIB are an integral part of the Printer System. This MIB
>   does not apply to a Finisher Device that is not connected to a
>   Printer System.
> 
> Working Group Summary
>  
>     This document was reviewed by the Internet Print Protocol 
> Working Group
>     but is not a product of that group.
>  
> Protocol Quality
>  
>     Bert Wijnen and Ned Freed reviewed the document for the IESG.
> 
> --------------------------------------------------------------
> ----------
> To: IETF-Announce:;
> Dcc: *******
> Cc: RFC Editor <[email-masked]>,
>  Internet Architecture Board <[email-masked]>,
> From: The IESG <[email-masked]>
> Subject: Document Action: IANA Charset MIB to Informational
> -------------
> 
> The IESG has approved the Internet-Draft 'IANA Charset MIB'
> <draft-mcdonald-iana-charset-mib-02.txt> as an Informational RFC.
> This has been reviewed in the IETF but is not the product of an IETF
> Working Group. The IESG contact persons are Ned Freed and Ted Hardie.
>  
> Technical Summary
>  
>       This memo defines a portion of the Management 
> Information Base (MIB)
>       for use with network management protocols in the 
> Internet community.
>       This IANA Charset MIB is [intended to become] an IANA 
> registry. In
>       particular, a single textual convention 'IANACharset' 
> is defined that
>       may be used to specify charset labels in MIB objects. 
> 'IANACharset'
>       was extracted from Printer MIB v2 (work-in-progress). 
> 'IANACharset'
>       was originally defined (and mis-named) as 
> 'CodedCharSet' in Printer
>       MIB v1 (RFC 1759). A tool has been written in C, that 
> may be used by
>       IANA to regenerate this IANA Charset MIB, when future 
> charsets are in
>       accordance with the IANA Charset Registration 
> Procedures (RFC 2978).
>  
> Working Group Summary
>  
>     This document was reviewed by the Internet Print Protocol 
> Working Group
>     but is not a product of that group.
>  
> Protocol Quality
>  
>     Bert Wijnen and Ned Freed reviewed the document for the IESG.
> 
> RFC Editor Note
> 
>   The copyright notice in the MIB module does not conform to the
>   recently-adopted format for IANA-maintained MIB modules. The notice
>   in the DESCRIPTION clause of the MODULE-IDENTITY statement needs to
>   be changed from:
> 
>       Copyright (C) The Internet Society (year). This
>       version of this MIB module is part of RFC xxxx;
>       see the RFC itself for full legal notices."
> 
>   to:
> 
>       Copyright (C) The Internet Society (year). The
>       initial version of this MIB module was published
>       in RFC xxxx. For full legal notices see the RFC
>       itself or see: http://www.ietf.org/copyrights/ianamib.html"
> 
> --------------------------------------------------------------
> ----------
>

---

From: "McDonald, Ira" <[email-masked]>
Date: Sat, 24 May 2003 10:48:27 -0700

Hi,

[egg on face] My apologies for mis-reading the details pages in
the IETF Data Tracker yesterday.

Let's hope the IESG _does_ approve these MIBs this coming Thursday.

Cheers,
- Ira

-----Original Message-----
From: Wijnen, Bert (Bert) [mailto:[email-masked]]
Sent: Friday, May 23, 2003 5:55 PM
To: McDonald, Ira; [email-masked]
Cc: [email-masked]; [email-masked]'; [email-masked]'
Subject: RE: PWG-ANNOUNCE> IESG approved Printer MIB v2 and Finisher MIB
f or RFCs

Thanks,

---

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 26 May 2003 13:17:52 +0200

Well, so it seems you got it from teh ID-tracker when you click on
the "ballot" link. In there, yuou can see (at the bottom) the proposed
announcement message that the IESG has to evaluate and discuss and
decide upon. Once we have approved the document, that message is
then (possibly amended) posted to the IETF-announce mailing list,
and that makes it official.

What this (incident) has pointed out is that we (IESG, secretariat) 
need to work on making it clear (in the online info) that this
'draft announce message" should not be seen as approval yet.

Thanks,
Bert 

> Sent: zaterdag 24 mei 2003 19:48
> To: 'Wijnen, Bert (Bert)'; McDonald, Ira; [email-masked]