Subject: PMP> Re: Question Re intended agent support for RFC3805

From: Harry Lewis <[email-masked]>
Date: Thu, 12 Aug 2004 16:56:23 -0600

Larry, you are correct. The use of hrMIB was rather unfortunate in that it 
forced the munging of local resource indexing onto a networked device. For 
all intents and purposes, in the embedded network printer, the "host" IS 
the printer controller (there may still be implementations where the host 
is the NIC). The hrMIB is still useful in this context for helping 
distinguish internal printer resources like a storage device, for example. 
 
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 

"Larry R. Walsh" <[email-masked]> 
07/26/2004 03:29 PM
Please respond to
larrywalsh

To
Harry Lewis/Boulder/IBM@IBMUS
cc

Subject
Question Re intended agent support for RFC3805

Hello Harry,
RFC3805 appears to be clearly intended to be supported by an agent on a 
platform with attached printers ? as evidenced by using the index 
?hrDeviceIndex? in its tables.
Is it also intended for implementation as an embedded agent within a 
printer? If so, then I would assume that ?hrDeviceIndex? takes on one 
value that is local to the printer, and that value has nothing to do with 
the host resource index on the platform. Right?
Thanks for any insights you can provide.
Best Regards, Larry

Larry R. Walsh
SNMP Training & SNMP Development
Embedded Systems Software Development
360 862-1154
[email-masked] 
www.chateausystems.com

---

From: "McDonald, Ira" <[email-masked]>
Date: Fri, 13 Aug 2004 09:40:36 -0700

Hi Larry,

Two more bits about Host Resources MIB (RFC 2790)

- System group (extends System group in MIB-II)
  contains the very useful attributes
  'hrSystemUptime' (since last boot) and
  'hrSystemDate' (date and time, with time zone)

- Software Installed group (optional) contains
  'hrSWInstalledLastChange' (last change any s/w) and
  'hrSWInstalledName' (description of s/w element)

Note that MS Windows has ubiquitously supported
the Software Installed and (parallel) Software
Running groups for some years, so this is useful
for more than printers in a monitor.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Harry Lewis
Sent: Thursday, August 12, 2004 6:56 PM
To: [email-masked]
Cc: [email-masked]
Subject: PMP> Re: Question Re intended agent support for RFC3805

Larry, you are correct. The use of hrMIB was rather unfortunate in that it
forced the munging of local resource indexing onto a networked device. For
all intents and purposes, in the embedded network printer, the "host" IS the
printer controller (there may still be implementations where the host is the
NIC). The hrMIB is still useful in this context for helping distinguish
internal printer resources like a storage device, for example.   
---------------------------------------------- 
Harry Lewis 
IBM STSM
Chairman - IEEE-ISTO Printer Working Group
http://www.pwg.org
IBM Printing Systems 
http://www.ibm.com/printers
303-924-5337
---------------------------------------------- 

"Larry R. Walsh" <[email-masked]> 
07/26/2004 03:29 PM Please respond to
larrywalsh

ToHarry Lewis/Boulder/IBM@IBMUS 
cc
SubjectQuestion Re intended agent support for RFC3805

Hello Harry, 
RFC3805 appears to be clearly intended to be supported by an agent on a
platform with attached printers - as evidenced by using the index
"hrDeviceIndex" in its tables. 
Is it also intended for implementation as an embedded agent within a
printer? If so, then I would assume that "hrDeviceIndex" takes on one value
that is local to the printer, and that value has nothing to do with the host
resource index on the platform. Right? 
Thanks for any insights you can provide. 
Best Regards, Larry 
Larry R. Walsh
SNMP Training & SNMP Development
Embedded Systems Software Development
360 862-1154
[email-masked] 
www.chateausystems.com