Subject: PMP> prtChannelType for WS-Print

From: "Zehler, Peter" <[email-masked]>
Date: Tue, 30 Oct 2007 19:00:05 -0400

All,

I would like to see chWsPrint(46) registered for the WS-Print print
channel.  What would have to be done to accomplish this?  I would also
like to see the prtChannelProtocolVersion be defined to hold the target
namespace for the protocol.

Pete

Peter Zehler
XEROX
Xerox Research Center Webster
Email: [email-masked]
Voice: (585) 265-8755
FAX: (585) 265-7441
US Mail: Peter Zehler
Xerox Corp.
800 Phillips Rd.
M/S 128-25E
Webster NY, 14580-9701

---

From: "Ira McDonald" <[email-masked]>
Date: Wed, 31 Oct 2007 12:13:51 -0400

Hi Pete,

Answer - quoting from page 25 of Printer MIB v2 (RFC 3805):
------
2.4.1.  Registering Additional Enumerated Values

   The Printer MIB and the companion IANA Printer MIB each defines one
   category of textual convention, according to the process employed to
   control the addition of new enumerations:

   Type 1 - All of the legal values are defined in the Printer MIB.
   Additional enumerated values require the publication of a new Printer
   MIB.

>  Type 2 - All of the legal values are registered in the IANA Printer
>  MIB.  Additional enumerated values require a Designated Expert Review
>  defined in "Guidelines for Writing an IANA Considerations Section in
>  RFCs" [RFC2434].  The Designated Expert will be selected by the IETF
>   Area Director(s) of the Applications Area.
------

PrtChannelTypeTC is a Type 2 enumeration in the IANA Printer MIB.
So, the new multi-line value (with keywords and definitions for any
prtChannelInfo content) should be written up as an addition to this
textual convention.

The new value and an accompanying rationale should be posted to the
mailing list [email-masked]' for public review.  After at least two weeks
of public review, the PMP Chair (Ron Bergman) should declare working
group concensus and request that the IETF Designated Expert (Harry
Lewis) send the update request to IANA for registration.

Then we hope that IANA gets to the request quickly (probably at least
a few weeks).

Pretty simple.

Cheers,
- Ira (co-editor of Printer MIB v2)

On 10/30/07, Zehler, Peter <[email-masked]> wrote:
>
>
>
>
> All,
>
> I would like to see chWsPrint(46) registered for the WS-Print print channel.
>  What would have to be done to accomplish this?  I would also like to see
> the prtChannelProtocolVersion be defined to hold the target namespace for
> the protocol.
>
> Pete
>
>
>
> Peter Zehler
>  XEROX

-- 
Ira McDonald (Musician / Software Architect)
Chair - Linux Foundation Open Printing WG
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
work: +1-906-494-2434
home: +1-906-494-2697
email: [email-masked]