Subject: [ietf-provreg] optional elements and server policy

From: janusz sienkiewicz <[email-masked]>
Date: Thu, 09 Oct 2003 11:06:20 -0400

There are cases when policy requirements require an epp server
implementation to treat an OPTIONAL request element as mandatory. If
such OPTIONAL element is not provided the server could return 2308
error code ("Data management policy violation").

Is such a treatment of an OPTIONAL element a violation  of epp protocol?

Janusz Sienkiewicz

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 9 Oct 2003 11:47:06 -0400

> -----Original Message-----
> From: janusz sienkiewicz [mailto:[email-masked]] 
> Sent: Thursday, October 09, 2003 11:06 AM
> To: [email-masked]
> Subject: [ietf-provreg] optional elements and server policy
> 
> 

Personally, I don't think so.  The 2308 error code exists to make the
situation you described obvious.

-Scott-