Subject: RE: [ietf-provreg] RE: draft-hollenbeck-epp-rgp-01.txt comments/p roposal

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 1 Dec 2003 14:12:42 -0500

> The wording for <renew> command in rgp draft document could 
> be modified to
> indicate that the absence of period element in <renew> part 
> or value ZERO
> should indicate that renewal should not be a part of rgp 
> restore. Another
> option would be to force server to ignore the value of 
> <period> element and
> assume certain value.

I've thought about the zero value being appropriate here.  It's certainly an
approach.
> > If people are already doing RGP as an extended renewal, 
> what are they doing
> > about the renewal part of the command?
> 
> I am aware of one implementation that just ignores the value 
> of <period>
> element and assumes ZERO if rgp extension is present.

Oooh, accepting a non-zero value and ignoring it isn't a very good idea.
That would make data reconciliation very difficult in the future if one
tries to reconcile a non-zero-period <renew> command that was processed
without error, but with no change to the expiration date.  I'd rather
require a period of zero for RGP situations.

-Scott-

---

From: janusz sienkiewicz <[email-masked]>
Date: Mon, 01 Dec 2003 14:29:06 -0500

I also prefer required zero value for RGP situations. Such behavior would
improve interoperatibility of RGP implementations.

Janusz Sienkiewicz