Subject: [ietf-provreg] registries, XML & EPP (again)

From: Klaus Malorny <[email-masked]>
Date: Wed, 05 Oct 2005 12:26:25 +0200

Hi all,

digging deeper into the EURid EPP specs I discovered something that is in my 
humble opinion a bit more serious than the prefix problem. It looks like that 
they took the XML schema files of the domain and contact objects (RFC 3731, 
3733) and deliberately modified them, like adding a new contact type or changing 
whether elements are mandatory or not. I am not completely aware of all changes, 
as the schema files are not available yet. While the changes themselves are not 
a problem at all, EURid still associates these new schemes with the IETF 
namespaces, namely urn:ietf:params:xml:ns:contact-1.0 and 
urn:ietf:params:xml:ns:domain-1.0. Isn't this something that should really be 
avoided for the sake of the clarity and compatibility? Technically, it is not a 
problem to use any other URI, like they did for their proprietary extensions anyway.

Please don't misunderstand me, I do not want to start an EURid or whatever 
registry bashing here, but the least what we need is a standard that isn't one 
(for whatever reason). Lessons like SQL or HTML have shown where something can end.

regards,

Klaus

___________________________________________________________________________
      |       |
      | knipp |                   Knipp  Medien und Kommunikation GmbH
       -------                           Technologiepark
                                         Martin-Schmeißer-Weg 9
      Dipl. Inf. Klaus Malorny           44227 Dortmund
      [email-masked]             Tel. +49 231 9703 0

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 19 Oct 2005 13:17:14 -0400

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Klaus Malorny
> Sent: Wednesday, October 19, 2005 12:09 PM
> To: Edward Lewis
> Cc: [email-masked]
> Subject: Re: [ietf-provreg] registries, XML & EPP (again)

[snip]

> Sorry to say that, but in the beginning of the provreg 
> working group Scott and 
> others of the gTLD faction were just too confined to the 
> Verisign model and 
> fully ignored the ccTLDs, their needs and their models. IMHO 
> this discouraged 
> many ccTLDs from participating. EPP is indeed "extensible", 
> but in some aspects 
> just not at all.

I still really resent statements like this because no one "fully
ignored" anybody's needs.  I know that I and others took great pains to
try to boil down the defined structures to essential minimums as issues
were brought to the group's attention, pushing as much TLD-specific
stuff as possible off for local definition.  That means that "local
policy" things needed by individual registries are up to them to
specify.

I firmly believe that any attempt to specify an "out of the box" domain
registration protocol that included all of the features needed by every
TLD registry would have failed miserably.

-Scott-