Subject: Re: [ietf-provreg] restore report

From: Eugenio Pinto <[email-masked]>
Date: Tue, 25 Mar 2008 12:03:52 +0000

Hi all!

Is this the correct way to extend the EPP protocol in order to define a 
new command name?

<?xml version="1.0" encoding="UTF-8" standalone="no"?>

<epp xmlns="urn:ietf:params:xml:ns:epp-1.0"

     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

     xsi:schemaLocation="urn:ietf:params:xml:ns:epp-1.0

     epp-1.0.xsd">

  <extension>

    <ptdomain:command

     xmlns:ptdomain="http://www.dns.pt/xml/epp/ptdomain-1.0"

     xsi:schemaLocation="http://www.dns.pt/xml/epp/ptdomain-1.0

     ptdomain-1.0.xsd">

      <ptdomain:removeAsSponsor>

        <ptdomain:name>example.pt</ptdomain:name>

      </ptdomain:removeAsSponsor>

      <ptdomain:clTRID>1549272074</ptdomain:clTRID>

    </ptdomain:command>

  </extension>

</epp>

-- 
Best Regards,
 
Eugénio Pinto
WG-DNS

FCCN - Fundação para a Computação Científica Nacional | DNS.PT
Apartado 50336 | 1708-001 Lisboa | Portugal
Tel.: +351 218 440 132 | Fax.: +351 218 440 157
Email: [email-masked] <mailto:[email-masked]>
http://www.dns.pt

[ Before printing this message, think about environment ]
 
CONFIDENTIALITY NOTICE: This e-mail and any attachments are confidential 
and may be privileged. If you are not a named recipient, please notify 
the sender immediately and do not disclose the contents to another 
person, use it for any purpose or store or copy the information in any 
medium.

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 25 Mar 2008 09:21:35 -0400

Without knowing what you're trying to accomplish it's hard to say for sure.  What you've done might work mechanically.  It might make no sense semantically.  I can't tell if you're trying to remove a domain name from something or if you're trying to remove something from a domain name.
 
-Scott- 

________________________________

	From: [email-masked] [mailto:[email-masked]] On Behalf Of Eugenio Pinto
	Sent: Tuesday, March 25, 2008 8:04 AM
	To: [email-masked]
	Subject: Re: [ietf-provreg] restore report

	Hi all!
	
	Is this the correct way to extend the EPP protocol in order to define a new command name?

	     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" <http://www.w3.org/2001/XMLSchema-instance> 

	     epp-1.0.xsd">

	  <extension>

	    <ptdomain:command

	     xmlns:ptdomain="http://www.dns.pt/xml/epp/ptdomain-1.0" <http://www.dns.pt/xml/epp/ptdomain-1.0> 

	     ptdomain-1.0.xsd">

	    </ptdomain:command>

	  </extension>

	</epp>

	-- 
	
	Best Regards,
	 
	Eugénio Pinto
	WG-DNS

Email: [email-masked]
http://www.dns.pt

	CONFIDENTIALITY NOTICE: This e-mail and any attachments are confidential and may be privileged. If you are not a named recipient, please notify the sender immediately and do not disclose the contents to another person, use it for any purpose or store or copy the information in any medium.