Subject: [provreg] Fwd: registry software availability

From: [email-masked]
Date: Fri, 22 Jul 2011 11:48:12 -0400

Colleagues,

I'm looking for pointers to licensing terms and conditions for some or
all the components of a registry and registrar system, which uses EPP
as the provisioning protocol.

I will summarize for the Joint Application Support Working Group, and
the consumers of its work product, and this mailing list.

I've updated the note forwarded, and will annotate a table of source
bases, licensing terms, and things I think useful, and make it
available.

Thanks in advance,
Eric
------- Forwarded Message

From: [email-masked]
To: [email-masked]
Subject: Re: [soac-newgtldapsup-wg] registry software availability
Date: Fri, 22 Jul 2011 06:40:50 -0400
Sender: [email-masked]

Colleagues,

The following, from the "There exists some similar programs" link from
the http://codev-nic.generic-nic.net/ site is what I'd in mind when
suggesting that the JAS-WG inquire into registry implementation sources
and their licensing conditions.

OpenReg of ISC http://www.isc.org/index.pl?/sw/openreg/ 
SRS of .nz http://sourceforge.net/projects/dnrs/
mod_epp of .at http://sourceforge.net/projects/aepps/
FRED of .cz http://fred.nic.cz/
CoCCA of .cx http://trac.cocca.org.au/

(dead link pointed out by Michele Neylon,
alt: https://downloads.coccaregistry.net/
in follow-up mail to the JAS-WG mailing list)

registro of .br http://www.registro.br/
tinyReg of NSRC http://nsrc.org/tinyReg/

And of course, as Fabien helpfully pointed out, there is CODEC-NIC.
(at http://codev-nic.generic-nic.net/ )

Eric

------- End of Forwarded Message

---

From: "Michele Neylon :: Blacknight" <[email-masked]>
Date: Fri, 22 Jul 2011 18:25:57 +0000

Eric

I haven't come across much in the way of "registrar" software for EPP. There are a few libraries floating around, but I don't recall ever seeing anything that was an actual "full" solution that you could deploy "out of the box". There are commercial services available from a growing number of companies, but they're pretty much all "hosted" services.

Regards

Michele

Mr Michele Neylon
Blacknight Solutions
Hosting & Colocation, Brand Protection
ICANN Accredited Registrar
http://www.blacknight.com/
http://blog.blacknight.com/
http://blacknight.mobi/
http://mneylon.tel
Intl. +353 (0) 59  9183072
US: 213-233-1612 
UK: 0844 484 9361
Direct Dial: +353 (0)59 9183090
Fax. +353 (0) 1 4811 763
-------------------------------
Blacknight Internet Solutions Ltd, Unit 12A,Barrowside Business Park,Sleaty
Road,Graiguecullen,Carlow,Ireland  Company No.: 370845

---

From: Patrik Fältström <[email-masked]>
Date: Sat, 23 Jul 2011 08:35:52 +0200

> I haven't come across much in the way of "registrar" software for EPP. There are a few libraries floating around, but I don't recall ever seeing anything that was an actual "full" solution that you…

I do not know of any either, as the registries have so much different implementations of epp. So if you want to support more than one registry, you (from my point of view) must do your own hack.

Yes, as Michele says, one can of course use one of the existing epp libraries. I think Net::DRI in perl is one of the ones that is the one that covers the various epp implementations the best.

http://www.dotandco.com/services/software/Net-DRI/

Myself, I did choose to not use Net::DRI, but instead implement from ground up. No, not open source.

But I am very interested in the result of the investigation as I, as you see, have not seen around what I want to see.

   Patrik