Subject: Re: [provreg] EPP extensions working group

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 12 Aug 2013 13:41:54 +0000

In the interest of trying to move this forward, how about these three drafts as a starting point?

draft-gieben-epp-keyrelay (http://datatracker.ietf.org/doc/draft-gieben-epp-keyrelay/)
draft-obispo-epp-idn (http://datatracker.ietf.org/doc/draft-obispo-epp-idn/)
draft-tan-epp-launchphase (http://datatracker.ietf.org/doc/draft-tan-epp-launchphase/)

Scott

---

From: Wil Tan <[email-masked]>
Date: Mon, 12 Aug 2013 23:59:24 +1000

On Mon, Aug 12, 2013 at 11:41 PM, Hollenbeck, Scott <
[email-masked]> wrote:

> draft-gieben-epp-keyrelay (
> http://datatracker.ietf.org/doc/draft-gieben-epp-keyrelay/)
> draft-obispo-epp-idn (
> http://datatracker.ietf.org/doc/draft-obispo-epp-idn/)
> draft-tan-epp-launchphase (
> http://datatracker.ietf.org/doc/draft-tan-epp-launchphase/)
>
>
+1

.wil

---

From: "Marco Davids (SIDN)" <[email-masked]>
Date: Mon, 12 Aug 2013 16:22:57 +0200

> draft-tan-epp-launchphase (http://datatracker.ietf.org/doc/draft-tan-epp-launchphase/)

Sounds good, +1

--
Marco

---

From: Peter Koch <[email-masked]>
Date: Mon, 12 Aug 2013 17:57:47 +0200

> draft-tan-epp-launchphase (http://datatracker.ietf.org/doc/draft-tan-epp-launchphase/)

{disclosure: my employer does not use EPP, but I have some interest in
 the topic addressed by the first draft}

playing devil's advocate again, what would be the purpose of the organisational
overhead of forming a WG here?  I understand the change control issue might
be obvious in all three cases, which may speak in favor of publishing the
documents in the IETF stream, even though the IETF URN registry only says
'specification required'. Is there an incentive to get these on standards track
(which still wouldn't require a WG)?

-Peter

---

From: "Gould, James" <[email-masked]>
Date: Mon, 12 Aug 2013 17:27:22 +0000

I would include draft-lozano-tmch-smd with draft-tan-epp-launchphase since there is an existing dependency.
--

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: Wil Tan <[email-masked]<mailto:[email-masked]>>
Date: Monday, August 12, 2013 9:59 AM
To: "Hollenbeck, Scott" <[email-masked]<mailto:[email-masked]>>
Cc: EPP Provreg <[email-masked]<mailto:[email-masked]>>
Subject: Re: [provreg] EPP extensions working group

On Mon, Aug 12, 2013 at 11:41 PM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
In the interest of trying to move this forward, how about these three drafts as a starting point?

+1

.wil

---

From: Ning Kong <[email-masked]>
Date: Tue, 13 Aug 2013 09:10:53 +0800

+1

I suggest my ID about IDN variants can be also considered.

http://datatracker.ietf.org/doc/draft-kong-epp-idn-variants-mapping/

Cheers,
Ning

> _______________________________________________
> provreg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/provreg

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 13 Aug 2013 06:45:44 +0200

It would be interesting to know for each one of the I-D what registries have implemented them.

I.e. my goal with an exercise like this would be to get a registry of extensions, in one location. Then if the inventor of the extension so wishes in order a. review and b. change control with ietf.

But registry is most important. Like we have done with sip and enum.

   Patrik

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 13 Aug 2013 10:57:45 +0000

> -----Original Message-----
> From: Patrik Fältström [mailto:[email-masked]]
> Sent: Tuesday, August 13, 2013 12:46 AM
> To: Ning Kong
> Cc: Hollenbeck, Scott; [email-masked]
> I.e. my goal with an exercise like this would be to get a registry of
> extensions, in one location. Then if the inventor of the extension so
> wishes in order a. review and b. change control with ietf.
> 

We can suggest a WG milestone to develop an extensions registry document. It goes beyond what Pete has said he'll consider, but maybe he can be convinced of the need.

Scott

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 13 Aug 2013 12:23:03 +0000

> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Peter Koch
> Sent: Monday, August 12, 2013 11:58 AM
> To: [email-masked]

My take: the small number of documents probably don't merit the overhead of forming a working group. When I talked to Pete in Berlin he used words like "short duration" and "won't meet formally" - which I interpret to mean "minimize the overhead". I believe he is willing to entertain the idea of helping us move the documents along with the benefit of a little working group process iff we can keep the amount of required overhead small. He'll hold his nose if it helps us get the job done.

There is a larger issue here, though - the registry development task that Patrik mentioned here:

http://www.ietf.org/mail-archive/web/provreg/current/msg07420.html

This is more challenging than moving a small number of existing drafts through the standards track. Sure, people can write individual submissions to describe proposals and one might actually rise to the top, but this is a task for which working group discussion will probably be beneficial.

I don't know if Pete agrees. I plan to ask him.

Scott

---

From: Patrik Fältström <[email-masked]>
Date: Tue, 13 Aug 2013 14:36:17 +0200

On 13 aug 2013, at 14:23, "Hollenbeck, Scott" <[email-masked]> wrote:

> This is more challenging than moving a small number of existing drafts through the standards track.

Maybe too challenging?

If so, lets just agree it is. I am prepared on at least trying...

   Patrik

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 13 Aug 2013 12:42:00 +0000

> Sent: Tuesday, August 13, 2013 8:36 AM
> To: Hollenbeck, Scott
> Cc: Peter Koch; [email-masked]

I'm willing to try, too. I think we can do it.

Scott

---

From: Patrick Mevzek <[email-masked]>
Date: Tue, 13 Aug 2013 15:20:37 +0200

Patrik Fältström <[email-masked]> 2013-08-13 06:47
> It would be interesting to know for each one of the I-D what registries have implemented them.
 
I've started to compile such document (map between XML namespaces to
TLD using it first, adding doc/specification URL if I have it then),
based on my implemented code, so that it could then be edited for
errors and adding missing I-Ds.

A first iteration should be ready in a few hours, if my current
conference WiFi behaves.

HTH,

-- 
Patrick Mevzek

---

From: Jay Daley <[email-masked]>
Date: Wed, 14 Aug 2013 14:44:12 +1200

Patrik

> But registry is most important. Like we have done with sip and enum.

I proposed a set of fields to go in this registry last week ()

To reiterate them:

Name,  Maintaining Organisation,  TLD,  Purpose,  I-D,  Licensable

- Name is the name of the extension
- Maintaining Organisation is whoever is responsible for it now
- TLD is only included if the extension is limited to one TLD
- Purpose is a paragraph explaining what this extension is for
- I-D is the name of the IETF I-D if one exists
- Licensable is intended to tell others if they can legally use it, which should be either "No", "Maybe" or "Yes" with details of the appropriate license.

Any thoughts on those?

I used 'Maintaining Organisation' instead of 'registry' because I think the term registry will soon become confusing.  There will soon be backend registry providers who set the technical standards for a whole bunch of TLDs that contract with them, but the term 'registry' will be used both to apply to them and to the TLD operator that they are contracting with.

It's also not going to be practical to list the full set of TLDs that use a particular extension when it might number in the hundreds.

Jay

-- 
Jay Daley
Chief Executive
.nz Registry Services (New Zealand Domain Name Registry Limited)
desk: +64 4 931 6977
mobile: +64 21 678840
linkedin: www.linkedin.com/in/jaydaley

---

From: 齐超 <[email-masked]>
Date: Wed, 14 Aug 2013 11:01:51 +0800

Hello，

  I think the "applicaton date " is needed for some I-D is comming soon.

齐超 via foxmail

Sender: Jay Daley
Date: 2013年8月14日(星期三) 上午10:44
To: Patrik F鋖tstr鰉
CC: provreg
Subject: Re: [provreg] EPP extensions working group
Patrik

To reiterate them:

Any thoughts on those?

Jay

---

From: "Linlin Zhou" <[email-masked]>
Date: Wed, 14 Aug 2013 11:13:16 +0800

Agreed. draft-kong-epp-idn-variants-mapping gives the specification of the
variants IDN status, whether it is active or not, I think this needs to be
considered.

Regards,
Linlin

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ning Kong
> Sent: Tuesday, August 13, 2013 9:11 AM
> To: Hollenbeck, Scott
> Cc: [email-masked]
> > In the interest of trying to move this forward, how about these three
drafts
> as a starting point?
> >
> > draft-gieben-epp-keyrelay
> (http://datatracker.ietf.org/doc/draft-gieben-epp-keyrelay/)
> > draft-obispo-epp-idn
(http://datatracker.ietf.org/doc/draft-obispo-epp-idn/)
> > draft-tan-epp-launchphase
> (http://datatracker.ietf.org/doc/draft-tan-epp-launchphase/)
> >
> > Scott
> >

---

From: Patrik Fältström <[email-masked]>
Date: Wed, 14 Aug 2013 06:47:50 +0200

> - Licensable is intended to tell others if they can legally use it, which should be either "No", "Maybe" or "Yes" with details of the appropriate license.

I think you should also include:

- The identifier (that might be the same for many extensions, as the id is for the DTD) -- or is this what you call "name"?

- The object or function the extension touches

- The TLD that uses the extension

- The URL to the DTD/description (if available)

I also propose "licensable" can indicate whether NDA is needed to even get the documentation (which is the case for some TLDs, i.e. you must sign up to be a registrar before you even know what extensions to EPP you must implement).

   Patrik

---

From: Patrick Mevzek <[email-masked]>
Date: Wed, 21 Aug 2013 23:18:20 +0200

Patrick Mevzek <[email-masked]> 2013-08-13 15:24
> A first iteration should be ready in a few hours, if my current
 
Sorry for the delay, since one week I'm trying to post my results
inline in my email to this list and for whatever reason it does not
seem to get through :-(

Here I'm hoping it would, with another way:
please find my document at
http://www.deepcore.org/epp-extensions.txt

with this previous caveat:
Please find below a rough draft of such a list, based on my current or
future code (so some parts may be obsolete)
I've put the EPP XML namespace used, the document related into
parentheses if I
know it (either some internet draft - rare - or some registry
documentation), and the tlds using it (in no particular useful order).

I've not done a search on all internet drafts having "epp" in their
name, that should bring some more stuff.

Let me know if that helps and how to go forward from there.

-- 
Patrick Mevzek