Subject: Re: [provreg] Registry Fee Extension for the Extensible Provisioning Protocol

From: Michele Neylon - Blacknight <[email-masked]>
Date: Thu, 31 Oct 2013 16:54:00 +0000

Gavin

So in plain English you think that registrars should be getting pricing from registries via EPP??

Did I understand you correctly?

Regards

Michele

--
Mr Michele Neylon
Blacknight Solutions
Hosting & Colocation, Domains
http://www.blacknight.co/
http://blog.blacknight.com/
http://www.technology.ie
Intl. +353 (0) 59  9183072
Locall: 1850 929 929
Direct Dial: +353 (0)59 9183090
Fax. +353 (0) 1 4811 763
Twitter: http://twitter.com/mneylon
-------------------------------
Blacknight Internet Solutions Ltd, Unit 12A,Barrowside Business Park,Sleaty
Road,Graiguecullen,Carlow,Ireland  Company No.: 370845

________________________________________
From: [email-masked] [[email-masked]] on behalf of Gavin Brown [[email-masked]]
Sent: 31 October 2013 16:51
To: [email-masked]
Subject: [provreg] Registry Fee Extension for the Extensible Provisioning       Protocol

Dear colleagues,

As the I-D submission window is closed, I am unable to submit this to
the IETF, but I plan to do so once the submissions re-open.

https://raw.github.com/centralnic/epp-fee-extension/master/draft-brown-epp-fees.txt

I would like to request that this be considered for adoption by the
eppext group.

>From the introduction:

Historically, domain name registries have applied a simple fee structure
for billable transactions, namely a basic unit price applied to domain
<create>, <renew>, <transfer> and RGP restore commands.  Given the
relatively small number of EPP servers that EPP clients have been
required to connect to, it has generally been the case that client
operators have been able to obtain details of these fees out-of-band by
contacting the server operators.

Given the imminent expansion of the DNS namespace, and the proliferation
of novel business models, it is now desirable to provide a method for
EPP clients to query EPP servers for the fees associated with certain
commands and specific objects.

This document describes an extension mapping for version 1.0 of the
Extensible Provisioning Protocol (EPP) [RFC5730].  This EPP mapping
provides a mechanism by which EPP clients may query the fees associated
with various billable transactions.

You can fork the draft and push changes to me from here:

https://github.com/centralnic/epp-fee-extension

Regards,

--
Gavin Brown
Chief Technology Officer
CentralNic Group plc (LSE:CNIC)
Innovative, Reliable and Flexible Registry Services
for ccTLD, gTLD and private domain name registries
https://www.centralnic.com/

CentralNic Group plc is a company registered in England and Wales with
company number 8576358. Registered Offices: 35-39 Moorgate, London,
EC2R 6AR.
_______________________________________________
provreg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/provreg

---

From: Gavin Brown <[email-masked]>
Date: Thu, 31 Oct 2013 16:57:19 +0000

> So in plain English you think that registrars should be getting pricing from registries via EPP??

Yes.

Let's say you have a registry which has a complex pricing model:
casino.foobar might be $1000 but randomname.foobar is only $10.
Similarly, it might cost $10 to register a domain for 1 year but only
$15 for 2 years.

As a registrar you need to know what to charge your customer. If the
rules are complicated, you'd otherwise have to implement your own code
to calculate the price to show the customer. This extension eliminates
this need, because you can ask for the price at the same time you do
your check, and then display as part of your availability results
(having added your markup, presumably).

G.

---

From: Michele Neylon - Blacknight <[email-masked]>
Date: Thu, 31 Oct 2013 17:00:40 +0000

Gavin

If the registry has that kind of complex pricing I doubt many registrars would want to deal with them .. 

And EPP really isn't the best way to communicate pricing

Seriously

Regards

Michele

________________________________________
From: Gavin Brown [[email-masked]]
Sent: 31 October 2013 16:57
To: Michele Neylon - Blacknight; [email-masked]
Subject: Re: [provreg] Registry Fee Extension for the Extensible Provisioning Protocol

Yes.

G.

---

From: Klaus Malorny <[email-masked]>
Date: Thu, 31 Oct 2013 19:05:06 +0100

On 31.10.2013 18:00, Michele Neylon - Blacknight wrote:

Hi,

> If the registry has that kind of complex pricing I doubt many registrars would want to deal with them ..

I wouldn't say that. For a registry, we developed a similar extension (actually, 
it is a pseudo object) in the context of a promotion system. By using it, the 
registrar can inquire whether a given promotion code is valid as such, has been 
consumed, the validity period of the promotion, the purpose (create/renew) and 
the resulting (lowered) price. And to my knowledge, it is actually used.

The only problem I see with such an extension are promotional models of 
registries that depend on some total numbers, (e.g. you get some rebates if you 
register more than x domains/month).

> And EPP really isn't the best way to communicate pricing

Why, and what is the better way?

By the way, maybe just as an inspiration ;-) -- I once had the idea of an 
extension that allows the reporting of the "total cost of ownership" of a 
domain, i.e. the book entries of the create/transfer/renews (and maybe other 
charged operations). But for various reasons, I did not follow up that matter. 
One reason was that I don't know whether there is actually a use case for this 
on the registrar side.

Regards,

Klaus