Subject: requirements draft version 06

From: "Xipeng Xiao" <[email-masked]>
Date: Sun, 29 Jun 2003 16:05:34 -0700

Hi there,
 
The requirements draft has been updated.  The changes made in this version are:
 
1. Added a subsection on checksum handling
 
4.1.4.  Validation of PW-PDU
 
   Most L2 frames have a checksum field to assure frame integrity. Every
   PWE3 service MUST specify whether the frame's checksum should be
   preserved across the PW, or should be removed at the ingress PE and
   then be re-calculated and inserted at the egress PE. For protocols
   such as ATM and FR, the checksum covers link-local information such
   as the circuit identifiers (e.g. FR DLCI or ATM VPI/VCI). With PWE3,
   the two ACs can have different circuit identifiers. Therefore, it
   would be more efficient to remove and recalculate the checksum.
 
2. Added a subsection on differentiating payload type
 
4.1.5.  Conveyance of Payload Type Information
 
   Under some circumstances, it is desirable to be able to distinguish
   PW traffic from other types of traffic such as IPv4 or IPv6 or OAM.
   For example, if ECMP is employed in a PSN, this additional
   distinguishability can be used to reduce the chance that PW packets
   get misordered by the load balancing mechanism. Some mechanism SHOULD
   provide this distinguishability if needed.  Such mechanism MAY be
   defined in the PWE3 WG or other WGs.
 
3. Section 5.2 and 5.3 are reorganized. There is no change in substance.  All discussions related to handling native maintenance messages (from the CEs) are now in section 5.2.  Section 5.3 is dedicated to discussing "PE-initiated maintenance messages" that are triggered by fault etc (without the presence of native maintenance messages from the CEs).  
 
The draft can be accessed at the following link before it is officially posted: http://www.cse.msu.edu/~xiaoxipe/pwe3/draft-ietf-pwe3-requirements-06.txt
 
thanks,
 
XiPeng

---

From: Danny McPherson <[email-masked]>
Date: Mon, 30 Jun 2003 06:18:17 -0600

Folks,
Consider today the start of the two week last call *on these changes* to the
Requirements document.  Last call ends July 14.

-danny

On 6/29/03 5:05 PM, "Xipeng Xiao" <[email-masked]> wrote:

> 3. Section 5.2 and 5.3 are reorganized. There is no change in substance.  All
> discussions related to handling native maintenance messages (from the CEs) are
> now in section 5.2.  Section 5.3 is dedicated to discussing "PE-initiated
> maintenance messages" that are triggered by fault etc (without the presence of
> native maintenance messages from the CEs).
> 
> The draft can be accessed at the following link before it is officially
> posted: 
> http://www.cse.msu.edu/~xiaoxipe/pwe3/draft-ietf-pwe3-requirements-06.txt
> 
> thanks,
> 
> XiPeng
> 
>