Subject: RE: RE: Is PWE a layer?

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 3 Jun 2003 08:23:07 -0400

> -----Original Message-----
> From: Mark Seery [mailto:[email-masked]] 
> Sent: Saturday, May 31, 2003 12:10 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: RE: [PWE3] RE: Is PWE a layer?
> 
> 
> 
> --- "Thomas D. Nadeau" <[email-masked]> wrote:
> [SNIP]
> 
> >> I am totally in favor of this approach. In fact,
> I have been advocating an evolutionary approach for
> over 
> a year now that includes lots of tools and techniques,
> not any single one. <<
> 
> Tom, that seems like a constructive position to take,
> thanks for offering that.
> 
> That being the case, how do you feel about Dave's
> suggestion of the following:
> 
> "1) We require a mechanism to distinguish OAM flows in
> PWs. The discussion is moving in a direction whereby
> there is a requirement to support multiple flows or 
> combinations of the same (LSP-PING, Y.1711, other) depending 
> on operator sensibilities.

	I don't think that we need to define
more than one mechanism for the reasons I have 
explained my my prior posting.  My customers certainly 
don't want more than one mechanism.  Also, before any
conclusion is drawn, I suggest asking the WG for
consensus on such a decision.

	--Tom

> 2) The mechanism needs to work and have useful OAM 
> characteristics (aka fate sharing) in the presence of all 
> known (or alluded to) ECMP mechanisms (which I believe 
> uniquely impact PWs over MPLS unless folks have bizzare plans 
> for L2TPv3 ;-). This means no reserved labels or appearance 
> as an IP packet directly as MPLS/PW payload for any OAM 
> tools, or aliasing as an IP packet.
> 
> IMHO this pushes us directly into the MPLS PID space
> as the only tractable compromise solution that meets
> the criteria above (we needed more header bits
> somewhere and it has to be somthing new :-( ). It
> complicates life as PW control words now pretty much
> become mandatory.
> 
> This has a number of benefits as it can also apply to
> MPLS as a layer independent of the PW application, so
> it would appear that both MPLS and PWs in general have
> a mechanism for muxing OAM (and possibly control)
> flows with payload.
> 
> So the above being said, some practical steps that
> facilitate getting to your proposal  are:
> 
> 1) Agree on the above requirements
> 2) Devise a converged MPLS/PW PID approach that
> permits multiple OAM tools to be employed over PWs and
> LSPs
> 3) Get the requisite missing PIDs from IANA for tools
> we wish to have as candidiates "
> 
> -Mark
> 
>

---

From: Mark Seery <[email-masked]>
Date: Tue, 3 Jun 2003 09:06:39 -0700 (PDT)

It was suggested to me that it would be advisable to
repost Dave Allan's suggestion under a different
subject line as many people have stopped listening to
the is PWE a layer thread.

So here it is again....

Comments please.

Mark

Dave's proposal:

1) We require a mechanism to distinguish OAM flows in
PWs. The discussion is moving in a direction whereby
there is a requirement to support multiple flows or
combinations of the same (LSP-PING, Y.1711, other)
depending on operator sensibilities.

2) The mechanism needs to work and have useful OAM
characteristics (aka fate sharing) in the presence of
all known (or alluded to) ECMP mechanisms (which I
believe uniquely impact PWs over MPLS unless folks
have bizzare plans for L2TPv3 ;-). This means no
reserved labels or appearance as an IP packet directly
as MPLS/PW payload for any OAM tools, or aliasing as
an IP packet.

we wish to have as candidiates