Subject: RE: PWE Service interworking

From: "Jack Pugaczewski" <[email-masked]>
Date: Thu, 5 Jun 2003 06:38:45 -0500

Neil's comments are right on the money - literally.  Any convergence
solution must address the service interworking issue.  Now is the time for
manufacturers to recognize this and take appropriate design action.  It will
not be to the manufacturers, nor carriers advantage to discover this once
equipment is brought into the carrier's lab.

PJMWBGJJREGTATALDBJHJHSLDHGSDWJAMY

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: Thursday, June 05, 2003 3:30 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [PWE3] PWE Service interworking
>
>
> Eric,
> > Shahram> Regarding Service interworking I believe the simplest and
> > Shahram> most logical model is to do service interworking with MPLS
> > Shahram> on both IWFs.
> >
> > Fortunately, "service interworking with MPLS" is not possible
> > at the current
> > time  as there  is  such  thing (at  least  not in  the
> > IETF)  as an  "MPLS
> > service".  And hopefully things will stay that way.
> NH=> I can understand why you might say this.....and I can
> certainly see its
> a good way to keep market control ;-)
> >
> > Shahram> The  advantage is  that each  PE needs  to support
> > a maximum  of N
> > Shahram> service interworking functions (N is all known L2
> > protocols). While
> > Shahram> your  proposed   model  requires  N   square
> > service  interworking
> > Shahram> functions to be supported in a single PE.
> >
> > There  are certain  theoretical  advantages  to having  a
> > sort of  "generic
> > service"  to/from which  all other  services could  be
> > mapped.
> NH=> It's not theoretical...and its also about trying to get away from the
> notion that 'technology-service'....that leads to overlaid stovepipes.  If
> we have a common MPLS core to which we can interwork FR/ATM (with maybe
> ethernet access) it will significantly reduce our capex/opex.  If
> we have to
> run parallel networks (which is effectively what you are
> advocating) then we
> won't see those capex/opex savings.  Remember, there are many large
> operators out there with hugh FR/ATM network deployments who are
> looking to
> where the next generation equipment will be.  All vendors show
> MPLS in this
> space.  But it will have to be the right type of MPLS.
>
> I can't speak for other operators but we want to have 3 core modes - cnls,
> co pkt-sw and co cct-sw.  They all do different jobs and they are all
> required in our view.  What we don't want is several different
> technologies
> effectively doing the same job.  So functional convergence of technologies
> *within* each mode makes a great deal of technical and business sense.  If
> for whatever reason you find this rationale is unpalatable then
> OK, but I do
> think it has great merit if one can look at the issues dispassionately.
>
> regards, Neil
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Mark Seery <[email-masked]>
Date: Thu, 5 Jun 2003 07:42:19 -0700 (PDT)

Hi Neil,

--- [email-masked] wrote:
[SNIP]
>> I can't speak for other operators but we want to
have 3 core modes - cnls, co pkt-sw and co cct-sw.
They all do different jobs and they are all required
in our view.  What we don't want is several different
technologies effectively doing the same job.  So
functional convergence of technologies *within* each
mode makes a great deal of technical and business
sense. <<

ms=> WRT this issue, I am not sure I understand the
point you are making. 

For example, if an equipment operator was to implement
the following:

CE--FR--PE--FR/PW/PSN--PE-FR-IWF-ATM-CE

Where the FR-IWF-ATM step was implemented in the same
PE, why that would lead to:

-Parallel networks
-Lack of functional convergence

If the problem is that MPLS is not perceived as truly
CO-PKT-SW, then that of course is a problem, but
orthogonal to this particular issue?

What exactly about this approach does not get you
where you need to be?

I think expanding on your initial statement would aid
our understanding greatly.

Thanks,
Mark