Subject: Virtual ATM Networks over IP/MPLS(draft-ietf-pwe3-atm-encap-01.txt)

From: Raj Sarkar <[email-masked]>
Date: Thu, 26 Jun 2003 15:59:06 -0700

Hi All,

This question is regarding the draft-ietf-pwe3-atm-encap-01.txt which is
still a working document
of the pwe3 group.

                 -------
--------                              --------              --------
                 |                 |
|                     |
|                     |              |                    |
   ATM a )               O------OOOOOOOOOOOOOOOOOOOOOO----
O                  ( ATM b
                          lport A             VPC Terminatio  to
PN Tunnel to VPC Term         lport B
                                   |
|                     |
|                      |              |                   |
                 -------
--------                               --------               -------

For simplicity i am assuming that the PN Tunnel is an MPLS LSP which
traverses over an MPLS
core network.

Now i want ATM Network a to talk to ATM Network b even without it being
aware that the
cells are travelling over an Non - ATM Network. Hypothetically, if we
have two logical ports
as in the diagram with signalling channels on them,  for the ATM Network
it would be like

                            lport A  -----(logical link) ------- lport B

Hence, we can ideally tunnel signalling as well over the MPLS LSP. Why
is this not a part of the
working draft?

It actually makes the signalling interworking with MPLS much simpler in
case of an ATM-MPLS
-ATM netowrk. The administrator just needs to create two logical ports
on the CE. Now the PE
adds a LSP which maps the logical ports (VP Tunnels) VPI to an LSP. Now,
following the draft
recommendations the ATM cells are transported over the MPLS Network as
well as the signalling packets. This will be much  simpler if we want to
create ATM Networks over MPLS.

Also, when TE comes into the picture, we should remember that whenever
we use VP Tunnels
in actual ATM Network , the individual VC guarantees are lost anyway.
For efficiency, the
PE can add an LSP with different diffserv codepoints. So, the CE can
create CBR Logical ports,
VBR Logical ports with CBR,VBR Traffic respectively and map it to an
EF Queue or AF Queue
in the PE Router.

Hence, using the following approach we can do PNNI Tunelling across the
MPLS Network and
create virtual ATM Networks.

Thanks,
Raj Sarkar

---

From: Mustapha Aissaoui <[email-masked]>
Date: Fri, 27 Jun 2003 09:27:00 -0400

Raj,
the ability to model a LSP as a virtual link and to run PNNI routing
and signaling control channels is already specified in the ATM Forum
for ATM-MPLS network interworking. This specification allows the
model below but does not even require VPCs.

This document is currently in straw ballot and its title is:
str-cs-atmmpls-01.01

Regards,
Mustapha.
-------------
Raj Sarkar wrote:

> Hi All,
>
> This question is regarding the draft-ietf-pwe3-atm-encap-01.txt
> which is still a working document
> of the pwe3 group.
>
>                  -------
> --------                              --------
> --------
>                  |                 |
> |                     |
> |                     |              |                    |
>                    lport A             VPC Terminatio  to PN
> Tunnel to VPC Term         lport B
>                                    |
> |                     |
> |                      |              |                   |
>                  -------
> --------                               --------
> -------
>
> For simplicity i am assuming that the PN Tunnel is an MPLS LSP
> which traverses over an MPLS
> core network.
>
> Now i want ATM Network a to talk to ATM Network b even without it
> being aware that the
> cells are travelling over an Non - ATM Network. Hypothetically, if
> we have two logical ports
> as in the diagram with signalling channels on them,  for the ATM
> Network it would be like
>
> Hence, we can ideally tunnel signalling as well over the MPLS LSP.
> Why is this not a part of the
> working draft?
>
> It actually makes the signalling interworking with MPLS much
> simpler in case of an ATM-MPLS
> -ATM netowrk. The administrator just needs to create two logical
> ports on the CE. Now the PE
> adds a LSP which maps the logical ports (VP Tunnels) VPI to an
> LSP. Now, following the draft
> recommendations the ATM cells are transported over the MPLS
> Network as well as the signalling packets. This will be much
> simpler if we want to create ATM Networks over MPLS.
>
> Also, when TE comes into the picture, we should remember that
> whenever we use VP Tunnels
> in actual ATM Network , the individual VC guarantees are lost
> anyway. For efficiency, the
> PE can add an LSP with different diffserv codepoints. So, the CE
> can create CBR Logical ports,
> VBR Logical ports with CBR,VBR Traffic respectively and map it to
> an EF Queue or AF Queue
> in the PE Router.
>
>
> Hence, using the following approach we can do PNNI Tunelling
> across the MPLS Network and

---

From: [email-masked]
Date: Fri, 27 Jun 2003 08:52:45 +0100

Raj,

Please see some comments below.

Best regards,

Matthew

-----------------------------------------
Matthew Bocci
Office of the CTO
Alcatel Fixed Networks Division
-----------------------------------------

|---------+--------------------------->
|         |           Raj Sarkar      |
|         |           <raj_sarkar@net.|
|         |           com>            |
|         |           Sent by:        |
|         |           pwe3-admin@ietf.|
|         |           org             |
|         |                           |
|         |                           |
|         |           26/06/2003 23:59|
|         |                           |
|---------+--------------------------->
  >-------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                               |
  |        To:      [email-masked]                                                                                                 |
  |        cc:                                                                                                                    |
  |        Subject: [PWE3] Virtual ATM Networks over IP/MPLS(draft-ietf-pwe3-atm-encap-01.txt)                                    |
  >-------------------------------------------------------------------------------------------------------------------------------|

Hi All,

                 -------                    --------
--------              --------
                 |                 |                   |
|                              |                     |              |
|
   ATM a )               O------OOOOOOOOOOOOOOOOOOOOOO---- O
( ATM b
                          lport A             VPC Terminatio  to PN Tunnel
to VPC Term         lport B
                                   |                   |
|                              |                      |              |
|
                 -------                   --------
--------               -------

Now i want ATM Network a to talk to ATM Network b even without it being
aware that the
cells are travelling over an Non - ATM Network. Hypothetically, if we have
two logical ports
as in the diagram with signalling channels on them,  for the ATM Network it
would be like

Hence, we can ideally tunnel signalling as well over the MPLS LSP. Why is
this not a part of the
working draft?

Matthew> What you describe is the port trunking service, which has been
discussed at length on this list in the past, but I think it was decided to
separate the encapsulations from the services that you could implement with
them. You can implement this service using encapsulations described in the
draft, depending on whether the logical link in the above diagram is the
PSN tunnel, or the Pseudo-Wire. However, there are a number of issues with
this service that make it harder to implement than might at first appear.
The first issue is that ATM traffic contracts are defined on a per-ATM
connection basis, not per-port. This makes it more difficult to apply
traffic management to pseudo-wires to support ATM QoS without
over-provisioning. There were also issues raised with regard to OAM and
fault  management.

It actually makes the signalling interworking with MPLS much simpler in
case of an ATM-MPLS
-ATM netowrk. The administrator just needs to create two logical ports on
the CE. Now the PE
adds a LSP which maps the logical ports (VP Tunnels) VPI to an LSP. Now,
following the draft
recommendations the ATM cells are transported over the MPLS Network as well
as the signalling packets. This will be much  simpler if we want to create
ATM Networks over MPLS.

Matthew> Are you descibing tunnelling VPCs across the network (one VPI per
logical port)? If so, this can be done with either the one to one or the N
to one modes.
As you correctly point out, tunnelling PNNI through the PSN is one of the
simplest ways of interworking with the ATM control plane. This can be
implemented without using a port trunking service and instead simply
mapping the PNNI routing control channel and signalling channels to
pseudo-wires, to transport the ATM control plane traffic. The ATM Forum has
been working on an approach based on this for  awhile now.

Also, when TE comes into the picture, we should remember that whenever we
use VP Tunnels
in actual ATM Network , the individual VC guarantees are lost anyway. For
efficiency, the
PE can add an LSP with different diffserv codepoints. So, the CE can create
CBR Logical ports,
VBR Logical ports with CBR,VBR Traffic respectively and map it to an EF
Queue or AF Queue
in the PE Router.

Matthew> Put this a different way, if you use VPCs in an ATM network, the
traffic contract is on the VPC. You must provision that VPC so that any QoS
guarantees made to ATM VCs on it are supported.

Thanks,
Raj Sarkar

 (See attached file: raj_sarkar.vcf)