Subject: RE: PWE Service interworking

From: Mark Seery <[email-masked]>
Date: Wed, 4 Jun 2003 16:53:53 -0700 (PDT)

Hamid,

--- Hamid Ould-Brahim <[email-masked]>
wrote:
> Eric,
> 
> [clipped]...
> 
> 
> > I think this is the same as you indicate in your
> example:
> >
> >      CE--FR--PE--FR/PW/PSN--PE-IWF-ATM-CE
> >
> 
> I think you meant something like:
>  
>       CE--FR--PE--FR/PW/PSN--PE-FR-IWF-ATM-CE
>                                 ^^

As I was the originator of this, let me comment. Yes,
what you have depicted is more accurate.

Thanks,
Mark

---

From: Mustapha Aissaoui <[email-masked]>
Date: Fri, 06 Jun 2003 09:45:24 -0400

Hamid,
see below.

Mustapha.
-----------

> Hamid Ould-Brahim wrote:

[snipped]
> > In  the special  case where  the  payload is  always IP
> > datagrams, but  the
> > ingress  and  egress  ACs  use  different data  link
> > protocols,  then  "ARP
> > Mediation" can  be used  for interworking, as  long as  there
> > is no  need to
> > provide any sort of faithful data  link emulation.  This
> > seems to be the one
> > case that might be of interest to the IETF.
> >
> 
> I have no problem with IP-only interworking approach when
> there is no available interworking function to use
> (outside the pw), particularly if most of the traffic carried
> over a PW is IP. However, my questions probably best answered
> by the providers deploying pws where both attachment circuits
> are of different protocols are:
> 
> a) Are there applications/situations where
>    even if the payload is IP, the client requires the
>    provider not to make any assumption on the payload
>    (maybe situations of regulatory scenarios)?
> 
> b) For the case where the provider has upgraded his l2 network
>    to MPLS/IP and the native l2 services are replaced with PWs,
>    can the provider guarantee/assume in all cases that the traffic
>    is always IP, or can he assumes that on any given PW there is
>    no case where both IP and non IP traffic are being sent (since
>    the upgraded service initially didn't make that assumption,
>    or maybe the provider can't tell whether it is always
>    IP since it doesn't control customer devices)?

This is the case that requires the most attention. One of my
customer's customers runs IPX and IP over the same FR connection. 
Also, some ISPs buy leased line service from a SP to connect their
POPs. Today, they use FR and ATM. That one connection can carry IP
and CLNP (for IS-IS).
Although IP might be the dominant protocol in volume, many of the
existing L2 VPN services have a small amount of other protocols.
That is why if one terminates each L2 locally at a PE in service
interworking between different link layers (e.g., FR-MPLS-Ethernet),
then there is a need to identify multiple protocols in the same PW
or LSP.

Mustapha.