Subject: Re: PWE Service interworking

From: Mark Seery <[email-masked]>
Date: Tue, 3 Jun 2003 10:25:49 -0700 (PDT)

I would be curious to know whether encaps authors
looked at existing adaptations (1490, 1483, AAL1,
AAL5) and decided they were unsuitable for some
reason.

An historical curiousity at this point (within this
organization) I guess.....

Mark

---

From: Mustapha Aissaoui <[email-masked]>
Date: Tue, 03 Jun 2003 13:34:30 -0400

Mark,
in service interworking, there is one case in which one should be
able to identify more than one protocol by inspecting the PW header.
This is the case where each L2 access layer is terminated at the PE.
A CPE running RFC 2684 (obsoletes 1483) or RFC 2427 (obsoletes 1490)
may route more than one network layer protocol, or may combine a
routed protocol and a bridged protocol in the same VC. We need to be
able to interwork with this case, similar to FR/ATM service
interworking (FRF.8.1).

It is my opinion that the proper way to addres this case is to add
multiprotocol support to the PW/MPLS PID in a way compatible with
the above RFC's.

I am planning to post a proposal on this soon.

Mustapha.
------------
Mark Seery wrote:

> It has been stated that service interworking is not
> part of the current charter. This might be
> appropriate, but I believe some consideration to this
> issue is advisable, most especially the encapsulations
> fixed on in the standards.
>
> My best current view of the situation is that PWE is
> an adaptation layer in both the IP and MPLS cases, and
> in the MPLS case, a 1:1 mapping between attachment
> circuits and unique LSPs (i.e. not the PSN LSP) is
> also provided; in the IP case PWE provides a
> multiplexing field rather than creating a new layer as
> it does in the MPLS case.
>
> As such, I have no philisophical problem with viewing
> PW as an adaptation layer that is equivalent to 1490
> over FR, 1483 over ATM, AAL1 over ATM, or AAl5 over
> ATM. Therefore, to me the test is whether PW can
> interwork with 1490, 1483, AAL1, and AAL5. This I
> imagine is mostly a function of whether the encaps are
> defined for PW in such a way that interworking is
> possible without too many contortions (0 being
> desireable)
>
> I understand the argument that by placing too much
> functionality in the PW adaption process, then PW runs
> the risk of evolving into being more than a minimalist
> adaptation - I am still study the implications of
> this, but for now my main concern is that encaps
> chosen for x/PW services enables interworking with
> existing service networks that use 1490, 1483, AAL1,
> and AAL5.
>
> So even though authors of such encaps are not bound by
> the current charter to make an assessment of this, it
> would seem to me to be valuable if they did before
> these encaps become further entrenched in service
> networks.
>
> Is this being considered already in encap
> specifications?
>
> Mark
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Eric Rosen <[email-masked]>
Date: Tue, 03 Jun 2003 13:46:09 -0400

Mark> It has been stated that service interworking is not
Mark> part of the current charter. This might be
Mark> appropriate, but I believe some consideration to this
Mark> issue is advisable, most especially the encapsulations
Mark> fixed on in the standards.

To head  off the start of  another long, useless, and  in-bred thread, could
you start  by offering a  precise definition of "service  interworking"?  In
your answer, please do not  refer to any document whose designation consists
of a letter  followed by a period followed by a  sequence of numbers.  Also,
please do not use the word "layer" in your answer.

Mark> I would be curious to know whether encaps authors
Mark> looked at existing adaptations (1490, 1483, AAL1,
Mark> AAL5) and decided they were unsuitable for some
Mark> reason.

Those existing  adaptations are for  a completely different purpose,  so I'm
not sure just what you're asking.