Subject: RE: PWE Service interworking

From: "Thomas D. Nadeau" <[email-masked]>
Date: Sat, 7 Jun 2003 08:32:13 -0400

I think you need to clarify what "end to end"
means. In the way of PWE/MPLS I believe it means
PE-PE imposition/disposition points. 

	--Tom

> Sorry to interrupt your very informative discussions, but I 
> have a question. In the case of the MPLS (which is our 
> topic?) my understanding is that OAMs are always end-to-end? 
> "Segment" OAMs similar to ATM can be created for MPLS simply 
> by stacking a new MPLS header?
> 
> Thanks for any clarification
> Zhi
> 
> 
> > -----Original Message-----
> > From: Shahram Davari [mailto:[email-masked]]
> > Sent: Thursday, June 05, 2003 3:56 PM
> > To: 'Mark Seery'; Jack Pugaczewski
> > Cc: [email-masked]
> > Subject: RE: [PWE3] PWE Service interworking
> > 
> > 
> > Mark,
> > 
> > 1) Each layer should have segment OAM mechanism that applies
> > only to that layer.
> > 2) End-to-end OAM at each layer corresponds to the 
> > terminating points of that layer.
> > 
> > -Shahram
> > 
> > >-----Original Message-----
> > >From: Mark Seery [mailto:[email-masked]]
> > >Sent: Thursday, June 05, 2003 3:48 PM
> > >To: Jack Pugaczewski
> > >Cc: [email-masked]
> > >Subject: RE: [PWE3] PWE Service interworking
> > >
> > >
> > >--- Jack Pugaczewski <[email-masked]> wrote:
> > >> Segment and End-to-End OAM are utilized on an every
> > >> day basis and a
> > >> strategic part of the fault isolation process.  More 
> specifically, 
> > >> the ability to generate an End-to-End at an intermediate
> > >> node is essential.
> > >> This allows the client (or client application) to
> > >> initiate the request to a
> > >> single element management system.
> > >> 
> > >> PJMWBGJJREGTATALDBJHJHSLDHGSDWJAMY
> > >
> > >Thanks Jack,
> > >
> > >1) Is it important that every layer be able to do a
> > >segment OAM on every segment, or just the segments
> > >that logically belong to that layer (i.e. as
> > >delineated by access points of that layer)? For
> > >example, in the following network:
> > >
> > > 1      2        3    4     5      6        7         
> > >CE----ATM_SW-----PE----P----PE----ATM_SW----CE
> > >
> > >From the perspective of the ATM layer (assume VCC, no
> > >VPC), Is a segment between 2 and 6 or are 2-3, 3-4,
> > >4-5, and 5-6 also considered segments (from the
> > >perspective of your requirements as an operator).
> > >
> > >2) When an end-to-end OAM is initiated from an
> > >intermediate node, what is considered end-to-end? For 
> example, in the 
> > >following network:
> > >
> > >
> > > 1      2        3    4     5      6        7         
> > >CE----FR_SW-----PE----P----PE----ATM_SW----CE
> > >
> > >If an end-to-end OAM is initiated at "6" towards the direction of 
> > >"1", where would you expect the OAM to terminate/take action?
> > >
> > >Thanks,
> > >Mark
> > >
> > >
> > >_______________________________________________
> > >pwe3 mailing list
> > >[email-masked]
> > >https://www1.ietf.org/mailman/listinfo/pwe3
> > >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> > 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Mark Seery" <[email-masked]>
Date: Sat, 7 Jun 2003 16:50:03 -0700

Hi Zhi,

Imagine a network:

         |----------------------------|

               |----|-----|-----|      TE COS = Gold

CE1----PE1----P1----P2----P3----P4----PE1----CE2

There are two end-to-end OAMs that may be desireable in this network:

1) PE1--PE2 (the user plane for the LDP-LDP connection between PE1 and PE2)
2) P1-P4

If you take the layer between P1 and P4 and add a label, you do not reveal
the segments you obfiscate them by creating another "layer". The segments
P1-P2, P2-P3, and P3-P4 would ideally be treated via special segment OAMs,
and the end-to-end OAM between P1 and P4 would be handled by a different
type of OAM, and end-to-end OAM.

With PW, labels are used to represent attachment circuits (essentially as a
mux field), creating another Label push:

       |--------------------------------|

         |----------------------------|

               |----|-----|-----|

CE1----PE1----P1----P2----P3----P4----PE1----CE2

Creating another End-to-End OAM, the discussion then becomes what is the
termination points of this "layer". If you view PW as just a mux function,
and you create a mux field rather than pushing another label, then the
network looks like this:

 |---------------------------------------------|

         |----------------------------|

               |----|-----|-----|      TE COS = Gold

CE1----PE1----P1----P2----P3----P4----PE1----CE2

However, I suspect that the label push was used as automating the way a mux
indication is assigned to an attachment circuit. Perhaps an alternative
solution may have been to use signaling to indicate the relationship between
mux numbers and attachment circuits, and then use a mux field and not push a
label.

if you believe the OAM needs to flow to a different point in the PE system
because the PW logic is implemented in a different part of the system, then
you are back to this:

       |--------------------------------|

         |----------------------------|

               |----|-----|-----|

CE1----PE1----P1----P2----P3----P4----PE1----CE2

Which brings us back to the old conversations (described previously as
"useless" and "in-bred") about what is a layer.

Mark

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Lin,
Zhi-Wei
Sent: Friday, June 06, 2003 5:52 AM
To: 'Shahram Davari'; 'Mark Seery'; Jack Pugaczewski
Cc: [email-masked]
Subject: RE: [PWE3] PWE Service interworking

Hi all,

Sorry to interrupt your very informative discussions, but I have a question.
In the case of the MPLS (which is our topic?) my understanding is that OAMs
are always end-to-end? "Segment" OAMs similar to ATM can be created for MPLS
simply by stacking a new MPLS header?