Subject: RE: status signalling of MPLS PW state

From: Mark Seery <[email-masked]>
Date: Tue, 10 Jun 2003 18:02:35 -0700 (PDT)

Thanks Hamid.

I agree as a general principle it is good to know why
an error has occurred. But in mulling this over since
I first wrote it, it occurs to me that it might depend
on where/why the error is communicated.

For example, the full link error information could be
communicated via the management plane - if an operator
really needs to know. I guess the real question is why
is the control plane being asked to communicate this
information from one LDP peer to the other. Is it
because it expects the LDP peer to take some action?
If so, then simply knowing there has been an
error+forwarding status might be enough. If the extra
information can not be used by the control plane, then
it probably doesn't make sense to carry it around, we
are just complicating the implemenation.

Bottom line is I am not sure I understand what the
intended consequences/actions are of the LDP peer
receiving this information, so now not sure what is
sufficient information or not.

Perhaps Luca could give some background, or perhaps it
is simply an implementation decision what to do with
the new knowledge that the other end of a PW has
experienced a failure.

mark

--- Hamid Ould-Brahim <[email-masked]>
wrote:
> Mark,
> 
> > 
> > In addition, I would be interested to know if
> operators would like
> > information on the type of link error, and if yes,
> maybe a field where
> > vendors can place a description code.
> > 
> 
> I agree. It is beneficial to know the nature of the
> error. Something
> like diagnostic code-description needs to be
> supported.
> 
> Hamid.
>

---

From: Luca Martini <[email-masked]>
Date: Wed, 11 Jun 2003 10:57:45 -0600

Hamid Ould-Brahim wrote:
> Mark,
> 
>  >
>  > In addition, I would be interested to know if operators would like
>  > information on the type of link error, and if yes, maybe a field where
> I agree. It is beneficial to know the nature of the error. Something
> like diagnostic code-description needs to be supported.
> 
> Hamid.
> 
Let's make the distinction between reporting an error  to the operator , and 
the need to send the specific cause in the protocol.
There is no doubt that the nature of the error has to be reported to the 
operator, but the specifics need only be reported by the PE that is 
experiencing the problem.

So for example , as PW might be down because the local PE is out of buffer 
memory. The message to the remote PE can simply be     0x0001 - Pseudo Wire Not 
Forwarding.
Yet the message sent, by the local PE, as a SNMP trap or to syslog, can be 
"Pseudo Wire Not Forwarding out of buffer memory".

There is an assumption here that some operator will monitor both sides.

Luca