Subject: RE: PWE Service interworking

From: Mark Seery <[email-masked]>
Date: Wed, 4 Jun 2003 08:38:59 -0700 (PDT)

Sharam,

I agree this is simpler and also more technically
accurate/and more reflective of current interworking
standards by the inclusion of "Q.922". So happy to go
with your model.

Question for you though, is it interworking to MPLS
that is required, or interworking to PW that is
required.

I would also not that at one of the IWFs
RFC1483/RFC1490 interworking should be an option, what
would you suggest in that regard?

Also I assume you don't ever see MPLS as being as
service interface from your response?

And do you see this model working also for Ethernet to
ATM/FR interworking?

Thanks,
Mark
 
--- Shahram Davari <[email-masked]>
wrote:
> Mark,
> 
> Regarding Service interworking I believe the
> simplest and
> most logical model is to do service interworking
> with MPLS
> on both IWFs. Assuming (PL= Payload), the following
> figure shows an
> example of what I think is a proper AT-MPLS-FR
> service interworking:
> 
> 
> CE--------PE-------P--------PE---------CE
>      PL        PL      PL        PL
>     AAL5       X       X        Q.922
>     ATM       MPLS    MPLS       FR
> 
> Both PEs do service interworking. One does ATM-MPLS
> service
> interworking and the other one does FR-MPLS service
> interworking.
> 
> The advantage is that each PE needs to support a
> maximum of N service
> interworking functions (N is all known L2
> protocols). While your 
> proposed model requires N square service
> interworking functions to be
> supported in a single PE.
> 
> Yours,
> -Shahram

---

From: Eric Rosen <[email-masked]>
Date: Wed, 04 Jun 2003 13:47:51 -0400

Shahram> Regarding Service interworking I believe the simplest and
Shahram> most logical model is to do service interworking with MPLS
Shahram> on both IWFs. 

Fortunately, "service interworking with MPLS" is not possible at the current
time  as there  is  such  thing (at  least  not in  the  IETF)  as an  "MPLS
service".  And hopefully things will stay that way.

Shahram> The  advantage is  that each  PE needs  to support  a maximum  of N
Shahram> service interworking functions (N is all known L2 protocols). While
Shahram> your  proposed   model  requires  N   square  service  interworking
Shahram> functions to be supported in a single PE. 

There  are certain  theoretical  advantages  to having  a  sort of  "generic
service"  to/from which  all other  services could  be mapped.   However, if
FR/ATM interworking  on the  one hand  and ARP Mediation  on the  other hand
cover 99% of the  space, there doesn't really seem to be  much need for this
generic service.

---

From: Mark Seery <[email-masked]>
Date: Wed, 4 Jun 2003 11:00:39 -0700 (PDT)

Hi Sharam,

A follow-up below,
Mark

> interworking and the other one does FR-MPLS service

MS=> From a logisitical perspective, does this
approach require the common "X" payload to be
(re)defined, and then does it replace existing encap
definitions - my assumption is that it would. Note:
not making a value judgement, just asking what the
path forward would look like.
 
> supported in a single PE.

Understood, thanks for pointing out.
Mark