Subject: WG Last Call: draft-ietf-pwe3-control-protocol-04.txt

From: Danny McPherson <[email-masked]>
Date: Thu, 23 Oct 2003 09:57:50 -0600

Folks,
Please consider today the start of WG Last Call for
draft-ietf-pwe3-control-protocol-04.txt.  The Last
Call will end on Thursday, November 6.

Please post comments on this draft to the WG mailing
list or authors as soon as possible.

Thanks!

-danny & Stewart

[snip]

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Fri, 24 Oct 2003 13:28:02 -0400

Earlier this week I posted a comment on the L2VPN mailing list that has implications for the control draft. 

The control draft assumes that only the ingress and egress PE inspect the PW label. However, in several cases that may  not be true. It is possible that there are intermediate nodes that terminate one PSN tunnel, make a forwarding decision based on the PW label and forward the traffic over another PSN tunnel towards the destination.

Section 5.5 of draft-ietf-l2vpn-signaling-00 explains how this could work. However, as I explained in my earlier email, I think the proposed procedure has serious short-comings.

In my view, the fundamental problem is that both PWid FEC and Generalized ID FEC contain parameters such as VPN Id, Attachment Circuit Id etc. This is fine if ingress and egress PEs are directly connected, but not if there are intermediate hops. By using such application-specific parameters instead of regular IP addresses, it becomes impossible to utilize standard protocols and mechanisms for topology discovery and route determination.

In my email earlier this week I sugested that this problem can be solved by adding an Explicit Route Object to the LDP Label Mapping message, indicating the IP addresses of ingress and egress PE. There may be other and better solutions to this problem. In any case, I would prefer it if we could hold off on progressing the control draft until this problem of intermediate nodes is solved.

Peter

> -----Original Message-----
> From: Danny McPherson [mailto:[email-masked]]
> Sent: Thursday, October 23, 2003 11:58 AM
> To: [email-masked]
> Subject: [PWE3] WG Last Call: draft-ietf-pwe3-control-protocol-04.txt
> 
> 
> 
> Folks,
> From: [email-masked]
> Date: Mon Oct 13, 2003  1:57:00 PM America/Denver
> To: IETF-Announce: ;
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-pwe3-control-protocol-04.txt
> Reply-To: [email-masked]
> 
> A New Internet-Draft is available from the on-line Internet-Drafts  
> directories.
> This draft is a work item of the Pseudo Wire Emulation Edge to Edge  
> Working Group of the IETF.
> 
> 	Title		: Pseudowire Setup and Maintenance using LDP
> 	Author(s)	: L. Martini, N. El-Aawar, E. Rosen
> 	Filename	: draft-ietf-pwe3-control-protocol-04.txt
> 	Pages		: 31
> 	Date		: 2003-10-13
> 	
> Layer 2 services (such as Frame Relay, ATM, ethernet) can be
> 'emulated' over an IP and/or MPLS backbone by encapsulating the layer
> 2 PDUs and then transmitting them over 'pseudowires'.  It is also
> possible to use pseudowires to provide SONET circuit emulation over
> an IP and/or MPLS network. This document specifies a protocol for
> establishing and maintaining the pseudowires, using extensions to
> LDP.  Procedures for encapsulating layer 2 PDUs are specified in a
> set of companion documents.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-pwe3-control-protocol- 
> 04.txt
> 
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the  
> message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the  
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-pwe3-control-protocol-04.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-pwe3-control-protocol-04.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: Sasha Vainshtein <[email-masked]>
Date: Sun, 26 Oct 2003 13:05:04 +0200

Eric and all,
Please see inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> From: Eric Rosen [mailto:[email-masked]]
> Sent: Friday, October 24, 2003 8:50 PM
> To: Busschbach, Peter B (Peter)
> Cc: 'Danny McPherson'; [email-masked]
> Subject: Re: [PWE3] WG Last Call: 
> draft-ietf-pwe3-control-protocol-04.txt 
> 
> 
> 
> The  issue of  concern in  L2VPN is  how to  do the  
> signaling when  PWs get spliced together. 
>
... snipped ...
> 
> I don't see how this situation justifies holding up the 
> approval of the PWE3
> control spec.  Should  it turn out at some later time  that 
> L2VPN develops a
> solution which requires some extension of the PWE3 control 
> mechanisms, those
> extensions can be developed at that time. 
> 
[Sasha] I agree wholeheartedly.