Subject: ITU-T FR draft

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 12 Nov 2003 03:49:38 +0200

Dear WG chairs and everyone, 

I would like to re-iterate my suggestion that the IETF and
ITU-T SG17 work together to produce a single harmonized 
FR draft.

Since SG17 has adopted the PWE3 terminology,
and there is great overlap in authors of the PWE and ITU drafts,
it should be possible to make the documents precisely identical.

This has been done before (e.g. Megaco/H.248)
and has the advantage of ensuring that there can be
no minor issues that can later crop up due to different
wording.

Y(J)S

---

From: [email-masked]
Date: Fri, 14 Nov 2003 10:01:25 -0500

The objective of the contributors to ITU-T SG17 draft Recommendation on frame relay/MPLS (X.84) is to ensure that it is aligned with regard to the terminolgy and capabilities with PWE3 draft.

Claude
> 
> From: Luca Martini <[email-masked]>
> Date: 2003/11/13 Thu PM 06:12:04 EST
> To: Yaakov Stein <[email-masked]>
> CC: Danny McPherson <[email-masked]>,  [email-masked], 
>         Jon Peterson <[email-masked]>
> Subject: Re: [PWE3] ITU-T FR draft
> 
> My understanding is that Claude ( FR editor ) is making sure this is the 
> case today.
> 
> What is the problem Yakov ?
> 
> Luca
> 
> Danny McPherson wrote:
> 
> >
> > I think this is fine, so long as the IETF document is aligned
> > with the goals and consensus of the WG and the IETF.  Do you
> > foresee any potential reasons why this might not be the case?
> >
> > -danny
> >
> >
> > On Nov 11, 2003, at 6:49 PM, Yaakov Stein wrote:
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> >
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 19 Nov 2003 10:59:48 +0200

>From Claude's answer we see the problem.

I agree that the terminology used in X.84 is the same
as that we use in PWE3, but the document I have seen
is in form and wording quite different from the IETF
one.

My fear is that two similar but not identical documents
may hide subtle differences which will haunt us later.

Y(J)S

-----Original Message-----
From:	[email-masked] [mailto:[email-masked]]
Sent:	ו 14/11/2003 17:01
To:	Luca Martini; Yaakov Stein
Cc:	Danny McPherson; [email-masked]; Jon Peterson
Subject:	Re: Re: [PWE3] ITU-T FR draft

Claude

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 19 Nov 2003 11:09:03 +0200

Yaakov, Claude and all,
My understanding of the situation (which can be incomplete or even
incorrect) is that the present X.84 text fixes at least one bug that has
been found in draft-ietf-pwe3-frame-relay-01.txt (the packet lenth
definition), and the intention is to synchronize the PWE3 FR draft with X.84
once the latter is finalized (to avoid multiple intermediate revisions).
If this understanding is correct, IMO, the two documents have a very good
chance to define exactly the same "on the wire" behavior. In fact, skipping
intermediate revisions of the PWE3 FR draft can be even seen as facilitating
this objective.
Hopefully these nores will be helpful.
----------------------------------------------------------------------------
--------
With best regards,
                          Sasha Vainshtein
email:   [email-masked] <mailto:[email-masked]> 
phone:  +972-3-7659993 (office)
            +972-8-9254948 (home)
            +972-58-674833 (cellular)

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Wednesday, November 19, 2003 11:00 AM
To: [email-masked]; Luca Martini
Cc: Danny McPherson; [email-masked]; Jon Peterson
Subject: RE: Re: [PWE3] ITU-T FR draft

Y(J)S

-----Original Message-----
From:   [email-masked] [ mailto:[email-masked]
<mailto:[email-masked]> ]
Sent:   ו 14/11/2003 17:01
To:     Luca Martini; Yaakov Stein
Cc:     Danny McPherson; [email-masked]; Jon Peterson
Subject:        Re: Re: [PWE3] ITU-T FR draft

The objective of the contributors to ITU-T SG17 draft Recommendation on
frame relay/MPLS (X.84) is to ensure that it is aligned with regard to the
terminolgy and capabilities with PWE3 draft.

Claude
> >> no minor issues that can later crop up due to different
<https://www1.ietf.org/mailman/listinfo/pwe3> 
<https://www1.ietf.org/mailman/listinfo/pwe3>

---

From: [email-masked]
Date: Wed, 19 Nov 2003 10:33:39 -0000

> If this understanding is correct, IMO, the two documents have a very

> good chance to define exactly the same "on the wire" behavior.

If the intention is to make both documents essentially identical (though they may have slightly different wording), why do we need them both? Why not just standardise one (where isn't important) and cross-reference it where necessary?

> The objective of the contributors to ITU-T SG17 draft Recommendation

> on frame relay/MPLS (X.84) is to ensure that it is aligned with

> regard to the terminolgy and capabilities with PWE3 draft.

Equally then, is the objective of the contributors to the PWE3 frame relay/MPLS draft to ensure that it is aligned with terminology used by the ITU? e.g. the terminology used in G.805 to describe transport networks?

Richard