Subject: Re: PW-CE2-E

From: Wei Luo <[email-masked]>
Date: Wed, 12 Nov 2003 09:48:53 -0800

Yaakov,

Could you help us understand how different this is from renaming "CE" to "PE" 
and "PE" to "P" from the functionality point of view (excluding the 
administrative boundary issue for a second)?

Thanks,

---Wei

Yaakov Stein wrote:
>  From the questions people have asked after the presentation,
> I have realized that I may have been misunderstood.
> (except, of course, by people who read the draft ...)
> 
> My suggestion is to move the IWF only,
> not the PE signaling function,
> to the CE location.
> 
> The CE does not start participating in
> the PW setup - rather like the decoupled PE model
> in VPLS.
> 
> The new technical feature (the 5 percent I was talking about)
> is the ability to send a "light MPLS" packet
> from the CE to the PE. This packet contains the payload
> (of whatever type), the CW and the "inner" label.
> (See also Sasha's comments on this label.)
> 
> The present breed of MPLS edge routers do not understand
> what to do with such packets, and require the CE to use full IP
> encapsulation. So we end up with XoIPoMPLS instead of XoMPLS PWs.
> Albeit, this may be a subject for the MPLS WG,
> but the motivation is PWE.
> 
> Due to the state of the architecture draft,
> I withdraw my request to modify it.
> The question remains as to whether we need an additional
> draft to explain this case.
> 
> 
> Y(J)S
>

---

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 12 Nov 2003 13:00:31 -0500

Wei,
well the service boundary dictates everything here. I interpret what
Yaakov is looking for as a new attachment circuit type which uses
the shim header as the identifier. How this label is assigned
depends on the type of service being sold by the service provider.
It could be assigned by the SP and then gets swapped in the PE to a
PW lable (keep a 2-label stack model). Or it can be distributed
between the CE and the PE does not mess with it and instead adds a 2
label stack to it (3 label stack model with the bottom label treated
as a L2 identifier).

Mustapha.
-----------

Wei Luo wrote:
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3