Subject: RE: PW functional model and its OAM [was: FCS retention in PWE3]

From: "David Allan" <[email-masked]>
Date: Mon, 5 Jan 2004 10:07:16 -0500

Hi Peter:

<snipped>
> Yes, I believe VCCV protects against swapped or mismerged 
> LSPs. There are two cases:
> 
> Wrong PW Label:
> When LSP Ping is used over the PW, the original PW-id FEC is 
> included in the message. The receiving PE will check whether 
> the FEC in the Ping message matches the original PW-id FEC. 
> It will reply accordingly. 

The caveat being that the ping implementation when transported by VCCV cares
about the incoming label (more akin to the TTL exhaust path through the
code) unlike PING implementation for LDP where simply being a viable egress
LSR for the FEC is sufficient (PHP case).
 
> Wrong PSN Label:
> To detect failures in the underlying transport LSPs, one 
> could run LSP Ping over the PSN LSPs. However, as far as the 
> PWs are concerned, VCCV would also protect against swapped or 
> mismerged PSN LSPs.  

It can detect them, but given the current state of technology, there is no
way to actually traceroute the path a PW will take over a PSN. Best you can
do now is when a PW fault is detected, traceroute all ECMP permutations in
the PSN and if a fault is found, assume they correspond (ECMP extensions to
LSP-Query were designed to close that gap a bit better...). If 'P' routers
recognized TTL exhaust of VCCV probes you could traceroute, but I don't
think you can depend on that.

If you are already doing PSN misbranching proactively via LSR self test or
FEC-CV, then presumably you have independently caught any PSN problems, and
the problem is unique to the PW layer or the PW-PSN binding (either way the
problem is local to the PE).

happy new year
Dave

<snipped to end>

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Mon, 5 Jan 2004 11:15:35 -0500

> -----Original Message-----
> From: David Allan [mailto:[email-masked]]
> Sent: Monday, January 05, 2004 10:07 AM
> To: 'Busschbach, Peter B (Peter)'; 'Peter Willis'
> Cc: [email-masked]'; [email-masked];
> [email-masked]; [email-masked]
> Subject: RE: [PWE3] PW functional model and its OAM [was: FCS 
> retention
> in PWE3] 
> 
> 
> Hi Peter:
> 
> <snipped>
> way to actually traceroute the path a PW will take over a 
> PSN.

Hi Dave,

My point was that the tools specified in VCCV do enable detection of swapped or mismerged PSN LSPs. I agree that the tools do not enable the operator to locate the exact location of the failure. However, would that be different with Y.1711? It seems to me that any case of LSP swapping or mimerging requires network-wide fault coordination and possibly additional diagnostics to locate the failure.

Happy new year,

Peter

>Best you can

---

From: "David Allan" <[email-masked]>
Date: Mon, 5 Jan 2004 11:34:30 -0500

I didn't raise the point to be obnoxious, I raised it to identify IMO a gap
that exists in the current state of the art.

cheers
Dave

> From: Busschbach, Peter B (Peter) [mailto:[email-masked]] 
> Sent: Monday, January 05, 2004 11:16 AM
> To: Allan, David [CAR:NS00:EXCH]; 'Peter Willis'
> retention in PWE3] 
> My point was that the tools specified in VCCV do enable 
> detection of swapped or mismerged PSN LSPs. I agree that the 
> tools do not enable the operator to locate the exact location 
> of the failure. However, would that be different with Y.1711? 
> It seems to me that any case of LSP swapping or mimerging 
> requires network-wide fault coordination and possibly 
> additional diagnostics to locate the failure.
> 
> Happy new year,
> 
> Peter
> 
> 
> >Best you can
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Mon, 5 Jan 2004 12:32:48 -0500

Dave,
 
I am sorry if i sounded defensive. I didn't intend to be.
 
My question is: is there any OAM tool that automatically isolates the exact location where a switch overwrites label values incorrectly? I don't think Y.1711 does that and it is not obvious to me if it can be done with some light-weight OAM protocol at all.
 
Peter

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Monday, January 05, 2004 11:35 AM
To: 'Busschbach, Peter B (Peter)'; 'Peter Willis'
Cc: [email-masked]'; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [PWE3] PW functional model and its OAM [was: FCS retention in PWE3] 

I didn't raise the point to be obnoxious, I raised it to identify IMO a gap that exists in the current state of the art.

cheers 
Dave 

> From: Busschbach, Peter B (Peter) [ mailto:[email-masked] <mailto:[email-masked]> ] 
> > From: David Allan [ mailto:[email-masked] <mailto:[email-masked]> ] 
> https://www1.ietf.org/mailman/listinfo/pwe3 <https://www1.ietf.org/mailman/listinfo/pwe3>  
>

---

From: [email-masked]
Date: Tue, 6 Jan 2004 00:20:56 -0000

Peter,
 
You are right it should not do this either.  We have to split the problem into 2 stages:  (i) automatic detection and handling (ii) on-demand diagnostics.  The former needs to be simple and 'always on', the latter can be more complex and is invoked to investigate 'why' the defect was detected in the 1st place.  
 
The automatic detection/handling function also needs to be generic (ie applies to all applications) and associated with the entity that is networked.....and that is the LSP, not the PW as that is a specific client->server adaptation function.  This should also be an obvious requirement if we consider multiple operator I/W cases where MPLS could be used, ie LSPs could apply at several levels (ie one LSP being a server layer to another LSP as a client layer) and belong to different administrations, so the OAM must be bound to the LSP....the PW adaptation function only applies between a specific pair of top-level points.
 
regards, Neil

-----Original Message-----
From: Busschbach, Peter B (Peter) [mailto:[email-masked]]
Sent: 05 January 2004 17:33
To: 'David Allan'; Busschbach, Peter B (Peter); 'Peter Willis'
Cc: Harrison,N,Neil,IKR2 R; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [PWE3] PW functional model and its OAM [was: FCS retention in PWE3] 

Dave,

 
Peter

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Monday, January 05, 2004 11:35 AM
To: 'Busschbach, Peter B (Peter)'; 'Peter Willis'
Cc: [email-masked]'; [email-masked]; [email-masked]; [email-masked]
Subject: RE: [PWE3] PW functional model and its OAM [was: FCS retention in PWE3] 

cheers 
Dave 

> From: Busschbach, Peter B (Peter) [ mailto:[email-masked]] 
> > From: David Allan [ mailto:[email-masked]]