Subject: Re: Re: PW Status negotiation procedure

From: Eric Rosen <[email-masked]>
Date: Thu, 08 Jan 2004 13:25:07 -0500

Peter> So the question  is: what good does  it do to inform PE2  that AC1 is
Peter> down, if PE2 is not able to propagate the failure indication over AC2
Peter> for lack of FDI?  

Imagine an ethernet AC  on PE1 which is connected via PW  to layer 3 routing
on PE2.  This could be useful in  order to allow PE2 to treat PE1's ethernet
AC as if it  were an ethernet directly on PE2.  Then  PE2 would need to know
if the  PE1's AC goes  down, but there  are no ethernet  failure indications
that can be relied upon. 

Peter> If PE1 detects that there is a failure, why can't it send an alarm to
Peter> the  SP's fault  management  system?  Are you  assuming  that the  SP
Peter> monitors PE2, but not PE1?  

This could well be the case; PE2 might belong to a different SP.

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Thu, 8 Jan 2004 15:36:14 -0500

> From: Eric Rosen [mailto:[email-masked]]
> Sent: Thursday, January 08, 2004 1:25 PM

> if the  PE1's AC goes  down, but there  are no ethernet  

Good point

> This could well be the case; PE2 might belong to a different SP.

Here is the problem I perceive:

According to Luca, PW Status messages have two goals:

a) for data plane fault management
b) for accounting purposes (i.e. SLA downtime measurements)

I understand the need for (a), but I think that (b) should be seen as a derivative of (a) and not as a goal in itself.

I think the need for PW Status for data plane fault management is clear. E.g. in the case of Frame Relay, there is a need for a mechanism to convey the fact that a Frame Relay PVC is inactive from the ingress PE to the egress PE. On the other hand, if ATM is emulated over PW, the situation is different. According to 5.2.3 of the ATM encapsulation draft, if the PW transports OAM cells transparently, the ingress PE should generate AIS cells if it detects a failure on an attachment circuit. Only if it doesn't support the generation of OAM cells is may use PW Status to inform the egress PE. Conclusion, the use of PW Status to convey Attachment Circuit Failures depends on the emulated protocol and the features of the Native Service Processing part of each PE.

Luca's suggestion that PW Status could also be used for SLA downtime measurements, is dangerous because it suggests that no matter what the emulated protocol is, a PE needs to send a PW Status message to its peer in case of an attachment failure. I think that is a misconception.

For SLA downtime measurements, the Service Provider (or multiple Service Providers in case a connection crosses SP boundaries) needs to know the status of the end-to-end connection. How this is done depends on the service. In case of SONET, SDH or ATM, it relies, among other things, on the detection of AIS and RDI signals at the far ends of the connection. In case of Frame Relay it relies on STATUS messages across NNIs and proprietary mechanisms within Frame Relay domains.

Therefore, the role of PW Status messages in the conveyance of Attachment Circuit Failures only serves to guarantee that end-to-end fault management works. The suggestion that the ingress PE needs to use PW Status messages to inform the egress PE of failures on attachment circuits so that a Service Provider can then poll PE2 takes too narrowly a view and is incorrect.