Subject: Liaison from ATM Forum to PWE3 WG

From: [email-masked]
Date: Thu, 15 Jan 2004 23:48:01 +0000

Stewart and Danny,

In order to maintain the technical progress in the ATM Forum, we would very
much appreciate if the IETF PWE3 WG could expedite the IANA code point
assignment for FEC 128 and FEC 129 code points and the PW status TLV code
points in draft-ietf-pwe3-control-protocol-05.txt and
draft-ietf-pwe3-iana-allocation-02.txt.

The ATM Forum is developing a specification that uses procedures contained
in these documents to establish ATM control channels in ATM-MPLS Network
Interworking. To complete the work and approve the specification, these
code points require IANA assignment.

Please advise us at your earliest convenience on the status of the code
point assignments.

Best regards,

Matthew Bocci
Chair, ATM Forum AIC Working Group

---

From: [email-masked]
Date: Tue, 20 Jan 2004 18:24:47 +0000

Thomas,

Thank you for your response. Please see below for some comments.

Matthew

|---------+--------------------------->
|         |           Thomas Narten   |
|         |           <[email-masked]|
|         |           om>             |
|         |           Sent by:        |
|         |           pwe3-admin@ietf.|
|         |           org             |
|         |                           |
|         |                           |
|         |           20/01/2004 02:38|
|         |                           |
|---------+--------------------------->
  >-------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                               |
  |        To:      Matthew BOCCI/GB/ALCATEL@ALCATEL                                                                              |
  |        cc:      Stewart Bryant <[email-masked]>, Danny McPherson <[email-masked]>, [email-masked],                         |
  |        [email-masked], [email-masked]                                                                                |
  |        Subject: Re: [PWE3] Liaison from ATM Forum to PWE3 WG                                                                  |
  >-------------------------------------------------------------------------------------------------------------------------------|

Some clarifying questions.

> code points require IANA assignment.

Do you need the code points, or do you actually need both the code
points and completion of the relevant drafts? I.e., do you not need to
also reference the two above named drafts in a normative fashion as
well, in which case, having them be Internet-Drafts is presumably a
problem?

MB> Yes, in practice we would need to reference both the code points, and
the drafts themselves in a normative way.

Also, when you say "expedite", is there a specific deadline you are
trying to meet, where not having the IANA code points is a show
stopper of some kind (and the last remaining issue blocking completion
of something, e.g., publication of a standard?) If so, it would be
helpful to know the deadline and understand the nature of it.

MB> The ATM Forum specification depends on the procedures contained in the
above mentioned drafts and cannot be approved and published until the IANA
code points are allocated, and we have an RFC number for the PWE3 control
draft. The earliest that we could start the approvals process is at the
next ATMF meeting at the end of April 2004. Meetings run on a 3 month
cycle, so if the IANA code points are not allocated until after April, we
would have to wait until the following meeting (3 months later), and so on.

Thomas

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Thomas Narten <[email-masked]>
Date: Tue, 20 Jan 2004 18:21:15 -0500

> the drafts themselves in a normative way.

What this suggests to me is that expediting the IANA assignments
doesn't really help you a whole lot. What you really want is the
document to be approved for publicatoin as an RFC (together with the
IANA assignments). (Note: normally, at RFC publication time, IANA
would assign the code points.)

Is this a correct interpretation?

> would have to wait until the following meeting (3 months later), and so on.

This is good information to know, as it suggests good milestones for
the WG to try and achieve. I'll have to defer to the chairs and WG for
comments on how close the documents are for forwarding to the IESG and
what obstacles remain.

Thomas

---

From: [email-masked]
Date: Thu, 22 Jan 2004 17:39:23 +0000

Thomas,

Your interpretation is correct.

Best regards,

Matthew

|         |           20/01/2004 23:21|
  |                                                                                                                               |
  |        To:      Matthew BOCCI/GB/ALCATEL@ALCATEL                                                                              |
  |        cc:      Danny McPherson <[email-masked]>, [email-masked], [email-masked], [email-masked], [email-masked],|
  |        Stewart Bryant <[email-masked]>                                                                                    |
  |        Subject: Re: [PWE3] Liaison from ATM Forum to PWE3 WG                                                                  |

Thomas