Subject: Applicability of PWid FEC element.

From: "Roy, Anindya (Anindya)" <[email-masked]>
Date: Wed, 24 Mar 2004 12:24:03 -0500

Hi All,

	Can the group suggest the real world applicability of PWid FEC element. 

Unless there is a common consensus on how PWids should be generated how do we ensure guaranteed convergence of the LSPs in both direction to a single PW based on the PW IDs(ignoring the PW type factor for obvious reasons) ?
Suppose PE1 signals a PWID of X1, while PWE2 signals a PWID of Y1. It is not clear to me what happens at this point, since the PWIDs don't match, does this mean both PEs keep trying for different sets of Xi and Yj till they converge ? It is not clear from draft-ietf-pwe3-control-protocol-05, how long should the PEs try in an effort to match the PWids.

Based on the above, it appears a lot of bandwidth can be wasted in an effort to achieve common convergence based on PWids.

So why not just have the all purpose Generalized FEC element type 129 ?.

Thanks 
Anindya

---

From: "Busschbach, Peter B (Peter)" <[email-masked]>
Date: Wed, 24 Mar 2004 15:39:48 -0500

Anindya,

When the PWid FEC is used, the assumption is that the operator provisions both PEs with  the PWid value that is to be used. It is not a value that is randomly chosen from some kind of PWid space.

The Generalized FEC is usually related to some kind of automatic action. E.g. Pseudo Wire suetup as a consequence of an automatic VPLS discovery procedure or PW setup as an element in end-to-end signaled ATM VC set up. Instead, PWid FEC applies if the operator "manually" establishes PWs. E.g. the operator decides to set up a PW between PE1 and PE2. He or she assigns a number (the PWid) to this PW and then provisions PE1 and PE2, indicating the involved attachment circuits, the remote PE, the PWid and additional parameters. 

Hope this helps,

Peter

> -----Original Message-----
> From: Roy, Anindya (Anindya) [mailto:[email-masked]]
> Sent: Wednesday, March 24, 2004 12:24 PM
> To: [email-masked]
> Subject: [PWE3] Applicability of PWid FEC element.
> 
> 
> Hi All,
> 
> Unless there is a common consensus on how PWids should be 
> generated how do we ensure guaranteed convergence of the LSPs 
> in both direction to a single PW based on the PW IDs(ignoring 
> the PW type factor for obvious reasons) ?
> Suppose PE1 signals a PWID of X1, while PWE2 signals a PWID 
> of Y1. It is not clear to me what happens at this point, 
> since the PWIDs don't match, does this mean both PEs keep 
> trying for different sets of Xi and Yj till they converge ? 
> It is not clear from draft-ietf-pwe3-control-protocol-05, how 
> long should the PEs try in an effort to match the PWids.
> 
> Based on the above, it appears a lot of bandwidth can be 
> wasted in an effort to achieve common convergence based on PWids.
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

---

From: "Roy, Anindya (Anindya)" <[email-masked]>
Date: Wed, 24 Mar 2004 16:24:59 -0500

Thanks for making it clear Peter.
Anindya

-----Original Message-----
From: Busschbach, Peter B (Peter) 
Sent: Wednesday, March 24, 2004 3:40 PM
To: Roy, Anindya (Anindya); [email-masked]
Subject: RE: [PWE3] Applicability of PWid FEC element.

Anindya,

Hope this helps,

Peter