Subject: RE: Proposal to Progress draft-orly-pwe3-satop-mib and draft-orly-pwe3-tdm-mib

From: "Orly Nicklass" <[email-masked]>
Date: Tue, 2 Mar 2004 07:10:49 +0200

I agree, the two issues are important and indeed the first one is
implemented as described, the second need modification in the TC
document. I addressed both below.

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]] 
Sent: Monday, March 01, 2004 15:32
To: Orly Nicklass; [email-masked]
Subject: RE: [PWE3] Proposal to Progress draft-orly-pwe3-satop-mib and
draft-orly-pwe3-tdm-mib

	A few comments. First, they are both short and sweet, which
I like. 8)   Second, Although both MIB modules state that they
fit into the existing MIB framework, and have figures that show that
they do, it is unclear to me as to how they do. For exaple, they both
seem to define their own indexing, and do not describe how this
interacts with the PW-MIB as well as the native TDM (DSx) MIBs. For
example, the way all of the existing service "glue" MIBs work is to use
the PwIndex as common index:

  pwVcEnetEntry  OBJECT-TYPE 
      SYNTAX     PwVcEnetEntry 
      MAX-ACCESS  not-accessible 
      STATUS     current 
      DESCRIPTION  
          "This table is indexed by the same index that was created  
          for the associated entry in the PW Table in the PW MIB. 
          The PwVcIndex and the pwVcEnetPwVlan are used as indexes  
          to allow multiple VLANs to exist on the same PW. 
                           
          An entry is created in this table by the agent for every  
          entry in the pwVcTable with a pwVcType of 'ethernetTagged' 
          or 'ethernet'. Additional rows may be created by the  
          operator or the agent if multiple entries are required for 
          the same PW. 
        
          This table provides Ethernet port mapping and VLAN  
          configuration for each Ethernet PW." 
   
      INDEX { pwVcIndex, pwVcEnetPwVlan } 
      ::= { pwVcEnetTable 1 } 

	This allows one to look at the PW in the PW-MIB based on the
PwIndex and then look at the pwVcType associated with that entry and
quickly know how to find either the PSN or service "glue" MIB entry
because it uses that same entry. Please make sure you use this.

	Please make sure these MIBs are aligned for configuration with
the existing MIBs.

ON_____________________________________________________

An entry in the TDM table is created in the exact same way as done in
the example provided above, however for value 'tdm'. Section 7 in the
TDM draft describes the sequence of actions, items 5 and 6 relate to the
linking of the new entry to the source entry in the PW-std MIB using the
same index pwVcIndex .

 pwVcTDMEntry OBJECT-TYPE
     SYNTAX        PwVcTDMEntry
     MAX-ACCESS    not-accessible
     STATUS        current
     DESCRIPTION
         "This table is indexed by the same index that was
          created for the associated entry in the PW Table
          (in the PW-STD-MIB).

            - The PwVcIndex.

          An entry is created in this table by the agent for every
          entry in the pwVcTable with a pwVcType of 'TDM'."

     INDEX  { pwVcIndex }

        ::= { pwVcTDMTable 1 }

 The additional indexing type objects, I referred to, are 2 pointers to
entries in other tables holding additional parameters and 1  index
linking to the native service layer. I used pointers to allow for
multiple usage of the same PW configuration parameter set. It saves time
and it complies with similar methods done in ATM and FR native service
MIBs.
____________________________________________________________

	Finally, please check the PwVcType TC in
draft-ietf-pwe3-pw-tc-mib-04.txt to make sure that the appopriate Vc
Types are defined there to support your new modules as described above.

ON_______________________________________________

In January I addressed this issue to David Z. asking  the addition of
TDM value to the PwVcType.
I checked the latest draft 04, and as I mentioned in the meeting, we do
need to add this value in in order to get the system to work properly..
The latest PwVcType reads:

PwVcType ::= TEXTUAL-CONVENTION 
     STATUS      current 
     DESCRIPTION 
        "Indicate the PW type (i.e. the carried service). 
        " 
   SYNTAX   INTEGER { 
      other(0), 
      frameRelayDlci(1), 
      atmAal5SduVcc(2), 
      atmTransparent(3), 
      ethernetTagged(4), 
      ethernet(5), 
      hdlc(6), 
      ppp(7), 
      cem(8),  -- old format 
      atmCellNto1Vcc(9), 
      atmCellNto1Vpc(10), 
      ipLayer2Transport(11), 
      atmCell1to1Vcc(12), 
      atmCell1to1Vpc(13), 
      atmAal5PduVcc(14), 
      frameRelayPortMode(15), 
      cep(16) 
       }        
 We need value tdm(17) to be added.

__________________________________________
	So as long a the above are completed, I see no reason why these
both shouldn't be made WG drafts.

	--Tom

> Hi All,
> 
> Following my presentation today in Seoul, 
> http://www.dspcsp.com/tdmoip/draft-orly-pwe3-satop-mib-00.txt
> 
> http://www.dspcsp.com/tdmoip/draft-orly-pwe3-TDM-mib-00.txt

I would like to proceed with a proposal to progress the drafts as
Working Group items. 
Please comment. 

Orly Nicklass, PhD
Associate VP R&D,
RAD Data Communications Ltd,
24 Raoul Wallenberg St.
Tel Aviv, 69719, Israel
Tel : +972 3 765 9969; Fax : +972 3 644 0930
email: [email-masked]
RAD's web site : www.rad.com

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Orly Nicklass" <[email-masked]>
Date: Mon, 1 Mar 2004 08:59:18 +0200

Hi All, 

Orly Nicklass, PhD
Associate VP R&D,

---

From: "Yaakov Stein" <[email-masked]>
Date: Mon, 1 Mar 2004 09:29:18 +0200

> I would like to proceed with a proposal to progress the 
> drafts as Working Group items. 
> Please comment. 

Of course, I support the proposal.

These MIB drafts need to be standards track.

We will later need MIBs for the two informational drafts
(CESoPSN and TDMoIP).

Y(J)S

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Mon, 1 Mar 2004 08:32:13 -0500

A few comments. First, they are both short and sweet, which
I like. 8)   Second, Although both MIB modules state that they
fit into the existing MIB framework, and have
figures that show that they do, it is unclear to me
as to how they do. For exaple, they both seem to define their
own indexing, and do not describe how this interacts with
the PW-MIB as well as the native TDM (DSx) MIBs. For
example, the way all of the existing service "glue" MIBs
work is to use the PwIndex as common index:

        

	This allows one to look at the PW in the PW-MIB based on
the PwIndex and then look at the pwVcType associated with that
entry and quickly know how to find either the PSN or service
"glue" MIB entry because it uses that same entry. Please
make sure you use this.

	Please make sure these MIBs are aligned for configuration 
with the existing MIBs.

	Finally, please check the PwVcType TC in
draft-ietf-pwe3-pw-tc-mib-04.txt
to make sure that the appopriate Vc Types are defined there to
support your new modules as described above.

	So as long a the above are completed, I see no
reason why these both shouldn't be made WG drafts.

	--Tom

Orly Nicklass, PhD
Associate VP R&D,