Subject: Re: Proposed new 5.4.3 for arch draft

From: Stewart Bryant <[email-masked]>
Date: Wed, 03 Mar 2004 04:53:13 +0000

Alia Atlas wrote:

> At 08:52 PM 3/2/2004, Sasha Vainshtein wrote:
> 
>> Stewart and all,
>> Basically fine, please see a couple of minor comments inline (marked
>> [Sasha]).
>>
>> Regards,
>>                  Sasha.
>> ... snipped ...
>>
>> 5.4.3. PW Packets Aliasing IP Packets
>>
>> To allow accurate packet inspection in an MPLS PSN, and/or to operate
>> correctly over MPLS PSNs that have deployed equal-cost multiple-path
>> load-balancing (ECMP), a PW packet must not alias an IP packet.
>> [Sasha] IMO it should be MUST NOT or, probably, SHOULD NOT.
>> IP packets are carried in MPLS label stacks without any protocol
>> identifier. The method of packet discrimination must therefore
>> be based on some unique characteristic of the IP packet header,
>> which PWE3 must not mimic.
>> [Sasha] I honestly believe no one will ever propose verifying the cheksum
>> [Sasha] of the first 20 bytes after the bottom label as "the unique
>> [Sasha] characteristic of the IP packet header". But worse things have
>> [Sasha] happened, so maybe we should explicitly block this.
> 
> 
> The checksum is legitimate to consider as a verification, if one doesn't 
> want to depend on just the first nibble.
> 

However the primary decision is surely the first nibble, because
checksum is still ambiguous.

Once you think that you have an IP packet, then the normal IP
verificatuon rules apply, and surely we can just point to RFC 791
for how to parse an IP packet rather than spell it out in our
work?

- Stewart

> Alia
> 
>> This is the subject of work in progress.
>>
>> -----------------------------------------------------
>>
>>
>> 9.  IANA considerations
>>
>>     IANA considerations will be identified in the PWE3 documents that
>>     define the PWE3 encapsulation, control and management protocols.
>>
>>
>>
>>
>>
>> _______________________________________________
>> pwe3 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/pwe3
>>
>> _______________________________________________
>> pwe3 mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/pwe3
> 
> 
> 
> 
>

---

From: Alia Atlas <[email-masked]>
Date: Wed, 03 Mar 2004 00:07:13 -0500

>checksum is still ambiguous.

Yes, absolutely.

>for how to parse an IP packet rather than spell it out in our

Sounds fine to me.  I was objecting to having it explicitly ruled out as an 
additional verification.

Alia