Subject: Comments to draft-ietf-pwe3-iana-allocation-03

From: Sasha Vainshtein <[email-masked]>
Date: Sun, 28 Mar 2004 11:46:28 +0200

Luca and Mark,
I have just read the newly posted draft-ietf-pwe3-iana-allocation-03.
Unfortunately, some issues raised at the Seoul meeting and later on 
this list wrt the TDM PWs have not been addressed:

1. Renaming the CEP Payload Bytes interface parameter to CEP/TDM Payload
Bytes
2. Allocation of a new interface parameter ID for TDM options (could be
0x0b)
3. Allocation of a new LDP status code - TDM mis-configuration (could be
0x00000029).

Hopefully these issues can be easily addressed before the WG Last Call.
With best regards,
                                   Sasha Vainshtein
email:     [email-masked]
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

---

From: "Orly Nicklass" <[email-masked]>
Date: Mon, 29 Mar 2004 11:51:25 +0100

It seems like there is also miscounting or typo err in the newly added
PW types.
First there are two "0x0011", then assuming we want those two, the text
in section 2 should relate to dec values and not to hex values. (18 and
19 in the text should be changed) See below.

"....PW Type values 1 through 18
   are defined in this document. PW Type values 19 through 63 are to be
   assigned by IANA using the "IETF Consensus" policy defined in
   RFC2434.
...
      0x0010   SONET/SDH Circuit Emulation over Packet (CEP)
      0x0011   Structure-Agnostic TDM over Packet (SAToP)
      0x0011   Structure-agnostic E1 over Packet (SAToP)
      0x0012   Structure-agnostic T1 (DS1) over Packet (SAToP)
      0x0013   Structure-agnostic E3 over Packet (SAToP)
      0x0014   Structure-agnostic T3 (DS3) over Packet (SAToP)
      0x0015   CESoPSN basic mode
      0x0016   TDMoIP basic mode
      0x0017   CESoPSN TDM with CAS
      0x0018   TDMoIP TDM with CAS "

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sasha Vainshtein
Sent: Sunday, March 28, 2004 12:46
To: Luca Martini (E-mail); Mark Townsley (E-mail)
Cc: PWE3 WG (E-mail)
Subject: [PWE3] Comments to draft-ietf-pwe3-iana-allocation-03

Luca and Mark,
I have just read the newly posted draft-ietf-pwe3-iana-allocation-03.
Unfortunately, some issues raised at the Seoul meeting and later on this
list wrt the TDM PWs have not been addressed:

1. Renaming the CEP Payload Bytes interface parameter to CEP/TDM Payload
Bytes 2. Allocation of a new interface parameter ID for TDM options
(could be
0x0b)
3. Allocation of a new LDP status code - TDM mis-configuration (could be
0x00000029).

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Mon, 29 Mar 2004 10:27:08 -0700

>1. Renaming the CEP Payload Bytes interface parameter to CEP/TDM Payload
ok this will need to be updated in the draft-ietf-pwe3-sonet-03.txt as well.

>2. Allocation of a new interface parameter ID for TDM options (could be
ok, but we need to find a location for the text in 
draft-vainshtein-pwe3-tdm-control-protocol-extension-00.txt

I suggest that this text be included in it's  respective document.
In te future when we might add new technologies we do not want to go 
edit the original control protocol RFC every time.

>3. Allocation of a new LDP status code - TDM mis-configuration (could be
We only need one ? not the 6 that are defined in 
draft-vainshtein-pwe3-tdm-control-protocol-extension-00.txt ?

( I added only this one. )

Luca
( I 'll send the update after I get your response. )

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 29 Mar 2004 19:34:51 +0200

Luca,
Please see some answers inline.
With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> From: Luca Martini [mailto:[email-masked]]
> Sent: Monday, March 29, 2004 7:27 PM
> To: Sasha Vainshtein
> Cc: Mark Townsley (E-mail); PWE3 WG (E-mail)
> Subject: Re: Comments to draft-ietf-pwe3-iana-allocation-03
> 
> 
> 
> 
> Sasha Vainshtein wrote:
> 
> >Luca and Mark,
[Sasha] Ron, I hope this is OK with you.
> edit the original control protocol RFC every time.
[Sasha] OK with me. I'll resubmit the draft with all the necessary changes.
> draft-vainshtein-pwe3-tdm-control-protocol-extension-00.txt ?
[Sasha] I think that "just one" will be enough - just as it is enough for
SONET/SDH.

---

From: Luca Martini <[email-masked]>
Date: Mon, 29 Mar 2004 10:47:00 -0700

Orly,

Thanks, I had already noticed.
Luca

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 31 Mar 2004 13:44:11 +0200

Luca and Ron,
I've re-read the relevant section of the SONET draft
and I think that the same status code can be safely
re-used for both. It should be renamed to 
"CEP/TDM mis-configuration" but, hopefully, this will not
be a problem also.

With best regards,
                                   Sasha Vainshtein

> Sent: Tuesday, March 30, 2004 12:50 AM
> To: Sasha Vainshtein
> Cc: Mark Townsley (E-mail); PWE3 WG (E-mail); Orly Niklass 
> (E-mail); Ron Cohen (E-mail)
> Subject: Re: [PWE3] RE: Comments to draft-ietf-pwe3-iana-allocation-03
> 
> 
> 
> 
> >>>3. Allocation of a new LDP status code - TDM 
> >>>      
> >>>
> >>mis-configuration (could be
> >>    
> >>
> >>>0x00000029).
> >>>
> >>>      
> >>>
> In this case can we use the existing code for CEP ?
> 
> 
> Luca
> 
>

---

From: Luca Martini <[email-masked]>
Date: Wed, 31 Mar 2004 08:30:54 -0700

Excellent,
I will make the change.
Luca

Sasha Vainshtein wrote:

>>>[Sasha] I think that "just one" will be enough - just as it 
>>>      
>>>
>>is enough for
>>    
>>
>>>SONET/SDH.
>>>
>>>      
>>>