Subject: Re: Proposed new 5.4.3 for arch draft

From: Mustapha Aissaoui <[email-masked]>
Date: Tue, 02 Mar 2004 21:29:27 -0500

Stewart,
see a question below.

Mustapha.
--------------
Stewart Bryant wrote:
> 
> Here is the proposed change to 5.4.3 that was discussed
> at the WG meeting. Also here is the corresponding change
> to section 9.
> 
> The arch draft will become informational, and
> I will post a pre-draft of the full document with all
> the 07 changes incorporated some time next week.
> 
> Please consider this the start of a two week last
> call on this change.
> 
> I will put together a draft for the CW text in the
> next few days.
> 
> - Stewart
> ---------------------------------------------------
> 
> 5.4.3. PW Packets Aliasing IP Packets
> 
> To allow accurate packet inspection in an MPLS PSN, and/or to operate
> correctly over MPLS PSNs that have deployed equal-cost multiple-path
> load-balancing (ECMP), a PW packet must not alias an IP packet.
> IP packets are carried in MPLS label stacks without any protocol
> identifier. The method of packet discrimination must therefore
> be based on some unique characteristic of the IP packet header,
> which PWE3 must not mimic.
> 
> This is the subject of work in progress.

MA> I am not clear about the impact of the above paragraph on the
rest of Section 5.4.3 and on Section 5.4.4. I understand that option
3 in your presentation Monday proposes a separate "PWE3 control word
registry" which will not allow values of 4 and 6. If so, why it that
not sufficient? 
Why add that "the method of discrimination should be based on some
unique characteristic of the IP packet header"? 
 
> -----------------------------------------------------
> 
> 9.  IANA considerations
> 
>     IANA considerations will be identified in the PWE3 documents that
>     define the PWE3 encapsulation, control and management protocols.
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 03 Mar 2004 04:57:22 +0000

> registry" which will not allow values of 4 and 6. If so, why it that

It replaces 5.4.3 and 5.4.4 gets deleted.

> unique characteristic of the IP packet header"? 

The plan is to make the Arch draft as uncontroversial as possible
in this area so as to allow it to get though review and unblock the
other drafts. Hence I was trying not to prejudge the solution here.
Hence the non-specific language.

- Stewart

---

From: "Ron Cohen" <[email-masked]>
Date: Tue, 2 Mar 2004 21:13:37 -0800

Stewart,

Do you want to change to the following section 5.4.4, or intend to leave
it as is?

Thanks
Ron

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Stewart Bryant
> Sent: Tuesday, March 02, 2004 4:47 PM
> To: [email-masked]
> Subject: [PWE3] Proposed new 5.4.3 for arch draft
> 
>