Subject: RE: Proposal to Progress draft-orly-pwe3-satop-mib and dra ft-orly-pwe3-tdm-mib

From: David Zelig <[email-masked]>
Date: Tue, 2 Mar 2004 09:22:00 +0200

Orly,
There is an inconsistency between the MIB suggested and Sasha's draft
draft-vainshtein-pwe3-tdm-control-protocol-extension-00.txt - in the MIB
module you ask for a single PW type and the later draft suggests a PW type
per TDM mode. Since PwVcType should be one to one the PW type carried in the
signaling message, one of the two methods should be first selected.

In addition - I need a specific number allocated to whatever method  - so
when a decision will be made where the signaling extension for TDM will be
defined  - it should include suggested numbers and then I will update the tc
draft.
 
Thanks
David

> -----Original Message-----
> From: Orly Nicklass [mailto:[email-masked]]
> Sent: Tuesday, March 02, 2004 7:11 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [PWE3] Proposal to Progress 
> draft-orly-pwe3-satop-mib and draft-orly-pwe3-tdm-mib
> 
> 
>  
Snipped...

---

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 2 Mar 2004 09:52:14 +0200

David,
I was not aware of the need of one-to-one mapping between the PW
service types used in the Martini FEC and pwVcType values in the MIB.
You seem tospecify it as a mandatory requirement in your email.

Accommodating this requirement would, IMO, result in invalidating the
"generic" TDM MIB and distributing its contents among many specific
MIB modules. 

Using just a single "TDM PW Service type" is probably possible, but would
complicate the setup draft. Clearly some form of compromise should be found.

Maybe we (you, Orly, Yaakov and myself) should meet and discuss the
possibilities once we are back from Seoul.

Regards,
                 Sasha

-----Original Message-----
From: David Zelig
To: 'Orly Nicklass'
Cc: [email-masked]; [email-masked]
Sent: 3/2/2004 9:22 AM
Subject: RE: [PWE3] Proposal to Progress draft-orly-pwe3-satop-mib and dra
ft-orly-pwe3-tdm-mib

Orly,
There is an inconsistency between the MIB suggested and Sasha's draft
draft-vainshtein-pwe3-tdm-control-protocol-extension-00.txt - in the MIB
module you ask for a single PW type and the later draft suggests a PW
type
per TDM mode. Since PwVcType should be one to one the PW type carried in
the
signaling message, one of the two methods should be first selected.

In addition - I need a specific number allocated to whatever method  -
so
when a decision will be made where the signaling extension for TDM will
be
defined  - it should include suggested numbers and then I will update
the tc
draft.
 
Thanks
David

Snipped...

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Orly Nicklass" <[email-masked]>
Date: Tue, 2 Mar 2004 10:22:03 +0200

Since the TDM draft indicates creating an entry in the TDM generic table
upon the value of 'TDM', if the 4 values suggested by Sasha will become
the solution, we can extend the generic entry to be created based on one
of the 4 values rather then based on a single value.   Obviously the
process description will have to be modified in the draft, but it will
not break the concept.

In any case the TDM generic entry was assumed to support all types under
single name so nothing is violated by providing more than a single name.

The additional pointers in that table are also consistent with such
solution.

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Tuesday, March 02, 2004 09:52
To: 'David Zelig '; Orly Nicklass
Cc: [email-masked] '; [email-masked] '
Subject: RE: [PWE3] Proposal to Progress draft-orly-pwe3-satop-mib and
dra ft-orly-pwe3-tdm-mib

David,
I was not aware of the need of one-to-one mapping between the PW service
types used in the Martini FEC and pwVcType values in the MIB.
You seem tospecify it as a mandatory requirement in your email.

Accommodating this requirement would, IMO, result in invalidating the
"generic" TDM MIB and distributing its contents among many specific MIB
modules. 

Using just a single "TDM PW Service type" is probably possible, but
would complicate the setup draft. Clearly some form of compromise should
be found.

Regards,
                 Sasha

-----Original Message-----
From: David Zelig
To: 'Orly Nicklass'
Cc: [email-masked]; [email-masked]
Sent: 3/2/2004 9:22 AM
Subject: RE: [PWE3] Proposal to Progress draft-orly-pwe3-satop-mib and
dra ft-orly-pwe3-tdm-mib

Orly,
There is an inconsistency between the MIB suggested and Sasha's draft
draft-vainshtein-pwe3-tdm-control-protocol-extension-00.txt - in the MIB
module you ask for a single PW type and the later draft suggests a PW
type per TDM mode. Since PwVcType should be one to one the PW type
carried in the signaling message, one of the two methods should be first
selected.

In addition - I need a specific number allocated to whatever method  -
so when a decision will be made where the signaling extension for TDM
will be defined  - it should include suggested numbers and then I will
update the tc draft.
 
Thanks
David

> Subject: RE: [PWE3] Proposal to Progress draft-orly-pwe3-satop-mib and

> draft-orly-pwe3-tdm-mib
Snipped...

---

From: David Zelig <[email-masked]>
Date: Tue, 2 Mar 2004 19:19:05 +0200

Orly,
Your proposed solution make sense too.

David

> Sent: Tuesday, March 02, 2004 10:22 AM
> To: Alexander Vainshtein; David Zelig 
> draft-orly-pwe3-satop-mib and dra ft-orly-pwe3-tdm-mib
> 
> 
> draft-orly-pwe3-satop-mib and
> 
> > draft-orly-pwe3-tdm-mib
> > 
> > 
> >  
> Snipped...
>

---

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 1 Mar 2004 09:03:21 +0200

I support this proposal.

----------------------------------------------------------------------------
--------
With best regards,
                          Sasha Vainshtein
email:   [email-masked] <mailto:[email-masked]> 
phone:  +972-3-7659993 (office)
            +972-8-9254948 (home)
            +972-58-674833 (cellular)

> Sent: Monday, March 01, 2004 8:59 AM
> To: [email-masked]
> Hi All, 
> Following my presentation today in Seoul, 
> http://www.dspcsp.com/tdmoip/draft-orly-pwe3-satop-mib-00.txt
> 
> http://www.dspcsp.com/tdmoip/draft-orly-pwe3-TDM-mib-00.txt
> 
> I would like to proceed with a proposal to progress the drafts as
> Working Group items. 
> Please comment. 
>  
> 
> Orly Nicklass, PhD
> Associate VP R&D,
> RAD Data Communications Ltd,
> 24 Raoul Wallenberg St.
> Tel Aviv, 69719, Israel
> Tel : +972 3 765 9969; Fax : +972 3 644 0930
> email: [email-masked]
> RAD's web site : www.rad.com
> 
> 
> 
>  
>