Subject: Setup of TDM PWs: Follow-up for the Seoul meeting

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 10 Mar 2004 11:16:27 +0200

Luca, Mark and all,
Following my presentation at the Seoul WG session and our discussions there,
I;d like to ask you to update the PWE3 IANA Allocation draft (it expires
in April anyway:-) like following:

1. In Section 2 (PW Type), continume the list of PW Types like following:
...
0x0010   SONET/SDH Circuit Emulation over Packet (CEP) -- this is the last
entry so far
0x0011   Structure-agnostic E1 over Packet (SAToP)
0x0012   Structure-agnostic T1 (DS1) over Packet (SAToP) 
0x0013   Structure-agnostic E3 over Packet (SAToP) 
0x0014   Structure-agnostic T3 (DS3) over Packet (SAToP) 
0x0015   Structure-aware Basic NxDS0 (CESoPSN, TDMoIP)
0x0016   Structure-aware Trunk-specific NxDS0 with CAS (CESoPSN, TDMoIP)

Please note that this list corresponds to the list of services in the
TDM Requirements draft. Different MF formats for NxDS0 with CAS
will be accommodated in the next version of the TDM Control Protocol
Extensions
draft.

2. In Section 3 (Interface Parameters field), please continue the list of
Interface Parameters like following:
...
       0x09         2       Fragmentation indicator -- this is the last
entry so far
       0x10    4, 8 or 12   TDM Options [ref]

In addition, please change the name of the existing interface parameter
from CEP Payload Bytes to CEP/TDM Payload Bytes in the corresponding entry.
It would be really nice if you could accommodate this change also in the 
PWE3 Control Protocol draft.

Note: I seem to remember that somebody has asked for a new Interface
Parameter ID
already, so value 0x10 can be already allocated. If this is so, there would
be
no problem with using the next free value.

3. In Section 4 (LDP Status codes), please continuke the list of LDP Status
codes
as following:
...
           0x00000027 "CEP mis-configuration" -- this is the last entry so
far
           0x00000028 "TDM mis-configuration".

4. Add references to the SAToP, CESoPSN, TDMoIP and TDM Control Protocol
Extensions draft to the Section 8 (References).

I would like to update the TDM Control Protocol Extensions draft and re-post
it
ASAP, so I would highly appreciate your timely feedback.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked]
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 10 Mar 2004 12:12:33 +0200

> Luca, Mark and all,
> Following my presentation at the Seoul WG session and our 
> discussions there, I'd like to ask you to update the PWE3 
> IANA Allocation draft (it expires in April anyway:-) like following:
> 

I agree in principle, but we should separate the CESoPSN and TDMoIP
cases.

> Please note that this list corresponds to the list of 
> services in the TDM Requirements draft. Different MF formats 
> for NxDS0 with CAS will be accommodated in the next version 
> of the TDM Control Protocol Extensions draft.
> 
> 2. In Section 3 (Interface Parameters field), please continue 
> the list of Interface Parameters like following:
> ...
>        0x09         2       Fragmentation indicator -- this 
> is the last entry so far
> In addition, please change the name of the existing interface 
> parameter from CEP Payload Bytes to CEP/TDM Payload Bytes in 
> the corresponding entry.
> It would be really nice if you could accommodate this change 
> also in the PWE3 Control Protocol draft.

I think calling it TDM is enough
(the TDM requirements draft defines TDM as including SONET/SDH!)

 Y(J)S