Subject: RE: PWE3 state information in context to ATM

From: [email-masked]
Date: Wed, 24 Mar 2004 08:54:41 +0000

Anindya,

Please also note that the ATM encapsulation draft,
draft-ietf-pwe3-atm-encap-04.txt, says the following in Section 6.3 on
defect handling:
"  If the PW in one direction fails, then the complete bidirectional
service is considered to have failed."

Best regards,

Matthew

                      "Busschbach,                                                                                                     
                      Peter B (Peter)"         To:      "Roy, Anindya (Anindya)" <[email-masked]>, "[email-masked]'" <[email-masked]> 
                      <busschbach@luce         cc:                                                                                     
                      nt.com>                  Subject: RE: [PWE3] PWE3 state information in context to ATM                            
                      Sent by:                                                                                                         
                      pwe3-admin@ietf.                                                                                                 
                      org                                                                                                              

                      22/03/2004 15:32                                                                                                 

Anindya,

See draft-nadeau-pwe3-oam-msg-map-04.txt

Section 6 covers the mapping of PW failures and alarms to ATM alarms and
vice versa. Section 4.7 discusses some issues regarding the bi-directional
nature of Pseudo Wires.

One point that is not clearly covered in the current draft and that was
pointed out by Neil Harrison is that even if only one direction of a PW is
down, from a perspective of SLAs and Performance Monitoring the entire
emulated ATM VC must be considered failed.

Peter

> -----Original Message-----
> From: Roy, Anindya (Anindya) [mailto:[email-masked]]
> Sent: Monday, March 22, 2004 10:12 AM
> To: Roy, Anindya (Anindya); [email-masked]'
> Subject: [PWE3] PWE3 state information in context to ATM
>
>
>
> Hi All,
>
> Would like to get the groups view on the following issue.
>
> PWs can fail in a single direction or in both
> directions.However this may not be acceptable when the PWE3
> are used to emulate ATM Layer2 connections, to maintain the
> integrity of the  bidirectional property of ATM connections.
>
> My understanding is in order to preserve the integrity of the
> BI-DIRECTIONAL property of ATM VC/VP, any or both of the
> following MUSTBE supported.
>
> (1) If a PWE3 is emulating a ATM Layer 2 service, the PW must
> be bound to a *bi-directional* PSN tunnel because of the
> ATM's  bidirectional connection properties ?
>
> (2) Incase the PW is allowed to setup over two disjoint
> unidirectional tunnels in each direction, then the
> implementation must maintain state information of both the
> tunnels in order to synchronize the operational state of the
> ATM VC's in both the  direction to handle situations of PSN
> failures in single direction.
>
>
> If there is already a proposed solution can someone please
> provide a pointer.
>
> Thanks.
> Anindya
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: [email-masked]
Date: Wed, 24 Mar 2004 10:22:01 -0000

Thanks Matthew.......but pray tell me what the definition of failure is here, ie where are the defects specified (in terms of entry/exit criteria and consequent actions) and how are these related to the definition of trail availability (in both directions)?

As you should know, this is all specified in Y.1711......much careful thought went into getting this stuff right and keeping it as simple as possible.

regards, Neil

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: 24 March 2004 08:55
> To: Busschbach, Peter B (Peter)
> Cc: Roy, Anindya (Anindya); [email-masked]'; [email-masked]
> Subject: RE: [PWE3] PWE3 state information in context to ATM
> 
> 
> 
> Anindya,
> 
>                       Peter B (Peter)"         To:      "Roy, 
> Anindya (Anindya)" <[email-masked]>, "[email-masked]'" 
> <[email-masked]> 
>                       <busschbach@luce         cc:            
>                                                               
>            
>                       nt.com>                  Subject: RE: 
> [PWE3] PWE3 state information in context to ATM               
>              
>                       Sent by:                                
>                                                               
>            
>                       pwe3-admin@ietf.                        
>                                                               
>            
>                       org                                     
>                                                               
>            
>                                                               
>                                                               
>            
>                                                               
>                                                               
>            
>                       22/03/2004 15:32                        
>                                                               
>            
>                                                               
>                                                               
>            
>                                                               
>                                                               
>            
> 
> 
> 
> 
> Anindya,
>

---

From: Mustapha Aissaoui <[email-masked]>
Date: Wed, 24 Mar 2004 09:25:07 -0500

Neil,
you are right about the need to clearly define the types of defects
and the entry and exit criteria for a defect state. We made an
initial attempt to cover the different types of defects in
draft-aissaoui-l2vpn-vpws-iw-oam-00.txt. However, we need to add the
entry-exit criteria too. The same applies to
draft-nadeau-pwe3-oam-msg-map-04.txt.

As a next step, we are going to align the sections of the two drafts
on the homogeneous case (or network interworking). I, and I believe
the authors of both drafts too, intend to address comments you have
already made on the list lately.

Regards,
Mustapha.
-------------