Subject: Re: draft-ietf-pwe3-control-protocol-08.txt Generalized FEC clarific ation

From: Mustapha Aissaoui <[email-masked]>
Date: Tue, 28 Sep 2004 11:37:14 -0400

Peter,
the text proposed by Amulya in his email suggested that he was
trying to generalize the N:1 encapsulation to carry not just VPs
coming on a given port, but a mix of VPs and VCs coming from
different ports.

He was also suggesting to use LDP status notifications to add/remove
an a VC or VP into the already established PW.

That was of course not the Virtual Trunk application you are
describing here and which is being specified in the MFA.

Regards,
Mustapha.

"Busschbach, Peter B (Peter)" wrote:
> 
> Luca wrote:
> 
> > Yes , I am.  The question I have is the following:
> > Why do we have to transmit status of individual VPs in the
> > LDP control
> > protocol ?
> > ATM does a pretty good job already ... If the PW goes down
> > then we have
> > to know the VPs in use , and generate the appropriate OAM F4
> > cells ....
> > But the PW status down message is already there....
> >
> > Luca
> >
> 
> Luca,
> 
> Your comment is related to a discussion on ATM Virtual Trunks and OAM.
> 
> Let me explain the broader context. Manoj started this thread with a question about mapping multiple VPs onto a PW. You mentioned that only n=1 is currently supported in the atm-encap draft, upon which I made the point that you could interpret the draft as supporting n>1 as well. I referred to the work that is going on in the MPLS Frame Relay Alliance (MFA).
> 
> The MFA is working on an Implementation Agreement on MPL-ATM Control Plane Interworking. Among other things, it defines the concept of Virtual Trunks. A Virtual Trunk is a contiguous set of VPIs with a one ATM signaling and one ATM routing channel that run through the VP with the lowest VPI in the range. The ATM Switches at either end of the Virtual Trunk use the signaling channel to set up VPCs and VCCs through the trunk.
> 
> Virtual Trunks are primarily used in the following scenario:
> 
> ATM Switch 1   ---1--  PE1 ----2----  PE2 ---3--- ATM Switch 2
> 
> Interfaces 1 and 3 are ATM interfaces. 2 is the MPLS core. PE1 and PE2 are responsible for Pseudo Wire Emulation.
> 
> A Virtual Trunk extends from ATM Switch 1 to ATM Switch 2. When the VT is provisioned, the PEs learn that all cells with a VPI in the range {L, U} should be mapped onto a specific Pseudo Wire using n:1 cell mode encapsulation. The PEs don't have to know the state of individual VCs. They are not involved in the setup of VPCs and VCCs. The only thing they do is mapping VPIs to Pseudo Wires Labels.
> 
> The two ATM Switches behave as if the Virtual Trunk is a regular interface between them. There is one routing channel to exchange topology information and one signaling for connection setup. ATM routing and signaling information is transparent to the LERs.
> 
> OAM for Virtual Trunks is still being debated in the MFA. I would rather wait with describing the full solution until we have agreement within the MFA. However, I can respond to your question "Why do we have to transmit status of individual VPs in the LDP control protocol?"
> The answer is, we don't. The primary goal of Virtual Trunks is to define a solution in which the PEs are not aware of the status of individual VPs. Whatever solution the MFA comes up with, it will not require the use of PW Status notification for individual VPs within a Virtual Trunk.
> 
> Peter
> 
> >
> >
> [snipped to the end]
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Tue, 28 Sep 2004 14:42:01 -0600

ok, I agree. you can actually use PW type 0x0003 today to achieve this.
PW type "ATM transparent cell transport" means that you can have a PW 
that terminated into a virtual interface in a PE, and then you can 
switch an arbitrary set of VPs into it.

Thanks.
Luca