Subject: RE: Scaling RSVP-TE end-to-end (was: RSVP-TE and PW)

From: [email-masked]
Date: Thu, 30 Sep 2004 09:34:11 +0100

Chris,

> I can appreciate striving for a single protocol supporting
> PSN and PW setups. My general comments are:
> 
> - LDP is the defacto standard out there already running
> on a whole bunch of boxes ... for not only PW setups but
> is also the predominant PSN tunnel setup protocol.

Agreed, but that may not always be the case. The main reason RSVP-TE is not used to PE-PE today for setting up tunnels is that it does not scale for large networks mainly due to the number of tunnels and associated state to be maintained at tunnel midpoints. Today, a mixture LDP PE-PE and RSVP-TE in the core for FRR seems to offer a good solution from a traffic protection and scalability perspective, in which case using LDP for PW setup makes sense.

However, there is ongoing work on hierarchical RSVP-TE, which sounds like it may have the potential to scale RSVP-TE PE-PE using a 2+ layer hierarchy. Using RSVP-TE PE-PE would have several advantages, e.g. end-to-end FRR across the provider network, PE level CAC, and P2P/P2MP OAM and performance monitoring (i.e. no MP2P OAM issues where the source is lost). If we get to this stage then it would make sense to use RSVP-TE for PW signalling as well.

IMO using LDP PW signalling makes sense today, but if hierarchical RSVP-TE delivers then RSVP-TE PW signalling would make sense in the future for some deployments/providers. For this reason I would like to see the RSVP-TE PW signalling approach remain on the table and not be rejected at this time, at least until the capability to scale RSVP-TE PE-PE using hierarchy is proved/disproved.

Regards,
Richard

---

From: Chris Metz <[email-masked]>
Date: Thu, 30 Sep 2004 05:21:54 -0700

At 09:34 AM 9/30/2004 +0100, [email-masked] wrote:
>Agreed, but that may not always be the case. The main reason RSVP-TE is 
>not used to PE-PE today for setting up tunnels is that it does not scale 
>for large networks mainly due to the number of tunnels and associated 
>state to be maintained at tunnel midpoints. Today, a mixture LDP PE-PE and 
>RSVP-TE in the core for FRR seems to offer a good solution from a traffic 
>protection and scalability perspective, in which case using LDP for PW 
>setup makes sense.
>
>However, there is ongoing work on hierarchical RSVP-TE, which sounds like 
>it may have the potential to scale RSVP-TE PE-PE using a 2+ layer 
>hierarchy. Using RSVP-TE PE-PE would have several advantages, e.g. 
>end-to-end FRR across the provider network, PE level CAC, and P2P/P2MP OAM 
>and performance monitoring (i.e. no MP2P OAM issues where the source is 
>lost). If we get to this stage then it would make sense to use RSVP-TE for 
>PW signalling as well.

Richard-
Agree these efforts are intriguing for the reasons mentioned ....

Cheers ...

>IMO using LDP PW signalling makes sense today, but if hierarchical RSVP-TE 
>delivers then RSVP-TE PW signalling would make sense in the future for 
>some deployments/providers. For this reason I would like to see the 
>RSVP-TE PW signalling approach remain on the table and not be rejected at 
>this time, at least until the capability to scale RSVP-TE PE-PE using 
>hierarchy is proved/disproved.

---

From: [email-masked]
Date: Thu, 30 Sep 2004 16:38:20 +0100

I support your observations Richard.

regards, Neil

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: 30 September 2004 09:34
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [PWE3] Scaling RSVP-TE end-to-end (was: RSVP-TE and PW)
> 
> 
> Chris,
> 
> Agreed, but that may not always be the case. The main reason 
> RSVP-TE is not used to PE-PE today for setting up tunnels is 
> that it does not scale for large networks mainly due to the 
> number of tunnels and associated state to be maintained at 
> tunnel midpoints. Today, a mixture LDP PE-PE and RSVP-TE in 
> the core for FRR seems to offer a good solution from a 
> traffic protection and scalability perspective, in which case 
> using LDP for PW setup makes sense.
> 
> However, there is ongoing work on hierarchical RSVP-TE, which 
> sounds like it may have the potential to scale RSVP-TE PE-PE 
> using a 2+ layer hierarchy. Using RSVP-TE PE-PE would have 
> several advantages, e.g. end-to-end FRR across the provider 
> network, PE level CAC, and P2P/P2MP OAM and performance 
> monitoring (i.e. no MP2P OAM issues where the source is 
> lost). If we get to this stage then it would make sense to 
> use RSVP-TE for PW signalling as well.
> 
> IMO using LDP PW signalling makes sense today, but if 
> hierarchical RSVP-TE delivers then RSVP-TE PW signalling 
> would make sense in the future for some 
> deployments/providers. For this reason I would like to see 
> the RSVP-TE PW signalling approach remain on the table and 
> not be rejected at this time, at least until the capability 
> to scale RSVP-TE PE-PE using hierarchy is proved/disproved.
> 
> Regards,
> Richard
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>