Subject: Re: RSVP-TE and PW

From: Eric Rosen <[email-masked]>
Date: Wed, 29 Sep 2004 10:50:10 -0400

> Isn't the case simply that Cisco had developed LDP and tried to push this
> for TE tunnels, but lost to RSVP-TE? 

Nothing could be further from the truth!

Cisco and Juniper pushed RSVP-TE for  TE tunnels, Nortel and IBM (along with
many small vendors) pushed LDP for  TE tunnels.  Obviously you have not even
made an attempt to research the facts here.

> In comes PW setup and voila - LDP is back in the game

LDP was  never "out of  the game" because  most MPLS deployments do  not use
traffic engineering.

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 29 Sep 2004 08:22:45 -0700

Benny,

> Come on, let's have it on the table: Isn't the case simply that Cisco had
> developed LDP and tried to push this for TE tunnels, but lost to RSVP-TE? In
> comes PW setup and voila - LDP is back in the game...
> 
> I agree fully that it seems a bit much to have to implement another protocol
> JUST to carry a label value from one node to another... Oh, and to do so
> both nodes must be touched first...
> 
> However, RSVP-TE does have some refresh overhead that becomes nasty when
> there are many tunnels...

To address the issue of refresh overhead there is RSVP Refresh
Reduction spec (rfc2961).

Yakov.

> 
> /Benny
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Diego Caviglia
> Sent: 29. september 2004 15:38
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [PWE3] RSVP-TE and PW
> 
> 
> 
> Eric,
>            I see your point and I can agree with you but what I was
> actually meaning is: given that RSVP-TE is better than LDP for set-up
> tunnel in the PSN network (do you agree?) and there no advantage, at list i
> don't see any advantage, in using LDP in order to set-up PW why not use
> RSVP-TE for both PW and Tunnel set-up?
> 
> The botton line is why I have to implement two different signalling
> protocol in my box?
> 
> Regards
> 
> Diego
> 
> 
> 
> Eric Rosen <[email-masked]> on 09/29/2004 03:27:03 PM
> 
> Please respond to [email-masked]
> 
> To:    "Diego Caviglia" <[email-masked]>
> cc:    "Stewart Bryant <stbryant", pwe3 <[email-masked]>
> 
> Subject:    Re: [PWE3] RSVP-TE and PW
> 
> 
> 
> > given that RSVP-TE has some advantage w.r.t LDP (e.g. QoS)
> 
> The "some advantage" is not relevant in this context.
> 
> The network  layer tunnels  through which  the PWs flow  may have  QoS.
> The
> attachment circuits which are connected to each other via a PW may have
> QoS.
> But I  don't think there is  any notion of QoS  which is specific  to the
> PW
> itself, rather than to the network layer or the attachment circuits.
> 
> Therefore, any QoS  parameter carried in the PW  setup protocol would
> really
> be just an opaque object to that protocol.  A PW endpoint might want to
> pass
> this object  to the network layer, saying  in effect "put this  PW through
> a
> tunnel that has this QoS".  A PW  endpoint might want to pass this object
> to
> the NSP layer, saying in effect  "set up the attachment circuit according
> to
> these  QoS parameters".   But  the  PW setup  protocol  doesn't actually
> do
> anything itself  with the QoS parameter,  other than to carry  it around
> and
> pass it off. The only QoS  requirement for the PW signaling protocol is
> that
> it  be able to  carry an  opaque QoS  object from  one endpoint  to
> another.
> RSVP-TE has  no advantage over LDP  with respect to the  carrying of
> objects
> from one endpoint to another.
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3