Subject: PW Frame-relay encapsulation...

From: Luca Martini <[email-masked]>
Date: Wed, 22 Sep 2004 14:37:00 -0600

WG,

It has been brought to my attention that we have a problem with the 
Frame-relay PW. The encapsulation of the frame-relay FECN/BECN bit into 
the control word is reversed in the latest PWE3 draft, with respect to 
the original draft-martini design.
The draft-martini bit ordering has been implemented, and deployed, using 
exactly the same PW type and FEC as the latest PWE3 frame-relay/control 
protocol draft.

To ensure backward compatibility we have to somehow ensure that we flag 
the difference using the control, and maintenance protocol ( LDP )

I have 2 possible solutions in mind:

a) create an interface parameter flag , that would be set in the PWE3 
implementations to flag that encapsulation MUST be as follows:

 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|  Res  |F|B|D|C|I|L|  Length   | Sequence Number               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

b) Change the PW type for the PWE3 encap type to a new number ( 
currently 0x0001 )
    Next available is 0x0019

For reference the deployed implementations use :
 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
| Rsvd  |B|F|D|C|    Length     |        Sequence Number        | 
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

( the Length field is not an issue , as it will always have the 2 MSB as 0 )

Opinions ?

( I tend to favor b )

Luca

---

From: Sasha Vainshtein <[email-masked]>
Date: Sun, 26 Sep 2004 10:46:14 +0200

Luca, Andy and all,

I also prefer Option B but with the following clarifications:

1. Add an Annex to the Frame Relay encapsulation draft describing
   the difference between the two encapsulations (the WG draft vs.
draft-martini)
 
2. Add a note to the Control Protocol draft referring the "old" PW type to
this Annex
   and declaring intent to deprecate it in favor of the new PW Type.

IMO, this would follow the precedent set with CEP/CEM encapsulations
and resolve potential ambiguities.

Also, hopefully, this would not place excessive burden on the Editors of
the two drafts involved.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Luca Martini [mailto:[email-masked]]
> Sent: Thursday, September 23, 2004 5:43 PM
> To: W. Mark Townsley
> Cc: PWE3 WG (E-mail)
> Subject: Re: [PWE3] PW Frame-relay encapsulation...
> 
> 
> Yes, , but a new implementation can automatically adapt to an 
> old one , 
> by using the new Pw type as the default , but watching for the old pw 
> type advertisement ..... and negotiating.
> 
> One open question is the ITU definition, I believe that it 
> used 0x0001 
> with the new frame-relay implementation.
> Can somebody verify this ?
> 
> Thanks.
> Luca
> 
> 
> 
> W. Mark Townsley wrote:
> 
> >
> > Yes, given where we are now this is a very practical thing to do.
> >
> > b) sounds like the cleaner way to do it in the protocol. The only 
> > negative side-effect I could envision for this vs. the flag 
> method is 
> > that an implementation that uses the PW Type as part of its 
> > provisioning/management model might not allow a box that 
> can do only 
> > one type of encap (be it "martini" only now or "pwe3 only" 
> some time 
> > in the future) to interoperate seamlessly with a box that supports 
> > both encap types without making a special case for the two 
> FR PW Types 
> > at the provisioning/management level.
> >
> > - Mark
> >
> > Luca Martini wrote:
> >
> >> WG,
> >>
> >> Frame-relay PW. The encapsulation of the frame-relay FECN/BECN bit 
> >> into the control word is reversed in the latest PWE3 draft, with 
> >> respect to the original draft-martini design.
> >> The draft-martini bit ordering has been implemented, and deployed, 
> >> using exactly the same PW type and FEC as the latest PWE3 
> >> frame-relay/control protocol draft.
> >>
> >> To ensure backward compatibility we have to somehow ensure that we 
> >> flag the difference using the control, and maintenance 
> protocol ( LDP )
> >>
> >> ( the Length field is not an issue , as it will always 
> have the 2 MSB 
> >> as 0 )
> >>
> >>
> >> Opinions ?
> >>
> >> ( I tend to favor b )
> >>
> >> Luca
> >>
> >>
> >> _______________________________________________
> >> pwe3 mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/pwe3
> >>
> >
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pwe3
> >
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
>