Subject: PW-DRAFT05-MIB and PW-MPLS-DRAFT06-MIB questions

From: Benny Ammitzbøll <[email-masked]>
Date: Thu, 9 Sep 2004 13:23:07 +0200

Some questions:

1) When pwVcTable.pwVcOwner is set to 'genFecSignaling' (using Generalized
ID FEC signaling) there is no MIB object that can specify the value to be
used in an optional PW grouping TLV. The MIB object
pwVcTable.pwVcLocalGroupID could be used for that purpose, but it requires a
change in the description text.

2) PW-DRAFT05-MIB mentions an optional mode where pwVcTable rows are created
when signaling messages arrive. And this leads to creation of rows in
PW-MPLS-DRAFT06-MIB when MPLS PSN tunnels are used. However, am I correct in
assuming that an operator would still have to set up the rows in
PW-MPLS-DRAFT06-MIB manually? So even though Generalized ID FEC signaling
has the ability to signal a PW 'both ways' between two nodes by just
touching one of the nodes, it is always necessary to touch both nodes?

Regards,

Benny Lønstrup Ammitzbøll, M.Sc.E.E.
T|Pack A/S
Lautrupbjerg 7-11
DK-2750 Ballerup, Denmark
Phone: (+45) 44732100
Direct: (+45) 44732140
mailto:[email-masked] - www.tpack.net

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "David Zelig" <[email-masked]>
Date: Thu, 9 Sep 2004 16:10:12 +0200

Benny,
See inside

>  -----Original Message-----
> From: 	[email-masked] 
> [mailto:[email-masked]] 
> Sent:	Thursday, September 09, 2004 1:23 PM
> To:	David Zelig; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Cc:	Mikkel Elmholdt
> Subject:	PW-DRAFT05-MIB and PW-MPLS-DRAFT06-MIB questions
> 
> Some questions:
> 
> 1) When pwVcTable.pwVcOwner is set to 'genFecSignaling' 
> (using Generalized ID FEC signaling) there is no MIB object 
> that can specify the value to be used in an optional PW 
> grouping TLV. The MIB object pwVcTable.pwVcLocalGroupID could 
> be used for that purpose, but it requires a change in the 
> description text.
> 
OK. Will be fixed in next revision.

> 2) PW-DRAFT05-MIB mentions an optional mode where pwVcTable 
> rows are created when signaling messages arrive. And this 
> leads to creation of rows in PW-MPLS-DRAFT06-MIB when MPLS 
> PSN tunnels are used. However, am I correct in assuming that 
> an operator would still have to set up the rows in 
> PW-MPLS-DRAFT06-MIB manually? So even though Generalized ID 
> FEC signaling has the ability to signal a PW 'both ways' 
> between two nodes by just touching one of the nodes, it is 
> always necessary to touch both nodes?
> 

If the MPLS tunnels are LDP based, I do not see a need to specifically touch both node, the node can select automatically the tunnel going to the peer. Even in TE tunnels, there could be some local policy for tunnel selection so the tunnel will be selected automatically. In both cases the MIB will report the selected tunnel.

David
> Regards,
> 
> Benny L?nstrup Ammitzb?ll, M.Sc.E.E.
> T|Pack A/S
> Lautrupbjerg 7-11

---

From: "Benny Ammitzb?ll" <[email-masked]>
Date: Fri, 10 Sep 2004 10:32:18 +0200

David,

More questions:

1) I have yet not found anything that supports me in this, but I am assuming
that the PW-DRAFT05-MIB agent should implement some sort of retry-timer when
a pwVcTable row has been created? In case the peer node rejects the Label
Mapping message (e.g. due to misconfiguration in the peer node that is later
fixed) or if LDP is unable to establish an LDP session with the peer. If you
agree, then there is a need for a retry timer MIB object in pwVcTable.

2) I see a strong need for QoS signaling for PW such as e.g. proposed in
draft-shah-pwe3-pw-qos-signaling-00.txt. The pwVcTable lacks support for
this. Maybe via a RowPointer object that can optionally point to a traffic
parameter table entry in some other MIB?

Regards,

Benny

> From: 	David Zelig [mailto:[email-masked]] 
> Sent:	9. september 2004 16:10
> To:	Benny Ammitzb?ll; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc:	Mikkel Elmholdt
> Subject:	RE: PW-DRAFT05-MIB and PW-MPLS-DRAFT06-MIB questions
> 
> Benny,
> See inside
> 
> If the MPLS tunnels are LDP based, I do not see a need to specifically
> touch both node, the node can select automatically the tunnel going to the
> peer. Even in TE tunnels, there could be some local policy for tunnel
> selection so the tunnel will be selected automatically. In both cases the
> MIB will report the selected tunnel.
> 
> David
> > Regards,
> >

---

From: "Nurit Sprecher" <[email-masked]>
Date: Fri, 10 Sep 2004 12:04:15 +0200

Hi,
I can also see a strong need for “QoS signaling for PW”, however I think that the QoS is not defined for the PW but for the service that is emulated by the PW. Thus, the QoS should be defined for the service, and I can see no need to define it especially in  the general PW’s MIBs. 
Note that otherwise, when defining a service to be transmitted over the PW, CAC should be performed to verify that the PW has sufficient BW for the service.
Nurit.

		 -----Original Message-----
		From: 	[email-masked] [mailto:[email-masked]]  On Behalf Of Benny Ammitzb?ll
		Sent:	Friday, September 10, 2004 10:32
		To:	David Zelig; [email-masked]
		Cc:	Mikkel Elmholdt
		Subject:	[PWE3] RE: PW-DRAFT05-MIB and PW-MPLS-DRAFT06-MIB questions
		
		David,

		More questions:

		1) I have yet not found anything that supports me in this, but I am assuming that the PW-DRAFT05-MIB agent should implement some sort of retry-timer when a pwVcTable row has been created? In case the peer node rejects the Label Mapping message (e.g. due to misconfiguration in the peer node that is later fixed) or if LDP is unable to establish an LDP session with the peer. If you agree, then there is a need for a retry timer MIB object in pwVcTable.

		2) I see a strong need for QoS signaling for PW such as e.g. proposed in draft-shah-pwe3-pw-qos-signaling-00.txt. The pwVcTable lacks support for this. Maybe via a RowPointer object that can optionally point to a traffic parameter table entry in some other MIB?

		Regards,

		Benny

			 -----Original Message-----
			From: 	David Zelig [mailto:[email-masked]] 
			Sent:	9. september 2004 16:10
			To:	Benny Ammitzb?ll; [email-masked]; [email-masked]; [email-masked]; [email-masked]
			Cc:	Mikkel Elmholdt
			Subject:	RE: PW-DRAFT05-MIB and PW-MPLS-DRAFT06-MIB questions

			Benny,
			See inside

			David
			> Regards,
			> 
			> Benny Lרnstrup Ammitzbרll, M.Sc.E.E.
			> T|Pack A/S
			> Lautrupbjerg 7-11
			>  << File: ATT151210.txt >>

---

From: "David Zelig" <[email-masked]>
Date: Sun, 12 Sep 2004 10:23:43 +0200

Benny and Nurit,
1) For the QOS issue, it is currently not handled in the PWE3 signaling drafts, so the MIB module cannot handle it too. As you can see from Nurit answer, not sure this is the right place anyway.

2) For the retry timer, I believe this behavior is implementation specific (some implementations may use other methods than simple retry). 

David

> From: Nurit Sprecher [mailto:[email-masked]]
> Sent: Friday, September 10, 2004 12:04 PM
> To: Benny Ammitzb?ll; David Zelig
> Cc: Mikkel Elmholdt; [email-masked]
> Subject: RE: [PWE3] RE: PW-DRAFT05-MIB and 
> PW-MPLS-DRAFT06-MIB questions
> 
> 
> Hi,
> I can also see a strong need for “QoS signaling for PW”, 
> however I think that the QoS is not defined for the PW but 
> for the service that is emulated by the PW. Thus, the QoS 
> should be defined for the service, and I can see no need to 
> define it especially in  the general PW’s MIBs. 
> Note that otherwise, when defining a service to be 
> transmitted over the PW, CAC should be performed to verify 
> that the PW has sufficient BW for the service.
> Nurit.
> 
> 		From: 	[email-masked] 
> [mailto:[email-masked]]  On Behalf Of Benny Ammitzb?ll
> 		1) I have yet not found anything that supports 
> me in this, but I am assuming that the PW-DRAFT05-MIB agent 
> should implement some sort of retry-timer when a pwVcTable 
> row has been created? In case the peer node rejects the Label 
> Mapping message (e.g. due to misconfiguration in the peer 
> node that is later fixed) or if LDP is unable to establish an 
> LDP session with the peer. If you agree, then there is a need 
> for a retry timer MIB object in pwVcTable.
> 
> draft-shah-pwe3-pw-qos-signaling-00.txt. The pwVcTable lacks 
> support for this. Maybe via a RowPointer object that can 
> optionally point to a traffic parameter table entry in some other MIB?
> 
> 		Regards,
> 
> 		Benny
> 
> 			To:	Benny Ammitzb?ll; 
> [email-masked]; [email-masked]; 
> 			> [email-masked]; 
> 			If the MPLS tunnels are LDP based, I do 
> not see a need to specifically touch both node, the node can 
> select automatically the tunnel going to the peer. Even in TE 
> tunnels, there could be some local policy for tunnel 
> selection so the tunnel will be selected automatically. In 
> both cases the MIB will report the selected tunnel.
> 
> 			David
> 			> Regards,
> 			>