Subject: [PWE3] PWE3 Congestion

From: Stewart Bryant <[email-masked]>
Date: Tue, 09 Jan 2007 18:42:23 +0000

The PWE3 WG needs to form a consensus on whether to adopt

http://www.ietf.org/internet-drafts/draft-rosen-pwe3-congestion-04.txt

as a working group item.

For my part I think congestion is a topic that, for the
good of the Internet, we as a WG have a responsibility
to address.

So I put the question to the PWE3 WG:

Should the PWE3 WG adopt draft-rosen-pwe3-congestion-04.txt
as a working group draft?

- Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Mark Townsley <[email-masked]>
Date: Tue, 09 Jan 2007 19:53:33 +0100

> good of the Internet, we as a WG have a responsibility
And I'm certain the transport community agrees with you, Stewart.

- Mark

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 9 Jan 2007 14:01:46 -0500

I think this is a great topic for the WG to pursue,
at least investigate.

	--Tom

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 10 Jan 2007 09:43:12 +0200

[YJS]   Absolutely.

---

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Wed, 10 Jan 2007 05:16:18 -0600

> as a working group draft?

Yes.

---

From: Bob Briscoe <[email-masked]>
Date: Wed, 10 Jan 2007 16:17:31 +0000

Stewart,

>as a working group draft?

Yup

Bob

____________________________________________________________________________
Notice: This contribution is the personal view of the author and does not 
necessarily reflect the technical nor commercial direction of BT plc.
____________________________________________________________________________
Bob Briscoe,                           Networks Research Centre, BT Research
B54/77 Adastral Park,Martlesham Heath,Ipswich,IP5 3RE,UK.    +44 1473 645196

---

From: "Craig White" <[email-masked]>
Date: Wed, 10 Jan 2007 12:53:34 -0500

Stewart, et al.,

I have no problem with this working group discussing this issue, as we have
since the bofs, and during our presentations to other WG's (for example, I
first presented my draft in the RTP WG.) However, this issue is not one that
I feel needs to be (or even can be) solved by this working group.

As presented, this draft lays out many issues confronting us (by this us I
mean the IETF, not PWE3 in particular) regarding congestion control.

The issue of TCP friendly behavior has/been and will continue to be an issue
for several areas of IETF work, including but not limited to L2TP, RTP,
L2VPN, and even MPLS.

Because TCP also has issues that need to be addressed, some may be helped by
additional congestion profiles within DCCP, but other are still not yet
being addressed. Such as the those related to chronic link
(under)utilization.

Also, given Sally Floyd's recent work on fairness, it may not be feasible to
even define what TCP friendly is without some sort of a priori knowledge of
the traffic and what it is competing with.

And lastly, perhaps it is TCP itself that is problem. Perhaps this is simply
a case of we have a "congestion avoidance hammer" (TCP), but this problem is
best solved with a screwdriver ("other not specified congestion avoidance
mechanism") that work independent of the higher level protocol and may even
in effect "neuter" TCP's mechanisms.

In any case, I think this problem is an issue for a larger audience than
PWE3 and that this message needs to be communicated upward to the AD's, the
IESG, and the IAB. This issue should not be used to "hold up" (selected)
works of this group. IIt seems that the Transport area has certainly taken
this stance with some of the latest (higher speed) profiles within RTP and
that same position should be taken here.

The drafts advanced by this working group were designed with as much concern
for congession as can be reasonably be solved and/or expected. As was also
noted in this draft, the PWE3 architecture does include all the necessary
features to provide for the avoidance/control of congestion, each PW type
defined what was needed for each protocol, and in most case these are people
with significant experience in the deployment or planned deployments of
these protocols. I would also like to point out that several of these
protocols have been deployed for 2+ years.

IMHO
-craig

---

From: Nabil Seddigh <[email-masked]>
Date: Thu, 11 Jan 2007 13:00:59 -0500

Stewart,

I would agree with adopting "pwe congestion control
framework" as a WG item. As long as this particular
draft is seen only as a starting point, I am ok
with its adoption as a WG item.

Also, I'm not so sure whether the WG needs to take the
next step of defining actual congestion control
mechanisms for pwe.

There has been lots of prior/related work in this area including
TCP trunking and I wonder if it can be left to vendors to
adopt specific techniques. I get worried when I see things
resembling ATM rate control etc.

---
Best,

Nabil Seddigh
[email-masked]
http://www.solananetworks.com

---

From: "Eric Gray \(LO/EUS\)" <[email-masked]>
Date: Thu, 11 Jan 2007 15:37:49 -0600

Yes. 

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]] 
> Sent: Tuesday, January 09, 2007 1:42 PM
> To: pwe3
> Cc: Lars Eggert; Mark Townsley; Danny McPherson
> Subject: [PWE3] PWE3 Congestion
> 
>

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 12 Jan 2007 09:33:02 +0000

Nabil Seddigh wrote:
> I get worried when I see things

This is why I think that PWE3 must be actively engaged
in the definition of the congestion mechanism. We are well
aware that the dataplane for PWE3 needs to be a highly
efficient switching function.

I therefore see this as a partnership between us and
transport. They have expertise in control congestion
and the effects of congestion on the net. We have
expertise in the design and deployment of pseudowires
in a variety of network environments, and will push
back on any proposed mechanism that is impractical
in our environment. What we need is a lightweight
solution that to quote our charter "need only be
sufficient for the satisfactory operation of the
service"

- Stewart

---

From: <[email-masked]>
Date: Fri, 12 Jan 2007 12:27:03 +0200

> This is why I think that PWE3 must be actively engaged in the 
> definition of the congestion mechanism. We are well aware 
> that the dataplane for PWE3 needs to be a highly efficient 
> switching function.
> 
> transport. They have expertise in control congestion and the 
> effects of congestion on the net. We have expertise in the 
> design and deployment of pseudowires in a variety of network 
> environments, and will push back on any proposed mechanism 
> that is impractical in our environment. What we need is a 
> lightweight solution that to quote our charter "need only be 
> sufficient for the satisfactory operation of the service"

Completely agree. And I think the transport folks will understand that
pseudowires have special characteristics that require different
congestion control mechanisms than those currently in use for
transport-layer protocols. The constraints imposed by the pseudowire
characteristics might make it very hard to establish the usual TCP
friendliness and fairness properties, but if we come up with a general,
i.e., simple, mechanism to reduce bandwidth use during congestion and to
safely reacquire bandwidth after congestion, that'd be fine with me
personally.

Lars
-- 
NEW EMAIL: [email-masked]
NEW MOBILE: +358 50 48 24461
NEW JABBER: [email-masked] 
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Phil Bedard <[email-masked]>
Date: Fri, 12 Jan 2007 14:26:58 -0500

I think it's worthwhile to explore a light weight congestion control  
mechanism
especially for protection scenarios where only a lower-bandwidth path  
exists.
Would this PW congestion control modify the underlying transport  
layer for protocols that
support congestion notification, like a Frame-Relay PW?   Or is that  
an exercise better
left up to an equipment vendor?

Phil

---

From: Danny McPherson <[email-masked]>
Date: Mon, 15 Jan 2007 07:48:38 -0700

> as a working group draft?

I believe that given discussions here and in the last meeting, we've
seen consensus and should move forward with this as a WG draft.

Please post the next revision as such...

Thanks!

-danny