Subject: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

From: "Ahluwalia, Ajit \(Ajit\)" <[email-masked]>
Date: Thu, 4 Jan 2007 18:08:13 +0530

Hi,
1. Could anyone describe the format of inband TDM OAM format for MPLS
PSNs, section D.2 of draft-ietf-pwe3-tdmoip-06 just mentions first
nibble being 0001.
2. draft-ietf-pwe3-tdmoip-06.txt talks about out-of-band OAM format
where forward/reverse PW labels are 16 bit each, appropriate for UDP/IP
PSNs but how would this work for MPLS PSNs where more bits are required.

Thanks
Ajit

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Yaakov Stein" <[email-masked]>
Date: Thu, 4 Jan 2007 19:11:39 +0200

Ajit
 
The inband format relies on VCCV, which is the reason the CW is the PWACH one
rather than the user traffic CW. VCCV based on BFD could be used for most of the
functionality, but indeed it would be better to have a full-functioned OAM here
(for example, a Y.1731 format one).
 
The out-of-band OAM format is presently limited to the UDP/IP case.
There is no intent to extend it to the MPLS case, unless extending
the VCCV-based approach proves impossible. Incidentally, I admit
that there are advantages to the out-of-band approach for MPLS
where there may be many PWs in a single MPLS tunnel - 
but that is not the direction the WG wanted us to go.
 
Y(J)S

________________________________

From: Ahluwalia, Ajit (Ajit) [mailto:[email-masked]]
Sent: Thu 04/01/2007 14:38
To: [email-masked]
Subject: [PWE3] Inband/out-of-band TDM OAM format for MPLS PSNs

Hi,

Thanks
Ajit