Subject: [PWE3] VCCV-12 IANA questions

From: Stewart Bryant <[email-masked]>
Date: Mon, 22 Jan 2007 15:34:33 +0000

The first question that I have is what policy should be
applied to the selection of values for Pseudowire
Associated Channel Types

We currently have two allocations

0x21    Associated Channel carries an IPv4 packet   [RFC4385]
0x57    Associated Channel carries an IPv6 packet   [RFC4385]

These were chosen to be identical to the values assigned
the Assigned PPP DLL Protocol Numbers registry, and the
choice goes back to the days when we were thinking of using
that registry.

Now going forward, what policy does the WG think should
be used. Given that we have two independent registries
we had neither hope nor need of keeping then in sync. So
we can either

1) Start at 1 (reserving 0 for a rainy day) and continue up.

2) Where there is a similar identifier in Assigned PPP DLL
Protocol Numbers use it otherwise try to pick one that
will not be used by PPP.

The proposal by the VCCV authors  was to use 7 for BFD
Without IP/UDP Header (which PPP says is transparency
inefficient and therefore is unlikely to ever be used).

(1) will result in a more "compact registry", if you can
call a registry with 0x55 empty entries compact. (2) is
consistent with what we did in the past.

Anyone have any thoughts?

My second question concerns the several small registries
that are set up by VCCV

Control Channel Types  (8 possible values 3 used)
Connectivity Verification Types (CV Types) (8 possible values 6 used)
CC Types (8 possible values 1 used)

There are currently under expert review. However with
registries this small I am inclined to suggest that we
should make them IETF consensus?

Anyone have any thoughts.

Stewart

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 26 Jan 2007 11:30:33 -0500

Hi,

> Anyone have any thoughts?

	I think it might be useful to start a new registry
so that things are cleaner. However, I am worried about
existing implementations of VCCV, so I would like to
keep the actual values the same if we choose to do this.

> should make them IETF consensus?

	I personally prefer expert review for that very reason,
which is why the document is written as it is. There
are not a lot of values to play with and so I think we need
to be very careful about how the values are allocated in
the future.

	--Tom

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 26 Jan 2007 17:50:02 +0000

> keep the actual values the same if we choose to do this.

Whatever we do we keep 0x21 and 0x57. It the policy
for future ones I was asking about.

> to be very careful about how the values are allocated in

IETF consensus means you need an RFC (I think a stds track
RFC) and therefore is a higher hurdle than expert review.
No expert would decline a code point to a stds track RFC.
Sure, they would be involved in the discussion, but they
would go with the outcome of the IETF deliberation.

- Stewart

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 26 Jan 2007 13:09:10 -0500

> would go with the outcome of the IETF deliberation.

	I didn't realize that. I thought it was the
other way around.  If that is the case, then I agree
with you that it is good to have an RFC that explains
how the new code point is to be used.

	--Tom