Subject: [PWE3] WG LC: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt

From: Danny McPherson <[email-masked]>
Date: Sun, 4 Mar 2007 22:26:35 -0700

Folks,
Please consider today the beginning of a 3 week WG last call for
this document.  Please direct any comments with this revision of the
draft to the authors and PWE3 mailing list.

Thanks!

-danny & Stewart

Begin forwarded message:

> From: [email-masked]
> Date: February 13, 2007 1:50:03 PM MST
> To: [email-masked]
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt
> Reply-To: [email-masked]
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Pseudowire Emulation Edge to Edge  
> Working Group of the IETF.
>
> 	Title		: Managed Objects for TDM over Packet Switched Network (PSN)
> 	Author(s)	: O. Nicklass.
> 	Filename	: draft-ietf-pwe3-tdm-mib-07.txt
> 	Pages		: 42
> 	Date		: 2007-2-13
> 	
> This memo defines a portion of the Management Information Base (MIB)
>    for use with network management protocols in the Internet  
> community.
>    In particular, it describes managed objects for pseudo wire
>    encapsulation for structured or unstructured TDM (T1, E1, T3, E3)
>    circuits over a Packet Switch Network (PSN).
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-pwe3-tdm-mib-07.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
> "get draft-ietf-pwe3-tdm-mib-07.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-pwe3-tdm-mib-07.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> Content-Type: text/plain
> Content-ID: <[email-masked]>
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Suberri, Moshe" <[email-masked]>
Date: Fri, 30 Mar 2007 14:47:25 -0400

Dear Orly,

Regarding "pwTDMCfgPayloadSize" in the "pwTDMCfgTable" table 

With exception to the payload size all the objects that in the
"pwTDMCfgTable" are generic in nature and do not need to be crossed
checked with any other tables or objects.

The payload size is rather more complex object. In the case of
Structure-Aware PW or T1 Structure-Agnostic octet aligned PW, the
payload size is closely related to the TDM Rate. That is the payload
size must be an integer multiplication of the TDM rate. 

Having the payload size in the pwTDMCfgTable forces the NMS (or SNMP
agent) to validate that the payload size is correct with respect to all
the Structure-Aware circuits that are using this payload size.   

Therefore, I would like you to consider moving the "pwTDMCfgPayloadSize"
from the "pwTDMCfgTable" to the "pwTDMTable".

Best Regards
Moshe

---

From: "Orly Nicklass" <[email-masked]>
Date: Sat, 31 Mar 2007 12:15:24 +0300

pwTDMCfgTable is for all configurable objects while pwTDMTable is for
the framework. pwTDMTable holds the rate to distinguish among the
various TDM types in a smaller resolution than the one  exist in the
generic PW table. The validation is needed regardless of the object's
position and feasible in both cases.

-----Original Message-----
From: Suberri, Moshe [mailto:[email-masked]] 
Sent: Friday, March 30, 2007 21:47
To: Orly Nicklass
Cc: pwe3 ((((((((E-mail)))))))) WG
Subject: RE: [PWE3] WG LC: I-D ACTION:draft-ietf-pwe3-tdm-mib-07.txt 

Dear Orly,

Best Regards
Moshe