Subject: RE: [PWE3] PWE over Alternative networks

From: "Sasha Vainshtein" <[email-masked]>
Date: Thu, 22 Mar 2007 10:56:13 +0200

Luca and all,
A minor comment::
 
While the MEF CESoETH looks very much like an MPLS PW, it uses  an
EtherType value that differs from Unicast MPLS.  Hence I am not sure if
the Emulated Circuit ID (ECID) used in this spec can be really treated
as a label stack comprised of a single entry and containing the PW label
in spite of the fact that the ECID itself has been designed to be fully
compatible with RFC 3032.
 
The CESoETH spec (MEF.8)  can be found at:
http://www.metroethernetforum.org/PDFs/Standards/MEF8.doc
 
Regards,
             Sasha

________________________________

From: Luca Martini [mailto:[email-masked]] 
Sent: Thursday, March 22, 2007 9:37 AM
To: David Allan
Cc: [email-masked]
Subject: Re: [PWE3] PWE over Alternative networks

Dave,

The fact that we might use PHP when the MPLS PEs are adjacent does NOT
mean that there is no PSN  or that the PSN is Null.
Nowhere in the architecture do we specify a Null PSN. 

How ever I am unclear of what you are requesting. Here is a quote form
rfc4447:

" To transmit the packet   from one pseudowire endpoint to another, the
packet may need to
   travel through a "Packet Switched Network (PSN) tunnel"; this will
   require that an additional header be prepended to the packet."

Also note that the do not always need a tunnel label as stated in
rfc4447:

"However, if the pseudowire endpoints are immediately adjacent and
penultimate hop popping
behavior is in use, the MPLS tunnel may not be necessary.  Any sort of
PSN tunnel can be used, as long as it is possible to transmit MPLS
packets through it.  "

So it is perfectly fine to have 2 adjacent nodes and use no MPLS tunnel
label. In which case the label stack will consist of only one label.
By coincidence this is what the MEF has already used for MEF8
(CEoEthernet) .

So the fact that we might not have a tunnel label under certain
circumstances does not mean that there is no PSN. 

Luca

David Allan wrote: 

	Hi: <<Microsoft PowerPoint - PWE3 and Alternative PSNs.ppt.pdf>>

	Did not get to this on the agenda today and we agreed to go to
the
	list....
	
	I had put together some charts to advocate for a charter update
on the
	subject, which I've attached.
	
	For the time impaired, the assertion is that there is no
difference
	between a PWE MPLS label and a PSN MPLS label, therefore a PWE
label can
	run "naked" anywhere an MPLS label can run similarly inheriting
the
	transfer properties of the underlying network, and the charter
should
	simply acknowledge the case where the MPLS PSN is NULL....
	
	Comments?
	Dave

________________________________

	_______________________________________________
	pwe3 mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Luca Martini <[email-masked]>
Date: Thu, 22 Mar 2007 05:04:31 -0600

Sasha Vainshtein wrote:
> EtherType value that differs from Unicast MPLS. 
According to Yaakov it can also use the MPLS ethertype.
( I do not have the document here so i cannot look )
Luca

>  Hence I am not sure if