Subject: RE: [PWE3] PWE over Alternative networks

From: "Sasha Vainshtein" <[email-masked]>
Date: Wed, 21 Mar 2007 18:10:45 +0200

Yaakov, Dinesh and all,
One of the issues I have with draft-mohan-pwe3-vccv-eth-00/01.txt is
that it is really 
difficult to understand what is its intended scope:
- PWs over an Ethernet PSN?
- Ethernet PWs over MPLS and/or IP PSN?
- Arbitrary PW over an arbitrary PSN?

Regards,
            Sasha

-----Original Message-----
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, March 21, 2007 5:22 PM
To: Yaakov Stein; [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

Hi Yaakov:

<snipped>
 
> although this discussion was motivated by
draft-mohan-pwe3-vccv-eth-00.txt,
> this draft is not limited to Ethernet PSNs.  I would not want this
draft to be held up
> until Ethernet PSNs are admitted.

Agreed, both to applicability and desired outcome...

Dave

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "O'Connor, Don" <[email-masked]>
Date: Wed, 21 Mar 2007 11:34:50 -0500

I support the concept but I believe that 

1) The new PSN tunnel should be explicitly specified

More specifically it should be a MAC in MAC encapsulation, and even more specifically it should be a "standard" MAC in MAC. This leaves us IEEE 802.1ah Provider Backbone Bridge MAC in MAC

2) Per the original proposal from Ping, the "PSN tunnel" should also include SONET / SDH paths. I would make a guess that there is far more SONET / SDH equipment in metro networks today than Ethernet PSN equipment

The new PSN tunnel types should be explicitly specified in order insure multi-vendor interoperability

Regards

Don

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 11:11 AM
To: Yaakov Stein; [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

Yaakov, Dinesh and all,

Regards,
            Sasha

-----Original Message-----
From: David Allan [mailto:[email-masked]] 
Sent: Wednesday, March 21, 2007 5:22 PM
To: Yaakov Stein; [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

Hi Yaakov:

<snipped>
 
draft to be held up

Dave

---

From: "Yaakov Stein" <[email-masked]>
Date: Wed, 21 Mar 2007 20:01:38 +0200

Sasha

I want to claim  arbitrary over arbitrary
although I am not sure my co-authors will go along with this.

Certainly  Ethernet over arbitrary   and 
              arbitrary over Ethernet 
are completely understood from the addressing point of view,
and can thus be implemented immediately.

Y(J)S

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, March 21, 2007 18:11
To: Yaakov Stein; [email-masked]
Cc: [email-masked]; David Allan
Subject: RE: [PWE3] PWE over Alternative networks

Yaakov, Dinesh and all,
that it is really difficult to understand what is its intended scope:

Regards,
            Sasha

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 5:22 PM
To: Yaakov Stein; [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

Hi Yaakov:

<snipped>
 
draft to be held up

Dave

---

From: "David Allan" <[email-masked]>
Date: Wed, 21 Mar 2007 14:40:48 -0400

I agree...

Dave 

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]] 
Sent: Wednesday, March 21, 2007 2:02 PM
To: Sasha Vainshtein; Mohan, Dinesh (CAR:QW30)
Cc: [email-masked]; Allan, David (CAR:NS00)
Subject: RE: [PWE3] PWE over Alternative networks

Sasha

I want to claim  arbitrary over arbitrary although I am not sure my
co-authors will go along with this.

Certainly  Ethernet over arbitrary   and 
              arbitrary over Ethernet
are completely understood from the addressing point of view, and can
thus be implemented immediately.

Y(J)S

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 18:11
To: Yaakov Stein; [email-masked]
Cc: [email-masked]; David Allan
Subject: RE: [PWE3] PWE over Alternative networks

Yaakov, Dinesh and all,

Regards,
            Sasha

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 5:22 PM
To: Yaakov Stein; [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

Hi Yaakov:

<snipped>
 
draft to be held up

Dave

---

From: "O'Connor, Don" <[email-masked]>
Date: Wed, 21 Mar 2007 14:47:41 -0500

I disagree unless we totally disregard the concept that standards try to achieve some measure of multi-vendor / multi-network interoperability

Regards

Don

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 1:41 PM
To: Yaakov Stein; Sasha Vainshtein; Dinesh Mohan
Cc: [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

I agree...

Dave 

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]] 
Sent: Wednesday, March 21, 2007 2:02 PM
To: Sasha Vainshtein; Mohan, Dinesh (CAR:QW30)
Cc: [email-masked]; Allan, David (CAR:NS00)
Subject: RE: [PWE3] PWE over Alternative networks

Sasha

Y(J)S

-----Original Message-----
From: Sasha Vainshtein [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 18:11
To: Yaakov Stein; [email-masked]
Cc: [email-masked]; David Allan
Subject: RE: [PWE3] PWE over Alternative networks

Yaakov, Dinesh and all,

Regards,
            Sasha

-----Original Message-----
From: David Allan [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 5:22 PM
To: Yaakov Stein; [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

Hi Yaakov:

<snipped>
 
draft to be held up

Dave

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 21 Mar 2007 16:05:36 -0400

comments inline..

> From: O'Connor, Don [mailto:[email-masked]]
> Sent: Wednesday, March 21, 2007 12:35 PM
> To: Sasha Vainshtein; Yaakov Stein; [email-masked]
> Cc: [email-masked]
> More specifically it should be a MAC in MAC encapsulation, 
> and even more specifically it should be a "standard" MAC in 
> MAC. This leaves us IEEE 802.1ah Provider Backbone Bridge MAC in MAC

Why? A VLAN with a pair of known unicast MAC address with specific
.1P bits is as good of a L2 tunnel to carry a PW between two 'PE' 
endpoints as any. This is no different than PHP'd directly 'IP' connected
PEs with L2 network in between. It is not mandatory that it must
be MiM.

regards,
himanshu

> 
> 2) Per the original proposal from Ping, the "PSN tunnel" 
> should also include SONET / SDH paths. I would make a guess 
> that there is far more SONET / SDH equipment in metro 
> networks today than Ethernet PSN equipment
> 
> The new PSN tunnel types should be explicitly specified in 
> order insure multi-vendor interoperability
> 
> Regards
> 
> Don
>

---

From: "O'Connor, Don" <[email-masked]>
Date: Wed, 21 Mar 2007 15:34:43 -0500

Himanshu

802.1ah MAC in MAC would be my preference because this is somewhat similar to an IP/IP GRE tunnel, but I am open to other IEEE 802.1 VLAN based Ethernet PSN tunnel types as long as they are IEEE 802.1 standard. For example between IEEE 802.1Q or 802.1ad bridges. 

My primary point of view is that

1) Ethernet PSN tunnel type must be specified and must be standard (i.e. in agreement with the Ethernet VLAN bridge standards developed by IEEE 802.1)

Motivation is multi-vendor / multi-network interop and prevention of IETF providing "standardization" of some form of VLAN tagged Ethernet that is incompatible with the committee which has this responsibility (e.g. IEEE 802)

IETF has expresses similar concerns to ITU regarding some of the work on T-MPLS

2) SONET / SDH tunnels should also be supported

Regards

Don

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]]
Sent: Wednesday, March 21, 2007 3:06 PM
To: O'Connor, Don; Sasha Vainshtein; Yaakov Stein; [email-masked]
Cc: [email-masked]
Subject: RE: [PWE3] PWE over Alternative networks

comments inline..

regards,
himanshu

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 21 Mar 2007 16:43:36 -0400

Sure. 

I agree that underlying L2 technology must be an accredited standard
and IETF do not invent one.

/himanshu

> Sent: Wednesday, March 21, 2007 4:35 PM
> To: Shah, Himanshu; Sasha Vainshtein; Yaakov Stein; [email-masked]
> Cc: [email-masked]
> 802.1ah MAC in MAC would be my preference because this is 
> somewhat similar to an IP/IP GRE tunnel, but I am open to 
> other IEEE 802.1 VLAN based Ethernet PSN tunnel types as long 
> as they are IEEE 802.1 standard. For example between IEEE 
> 802.1Q or 802.1ad bridges. 
> 
> 1) Ethernet PSN tunnel type must be specified and must be 
> standard (i.e. in agreement with the Ethernet VLAN bridge 
> standards developed by IEEE 802.1)
> 
> Motivation is multi-vendor / multi-network interop and 
> prevention of IETF providing "standardization" of some form 
> of VLAN tagged Ethernet that is incompatible with the 
> committee which has this responsibility (e.g. IEEE 802)
>