Subject: [PWE3] BFD Support in draft-ietf-pwe3-segmented-pw-04.txt

From: "O'Connor, Don" <[email-masked]>
Date: Tue, 13 Mar 2007 08:51:16 -0500

For Multi-segment VCCV as documented in draft-ietf-pwe3-segmented-pw-04.txt, is use of BFD (including multi-segment BFD and BFD security) supported ? There is no mention of BFD in the latest draft.

Regards

Don
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 13 Mar 2007 10:19:58 -0400

> For Multi-segment VCCV as documented in draft-ietf-pwe3-segmented- 
> pw-04.txt, is use of BFD (including multi-segment BFD and BFD  
> security) supported ? There is no mention of BFD in the latest draft.

	There is no mention explicitly because it refers to the base VCCV  
draft where
the CC and CV types are defined.

	--Tom

---

From: "O'Connor, Don" <[email-masked]>
Date: Tue, 13 Mar 2007 13:07:37 -0500

My understanding is that the VCCV draft only covers single segment pseudowires. For multi-segment pseudowires, it should be possible to simultaneously enable
 
1) End to end BFD
 
2) Multi-segment BFD across one Service Provider domain
 
3) Single segment BFD across an Inter-Carrier Interface (ICI) between two Service Providers
 
It should be possible to bootstrap these individual BFD instances either by using LDP or LSP Ping
 
This capability should be specified in either the segmented pseudowires draft or a multi-segment VCCV draft
 
Regards
 
Don

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Tuesday, March 13, 2007 9:20 AM
To: O'Connor, Don
Cc: [email-masked]
Subject: Re: [PWE3] BFD Support in draft-ietf-pwe3-segmented-pw-04.txt 

There is no mention explicitly because it refers to the base VCCV draft where
the CC and CV types are defined.

--Tom

Regards 

Don

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 29 Mar 2007 08:16:31 -0400

> My understanding is that the VCCV draft only covers single segment  
> pseudowires. For multi-segment pseudowires, it should be possible  
> to simultaneously enable
>
> 1) End to end BFD
>

> between two Service Providers

	It was out intent to do the above in the segmented-pw draft.

> either by using LDP or LSP Ping

	I am not sure I understand what you mean here. The sessions for
the e2e case are signaled using the same "single-hop BFD" procedures
as a single-hop PW, they are just carried in the MH TLV.

	--Tom

> This capability should be specified in either the segmented  
> pseudowires draft or a multi-segment VCCV draft
>
> Regards
>
> Don

---

From: "O'Connor, Don" <[email-masked]>
Date: Fri, 30 Mar 2007 18:11:55 -0500

Tom
 
Please see my additional questions below
 
Regards
 
Don

-----Original Message-----
From: Thomas D. Nadeau [mailto:[email-masked]]
Sent: Thursday, March 29, 2007 7:17 AM
To: O'Connor, Don
Cc: [email-masked]
Subject: Re: [PWE3] BFD Support in draft-ietf-pwe3-segmented-pw-04.txt 

1) End to end BFD

 
[Don] Will this capability be documented in draft -05 ? 

I am not sure I understand what you mean here. The sessions for 
the e2e case are signaled using the same "single-hop BFD" procedures 
as a single-hop PW, they are just carried in the MH TLV.
[Don] By MH TLV do you mean the MH VCCV sub TLV in the MH VCCV CW ? If so, does it mean that support of multiple BFD sessions for MH PW will only be possible if the MH VCCV CW is used ?  Will this be documented in -05 ? 

--Tom

Regards
 
Don

-----Original Message-----
From: Thomas D. Nadeau [ mailto:[email-masked]]
Sent: Tuesday, March 13, 2007 9:20 AM
To: O'Connor, Don
Cc: [email-masked]
Subject: Re: [PWE3] BFD Support in draft-ietf-pwe3-segmented-pw-04.txt 

--Tom

Regards 

Don