Subject: [PWE3] planning

From: "agu kap" <[email-masked]>
Date: Tue, 27 May 2008 02:21:57 +0000

Dear Sr.
I´m trying to get how to calculate the ethernet bandwidth, using ATM/Pseudo
Wire/MPLS/IP/Ethernet but i could find an RFC that show this information,
could you tell me where i can find this king of information or anything
regard dimentioniong a Pseudo Wire?
Thanks,
Br.
Agustin,
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 27 May 2008 08:48:42 +0300

Start from the number of cells per second you wish to transport.
 
Assuming that you are talking about N:1 mode,
take the number of ATM cells you wish to put into a packet.
Add the overhead of the MPLS label stack if you have one (4 bytes per label)
the overhead of the PW label (4 bytes)
the overhead of the CW (4 bytes) if you are using it.
 
Now, are you putting the MPLS over IP directly or via GRE ?
Add the GRE overhead (8 bytes) if you are using it, 
and then the IP header size (20 bytes for IPv4, 
and finally the size of the Ethernet header (14 bytes plus 4 bytes for each VLAN tag) 
and trailer (4 bytes).
 
That's it. 
 
Y(J)S

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of agu kap
Sent: Tuesday, May 27, 2008 5:22 AM
To: [email-masked]
Subject: [PWE3] planning

Dear Sr.
I´m trying to get how to calculate the ethernet bandwidth, using ATM/Pseudo Wire/MPLS/IP/Ethernet but i could find an RFC that show this information, could you tell me where i can find this king of information or anything regard dimentioniong a Pseudo Wire?
Thanks,
Br.
Agustin,  
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 27 May 2008 12:22:04 +0100

Agustin

You start with the packet rate and packet size on the access circuit. 
Scale for the PW encapsulation. Then scale for the tunnel and Ethernet 
encapsulations.

Stewart

---

From: "agu kap" <[email-masked]>
Date: Tue, 27 May 2008 12:01:24 +0000

Yaakov:
Thank you very much for your help. I do understand that you tell how to get
the packet size, so the other thing I have to calculate is the packet
size. I believe i have to use the PCR and the cell per packet, do you know
how to calculate the cells per packet?
We will you MPLS over IP.
Br
Agustín

2008/5/27, Yaakov Stein <[email-masked]>:
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
> *agu kap
> *Sent:* Tuesday, May 27, 2008 5:22 AM
> *To:* [email-masked]
> *Subject:* [PWE3] planning
>
>
>   Dear Sr.

---

From: "Yaakov Stein" <[email-masked]>
Date: Tue, 27 May 2008 15:10:37 +0300

Agustin
 
The configuration sets up a maximum number of cells per packet.
 
The actual number depends on how bursty your cell rate is
since you will send out a packet after waiting some maximum amount of time
in order to reduce the latency.
 
Y(J)S

From: agu kap [mailto:[email-masked]] 
Sent: Tuesday, May 27, 2008 3:01 PM
To: Yaakov Stein
Cc: [email-masked]
Subject: Re: [PWE3] planning

Yaakov:
Thank you very much for your help. I do understand that you tell how to get the packet size, so the other thing I have to calculate is the packet size. I believe i have to use the PCR and the cell per packet, do you know how to calculate the cells per packet?
We will you MPLS over IP.
Br
Agustín  

	 

	That's it. 
	 
	Y(J)S

	
	Dear Sr.

---

From: Stewart Bryant <[email-masked]>
Date: Tue, 27 May 2008 13:36:47 +0100

> in order to reduce the latency.

... and, in case it is a limiting factor, the network MTU.

Stewart

---

From: Phil Bedard <[email-masked]>
Date: Tue, 27 May 2008 10:27:18 -0400

This will likely be vendor specific.  Different vendors have different  
options for configuring the amount of cell packing that is done based  
on acceptable transmit latency.   If there is no cell packing going on  
then you are going to use 53 bytes of ATM cell plus the associated  
overhead already given.  Based on your interface rate and maximum  
acceptable latency you should be able to calculate the peak possible  
burst rate.

Phil

On May 27, 2008, at 8:01 AM, agu kap wrote:

> Yaakov:
> Thank you very much for your help. I do understand that you tell how  
> to get the packet size, so the other thing I have to calculate is  
> the packet size. I believe i have to use the PCR and the cell per  
> packet, do you know how to calculate the cells per packet?
> I´m trying to get how to calculate the ethernet bandwidth, using ATM/ 
> Pseudo Wire/MPLS/IP/Ethernet but i could find an RFC that show this  
> information, could you tell me where i can find this king of  
> information or anything regard dimentioniong a Pseudo Wire?
> Thanks,
> Br.
> Agustin,
>

---

From: "agu kap" <[email-masked]>
Date: Wed, 28 May 2008 16:52:45 -0300

Thank you Phil I do understand your point that it's vendor specific,  I just
was wondering if there any dimentioning tool for implementing pwe3 in the
neer future in mobile phone company.
Br.
Agustin

2008/5/27, Phil Bedard <[email-masked]>:
> options for configuring the amount of cell packing that is done based on
> acceptable transmit latency.   If there is no cell packing going on then you
> are going to use 53 bytes of ATM cell plus the associated overhead already
> given.  Based on your interface rate and maximum acceptable latency you
> should be able to calculate the peak possible burst rate.
>
>
> Phil
>
>> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
>> Of *agu kap
>> I´m trying to get how to calculate the ethernet bandwidth,
>> using ATM/Pseudo Wire/MPLS/IP/Ethernet but i could find an RFC that show
>> this information, could you tell me where i can find this king of