Subject: Re: [PWE3] Reg. clarification on the object pwAtmInboundNto1MappedVpi

From: "Murugesan Ramalingam" <[email-masked]>
Date: Wed, 16 Jul 2008 11:16:36 +0530

> Hi Tom,
> Thanks for your reply.
>
>       There are two objects in the same table which is having
> description as "VPI value of this ATM PW" and "VCI value of this ATM
> PW" as you mentioned.  And more over the object
> "pwAtmInboundNto1MappedVpi" looks like the VPI values are mapped to
> something.   Can you please let me know the difference of the objects
> pwAtmInboundNto1Vpi  and pwAtmInboundNto1MappedVpi.
>
>  pwAtmInboundNto1Vpi OBJECT-TYPE
>       SYNTAX        AtmVpIdentifier
>       MAX-ACCESS    not-accessible
>       STATUS        current
>       DESCRIPTION
>           "VPI value of this ATM PW. In atmTransparent(3),
>            Vpi will be the equivalent of 0xFFFF."
>       ::= { pwAtmInboundNto1Entry 2 }
>
>   pwAtmInboundNto1Vci OBJECT-TYPE
>       SYNTAX        AtmVcIdentifier
>       MAX-ACCESS    not-accessible
>       STATUS        current
>       DESCRIPTION
>           "VCI value of this ATM PW. In atmTransparent(3), or
>            VP case, the value will be the equivalent of
>            0xFFFF"
>       ::= { pwAtmInboundNto1Entry 3 }
>
>
> On 15/07/2008, Nadeau Thomas <[email-masked]> wrote:
>>
>>
>>> Hi All,
>>>         I  have few query in the draft Managed Objects for ATM over
>>> Packet Switched Network  (draft-ietf-pwe3-pw-atm-mib-05.txt).
>>>
>>> 1) Can you let me know the difference between the tables
>>>    pwAtmOutboundNto1Table and pwAtmInboundNto1Table.
>>
>> 	From the Entry definition:
>>
>>    pwAtmInboundEntry OBJECT-TYPE
>>        SYNTAX    PwAtmInboundEntry
>>        MAX-ACCESS    not-accessible
>>        STATUS        current
>>        DESCRIPTION
>>            "A row in this table represents an ATM PW that needs to be
>>             sent into the ATM Network after reconstructing cells from
>>             Packets received from a PSN. This table is indexed by
>>             pwIndex from pwTable. An entry is created in this table
>>             for every entry in the pwTable with a
>>             pwType equal to one of the following:
>>             atmAal5SduVcc(2), atmCell1to1Vcc(12), atmCell1to1Vpc(13,)
>>             or atmAal5PduVcc(14), or atmTransparent(3).Unless otherwise
>>             specified, all writeable objects in this table MUST NOT
>>             be changed after row activation in the generic pwTable
>>             and values must persist after reboot."
>>
>> 	The OutBound side is for the out-going side.
>>
>>> 2) What is the purpose of these below mentioned objects?
>>>
>>> pwAtmOutboundNto1MappedVpi         OBJECT-TYPE
>>>      SYNTAX        AtmVpIdentifier
>>>      MAX-ACCESS    read-create
>>>      STATUS        current
>>>      DESCRIPTION
>>>          "The egress generated VPI value of this ATM PW. The
>>>          entry is valid for PW type of atmCellNto1Vcc(9),
>>>          atmCellNto1Vpc(10), atmCell1to1Vcc(12), or
>>>          atmCell1to1Vpc(13). In other types, the value will be the
>>>          equivalent of 0xFFFF. Value MAY be changed when the
>>>          PW is defined as not active "
>>>      ::= { pwAtmOutboundNto1Entry 6 }
>>
>>>
>>>
>>>  pwAtmOutboundNto1MappedVci      OBJECT-TYPE
>>>      SYNTAX        AtmVcIdentifier
>>>      MAX-ACCESS    read-create
>>>      STATUS        current
>>>      DESCRIPTION
>>>          "The egress generated VCI value of this ATM PW. The
>>>          entry is valid for PW type of atmCellNto1Vcc(9),
>>>          atmCellNto1Vpc(10), atmCell1to1Vcc(12), or
>>>          atmCell1to1Vpc(13. In VP case or other types, the
>>>          value will be the equivalent of 0xFFFF.
>>>          Value MAY be changed when the PW is defined
>>>          as not active."
>>>      ::= { pwAtmOutboundNto1Entry 7 }
>>
>> 	
>> 	The VPIs/VCI IDs for the PW in the in/out-bound sides.
>>
>> 	--Tom
>>
>>>
>>>
>>> Thanks & Regards,
>>> Murugesan R
>>> _______________________________________________
>>> pwe3 mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/pwe3
>>>
>>
>>
>
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Orly Nicklass" <[email-masked]>
Date: Thu, 17 Jul 2008 04:01:34 +0300

The original value of the ATM VC can be changed once going over the PSN and
the mapped object is used to indicate that.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Murugesan Ramalingam
Sent: Wednesday, July 16, 2008 8:47 AM
To: [email-masked]
Subject: Re: [PWE3] Reg. clarification on the object
pwAtmInboundNto1MappedVpi