Subject: [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

From: Stewart Bryant <[email-masked]>
Date: Thu, 02 Apr 2009 18:08:42 +0100

The authors of draft-martini-pwe3-iccp-01.txt

http://tools.ietf.org/id/draft-martini-pwe3-iccp-01.txt

have requested that this become a PWE3 WG document.

Please can you send comments to the list by 20th April
so that the chairs can judge consensus.

Thanks

Stewart

---

From: "David Allan" <[email-masked]>
Date: Thu, 2 Apr 2009 13:17:58 -0400

Hi Stewart

Comment that most resonated with me in Dublin was "how frequently would
mirrored nodes be multi-vendor", implying minimal interest from anyone
in standardizing this...

That seemed to be group consensus at the time, what has changed?

Cheers
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant
Sent: Thursday, April 02, 2009 1:09 PM
To: pwe3
Subject: [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

Please can you send comments to the list by 20th April so that the
chairs can judge consensus.

Thanks

Stewart
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 02 Apr 2009 13:22:40 -0400

> mirrored nodes be multi-vendor", implying minimal interest from anyone

    Speaking as a service provider interested in providing multi-vendor
interoperability on this function, I'd disagree that there is minimal
interest in standardizing this. I build and deploy multi-vendor networks and
need this feature to work on different platforms. There might not be
interest from vendors like youself (although the three I use are), having
spoken to other colleagues on the SP side, they are interested. I hope they
chime in on this thread to this effect.

    --Tom

-- 
Principal Architect - 21CN Networks

---

From: Sami Boutros <[email-masked]>
Date: Thu, 02 Apr 2009 10:27:53 -0700

Support,

Thanks,

Sami

---

From: "Siva Sivabalan (msiva)" <[email-masked]>
Date: Thu, 2 Apr 2009 13:58:22 -0400

Support. 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Stewart Bryant (stbryant)
Sent: Thursday, April 02, 2009 1:09 PM
To: pwe3
Subject: [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

Thanks

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 02 Apr 2009 19:52:45 +0100

Please will the authors clarify the IPR position.

Stewart

Shahram Davari wrote:
> Hi Stewart
>
> Could you please clarify whether there is any patent claim related to this
> draft or not? 
>
> Thanks,
> Shahram
>
>
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 02 Apr 2009 14:57:14 -0400

There are no claims from BT.

    --Tom

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 2 Apr 2009 15:14:57 -0400

Support.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Thomas D. Nadeau
Sent: Thursday, April 02, 2009 2:57 PM
To: Stewart Bryant (stbryant); [email-masked]
Cc: 'pwe3'
Subject: Re: [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

    --Tom

On 4/2/09 2:52 PM, "Stewart Bryant" <[email-masked]> wrote:

>> Could you please clarify whether there is any patent claim related to

>> this draft or not?
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of Stewart Bryant

---

From: Luca Martini <[email-masked]>
Date: Thu, 02 Apr 2009 13:31:24 -0600

Stewart Bryant wrote:
>> this
No , No patent claim has been filed at this time.
Luca

---

From: Danny McPherson <[email-masked]>
Date: Thu, 2 Apr 2009 13:57:33 -0600

> mirrored nodes be multi-vendor", implying minimal interest from anyone

The Dublin meeting minutes don't seem to support your statement
above.  Specifically, while the minutes are somewhat ambiguous as
to the source, they do state "Several proprietary versions floating
around, but providers want standardized version."  I believe that
was Luca [graciously proxying in his usual fashion for what providers
want :-)], but it seems a valid point to me.

In regard to your question, it's certainly safe to assume the answer
is "MUCH LESS frequently absent a mechanism such as ICCP".

-danny

---

From: "David Allan" <[email-masked]>
Date: Thu, 2 Apr 2009 16:17:53 -0400

My meeting notes do not provide an attribution either ... It was simply
the comment at the mike that stood out to me that best summarized and
explained the apparent ambivilance of the room at the time....

If there is more to this than "gracious proxying of desire..."  then I
have no objections... ;-)

D

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Danny McPherson
Sent: Thursday, April 02, 2009 3:58 PM
To: pwe3
Subject: Re: [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

On Apr 2, 2009, at 11:17 AM, David Allan wrote:

> Comment that most resonated with me in Dublin was "how frequently 
> would mirrored nodes be multi-vendor", implying minimal interest from 
> anyone in standardizing this...

The Dublin meeting minutes don't seem to support your statement above.
Specifically, while the minutes are somewhat ambiguous as to the source,
they do state "Several proprietary versions floating around, but
providers want standardized version."  I believe that was Luca
[graciously proxying in his usual fashion for what providers want :-)],
but it seems a valid point to me.

In regard to your question, it's certainly safe to assume the answer is
"MUCH LESS frequently absent a mechanism such as ICCP".

-danny

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 02 Apr 2009 16:46:08 -0400

On 4/2/09 3:57 PM, "Danny McPherson" <[email-masked]> wrote:

>> would
    
    And I've clarified this, at least from one current operator using PWE3s.
*)

    --Tom

---

From: Nitin Bahadur <[email-masked]>
Date: Thu, 2 Apr 2009 15:13:19 -0700

The draft addresses a good problem, but having it's applicability just
to PW/LDP
doesn't make sense. The transport mechansim for ICCP should be TCP and
not LDP IMO.
Then the draft and procedures can be used by any protocol that wants
ICCP like behavior.

Are we going the route of trying to come up with different standards for
different
inter-chassis communication needs? If yes, then I (personally), would
rather come up with a proprietary solution that solves all my ICC needs
using a single protocol.

My 2 cents (speaking as an individual)
Nitin

---

From: "Yuji KAMITE" <[email-masked]>
Date: Fri, 03 Apr 2009 12:37:59 +0900

I support this as very valuable work in general,
as I believe most SPs now will have desire for multi-vendor
possibility that supports redundancy.
However, I still have questions and a little concern.
Clarification is expected:

- It looks like the current drafts focuses on mLACP a lot, but
  I'm wondering if this fully explains what this mechanism means
  in reality in terms of PW's native service (e.g., description 
  about LAG forwarding behavior is missing). 
  It needs to distinguish between PW-specific part (from the view
  of operators) and Ethernet MAC/PHY-specific part (from the view
  of CE), because the current draft seems to be mixing them up.
  Also this is also the case in other applications
  (multi-chassis APS etc.).

- I couldn't find any statement why LDP is used for
  underlying protocol.  The proposed method doesn't advertise any labels.
  Does ICCP has no relationship with data-path between
  redundant PEs?   Please elaborate if there is any specific requirement
  or rationale from the view of protocol design, to adopt LDP.

- This might be editorial, but it might be better to
  split more distinctly the common protocol part and the application-specific
  behavior and its TLVs (whether or not they are sepcified in one
  document). 

Best regards,
-Yuji

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Stewart Bryant
> Sent: Friday, April 03, 2009 2:09 AM
> To: pwe3
> Please can you send comments to the list by 20th April so 
> that the chairs can judge consensus.
> 
> Thanks
> 
> Stewart

---

From: <[email-masked]>
Date: Fri, 3 Apr 2009 09:14:33 +0200

Support.
Fred

---

From: "Mallette, Edwin" <[email-masked]>
Date: Fri, 3 Apr 2009 09:19:07 -0400

I concur with Tom here.  As a multiservice operator we also have a high degree of interest in multivendor interop for mc-LAG, mc-APS functions which this draft enables.

 -Ed

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Thursday, April 02, 2009 1:23 PM
To: David Allan; Stewart Bryant; pwe3
Subject: Re: [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

    --Tom

CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.

---

From: Huub van Helvoort <[email-masked]>
Date: Fri, 03 Apr 2009 15:36:07 +0200

To the authors:

What do you mean by "SONET APS" and where is it located
in figure 1?

I could not find any reference in the refence sections either.

Regards, Huub.

=====================

-- 
================================================================
Always remember that you are unique...just like everyone else...

---

From: <[email-masked]>
Date: Fri, 3 Apr 2009 18:18:23 +0200

Support.

Regards

Philippe.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Stewart Bryant
Envoyé : jeudi 2 avril 2009 19:09
À : pwe3
Objet : [PWE3] Should draft-martini-pwe3-iccp-01 be a WG doc?

Please can you send comments to the list by 20th April so that the chairs can judge consensus.

Thanks

Stewart

---

From: "Shahram Davari" <[email-masked]>
Date: Thu, 2 Apr 2009 13:56:54 -0400

Hi Stewart

Thanks,
Shahram

-----Original Message-----

Thanks

Stewart

---

From: Simon Delord <[email-masked]>
Date: Tue, 7 Apr 2009 08:29:34 +1000

Support,

Simon

2009/4/3 Stewart Bryant <[email-masked]>

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 8 Apr 2009 22:38:22 +0900

>    There are no claims from BT.

Softbank has no patent claim.

--
Satoru Matsushima

>>> Behalf Of

---

From: Luca Martini <[email-masked]>
Date: Thu, 30 Apr 2009 16:59:11 -0600

Huub,

You are correct, we have not included the SONET APS support yet.
This is something that we plan to include shortly, depending on how much 
interest the WG has in this topic.

Thanks.
Luca