Subject: [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?

From: Jörg Küchemann <[email-masked]>
Date: Wed, 1 Apr 2009 11:38:08 +0200

draft-bryant-filsfils-fat-pw-03 to WG draft? support*

**From:* [email-masked] [mailto:[email-masked]] *On Behalf Of
*BOCCI Matthew
*Sent:* Dienstag, März 31, 2009 13:51
*To:* [email-masked]
*Subject:* [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?

This is the start of a two week poll to judge the consensus to move
draft-bryant-filsfils-fat-pw-03
 to a PWE3 Working Group draft.

Please can you respond to the PWE3 list with your approval (or otherwise).

This poll will close on 14th April 2009.

Regards
Matthew

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 02 Apr 2009 09:21:37 +0100

Remember all packets that have a mutual order sensitivity go in the same
flow - that is
the definition of a flow.

A flow is a group of packets that have a "ships in the night"
relationship with another
flow.

An example would be two TCP sessions.

Stewart

[email-masked] wrote:
>
> stewart:
> for FAT PW Draft, though it realize a "big" traffics will be
> tranported by a few pw channel by ECMP. the key problem: how to keep
> ordering for big traffics?
>
> regards
> liu
>
>
> *Stewart Bryant <[email-masked]>*
> 发件人: [email-masked]
>
> 2009-04-02 00:38
> 请答复 给
> [email-masked]
>
>
> 	
> 收件人
> 	BUSI ITALO <[email-masked]>
> 抄送
> 	[email-masked], [email-masked]
> 主题
> 	Re: [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?
>
>
>
> 	
>
>
>
>
>
> Sorry I misread the subject line - that's the problem with having
> two drafts running in parallel :)
>
> Pkt PW may apply to MPLS-TP that is a MEAD team call.
>
> Fat PW I assume is only applicable to classic. The only way that
> I can see to do LAG in a transport context is to do pw-bonding, otherwise
> you violate the ordering.
>
> Sorry for any confusion.
>
> Stewart
>
>
>
>
>
>
>
>
> BUSI ITALO wrote:
> > Stewart,
> >
> > Could you please clarify the applicability of Fat PW to MPLS-TP?
> >
> > In SF, you stated that they are applicable to "ECMP and LAG case" and
> > this matched with my understanding of the draft.
> >
> > Due to the fact that ECMP is not used in MPLS-TP, I had assumed this
> > draft is not applicable in MPLS-TP.
> >
> > Did I miss/misunderstand anything?
> >
> > Thanks, Italo
> >
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]] On
> >> Behalf Of Stewart Bryant
> >> Sent: Wednesday, April 01, 2009 12:55 PM
> >> To: [email-masked]
> >> Cc: [email-masked]
> >> Subject: Re: [PWE3] draft-bryant-filsfils-fat-pw-03 to WG draft?
> >>
> >> The draft has applicability to Transport.
> >>
> >> I will come to the details below in a minute, but tell me how you
> >> propose to cope with
> >> ESSM in a client - surely you need to intervene rather than
> >> carry them
> >> transparently?
> >>
> >> Remember that the client layer performs the classification
> >> into protocol
> >> types
> >> so we just carry the classification over the server layer in a more
> >> convenient way.
> >>
> >> Remember if you don't like the pkt-pw you can always put a
> >> real interface in
> >> and use a L2 pw, and if you don't like that you can always
> >> but a clear
> >> fibre. What you do depends on how you wish to run the economics.
> >>
> >>
> >>
> >> [email-masked] wrote:
> >>
> >>> Stewart, can I please ask if this draft would be applicable
> >>>
> >> to MPLS-TP?
> >>
> >>>
> >>> I ask this because a transport network should satisfy the
> >>>
> >> requirements
> >>
> >>> of transparency....which in brief means:
> >>>
> >>> - all client bits treated equally
> >>>
> >> That happens here
> >>
> >>> - client bit ordering preserved
> >>>
> >> That also happens here
> >>
> >>> - no attempt made to try understand semantics of client
> >>>
> >> symbols (ie
> >>
> >>> client message/traffic-unit formed from N client bits) and never
> >>> change client bits
> >>>
> >> In this mechanism it is the client layer that makes the changes - not
> >> the server layer. The client presents the packet and and
> >> metadata saying
> >> what pid the server is to write into the PID
> >>
> >>> - server ensures client X traffic behaviour cannot impact
> >>> performance experienced by client Y
> >>>
> >> We pass that test
> >>
> >>>
> >>> ...and I cannot reconcile this with this draft. So perhaps
> >>>
> >> this draft
> >>
> >>> is only intended to apply to 'classical' MPLS?
> >>>
> >> It's not clear that it fails the test when you realize that
> >> the client
> >> is presenting the modified data to the server.
> >>
> >> Stewart
> >>
> >>
> >>>
> >>> regards, Neil
> >>>
> >>>
> >>>
> >> --------------------------------------------------------------
> >> ----------
> >>
> >>> *From:* [email-masked] [mailto:[email-masked]] *On
> >>> Behalf Of *BOCCI Matthew
> >>> *Sent:* 31 March 2009 12:51
> >>> *To:* [email-masked]
> >>> This is the start of a two week poll to judge the consensus to
> >>> move draft-bryant-filsfils-fat-pw-03
> >> _______________________________________________
> >> pwe3 mailing list
> >> [email-masked]
> >> https://www.ietf.org/mailman/listinfo/pwe3
> >>
> >>
> > _______________________________________________
> > pwe3 mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/pwe3
> >
> >
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>
> --------------------------------------------------------
> ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
> This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
> This message has been scanned for viruses and Spam by ZTE Anti-Spam system.
>