Subject: Re: [PWE3] Comments on draft-jounay-pwe3-leaf-initiated-p2mp-pw-01

From: Sherry Xue <[email-masked]>
Date: Thu, 07 May 2009 10:51:01 +0800

Thanks Fred,
 
Thanks for clarifying the items.
So there are four methods four instances, am I right?
-Leaf-initiated P2MP MS-PW (draft-jounay-pwe3-leaf-initiated-p2mp-pw)
	As described in the draft, downstream label assignment, and P2MP
MS-PW over
 P2P LSP only.
 
-Leaf-initiated P2MP SS-PW
    Upstream label request (leaf) +upstream label assignment (source), and
P2MP
 SS-PW over P2MP PSN tunnel only

 -Source-initiated P2MP MS-PW
    Upstream unsolicited label assignment and P2MP MS-PW over P2P PSN tunnel
 only
 
 -Source-initiated P2MP SS-PW (draft-jounay-pwe3-source-initiated-p2mp-pw)
     As described in the draft, upstream unsolicited label assignment, and
P2MP
 over P2MP PSN tunnel only.

 I was confused, if in the P2MP MS-PW architecture, the underlying layer
which
 supports PW segment belonging to the PW tree may be either a P2P pr a P2MP
PSN
 tunnel(depicted in [P2MP PW REQ]),  how the PW routing should work, because
 of the merge point. More works should be needed. It may be complex. Now I
clear
 about the items, and thanks Fred again.
 
 Regards
 Sherry
 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]
> > Sent: Wednesday, May 06, 2009 10:00 PM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: RE: Re: Comments on draft-jounay-pwe3-leaf-initiated-p2mp-pw-01
> >
> > Hi Sherry,
> >
> > Let me sum up the main items below (we may get lost with inline comment
> > stacking...)
> >
> > - Leaf-initiated P2MP SS-PW: the most efficient way IMO for the leaf PE
is
> to
> > send to source PE an upstream Label request message to take benefit from
the
> > P2MP underlying layer. Hence the source PE-assigned upstream P2MP PW
label
> is
> > mapped to P2MP PSN tunnel.
> >
> > - Source-initiated P2MP MS-PW: we think more consistent to consider only
the
> > upstream label assignement even for PW segment supported over P2P PSN
tunnel.
> > Having different label assignment procedures depending on underlying
layer
> may
> > be confused
> >
> > - Dynamicity: the P2MP PW REQ draft in section 4.3.5 defines this
requirement
> > (leaf grafting/pruning). But how the source PE discovers the leaf PE to
be
> > attached to the tree is out of scope (either via BGP or NMS) of the
solution
> > draft for the time being. For MS-PW the draft relies on the use of AII
routing
> > table on S/T-PEs, the dyn MS-PW setup is defined in
> > draft-ietf-pwe3-dynamic-ms-pw, and the table may be populated via BGP,
OSPF
> > or optionnaly T-LDP at the edge.
> >
> > Regards,
> > Fred
> >
> >
> > -----Message d'origine-----
> > De : Sherry Xue [mailto:[email-masked]]
> > Envoyé : mercredi 6 mai 2009 14:37
> > À : JOUNAY Frederic RD-RESA-LAN
> > Cc : [email-masked]
> > Objet : RE: Re: Comments on draft-jounay-pwe3-leaf-initiated-p2mp-pw-01
> >
> > Thanks Fred,
> > Please see inline.
> >
> > Regards
> > Sherry
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]
> > > Sent: Tuesday, May 05, 2009 10:03 PM
> > > To: [email-masked]
> > > Cc: [email-masked]
> > > Subject: TR: Re: Comments on
> > > draft-jounay-pwe3-leaf-initiated-p2mp-pw-01
> > >
> > > Hi Sherry,
> > >
> > > Thanks for the comments
> > > Please see my answer inline marked [FJ]
> > >
> > > Regards,
> > > Fred
> > >
> > >
> > > -----Message d'origine-----
> > > De : Sherry Xue [mailto:[email-masked]] Envoyé : samedi 25 avril
> > > 2009
> > 09:42
> > > À : JOUNAY Frederic RD-RESA-LAN Cc : [email-masked] Objet : Re:Re:
> > > Comments on draft-jounay-pwe3-leaf-initiated-p2mp-pw-01
> > >
> > > Hi, Fred,
> > > I totally agree with your opinion that the leaf-initiated mode and
> > > source-initiated mode are not restricted in the application of SS-PW
> > > and
> > MS-PW.
> > > IMO, leaf initiated mode is more conveniently for MS-PW, and in the
> > > source initiated mode, more work should be considered for MS-PW, such
> > > as AD and
> > PW
> > > routing. I agree the standardization work course with admiration.
> > > [FJ] Yes, it's true, we probably need both setup modes depending on SP
> > > requirements. That's why we tried to define a new multicast FEC
> > > element
> > which
> > > could fit to both.
> > >
> > > For P2MP SS-PW setup in leaf-initiated mode, it may be divided into
> > > two
> > > instances:
> > > [FJ] I think you mean P2MP MS-PW?
> >
> > [SX] In this case, I mean P2MP SS-PW exactly. In Leaf-initiated mode,
P2MP
> MS-PW
> > setup procedure had been described correctly, and P2MP SS-PW should be
> > considered also IMO.
> > That it to say, there is no S-PE between the source PE and the leaf-PEs.
> > AND, the leaf-PEs initiate the P2MP SS-PW setup.
> >
> > > 1)over P2P PSN :
> > > this case may be according to MP2P signaling, similarly as
> > > star-topology(logically), in which P2MP SS-PW is composed of m(leaf
> > no.)*P2P
> > > SS-PW, and all the P2P SS-PWs should be setup individually without
> > > consideration of the merge-node(physically). That is to say in the
> > > merge
> > node,
> > > there will be different labels allocated upstream for different
> > > downstream T-PEs.
> > > [FJ] In that case the downstream Label assignment should be
> > > considered, is
> > it
> > > what you mean?
> >
> > [SX]yes, as pre-described, In leaf-initiated mode, the downstream label
> > assignment should be considered. Each leaf-PE should assignment PW label
to
> > source.
> >
> > > 2) over P2MP PSN
> > > The merge-node should record the Label(called label L) allocated by
> > > the downstream TAII(called  X) with SAII( S ), and if another
> > > signaling
> > message
> > > from other TAII(i.e.,Y) is received with same SAII, the merge-node
> > > should allocated label L for TAII Y(upstream label assignment), and
> > > then allocate upstream label to next upstream hop.
> > > IMO, if the P2MP PW is initiated by the leafs, the PSN tunnel should
> > > be
> > restrict
> > > to P2P, because it sounds illogical that the leaf node is used to
> > > manage a
> > P2MP
> > > LSP or PW? What about your opinion?
> > > [FJ] I think if we consider PW segments over P2MP LSP, we must
> > > consider
> > only
> > > the upstream Label assignment. Because in your first step you
> > > derscribe,
> > the
> > > dowstream Label assigned by the first Leaf could be already in use by
> > another
> > > P2MP PW.
> >
> > [SX] Correctly,in the case of PW segments over P2MP LSP, I appreciate if
the
> > label assignment should be restricted in upstream assignment.
> >
> > > [FJ]I've the feeling we may have the requirement to define P2MP
> > > MS-PW/P2MP
> > LSP,
> > > and this would require Leaf PE to request the upstream PW P2MP Label
> > > for
> > this
> > > segment. We need more feedbazck on it from the WG
> >
> > [SX] I agree. P2MP MS-PW over P2MP LSP should be defined. And MAY the
case
> be
> > that the P2MP MS-PW is coincident with the P2MP LSP. Other cases, such
as,
> LSPs
> > which carry P2MP MS-PW is composed by more than one P2MP LSP and/or P2P
LSP
> > may not be required, only complex and confusion.
> >
> >
> >
> > > For P2MP MS-PW setup in source-initiated mode, the explicit routing
> > > should
> > be
> > > provided in the source PE. So the LDP should be extended for MS-PW
> > > setup according explicit routing. Right? Whether the explicit routing
> > > is the
> > only
> > > method for the PW routing?
> > > [FJ] the explicit routing mode is not mandatory for the
> > > source-initiated solution.
> >
> > [SX] If the explicit routing is not mandatory, the dynamic routing
should
> be
> > considered? Such as some multicast routing protocol?
> >
> > > Regarding the P2P PW setup procedure, there are two protocols, LDP and
> > BGP.
> > > Could we use BGP for P2MP PW setup?
> > > [FJ] Rahul has proposed an ID for P2MP PW setup based on BGP, derived
> > > from
> > the
> > > VPLS multicast solution. Based on existing deployment around L2VPN,
> > > the SP
> > may
> > > need to both solutions (LDP, and BGP)
> > > http://www.potaroo.net/ietf/idref/draft-raggarwa-l2vpn-p2mp-pw/
> >
> > [SX] thanks Fred for informing about the draft.
> > >
> > >
> > > Best wishes and regards
> > > Sherry
> > >
> > >

---

From: <[email-masked]>
Date: Mon, 11 May 2009 10:27:54 +0200

Hi Sherry,

Yes that's correct, except for source-initiated MS-PW.
Since upstream label assignment is used, it would make sense to get P2MP PSN tunnel.

Regards,
Fred

-----Message d'origine-----
De : Sherry Xue [mailto:[email-masked]] 
Envoyé : jeudi 7 mai 2009 04:51
À : JOUNAY Frederic RD-RESA-LAN
Cc : [email-masked]
Objet : RE: Re: Comments on draft-jounay-pwe3-leaf-initiated-p2mp-pw-01

 Thanks Fred,
 
Thanks for clarifying the items.
So there are four methods four instances, am I right?
-Leaf-initiated P2MP MS-PW (draft-jounay-pwe3-leaf-initiated-p2mp-pw)
	As described in the draft, downstream label assignment, and P2MP MS-PW over  P2P LSP only.
 
-Leaf-initiated P2MP SS-PW
    Upstream label request (leaf) +upstream label assignment (source), and P2MP  SS-PW over P2MP PSN tunnel only

 -Source-initiated P2MP MS-PW
    Upstream unsolicited label assignment and P2MP MS-PW over P2P PSN tunnel  only
 
 -Source-initiated P2MP SS-PW (draft-jounay-pwe3-source-initiated-p2mp-pw)
     As described in the draft, upstream unsolicited label assignment, and P2MP  over P2MP PSN tunnel only.

 I was confused, if in the P2MP MS-PW architecture, the underlying layer which  supports PW segment belonging to the PW tree may be either a P2P pr a P2MP PSN  tunnel(depicted in [P2MP PW REQ]),  how the PW routing should work, because  of the merge point. More works should be needed. It may be complex. Now I clear  about the items, and thanks Fred again.
 
 Regards
 Sherry
 
> > Subject: RE: Re: Comments on 
is
the
label
the
tunnel.
layer
requirement
be
solution
routing
OSPF
> > De : Sherry Xue [mailto:[email-masked]] Envoyé : mercredi 6 mai 
> > 2009 14:37 À : JOUNAY Frederic RD-RESA-LAN Cc : [email-masked] Objet 
> > : RE: Re: Comments on draft-jounay-pwe3-leaf-initiated-p2mp-pw-01
> >
> > Thanks Fred,
> > Please see inline.
> >
> > Regards
> > Sherry
> > > source-initiated mode are not restricted in the application of 
> > > SS-PW and
> > MS-PW.
> > > IMO, leaf initiated mode is more conveniently for MS-PW, and in 
> > > the source initiated mode, more work should be considered for 
> > > MS-PW, such as AD and
> > PW
> > > [FJ] Yes, it's true, we probably need both setup modes depending 
> > > on SP requirements. That's why we tried to define a new multicast 
> > > FEC element
> > which
> > > could fit to both.
> > >
> > > For P2MP SS-PW setup in leaf-initiated mode, it may be divided 
> > > into two
> > > instances:
P2MP
> MS-PW
> > setup procedure had been described correctly, and P2MP SS-PW should 
> > be considered also IMO.
> > [SX]yes, as pre-described, In leaf-initiated mode, the downstream 
> > label assignment should be considered. Each leaf-PE should 
> > assignment PW label
to
> > source.
> >
> > > 2) over P2MP PSN
> > > The merge-node should record the Label(called label L) allocated 
> > > by the downstream TAII(called  X) with SAII( S ), and if another 
> > > signaling
> > message
> > > should allocated label L for TAII Y(upstream label assignment), 
> > > and then allocate upstream label to next upstream hop.
> > > IMO, if the P2MP PW is initiated by the leafs, the PSN tunnel 
> > > should be
> > restrict
the
> > > and this would require Leaf PE to request the upstream PW P2MP 
> > > Label for
> > this
case
as,
LSP
> > > For P2MP MS-PW setup in source-initiated mode, the explicit 
> > > routing should
> > be
> > > setup according explicit routing. Right? Whether the explicit 
> > > routing is the
> > only
should
> > > [FJ] Rahul has proposed an ID for P2MP PW setup based on BGP, 
> > > derived from
> > the
> > > VPLS multicast solution. Based on existing deployment around 
> > > L2VPN, the SP
> > may