Subject: [PWE3] a question of draft-ietf-pwe3-fat-pw-00

From: [email-masked]
Date: Fri, 3 Jul 2009 12:27:21 +0800

hi,all
 for the draft,I have a question of flow label. for example  there is a 
situation as the following : 
 
according the solutions in this draft, there is a great traffic AC1 ,which 
may be transported in two pw path, e.g. PW1,PW2. and at resource and sink 
points, there is the same flow label . now we supposed there is another 
traffic AC2 ,which may be transported by encapsulation in pw3. 

question: if  pw3 label is the same AC1 flow label. how to distinguish 
them very well. whether AC1 service packets may be wrong regarded as AC2 
services packets.

best regards
liu

[email-masked] 
发件人:  [email-masked]
2009-07-02 16:15

收件人
[email-masked]
抄送
[email-masked]
主题
[PWE3] I-D Action:draft-ietf-pwe3-fat-pw-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts 
directories.
This draft is a work item of the Pseudowire Emulation Edge to Edge Working 
Group of the IETF.

                 Title           : Flow Aware Transport of Pseudowires 
over an MPLS PSN
                 Author(s)       : S. Bryant, et al.
                 Filename        : draft-ietf-pwe3-fat-pw-00.txt
                 Pages           : 18
                 Date            : 2009-07-01

Where the payload carried over a pseudowire carries a number of
identifiable flows it can in some circumstances be desirable to carry
those flows over the equal cost multiple paths (ECMPs) that exist in
the packet switched network.  Most forwarding engines are able to
hash based on label stacks and use this to balance flows over ECMPs.
This draft describes a method of identifying the flows, or flow
groups, to the label switched routers by including an additional
label in the label stack.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-fat-pw-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
ftp://[email-masked]/internet-drafts/draft-ietf-pwe3-fat-pw-00.txt
_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 03 Jul 2009 08:19:09 +0100

Liu

There is only one PW between the AC1 pair (PW1).

There are however multiple LSPs over which the PW1 could have been
routed due to ECMP (remember this is hop by hop forwarding
in an LDP environment in which the routes are inherited from the IGP).
What the draft does is to spread the PW1 traffic over those
paths in a way that does not damage the user traffic.

PW2 does not exist.

There is a statistical chance that PW3 will be co-routed, but that
is what happens in a hop by hop system.

PW1 pkts are distinguished from PW3 pkts by their PW
labels which are always present. The flow label is an
additional label.

- Stewart

[email-masked] wrote:
> according the solutions in this draft, there is a great traffic AC1
> ,which may be transported in two pw path, e.g. PW1,PW2. and at
> resource and sink points, there is the same flow label . now we
> supposed there is another traffic AC2 ,which may be transported by
> encapsulation in pw3.
>
> them very well. whether AC1 service packets may be wrong regarded as
> AC2 services packets.
>
>
> best regards
> liu
>
> 	
>
>
>
>
>
> [email-masked]*
> This draft is a work item of the Pseudowire Emulation Edge to Edge
> Working Group of the IETF.
>
>
> Title : Flow Aware Transport of Pseudowires over an MPLS PSN
> ftp://[email-masked]/internet-drafts/draft-ietf-pwe3-fat-pw-00.txt_______________________________________________
> pwe3 mailing list
> [email-masked]
> ZTEInformationSecurityNotice:Theinformationcontainedinthismailissolelypropertyofthesender'sorganization.Thismailcommunicationisconfidential.Recipientsnamedaboveareobligatedtomaintainsecrecyandarenotpermittedtodisclosethecontentsofthiscommunicationtoothers.
> Thisemailandanyfilestransmittedwithitareconfidentialandintendedsolelyfortheuseoftheindividualorentitytowhomtheyareaddressed.Ifyouhavereceivedthisemailinerrorpleasenotifytheoriginatorofthemessage.Anyviewsexpressedinthismessagearethoseoftheindividualsender.
> ThismessagehasbeenscannedforvirusesandSpambyZTEAnti-Spamsystem.
>   
> ------------------------------------------------------------------------
>

---

From: [email-masked]
Date: Fri, 3 Jul 2009 15:46:12 +0800

Stewart： 
  according to your answer,  I have a few   comments:
   1 how  to ensure the same pw label in multiple LSPs ?  it says, maybe 
this pw label used for AC service, have been assigned to another AC 
service in a LSP of the multiple LSPs.

   2 for sink points. IMO , flow label and pw label can't be distinguished 
only by Label Stack Level. it says , there is a  possibility to regards 
the flow 
   label as another pw label ,so it  processed  this flow label by 
mistakes.

  best regards
  liu

Stewart Bryant <[email-masked]> 
2009-07-03 15:19
请答复 给
[email-masked]

收件人
[email-masked]
抄送
"[email-masked]" <[email-masked]>
主题
Re: [PWE3] a question of draft-ietf-pwe3-fat-pw-00

Liu

PW2 does not exist.

- Stewart

hi,all 

best regards 
liu

[email-masked] 

收件人
[email-masked] 
抄送
[email-masked] 
主题

                Title           : Flow Aware Transport of Pseudowires over 
an MPLS PSN
                Author(s)       : S. Bryant, et al.
                Filename        : draft-ietf-pwe3-fat-pw-00.txt
                Pages           : 18
                Date            : 2009-07-01

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

---

From: Stewart Bryant <[email-masked]>
Date: Fri, 03 Jul 2009 10:21:01 +0100

> service in a LSP of the multiple LSPs.

You assign PW labels exactly as you do today.

You pick LB labels by any method you wish regardless of whether the same
label is used more than once.

The flow label is simply a hint to the ECMP code, and has no
significance to anyone.

>
> 2 for sink points. IMO , flow label and pw label can't be
> distinguished only by Label Stack Level. it says , there is a
> possibility to regards the flow
> label as another pw label ,so it processed this flow label by mistakes.
Sure, but this is a problem in any MPLS system - push or pop one label
too many and the result is undetermined.

You should know (from the PW label) whether you expect to see a LB label
and if you are expecting one you simply toss the next label.

Stewart

---

From: [email-masked]
Date: Sat, 4 Jul 2009 16:25:57 +0800

stewart:
  thank you for your explaining, I have already understood your meaning in 
 your draft

best regards
liu

2009-07-03 17:21
请答复 给
[email-masked]

收件人
[email-masked]
抄送

Stewart