Subject: [PWE3] FW: New Version Notification for draft-delregno-pw-vccv-impl-survey-results-00

From: "Delregno, Christopher N (Nick DelRegno)" <[email-masked]>
Date: Tue, 08 Mar 2011 14:27:25 +0000

Folks:

The 00 draft of the PW/VCCV Implementation Survey Results have been uploaded.  I will be presenting the results at IETF80.

https://datatracker.ietf.org/doc/draft-delregno-pw-vccv-impl-survey-results/

Thanks,
Nick

Christopher N. Del Regno, PMTS
C&T, Ethernet Network Architecture & Design
400 International Pkwy
Richardson, TX  75081
972-729-3411
[email-masked]

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Tuesday, March 08, 2011 8:16 AM
To: Delregno, Christopher N (Nick DelRegno)
Subject: New Version Notification for draft-delregno-pw-vccv-impl-survey-results-00

A new version of I-D, draft-delregno-pw-vccv-impl-survey-results-00.txt has been successfully submitted by Nick Del Regno and posted to the IETF repository.

Filename:	 draft-delregno-pw-vccv-impl-survey-results
Revision:	 00
Title:		 The Pseudowire (PW) & Virtual Circuit Connectivity Verification (VCCV) Implementation Survey Results
Creation_date:	 2011-03-07
WG ID:		 Independent Submission
Number_of_pages: 16

Abstract:
Most Pseudowire Emulation Edge-to-Edge (PWE3) encapsulations mandate
the use of the Control Word (CW) in order to better emulate the
services for which the encapsulations have been defined.  However,
some encapulations treat the Control Word as optional.  As a result,
implementations of the CW, for encapsulations for which it is
optional, vary by equipment manufacturer, equipment model and service
provider network.  Similarly, Virtual Circuit Connectivity
Verification (VCCV) supports three Control Channel (CC) types and
multiple Connectivity Verification (CV) Types.  This flexibility has
led to reports of interoperability issues within deployed networks
and associated drafts to attempt to remedy the situation.  This
survey of the PW/VCCV user community was conducted to determine
implementation trends.  The survey and results is presented herein.

The IETF Secretariat.

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 15 Mar 2011 15:41:33 +0000

Nick, 

In section 2.2 the percentages make sense under the assumption of 18 respondents :
5.6%   =  1 / 18
11.1%  =  2 / 18
16.7%  =  3 / 18
22.2%  =  4 / 18
44.4%  =  8 / 18
77.8%  = 14 / 18 

but section 2.1 only lists 17 :
1.	Time Warner Cable
2.	Bright House Networks
3.	Tinet
4.	AboveNet
5.	Telecom New Zealand
6.	Cox Communications
7.	MTN South Africa
8.	Wipro Technologies
9.	Verizon
10.	AMS-IX
11.	Superonline
12.	Deutsche Telekom AG
13.	Internet Solution
14.	Easynet Global Services
15.	Telstra Corporation
16.	OJSC MegaFon
17.	France Telecom Orange

Did you leave someone off, or did someone answer twice ?

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Delregno, Christopher N (Nick DelRegno)
Sent: Tuesday, March 08, 2011 16:27
To: pwe3
Subject: [PWE3] FW: New Version Notification for draft-delregno-pw-vccv-impl-survey-results-00

Folks:

Thanks,
Nick

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Tuesday, March 08, 2011 8:16 AM
To: Delregno, Christopher N (Nick DelRegno)
Subject: New Version Notification for draft-delregno-pw-vccv-impl-survey-results-00

Abstract:

The IETF Secretariat.

_______________________________________________
pwe3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pwe3

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 15 Mar 2011 18:21:21 +0200

Nick,
I also remember that 18 respondents have been mentioned when you've announced that the survey has been completed... 

Regards,
     Sasha

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Yaakov Stein
> Sent: Tuesday, March 15, 2011 5:42 PM
> Cc: pwe3
> Subject: Re: [PWE3] FW: New Version Notification for draft-delregno-pw-
> vccv-impl-survey-results-00
> 
> Nick,
> 
> The 00 draft of the PW/VCCV Implementation Survey Results have been
> uploaded.  I will be presenting the results at IETF80.
> 
> A new version of I-D, draft-delregno-pw-vccv-impl-survey-results-00.txt
> has been successfully submitted by Nick Del Regno and posted to the
> IETF repository.
> 
> Title:		 The Pseudowire (PW) & Virtual Circuit Connectivity
> Verification (VCCV) Implementation Survey Results

---

From: Luca Martini <[email-masked]>
Date: Tue, 15 Mar 2011 10:31:10 -0600

Nick,
Good survey, thanks for the work.

Are we going to publish this as informational ?
I think we should .
Also there is a mention of AToM in section 2.7 item 5 . It should be
changed to PWE ( AToM is a cisco marketing term , so we want o keep this
anonymous )
Thanks.
Luca

---

From: Thomas Nadeau <[email-masked]>
Date: Tue, 15 Mar 2011 15:18:01 -0400

One thing I'd ask is that we augment the survey to ask about the BFD mode for 
VCCV. It seems to have been left out of the survey, potentially skewing the results. 
As I understand it, this is the most popular mode.

	--Tom

---

From: "Delregno, Christopher N (Nick DelRegno)" <[email-masked]>
Date: Thu, 17 Mar 2011 15:54:44 +0000

Yaakov:

I'll take a look.  We did have one respondent answer twice, with the
second the same as the first except for one addition and a response to
the open-ended question.  I merged the response and the results of that
should have been reflected in the results, but I'll double check.

Thanks,
Nick

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]] 
Sent: Tuesday, March 15, 2011 10:42 AM
To: Delregno, Christopher N (Nick DelRegno)
Cc: pwe3
Subject: RE: [PWE3] FW: New Version Notification for
draft-delregno-pw-vccv-impl-survey-results-00

Nick, 

In section 2.2 the percentages make sense under the assumption of 18
respondents :
5.6%   =  1 / 18
11.1%  =  2 / 18
16.7%  =  3 / 18
22.2%  =  4 / 18
44.4%  =  8 / 18
77.8%  = 14 / 18 

Y(J)S

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Delregno, Christopher N (Nick DelRegno)
Sent: Tuesday, March 08, 2011 16:27
To: pwe3
Subject: [PWE3] FW: New Version Notification for
draft-delregno-pw-vccv-impl-survey-results-00

Folks:

https://datatracker.ietf.org/doc/draft-delregno-pw-vccv-impl-survey-resu
lts/

Thanks,
Nick

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Tuesday, March 08, 2011 8:16 AM
To: Delregno, Christopher N (Nick DelRegno)
Subject: New Version Notification for
draft-delregno-pw-vccv-impl-survey-results-00

A new version of I-D, draft-delregno-pw-vccv-impl-survey-results-00.txt
has been successfully submitted by Nick Del Regno and posted to the IETF
repository.

Abstract:

The IETF Secretariat.

---

From: "Delregno, Christopher N (Nick DelRegno)" <[email-masked]>
Date: Thu, 17 Mar 2011 16:00:35 +0000

Luca:

Yes, the plan is to publish as informational.

Regarding Section 2.7 Item 5, this was verbatim response from the
open-ended question.  As such, I didn't edit the responses for anything
other than explicit company names as denoted by "COMPANY" and "EQUIPMENT
MANUFACTURER".

I agree that AToM is a Cisco marketing term.  I believe the respondent
used the term loosely since there was no specific reference to the
EQUIPMENT MANUFACTURER providing that service.

Nick

-----Original Message-----
From: Luca Martini [mailto:[email-masked]] 
Sent: Tuesday, March 15, 2011 11:31 AM
To: Delregno, Christopher N (Nick DelRegno)
Cc: Yaakov Stein; pwe3
Subject: Re: [PWE3] FW: New Version Notification for

Nick,

respondents :
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of Delregno, Christopher N (Nick DelRegno)
> A new version of I-D,
draft-delregno-pw-vccv-impl-survey-results-00.txt has been successfully
submitted by Nick Del Regno and posted to the IETF repository.
> Title:		 The Pseudowire (PW) & Virtual Circuit
Connectivity Verification (VCCV) Implementation Survey Results

---

From: "Delregno, Christopher N (Nick DelRegno)" <[email-masked]>
Date: Thu, 17 Mar 2011 16:03:09 +0000

Tom:

Please pose that question to the WG (maybe that's what you were doing).
When we crafted the survey, omitting BFD was an oversight.  However, the
list of questions was sent to the WG for comment before the survey was
conducted.  If the WG would like, I can contact the respondents directly
to inquire of their BFD usage as well.  However, I don't think the
survey should be reopened.

Thanks,
Nick

-----Original Message-----
From: Thomas Nadeau [mailto:[email-masked]] 
Sent: Tuesday, March 15, 2011 2:18 PM
To: Luca Martini
Cc: Delregno, Christopher N (Nick DelRegno); Yaakov Stein; pwe3
Subject: Re: [PWE3] FW: New Version Notification for

	One thing I'd ask is that we augment the survey to ask about the
BFD mode for 
VCCV. It seems to have been left out of the survey, potentially skewing
the results. 
As I understand it, this is the most popular mode.

	--Tom

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 17 Mar 2011 13:03:28 -0400

That's precisely what I'm asking for: for the wg to agree to augment the existing survey with a short additional one that focuses in the missing bfd mode only.

Tom

---

From: "Delregno, Christopher N (Nick DelRegno)" <[email-masked]>
Date: Thu, 17 Mar 2011 20:32:15 +0000

Yaakov:

Yep, looks like that section was based on the 18 responses as you
deduced.  Nice catch.

I will update based on the 17 results and also scrub the rest of the
results as well.

I will post an updated version when complete.

Thanks,
Nick

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]] 
Sent: Tuesday, March 15, 2011 10:42 AM
To: Delregno, Christopher N (Nick DelRegno)
Cc: pwe3
Subject: RE: [PWE3] FW: New Version Notification for

Nick, 

Y(J)S

-----Original Message-----

Folks:

Thanks,
Nick

-----Original Message-----
From: IETF I-D Submission Tool [mailto:[email-masked]] 
Sent: Tuesday, March 08, 2011 8:16 AM
To: Delregno, Christopher N (Nick DelRegno)
Subject: New Version Notification for

Abstract:

The IETF Secretariat.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 18 Mar 2011 12:56:56 -0400

Are there any objections in the WG to Tom's suggestion?

Thanks,
Andy

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 28 Mar 2011 20:34:11 +0200

Andy, Tom, Nick and all,
I support Tom's suggestion. 

I would also like to suggest one more extension to the survey.

In its present form, it says how many *operators* can use CW in this or that PW type where it is optional, and how many *operators* actually use it - again, per PW type. It also says how many PWs of this or that type have been actually deployed.

IMHO and FWIW, it would be most helpful if we could have the information about the number of *PW instances* that use (or do not use) an optional  CW - again, per PW type.

Regards,
     Sasha

> Andrew G. Malis
> Sent: Friday, March 18, 2011 6:57 PM
> To: Thomas Nadeau
> Cc: Luca Martini; Yaakov Stein; pwe3
> > That's precisely what I'm asking for: for the wg to agree to augment
> the existing survey with a short additional one that focuses in the
> missing bfd mode only.
> >
> > Tom
> >
> > On Mar 17, 2011, at 12:03 PM, "Delregno, Christopher N (Nick
> DelRegno)" <[email-masked]> wrote:
> >
> >> Tom:
> >>