Subject: Re: [PWE3] negotiation of CC encapsulation

From: David Allan I <[email-masked]>
Date: Mon, 28 Mar 2011 05:08:36 -0400

HI:

Yakov raised some interesting points during PWE today.

My concern is receiving something unexpected could be an indication of more than simply poor configuration. So it would be useful for an implementation to go further than simple silent discard. It MAY examine the unexpected frame to see if it is coming from an unexpected source. Sufficient information exists in some cases to do so (e.g. NOT RFC 5885 encap)...

My 2 cents
D

---

From: Curtis Villamizar <[email-masked]>
Date: Mon, 28 Mar 2011 05:35:59 -0400

In message <[email-masked]>
David Allan I writes:
> Hi:
> My concern is receiving something unexpected could be an indication of more=
>  than simply poor configuration. So it would be useful for an implementatio=
> n to go further than simple silent discard. It MAY examine the unexpected f=
> rame to see if it is coming from an unexpected source. Sufficient informati=
> on exists in some cases to do so (e.g. NOT RFC 5885 encap)...
>  
> My 2 cents
> D

MS-PW may force the use of both CW or GAL and TTL, with TTL used to
traceroute a MS-PW and CW or GAL used when addressing the end node.

Unless I'm mistaken, preferring CW or GAL but accepting CW or GAL (or
both) and also accepting TTL would not be a problem.  Sending TTL in
that case for traceroute only might yield a dead spot just like
hitting an IP router with ICMP on TTL disabled does today.

Curtis