Subject: [PWE3] PW status TLV vs BFD diagnostic codes

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 28 Mar 2011 11:33:46 +0200

Yaakov and all,
I'd like to reiterate the point Rob and I have made in the PWE3 meeting today:

The status mechanisms based on BFD diagnostic codes does not support (and, AFAIK, cannot support) the PW redundancy mechanism.

Regards,
     Sasha

---

From: "Mallette, Edwin" <[email-masked]>
Date: Mon, 28 Mar 2011 06:24:45 -0400

Yaakov,

It also strikes me that this is an attempt at solving a narrow corner case with additional specification language.  Protocol inter-dependence is common, so I'm not sure why the need to split this particular hair.  IMO the mechanism BFD -> PW status TLV works fine.   I suppose your point is that if you don't support PW status TLV that then you have to use label withdrawals, not ideal perhaps, but is this really a problem in existing deployments ?   Is there a broad deployment of PWs out there that don't support PW Status TLV ?  I don't think so.

And to Sasha's point, a large reason I would use BFD would be for PW Redundancy fault detection and I wouldn't want to be muddying those waters overmuch.

Cheers!
Ed

From: Alexander Vainshtein <[email-masked]<mailto:[email-masked]>>
Date: Mon, 28 Mar 2011 05:33:46 -0400
To: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, pwe3 <[email-masked]<mailto:[email-masked]>>, Robert Rennison <[email-masked]<mailto:[email-masked]>>
Subject: [PWE3] PW status TLV vs BFD diagnostic codes

Yaakov and all,
I’d like to reiterate the point Rob and I have made in the PWE3 meeting today:

Regards,
     Sasha

________________________________
CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.