Subject: [PWE3] Entropy labels and the GAL....

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 10:08:43 -0400

HI

During yesterday's PWE session the subject of GALs and PWs came up.

To reiterate my concern, it was that the use of the GAL for a PW in a network that could employ ECMP rendered the OAM useless. For some strange reason this is permitted in RFC 5586, while use of the GAL for a PW in an MPLS-TP network is not (where the explicit prohibition against ECMP means it COULD be safely used), huh!???

My belief is that permitting the use of the GAL for PWs in both domains will result in MS-PWs for which the OAM is useless. FM PM, and DM will return false indications due to the lack of fate sharing... so different latency, out of order delivery of PM loss measurement, and potential false positives, or negatives for FM.

My conclusion was that IF steps were being taken such that reserved labels (or at least the GAL) were explicitly excluded from ECMP processing THEN it would make sense to open Pandora's box. During the meeting it was suggested this was the case in work progressing in draft-ietf-mpls-entropy-label-00 and so I withdrew my objection to things continuing on their merry way.

So I went and read the current version of the entropy label draft and unfortunately this is only true in a narrow sense. Fate sharing would only be preserved for implementations that ONLY hashed the bottom label of a PW using the entropy label. Not for any generic use of the GAL with PWs.

So not only do I now believe the problem not on it's way to resolution, IMO the scenario is actually GETTING WORSE. We are now permitting the GAL to be other than bottom label to address a narrow case and only a small portion of RFC 4928. I would now assert that allowing the GAL to be other than the bottom label is a worse and incomplete solution vs. excluding label 13 from ECMP processing and is perpetuating a bad situation.

So t'was my bad for rolling over yesterday without doing my homework, but there you have it

Dave

BTW If I could make a suggestion, if we are XORing one or more labels together prior to doing further processing, also XOR it with 13, and make the GAL the ONE label value that has no effect. It would do the world a huge favor.

---

From: John E Drake <[email-masked]>
Date: Wed, 27 Jul 2011 08:56:19 -0700

Dave,

A previous version of the Entropy Label draft stipulated that reserved labels were not to be input to a transit node's load balancing function;  this was inadvertently dropped from the current version but will be re-added to the next version.  I am thinking that a bis version of Stewart's ECMP considerations RFC that also specifies this behavior would be the appropriate place to codify this once and for all.

Thanks,

John

Sent from my iPhone

From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Wednesday, July 27, 2011 7:09 AM
To: [email-masked]
Cc: [email-masked]
Subject: [PWE3] Entropy labels and the GAL....

HI

Dave

---

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 13:51:02 -0400

HI John:

Thanks for this!

Updating 4928 to me is the right way to go but I'd also want to see us revert to restricting GAL to bottom label at the same time. It also means that we are saying SOMETHING prescriptive about ECMP implementations which is "where no MPLS RFC has gone before", but I for one am OK with that, IMO it is long overdue!

cheers
Dave

________________________________
From: John E Drake [mailto:[email-masked]]
Sent: Wednesday, July 27, 2011 11:56 AM
To: David Allan I; [email-masked]
Cc: [email-masked]; Kireeti Kompella
Subject: RE: Entropy labels and the GAL....

Dave,

Thanks,

John

Sent from my iPhone

HI

Dave

---

From: John E Drake <[email-masked]>
Date: Wed, 27 Jul 2011 11:03:25 -0700

Dave,

Unfortunately that is not possible.   The GAL effectively functions as an application label, and the logic at the egress node uses the application label, in which it would normally expect to see BOS set to 1, with BOS  set to 0 as an indicator of the presence of an entropy label.

Thanks,

John

Sent from my iPhone

From: David Allan I [mailto:[email-masked]]
Sent: Wednesday, July 27, 2011 10:51 AM
To: John E Drake; [email-masked]
Cc: [email-masked]; Kireeti Kompella
Subject: RE: Entropy labels and the GAL....

HI John:

Thanks for this!

cheers
Dave

Thanks,

John

Sent from my iPhone

HI

Dave

---

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 14:17:54 -0400

I'm confused, this suggests that the GAL is an ELI for OAM and somthing else is an ELI for payload. IMO that seems broken unless you are only hashing top label.

Presumably an entropy label can alias as a GAL or RA as well..?

D

Sent: Wednesday, July 27, 2011 2:03 PM

Dave,

Thanks,

John

Sent from my iPhone

HI John:

Thanks for this!

cheers
Dave

Thanks,

John

Sent from my iPhone

HI

Dave

---

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 14:26:17 -0400

I withdraw the second comment...

D

________________________________
From: David Allan I
Sent: Wednesday, July 27, 2011 2:18 PM
To: 'John E Drake'; [email-masked]
Cc: [email-masked]; Kireeti Kompella
Subject: RE: Entropy labels and the GAL....

D

Dave,

Thanks,

John

Sent from my iPhone

HI John:

Thanks for this!

cheers
Dave

Thanks,

John

Sent from my iPhone

HI

Dave

---

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 14:36:40 -0400

Apologies for repeated messages....

I'm confused as to why the GAL takes the role of the application label. It does not seem necessary. If I want PW OAM the PW label would need to be there, if I were to fate share with the path taken for the flow associated with the entopy label, the TL, AL, ELI etc. all have to be there as the draft recommends using the whole stack as a key.

So IMO there is no apparent justification for overloading the GAL and removing the BOS restriction...There is justification for not hashing reserved labels...

?
Dave

Dave,

Thanks,

John

Sent from my iPhone

HI John:

Thanks for this!

cheers
Dave

Thanks,

John

Sent from my iPhone

HI

Dave

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 27 Jul 2011 19:44:44 +0100

Dave

There may have been some confusion in our discussion at the Mike yesterday.

A fat label cannot be a reserved label. If the hash of the flow signature
aliases to a reserved label and new hash must be generated, or the hash
suitably modified (for example by adding 16 to the output, or forcing a 
bit, or
rehashing ....). If this is not done all  mechanisms that use reserved 
labels
will break.

You may however have been making a different point that I missed.

Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 27 Jul 2011 19:48:42 +0100

>  There /is/ justification for not hashing reserved labels...

That would fix a bunch of the OAM problems, but unfortunately
would not be backwards compatible with deployed
P routers or SPEs

Stewart

---

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 14:49:50 -0400

Hi Stewart,

I had not read the entire document at that point, it is clear on precluding use of a reserved value for an entropy label....just had not hit that part hopping around the content...

D

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Wednesday, July 27, 2011 2:45 PM
To: [email-masked]
Subject: Re: [PWE3] Entropy labels and the GAL....

Dave

A fat label cannot be a reserved label. If the hash of the flow signature
aliases to a reserved label and new hash must be generated, or the hash
suitably modified (for example by adding 16 to the output, or forcing a bit, or
rehashing ....). If this is not done all  mechanisms that use reserved labels
will break.

Stewart

---

From: David Allan I <[email-masked]>
Date: Wed, 27 Jul 2011 14:52:35 -0400

Which gets back to my original point, creating an environment where we would use a GAL where existing kit would obstruct fate sharing is IMO a mistake...

I can't stuff toothpaste back into the tube, but I can avoid squeezing the tube again....

D

________________________________
From: Stewart Bryant [mailto:[email-masked]]
Sent: Wednesday, July 27, 2011 2:49 PM
To: David Allan I
Cc: John E Drake; [email-masked]; Kireeti Kompella; [email-masked]
Subject: Re: [PWE3] Entropy labels and the GAL....

> There is justification for not hashing reserved labels...

Stewart