Subject: [PWE3] Payload needs to align with a 32-bit boundary

From: Javi Muñoz <[email-masked]>
Date: Thu, 01 Dec 2011 17:37:26 +0100

The requeriment "PW payload must be an integer number of 4 octets" 
affects to:

* Any PW:
     + TDMPWs (any type -SAToP, CESoPSN, TDMoIP AA1/AAL2-  and 
with/without RTP header)
     + HDLCPWs
     + FRPWs, ...

* and for any PSN:
     + L2TPv3
     + MPLS
     + UDP/IP
     + Ethernet

or only some of them?

Regards,

Javi

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 1 Dec 2011 19:07:51 +0200

Javi,
RFC 4448 does not add any padding to Ethernet frames (comprising the payload of Ethernet PWs), nor does it provide for removing such padding. And since Ethernet frames can be of any length starting from 64 octets and up to the MTU, there is clearly no requirement for the alignment of you're asking about.
The same applies to HDLC and FR PWs.

For ATM PWs carrying cells in N:1 mode the payload size would be a multiple of 52 and hence a multiple of 4.  But the rest of the ATM modes would not impose any "alignment" restrictions on the payload size.

With TDMoIP in AAL1 mode (Yaakov, please correct me if I am missing something) the payload of a PW packet is comprised by several AAL1 PDUs, and hence its size is a multiple of 48. I am not sure about TDMoIP in AAL2 mode.

Last but not least, RFC 4553 (SAToP) does not place any limitations on the payload size. With CESoPSN, the payload size must be a multiple of the number of timeslots a given CESoPSN PW carries, bit no other restrictions exist.

Regards,
     Sasha

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Javi Mu?oz
> Sent: Thursday, December 01, 2011 6:37 PM
> To: [email-masked]
> Subject: [PWE3] Payload needs to align with a 32-bit boundary
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: Javi Muñoz <[email-masked]>
Date: Mon, 05 Dec 2011 10:36:54 +0100

Sasha,

Thanks, I agree.

We had an internal discussion in our working group. I just wanted to 
confirm my opinion.

Regards,

PD: With TDMoIP in AAL2 mode, the payload of a PW packet is comprised by 
several mini-cells, each 4 to 67 bytes.

Javi