Subject: Re: [PWE3] WG last call for draft-ietf-pwe3-pw-typed-wc-fec-02

From: Lizhong Jin <[email-masked]>
Date: Sun, 15 Jan 2012 21:43:34 +0800

Hi Kamran,
I review this new version, and in section 3, it says: "Label TLV in label
messages to further constraint the wildcard to all FECs of the specified
FEC type [and its specific filter] that are also bound to the specified
label."
Does that mean, there would be one label allocated for more than one
PW-FEC? The PW label would be allocated from the per-platform label space.
Could you give me an example that one PW label is allocated for more than
one PW-FEC?

Thank you.
Lizhong

> ------------------------------
>
> Message: 3
> Date: Thu, 12 Jan 2012 14:48:32 -0500
> From: "Andrew G. Malis" <[email-masked]>
> To: [email-masked]
> Subject: [PWE3] WG last call for draft-ietf-pwe3-pw-typed-wc-fec-02
> Message-ID:
>        <CAK+d4xtmnnxQ5ZppXvYy18ik6LxdbNwp7kyYakC4sVcL=[email-masked]
> >
> Content-Type: text/plain; charset="iso-8859-1"
>
> This email begins a two week working group last call for
> draft-ietf-pwe3-pw-typed-wc-fec-02.
>
> Please post any comments to the PWE3 mailing list.
>
> This working group last call will end on Thursday 26 January 2012.
>
> Regards,
> Andy & Matthew
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <
> http://www.ietf.org/mail-archive/web/pwe3/attachments/20120112/c7bfef1f/attachment.htm
> >
>
> ------------------------------
>

---

From: Kamran Raza <[email-masked]>
Date: Tue, 17 Jan 2012 08:07:23 -0500

Hi Lizhong,

Although same label (e.g. Implicit-null) can be used for more than one
prefix FEC, currently I do not see an example / usage of same label for PW
FEC. However, LDP Typed Wildcard spec/guidelines RFC 5918 allows a FEC
designer to possibly constrain Typed Wildcarding in a scope of some label,
hence the same applies to Typed WC PW FEC;  We should conform to Typed WC
guidelines while defining Typed WC FEC for a FEC and hence we should leave
this possibility for future even if it does not seem to apply currently.
Moreover, It does not harm as it is an optional param anyways.

HTC.

On 12-01-15 8:43 AM, "Lizhong Jin" <[email-masked]> wrote:

> messages to further constraint the wildcard to all FECs of the specified FEC
> type [and its specific filter] that are also bound to the specified label."
> Does that mean, there would be one label allocated for more than one PW-FEC?
> The PW label would be allocated from the per-platform label space. Could you
> give me an example that one PW label is allocated for more than one PW-FEC?
>  
> Thank you.
> Lizhong
>  
>  
>>        <CAK+d4xtmnnxQ5ZppXvYy18ik6LxdbNwp7kyYakC4sVcL=[email-masked]>
>> URL: 
>> <http://www.ietf.org/mail-archive/web/pwe3/attachments/20120112/c7bfef1f/atta
>> chment.htm>
>> 

-- 
Syed Kamran Raza
Technical Leader, SPRSG IOS-XR Routing (MPLS)
Cisco Systems, Inc.,
Kanata, ON, K2K 3E8, Canada
Ph: +1 (613) 254-4520
http://www.cisco.com

---

From: Lizhong Jin <[email-masked]>
Date: Wed, 18 Jan 2012 21:50:50 +0800

Hi Kamran,
Thank you for the clarification. I am OK with that now.

Lizhong

2012/1/17 Kamran Raza <[email-masked]>

> *http://www.cisco.com*