Subject: [PWE3] GAL in PW question

From: "Shahram Davari" <[email-masked]>
Date: Tue, 17 Jan 2012 17:52:50 -0800

Hi,

RFC 5586 now defines using GAL for PW. The question I have is don't we need to define a new CC type encoding (as per RFC 5085) for signaling this capability?

Thanks
Shahram

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 17 Jan 2012 21:06:58 -0500

Hi Shahram,
I think that draft-nadeau-pwe3-vccv-2-02 defines use of GAL on PW as VCCV CC Type 4.

    Regards,
        Greg

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Tuesday, January 17, 2012 5:53 PM
To: [email-masked]
Subject: [PWE3] GAL in PW question

Hi,

Thanks
Shahram

---

From: "Shahram Davari" <[email-masked]>
Date: Tue, 17 Jan 2012 21:25:48 -0800

Great, but first of it is expired and secondly it is informational. I think we need to bring it back to standards track.

Thx
Shahram

From: Gregory Mirsky [mailto:[email-masked]]
Sent: Tuesday, January 17, 2012 06:06 PM
To: Shahram Davari; [email-masked] <[email-masked]>
Subject: RE: GAL in PW question

Hi Shahram,

    Regards,
        Greg

Hi,

RFC 5586 now defines using GAL for PW. The question I have is don’t we need to define a new CC type encoding (as per RFC 5085) for signaling this capability?

Thanks
Shahram

---

From: Greg Mirsky <[email-masked]>
Date: Tue, 17 Jan 2012 22:04:01 -0800

Hi Shahram,
you're right, I've noticed that even though the proposal clearly defines
new behavior it, strangely, is on Informational track. But I think that
this is not a big problem and it can be easily put on standard's track next
time authors submit new revision. I think we'll learn of their plans soon.

Regards,
Greg

On Tue, Jan 17, 2012 at 9:25 PM, Shahram Davari <[email-masked]> wrote:

> **
> Great, but first of it is expired and secondly it is informational. I
> think we need to bring it back to standards track.
>
> Thx
> Shahram
>
>  *From*: Gregory Mirsky [mailto:[email-masked]]
> *Sent*: Tuesday, January 17, 2012 06:06 PM
> *To*: Shahram Davari; [email-masked] <[email-masked]>
> *Subject*: RE: GAL in PW question
>
> Hi Shahram,
>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf
> Of *Shahram Davari
> *Sent:* Tuesday, January 17, 2012 5:53 PM
> *To:* [email-masked]
> *Subject:* [PWE3] GAL in PW question
>
>  Hi,****
>
> ** **
>
> RFC 5586 now defines using GAL for PW. The question I have is don’t we
> need to define a new CC type encoding (as per RFC 5085) for signaling this
> capability?****
>
>  ****
>
> ** **
>
> Thanks****
>
> Shahram****
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 18 Jan 2012 09:19:40 +0200

Dear Greg, Shahram and all,
I see only two alternatives here:

 1.  Define VCCV Type 4 (GAL-based) explicitly in a Standard Track document that updates 5085. The definition must also address the issue of priorities among the CC types when the peers support multiple PW types, etc.
 2.  Decide that in spite of 5586 allowing usage of GAL with PWs it will not be used  - for good or until further notice (5586 does not specify any usage of GAL with PWs, simply allows it).

My 2c,

     Sasha

________________________________
From: [email-masked] [[email-masked]] On Behalf Of Greg Mirsky [[email-masked]]
Sent: Wednesday, January 18, 2012 8:04 AM
To: Shahram Davari
Cc: [email-masked]
Subject: Re: [PWE3] GAL in PW question

Hi Shahram,
you're right, I've noticed that even though the proposal clearly defines new behavior it, strangely, is on Informational track. But I think that this is not a big problem and it can be easily put on standard's track next time authors submit new revision. I think we'll learn of their plans soon.

Regards,
Greg

On Tue, Jan 17, 2012 at 9:25 PM, Shahram Davari <[email-masked]<mailto:[email-masked]>> wrote:
Great, but first of it is expired and secondly it is informational. I think we need to bring it back to standards track.

Thx
Shahram

From: Gregory Mirsky [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, January 17, 2012 06:06 PM
To: Shahram Davari; [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: GAL in PW question

Hi Shahram,

    Regards,
        Greg

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Shahram Davari
Sent: Tuesday, January 17, 2012 5:53 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [PWE3] GAL in PW question

Hi,

Thanks
Shahram

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: "Shahram Davari" <[email-masked]>
Date: Tue, 17 Jan 2012 23:49:52 -0800

Hi Sasha,

Two questions:

1) Does VCC1, 2, 3 apply to MPLS-TP PW?

2) should an MPLS-TP node be configured in order to process received VCCV4 packets? Or it should just process such packets without any configuration.

thanks
Shahram

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Tuesday, January 17, 2012 11:19 PM
To: Greg Mirsky <[email-masked]>; Shahram Davari
Cc: [email-masked] <[email-masked]>
Subject: RE: [PWE3] GAL in PW question

My 2c,

     Sasha

Hi Shahram,

Regards,
Greg

Thx
Shahram

Hi Shahram,

    Regards,
        Greg

Hi,

Thanks
Shahram

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 18 Jan 2012 00:46:59 -0800

Hi Shahram,
my $.02 in-line below.

Regards,
Greg

On Tue, Jan 17, 2012 at 11:49 PM, Shahram Davari <[email-masked]>wrote:

> GIM>>  Yes, absolutely.

> 2) should an MPLS-TP node be configured in order to process received VCCV4
> packets? Or it should just process such packets without any configuration.
> GIM>> PW VCCV CC Type 4 is, IMO, can be selected if all PEs support it
> when dynamic signalling used. Or be the explicitly configured for static
> PW. If another VCCV CC type selected/convigured, then packets with GAL must
> be dropped by PE.
>

Regards,
Greg

> thanks
> Shahram
>
>  *From*: Alexander Vainshtein [mailto:[email-masked]]
> *Sent*: Tuesday, January 17, 2012 11:19 PM
> *To*: Greg Mirsky <[email-masked]>; Shahram Davari
> *Cc*: [email-masked] <[email-masked]>
> *Subject*: RE: [PWE3] GAL in PW question
>
>    1. Define VCCV Type 4 (GAL-based) explicitly in a Standard Track
>    document that updates 5085. The definition must also address the issue of
>    priorities among the CC types when the peers support multiple PW types, etc.
>    2. Decide that in spite of 5586 allowing usage of GAL with PWs it will
>    not be used  - for good or until further notice (5586 does not specify any
>    usage of GAL with PWs, simply allows it).
>
> My 2c,
>
>      Sasha
>
> *From:* [email-masked] [[email-masked]] On Behalf Of Greg
> Mirsky [[email-masked]]
> *Sent:* Wednesday, January 18, 2012 8:04 AM
> *To:* Shahram Davari
> *Cc:* [email-masked]
> *Subject:* Re: [PWE3] GAL in PW question
>
>  Hi Shahram,
> On Tue, Jan 17, 2012 at 9:25 PM, Shahram Davari <[email-masked]>wrote:
>
>> **
>   This e-mail message is intended for the recipient only and contains
> information which is CONFIDENTIAL and which may be proprietary to ECI
> Telecom. If you have received this transmission in error, please inform us
> by e-mail, phone or fax, and then delete the original and all copies
> thereof.
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 18 Jan 2012 13:11:36 +0200

Shahram,
Please see some answers inline below.

My 2c,
     Sasha

From: Shahram Davari [mailto:[email-masked]]
Sent: Wednesday, January 18, 2012 9:50 AM
To: Alexander Vainshtein; [email-masked]'
Cc: [email-masked]'
Subject: Re: [PWE3] GAL in PW question

Hi Sasha,

Two questions:

1) Does VCC1, 2, 3 apply to MPLS-TP PW?
[[[Sasha]]] IMHO and FWIW VCCV Type 1 definitely applies since it can be used without IP/UDP encapsulation (the type of the OAM packets is defined by the A-CH).

2) Should an MPLS-TP node be configured in order to process received VCCV4 packets? Or it should just process such packets without any configuration.
[[[Sasha]]] So far there have been no mandatory VCCV type, and VCCV Type 1 has been mandated where CW is used. So I would say that, for the purpose of backward compatibility, configuration and coordination are required to use VCCV Type 4.

thanks
Shahram

My 2c,

     Sasha

Regards,
Greg

Thx
Shahram

Hi Shahram,

    Regards,
        Greg

Thanks
Shahram

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 18 Jan 2012 07:36:51 -0800

I agree.

Thx
SD

From: Greg Mirsky [mailto:[email-masked]]
Sent: Wednesday, January 18, 2012 12:46 AM
To: Shahram Davari
Cc: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Subject: Re: [PWE3] GAL in PW question

Hi Shahram,
my $.02 in-line below.

Regards,
Greg

On Tue, Jan 17, 2012 at 11:49 PM, Shahram Davari <[email-masked]<mailto:[email-masked]>> wrote:
Hi Sasha,

Two questions:

2) should an MPLS-TP node be configured in order to process received VCCV4 packets? Or it should just process such packets without any configuration.
GIM>> PW VCCV CC Type 4 is, IMO, can be selected if all PEs support it when dynamic signalling used. Or be the explicitly configured for static PW. If another VCCV CC type selected/convigured, then packets with GAL must be dropped by PE.

Regards,
Greg
thanks
Shahram

From: Alexander Vainshtein [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Tuesday, January 17, 2012 11:19 PM
To: Greg Mirsky <[email-masked]<mailto:[email-masked]>>; Shahram Davari
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: RE: [PWE3] GAL in PW question

My 2c,

     Sasha

________________________________
From: [email-masked]<mailto:[email-masked]> [[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky [[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, January 18, 2012 8:04 AM
To: Shahram Davari
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [PWE3] GAL in PW question

Hi Shahram,

Regards,
Greg

Thx
Shahram

Hi Shahram,

    Regards,
        Greg

Hi,

Thanks
Shahram

---

From: "Shahram Davari" <[email-masked]>
Date: Wed, 18 Jan 2012 16:17:18 -0800

Thanks Sasha, seems reasonable.

Thx
SD

From: Alexander Vainshtein [mailto:[email-masked]]
Sent: Wednesday, January 18, 2012 3:12 AM
To: Shahram Davari
Cc: [email-masked]'; [email-masked]'
Subject: RE: [PWE3] GAL in PW question

Shahram,

My 2c,
     Sasha

Hi Sasha,

Two questions:

thanks
Shahram

My 2c,

     Sasha

Regards,
Greg

Thx
Shahram

Hi Shahram,

    Regards,
        Greg

Thanks
Shahram