Subject: [PWE3] I-D Action: draft-ietf-pwe3-pw-typed-wc-fec-03.txt

From: [email-masked]
Date: Mon, 06 Feb 2012 20:27:26 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Pseudowire Emulation Edge to Edge Working Group of the IETF.

	Title           : LDP Typed Wildcard FEC for PWid and Generalized PWid FEC Elements
	Author(s)       : Kamran Raza
                          Sami Boutros
                          Carlos Pignataro
	Filename        : draft-ietf-pwe3-pw-typed-wc-fec-03.txt
	Pages           : 9
	Date            : 2012-02-06

   The "Typed Wildcard Forwarding Equivalence Class (FEC) Element"
   defines an extension to the Label Distribution Protocol (LDP) that
   can be used when it is desired to request or withdraw or release all
   label bindings for a given FEC Element type.  However, a typed
   wildcard FEC element must be individually defined for each FEC
   element type.  This specification defines the typed wildcard FEC
   elements for the PWid (0x80) and Generalized PWid (0x81) FEC element
   types.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-pwe3-pw-typed-wc-fec-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-pwe3-pw-typed-wc-fec-03.txt

---

From: Kamran Raza <[email-masked]>
Date: Mon, 06 Feb 2012 23:39:27 -0500

The changes from rev -02 to -03 mainly incorporates comments received during
WG LC:

1- Clarifies that PW Typed WC FEC can be used in any LDP message that allows
FEC element - i.e. Label messages, Address Withdraw [ for VPLS], and
Notification.

 2 - New Section 4.4: Applicability of PW Typed WC FEC in VPLS MAC
Withdrawal to allow a PE node to ³wildcard² withdraw **all** MAC addresses
for:      
     o  all VPLS instances; or
     o  all VPLS instances corresponding to a given PW type.
 
  [ Ack Daniel Cohn for his input ]

3- Mandates that VPLS MAC Wdw (Address Withdrawal) MUST contain an ³empty²
list if PW Typed WC specified in FEC TLV.

Rgds,
-- Kamran

On 12-02-06 11:27 PM, "[email-masked]" <[email-masked]>
wrote:

> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the Pseudowire Emulation Edge to
> Edge Working Group of the IETF.
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3

-- 
Syed Kamran Raza
Technical Leader, SPRSG IOS-XR Routing (MPLS)
Cisco Systems, Inc.,
Kanata, ON, K2K 3E8, Canada
Ph: +1 (613) 254-4520
http://www.cisco.com

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 7 Feb 2012 07:04:23 +0100

Kamran,

Thanks to you and the other authors.

I'll leave this open for a couple of more days to give WG participants
a chance to review the changes, and assuming there aren't any further
comments, I'll forward it to the IESG.

I would like to remind the WG that you can easily generate a diff by
going to https://tools.ietf.org/html/draft-ietf-pwe3-pw-typed-wc-fec-03
and clicking on "Diff1" and "Diff2" to get two types of diffs.

Cheers,
Andy