Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

From: Lizhong Jin<[email-masked]>
Date: Wed, 14 Nov 2012 16:13:59 +0800

Hi Samer,
Could you provide more technical detail about the one without IPR? I must 
miss something in this discussion.

Thanks
Lizhong

> ------------------------------
> 
> Message: 2
> Date: Wed, 31 Oct 2012 15:42:55 +0000
> From: "Samer Salam (ssalam)" <[email-masked]>
> To: Yaakov Stein <[email-masked]>, "[email-masked]"
>    <[email-masked]>, "'Andrew G. Malis'"
>    <[email-masked]>,   "[email-masked]" <[email-masked]>,
>    "[email-masked]"
>    <[email-masked]>
> Cc: "Stewart Bryant \(stbryant\)" <[email-masked]>
> Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to
>    draft-ietf-pwe3-iccp-09
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="windows-1252"
> 
> Hi,
> 
> To further clarify: two ways of implementing the described procedure
> were identified in the course of the discussions, one without the 
> IPR and one with. The current draft only captures the latter because
> it offers better reversion time characteristics (note that failover 
> protection time is comparable for both, it is primarily the 
> reversion time upon recovery that is different). With the approval 
> of the other co-authors, we would be happy to:
> 
> 1- Either Capture only the option without the IPR, OR
> 2- Capture both options with the above tradeoff highlighted
> 
> Regards,
> Samer
> 
> From: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
> Date: Wednesday, October 31, 2012 1:06 AM
> To: "[email-masked]<mailto:[email-masked]>" 
<[email-masked]<
> mailto:[email-masked]>>, "'Andrew G. Malis'" 
<[email-masked]<
> mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]
> >" <[email-masked]<mailto:[email-masked]>>, "draft-ietf-pwe3-
> [email-masked]<mailto:[email-masked]>" 
> <[email-masked]<mailto:draft-ietf-pwe3-
> [email-masked]>>
> Cc: "Stewart Bryant (stbryant)" 
<[email-masked]<mailto:[email-masked]
> >>
> Subject: RE: [PWE3] Regarding Cisco's Statement of IPR Related to 
> draft-ietf-pwe3-iccp-09
> Resent-From: <[email-masked]<mailto:[email-masked]>>
> Resent-To: <[email-masked]<mailto:[email-masked]>>, 
> <[email-masked]<mailto:[email-masked]>>, <satoru.
> [email-masked]<mailto:[email-masked]
> >>, <[email-masked]<mailto:[email-masked]>>
> Resent-Date: Wednesday, October 31, 2012 1:06 AM
> 
> Adrian,
> 
> I support removal of the procedure.
> 
> Timely disclosure is required if IPR is "essential" for an 
> implementation to be compliant with an RFC.
> 
> Even if the procedure is optional, if it is written up in the RFC it
> is part of the IETF's definition
> of the behavior, and thus when parties choose to implement that 
> option the IPR becomes essential.
> This is not the case of IPR being one way of implementing a 
> described procedure.
> 
> I think that the IPR holders should support removal of the procedure as 
well,
> as their lack of disclosure could lead to a patent (if granted) 
> being ruled unenforceable.
> 
> Y(J)S
> 
> 
> From: [email-masked]<mailto:[email-masked]> [mailto:
> [email-masked]] On Behalf Of Adrian Farrel
> Sent: Saturday, October 27, 2012 16:00
> To: 'Samer Salam (ssalam)'; 'Andrew G. Malis'; [email-masked]<mailto:
> [email-masked]>; [email-masked]<mailto:draft-
> [email-masked]>
> Cc: 'Stewart Bryant (stbryant)'
> Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to 
> draft-ietf-pwe3-iccp-09
> 
> Hi,
> 
> Samer said:
> 
> > the use of the IPR is not mandatory in the draft. It is an 
> optional procedure for a specific error scenario.
> 
> That makes me wonder whether the WG would like to consider another 
> way of handling this specific error scenario, or even simply to 
> remove the optional procedure.
> 
> What do people think?
> 
> Thanks,
> Adrian
> 
> From: [email-masked]<mailto:[email-masked]> [mailto:
> [email-masked]] On Behalf Of Samer Salam (ssalam)
> Sent: 25 October 2012 17:50
> To: Andrew G. Malis; [email-masked]<mailto:[email-masked]>; draft-
> 
[email-masked]<mailto:[email-masked]>
> Cc: Stewart Bryant (stbryant)
> Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to 
> draft-ietf-pwe3-iccp-09
> 
> Hi Andy,
> 
> First and foremost we apologize for the late filing, it was an 
> oversight on our part. While there is no excuse for the tardiness, 
> we wish to assure the WG that no foul play was intended. Re-
> examining the evolution of the document, the procedures related to 
> the IPR were added to the draft in a later version ( draft-ietf-
> pwe3-iccp-03 to be precise) and not as part of the initial draft, 
> and this is our best guess as to why we missed filing the IPR 
> disclosure earlier, and it only came to our attention when we were 
> updating version ?09 of the draft, since the patent was allowed in 
> that same timeframe.
> 
> That said, we wish to clarify that the use of the IPR is not 
> mandatory in the draft. It is an optional procedure for a specific 
> error scenario. Furthermore, the terms of the IPR are no different 
> from any other filed by Cisco under 'reasonable non-discriminatory 
terms'.
> 
> Regards,
> Samer
> 
> From: "Andrew G. Malis" <[email-masked]<mailto:andrew.g.
> [email-masked]>>
> Date: Thursday, October 25, 2012 8:34 AM
> To: "[email-masked]<mailto:[email-masked]>" 
<[email-masked]<mailto:[email-masked]
> >>, "[email-masked]<mailto:draft-ietf-pwe3-
> [email-masked]>" <[email-masked]<mailto:
> [email-masked]>>
> Cc: "Stewart Bryant (stbryant)" 
<[email-masked]<mailto:[email-masked]
> >>
> Subject: [PWE3] Regarding Cisco's Statement of IPR Related to draft-
> ietf-pwe3-iccp-09
> 
> To the PWE3 WG and the authors of draft-ietf-pwe3-iccp:
> 
> PWE3 participants may have noticed the IPR announcement below.  This
> leads to two important questions:
> 
> 1. The two authors of the IPR were also co-authors on the original 
> draft-martini-pwe3-iccp, and the patent application was filed almost
> simultaneously with the publication of the original -00 version of 
> the draft. This leads to the difficult question of why this IPR 
> wasn't disclosed until now, more than four years after the initial 
> filing and almost three years from the public publication of the 
> filing.  The chairs would like the authors to respond to the 
> lateness of the filing, given the many announcements of the IETF's 
> IPR policy, notably in the draft boilerplate and in the Note Well, 
> and elsewhere as well.
> 
> 2. The chairs would also like to ask the working group if anyone has
> an opinion about how or whether to continue the current WG draft 
> given the disclosure of the IPR and the license terms that have 
beenpublished.
> 
> Thanks,
> Andy and Matthew
> ---------- Forwarded message ----------
> From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
> Date: Tue, Oct 23, 2012 at 4:23 PM
> Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to 
> draft-ietf-pwe3-iccp-09
> To: [email-masked]<mailto:[email-masked]>, [email-masked]<
> mailto:[email-masked]>, [email-masked]<mailto:[email-masked]
> >, [email-masked]<mailto:satoru.matsushima@tm.
> softbank.co.jp>
> Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<
> mailto:[email-masked]>, [email-masked]<mailto:
> [email-masked]>, [email-masked]<mailto:[email-masked]>
> 
> Dear Ali Sajassi, Luca Martini, Samer Salam, Satoru Matsushima:
> 
>  An IPR disclosure that pertains to your Internet-Draft entitled 
> "Inter-Chassis
> Communication Protocol for L2VPN PE Redundancy" (draft-ietf-pwe3-iccp) 
was
> submitted to the IETF Secretariat on 2012-10-23 and has been posted 
> on the "IETF
> Page of Intellectual Property Rights Disclosures"
> (https://datatracker.ietf.org/ipr/1898/). The title of the IPR 
disclosure is
> "Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09."");
> 
> The IETF Secretariat
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/pwe3
> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <http://www.ietf.org/mail-
> archive/web/pwe3/attachments/20121031/fc925f33/attachment.htm>
> 
> ------------------------------
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
> 
> 
> End of pwe3 Digest, Vol 102, Issue 16
> *************************************

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Thu, 15 Nov 2012 03:43:34 +0000

Hi Lizhong,

Essentially, the PE which encounters the core-isolation failure brings down the port towards the CE (e.g. by bringing down the line-protocol or disabling the Tx laser). This will cause the CE to fail-over to the other member link of the bundle. In terms of fail-over time, this is comparable to relying on LACP to bring down the Port Priority on the failed PE. However, for reversion after recovery from failure, this scheme will take slightly more time compared to the LACP approach, since the LACP hand-shake needs to be traversed in order to restore traffic to the recovering PE. That said, it is possible for implementations to minimize the reversion time by having the CE control the maximum links per bundle policy, since in this later case the CE continues to send traffic to the secondary PE until the link to the recovering PE is ready to join the bundle – at that point that link pre-empts the link to the secondary PE.

Regards,
Samer

From: Lizhong Jin <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 14, 2012 12:13 AM
To: "Samer Salam (ssalam)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi Samer,
Could you provide more technical detail about the one without IPR? I must miss something in this discussion.

Thanks
Lizhong

> From: "Samer Salam (ssalam)" <[email-masked]<mailto:[email-masked]>>
> To: Yaakov Stein <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>"
>    <[email-masked]<mailto:[email-masked]>>, "'Andrew G. Malis'"
>    <[email-masked]<mailto:[email-masked]>>,   "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>,
>    "[email-masked]<mailto:[email-masked]>"
>    <[email-masked]<mailto:[email-masked]>>
> Cc: "Stewart Bryant \(stbryant\)" <[email-masked]<mailto:[email-masked]>>
>    <[email-masked]<mailto:[email-masked]>>
> From: Yaakov Stein <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
> To: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]><
> mailto:[email-masked]>>, "'Andrew G. Malis'" <[email-masked]<mailto:[email-masked]><
> mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]><mailto:[email-masked]
> >" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>, "draft-ietf-pwe3-
> [email-masked]<mailto:[email-masked]><mailto:[email-masked]>"
> <[email-masked]<mailto:[email-masked]><mailto:draft-ietf-pwe3-
> [email-masked]<mailto:[email-masked]>>>
> Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]
> >>
> Resent-From: <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
> Resent-To: <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>,
> <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>, <satoru.
> [email-masked]<mailto:[email-masked]><mailto:[email-masked]
> >>, <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
> I think that the IPR holders should support removal of the procedure as well,
> From: [email-masked]<mailto:[email-masked]><mailto:[email-masked]> [mailto:
> [email-masked]<mailto:[email-masked]>] On Behalf Of Adrian Farrel
> To: 'Samer Salam (ssalam)'; 'Andrew G. Malis'; [email-masked]<mailto:[email-masked]><mailto:
> [email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]><mailto:draft-
> [email-masked]<mailto:[email-masked]>>
> From: [email-masked]<mailto:[email-masked]><mailto:[email-masked]> [mailto:
> [email-masked]<mailto:[email-masked]>] On Behalf Of Samer Salam (ssalam)
> To: Andrew G. Malis; [email-masked]<mailto:[email-masked]><mailto:[email-masked]>; draft-
> [email-masked]<mailto:[email-masked]><mailto:[email-masked]>
> from any other filed by Cisco under 'reasonable non-discriminatory terms'.
>
> Regards,
> Samer
>
> From: "Andrew G. Malis" <[email-masked]<mailto:[email-masked]><mailto:andrew.g.
> [email-masked]<mailto:[email-masked]>>>
> To: "[email-masked]<mailto:[email-masked]><mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]
> >>, "[email-masked]<mailto:[email-masked]><mailto:draft-ietf-pwe3-
> [email-masked]<mailto:[email-masked]>>" <[email-masked]<mailto:[email-masked]><mailto:
> [email-masked]<mailto:[email-masked]>>>
> Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]><mailto:[email-masked]
> >>
> given the disclosure of the IPR and the license terms that have beenpublished.
>
> Thanks,
> Andy and Matthew
> From: IETF Secretariat <[email-masked]<mailto:[email-masked]><mailto:[email-masked]>>
> To: [email-masked]<mailto:[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]><
> mailto:[email-masked]>, [email-masked]<mailto:[email-masked]><mailto:[email-masked]
> >, [email-masked]<mailto:[email-masked]><mailto:satoru.matsushima@tm.
> softbank.co.jp>
> Cc: [email-masked]<mailto:[email-masked]><mailto:[email-masked]>, [email-masked]<mailto:[email-masked]><
> mailto:[email-masked]>, [email-masked]<mailto:[email-masked]><mailto:
> [email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]><mailto:[email-masked]>
>
> Communication Protocol for L2VPN PE Redundancy" (draft-ietf-pwe3-iccp) was
> (https://datatracker.ietf.org/ipr/1898/). The title of the IPR disclosure is
> [email-masked]<mailto:[email-masked]><mailto:[email-masked]>

---

From: Lizhong Jin<[email-masked]>
Date: Thu, 15 Nov 2012 14:28:32 +0800

OK, then "brings down the port towards the CE" is different with "sending 
a message to the dual-homed device" in the patent. Actually, how to 
trigger CE to switch to the secondary PE could be implementation specific 
(e.g, by Eth OAM), and this draft could only focus on the interaction 
between two PEs. Anyway, I am OK with the second option you provided. And 
say the CE triggering is implementation specific, but could provide some 
examples, e.g, port down, or adjust priority.
This is my personal idea, thanks.

Lizhong

"Samer Salam (ssalam)" <[email-masked]> wrote 2012/11/15 11:43:34:

> Hi Lizhong,
> 
> Essentially, the PE which encounters the core-isolation failure 
> brings down the port towards the CE (e.g. by bringing down the line-
> protocol or disabling the Tx laser). This will cause the CE to fail-
> over to the other member link of the bundle. In terms of fail-over 
> time, this is comparable to relying on LACP to bring down the Port 
> Priority on the failed PE. However, for reversion after recovery 
> from failure, this scheme will take slightly more time compared to 
> the LACP approach, since the LACP hand-shake needs to be traversed 
> in order to restore traffic to the recovering PE. That said, it is 
> possible for implementations to minimize the reversion time by 
> having the CE control the maximum links per bundle policy, since in 
> this later case the CE continues to send traffic to the secondary PE
> until the link to the recovering PE is ready to join the bundle – at
> that point that link pre-empts the link to the secondary PE.
> 
> Regards,
> Samer
> 
> From: Lizhong Jin <[email-masked]>
> To: "Samer Salam (ssalam)" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" 
<
> [email-masked]>, "[email-masked]" <
> [email-masked]>, "Stewart Bryant (stbryant)" <
> [email-masked]>
<[email-masked]<
> > mailto:[email-masked]>>, "'Andrew G. Malis'" <andrew.g.
> [email-masked]<
> > Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:
> [email-masked]
> > >>
terms'.
> > To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:
> [email-masked]
> > Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:
> [email-masked]
> > >>
was
disclosure is

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 20 Nov 2012 15:59:48 -0500

PWEers,

Speaking as WG co-chair, I think it's time to call this question, and I
like the new approach along the lines discussed by Samer and Lizhong as a
way to move forward.  Please reply if you have a strong opinion either
agreeing, or preferring to keep the ICCP draft as is. Note that the absence
of strong opinions will be interpreted as agreeing to change the draft.
Also note that Matthew is recused from determining consensus because he's a
co-author, but he's free to reply on the list as an author rather than as a
co-chair. I'll keep this open for a week to give people something to mull
over while they digest their turkey. :-)

Thanks,
Andy

On Thu, Nov 15, 2012 at 1:28 AM, Lizhong Jin <[email-masked]> wrote:

> a message to the dual-homed device" in the patent. Actually, how to trigger
> CE to switch to the secondary PE could be implementation specific (e.g, by
> Eth OAM), and this draft could only focus on the interaction between two
> PEs. Anyway, I am OK with the second option you provided. And say the CE
> triggering is implementation specific, but could provide some examples,
> e.g, port down, or adjust priority.
> > Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "
> > > To: "[email-masked]<mailto:[email-masked]>" <
> [email-masked]<

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 28 Nov 2012 20:21:36 -0800

I'm calling consensus on the new approach. Authors, please update the draft.

Thanks,
Andy

On Tue, Nov 20, 2012 at 12:59 PM, Andrew G. Malis
<[email-masked]> wrote:
> PWEers,
>
> Speaking as WG co-chair, I think it's time to call this question, and I like
> the new approach along the lines discussed by Samer and Lizhong as a way to
> move forward.  Please reply if you have a strong opinion either agreeing, or
> preferring to keep the ICCP draft as is. Note that the absence of strong
> opinions will be interpreted as agreeing to change the draft. Also note that
> Matthew is recused from determining consensus because he's a co-author, but
> he's free to reply on the list as an author rather than as a co-chair. I'll
> keep this open for a week to give people something to mull over while they
> digest their turkey. :-)
>
> Thanks,
> Andy
>
>
>> triggering is implementation specific, but could provide some examples, e.g,
>> port down, or adjust priority.