Subject: Re: [PWE3] Stewart Bryant's Discuss on draft-ietf-mpls-ipv6-pw-lsp-ping-03: (with DISCUSS)

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Tue, 13 Nov 2012 08:54:29 +0000

Hi Carlos,

Not entirely, and I need to update my discuss.

I think that the draft really needs a review by a couple of PWE3 RFC4447 experts to make sure nothing got missed, and I see no evidence that anyone from PWE3 did a detailed review.

However, there is a point that only came to mind as I thought about the draft over night. In order to support IPv6 we will need to do a s/w update at both PEs. Thus the WG should consider whether it wishes to continue to support both FEC 128 and 129, or whether this is an opportunity to retire FEC 128. The only issue that I can think of with retiring 128 is if you have legacy 128 equipment behind a 6 to 4 translator, but I wonder how likely such a scenario really is.

Anyway I am concerned that this is a discussion that should have taken place in PWE3 before the draft got this far.

Stewart

Sent from my iPad

On 13 Nov 2012, at 01:32, "Carlos Pignataro (cpignata)" <[email-masked]> wrote:

> Stewart,
> 
> This document replaces an individual document that was initially presented simultaneously to the MPLS and PWE3 WGs (circa IETF82 timeframe). At the time (before this document was adopted as an MPLS WG item) we discussed with the chairs from both WGs and decided to progress it in MPLS, mainly because it was updating RFC 4379 and updating definitions created in the MPLS WG. 
> 
> The PWE3 working group has been reviewing this document from when it was an individual contribution, all the way to IETF LC. Here's some pointers to that effect:
> http://www.ietf.org/mail-archive/web/pwe3/current/msg12676.html // Sent to both lists.
> http://www.ietf.org/mail-archive/web/pwe3/current/msg12677.html // PWE3 chair commenting on it, both on the MPLS and PWE3 lists.
> http://www.ietf.org/mail-archive/web/pwe3/current/msg12808.html // Sent to both lists.
> http://www.ietf.org/mail-archive/web/pwe3/current/msg13332.html // All the way to IETF LC in both lists.
> 
> Does this address your concern?
> 
> Thanks,
> 
> -- Carlos.
> 
> On Nov 12, 2012, at 7:20 PM, Stewart Bryant <[email-masked]> wrote:
> 
>> ----------------------------------------------------------------------
>> DISCUSS:
>> ----------------------------------------------------------------------
>> 
>> This is a pseudowire document and it is a great pity that it was not
>> taken through the pseudowire WG so that it would be listed in their
>> document set and thus be more visible to readers looking for PW related
>> documents. I am not sure whether it is possible to get this to show on
>> with their doc set but it would be useful if it could.
>> 
>> As far as I am able to determin, this document was not reviewed by the
>> PWE3 WG, thus the main purpose of this discuss is to make sure that this
>> has been adequately reviewed by people with PW expertise.
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 13 Nov 2012 23:16:51 +0000

Hi, Stewart,

Thanks for the comments -- please see inline.

On Nov 13, 2012, at 3:54 AM, Stewart Bryant (stbryant) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Carlos,

I am not sure what specific evidence you are looking for or expecting. You are correct, this document did not get named non-co-author assigned reviewers explicitly representing PWE3 -- but that was not understood as a requirement, and the document was brought to PWE3 and the co-authors are also PWE3ers.

On the other hand, you can see from the IETF82 minutes that this was presented at PWE3:
http://tools.ietf.org/agenda/82/slides/pwe3-4.pdf

With the following minutes:
http://tools.ietf.org/wg/pwe3/minutes?item=minutes82.html

          10 min - IPv6 PW LSP Ping - Mach CHEN
          http://tools.ietf.org/html/draft-chen-mpls-ipv6-pw-lsp-ping

          Mach presented.

          Questions:
          No questions.  Will take discussion to the list.

          Andy noted that the Chairs think that this is an important piece of work
          for the WG.  Please review the draft.  Fills an existing hole in PWE3.

And the last paragraph signaled PWE3 awareness and review. Are you expecting appointed reviewers from PWE3?

That did not seem to be a consideration for 4447bis http://www.ietf.org/mail-archive/web/pwe3/current/msg13145.html

Thanks,

-- Carlos.

Stewart

Sent from my iPad

On 13 Nov 2012, at 01:32, "Carlos Pignataro (cpignata)" <[email-masked]<mailto:[email-masked]>> wrote:

Stewart,

Thanks,

-- Carlos.

On Nov 12, 2012, at 7:20 PM, Stewart Bryant <[email-masked]<mailto:[email-masked]>> wrote: