Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 1 Nov 2012 16:44:55 -0400

Samer, thanks for the offer!

The chairs would like to hear more opinions from the WG on the two options
offered by Samer.

Thanks,
Andy and Matthew

On Wed, Oct 31, 2012 at 11:42 AM, Samer Salam (ssalam) <[email-masked]>wrote:

>  Hi,
>
>  To further clarify: two ways of implementing the described procedure
> were identified in the course of the discussions, one without the IPR and
> one with. The current draft only captures the latter because it offers
> better reversion time characteristics (note that failover protection time
> is comparable for both, it is primarily the reversion time upon recovery
> that is different). With the approval of the other co-authors, we would be
> happy to:
>
>  1- Either Capture only the option without the IPR, OR
> 2- Capture both options with the above tradeoff highlighted
>
>  Regards,
> Samer
>
>   From: Yaakov Stein <[email-masked]>
> Date: Wednesday, October 31, 2012 1:06 AM
> To: "[email-masked]" <[email-masked]>, "'Andrew G. Malis'" <
> [email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>
>
> Cc: "Stewart Bryant (stbryant)" <[email-masked]>
> Subject: RE: [PWE3] Regarding Cisco's Statement of IPR Related to
> draft-ietf-pwe3-iccp-09
> Resent-From: <[email-masked]>
> Resent-To: <[email-masked]>, <[email-masked]>, <
> [email-masked]>, <[email-masked]>
> Resent-Date: Wednesday, October 31, 2012 1:06 AM
>
>    Adrian, ****
>
> ** **
>
> I support removal of the procedure.****
>
> ** **
>
> Timely disclosure is required if IPR is "essential" for an implementation
> to be compliant with an RFC.****
>
> ** **
>
> Even if the procedure is optional, if it is written up in the RFC it is
> part of the IETF's definition****
>
> of the behavior, and thus when parties choose to implement that option the
> IPR becomes essential.****
>
> This is not the case of IPR being one way of implementing a described
> procedure.****
>
> ** **
>
> I think that the IPR holders should support removal of the procedure as
> well, ****
>
> as their lack of disclosure could lead to a patent (if granted) being
> ruled unenforceable.****
>
> ** **
>
> Y(J)S****
>
>  ****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Adrian Farrel
> *Sent:* Saturday, October 27, 2012 16:00
> *To:* 'Samer Salam (ssalam)'; 'Andrew G. Malis'; [email-masked];
> [email-masked]
> *Cc:* 'Stewart Bryant (stbryant)'
> *Subject:* Re: [PWE3] Regarding Cisco's Statement of IPR Related to
> draft-ietf-pwe3-iccp-09****
>
> ** **
>
> Hi,****
>
> ** **
>
> Samer said:****
>
> ** **
>
> > the use of the IPR is not mandatory in the draft. It is an optional
> procedure for a specific error scenario.****
>
> ** **
>
> That makes me wonder whether the WG would like to consider another way of
> handling this specific error scenario, or even simply to remove the
> optional procedure.****
>
> ** **
>
> What do people think?****
>
> ** **
>
> Thanks,****
>
> Adrian****
>
> ** **
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Samer Salam (ssalam)
> *Sent:* 25 October 2012 17:50
> *To:* Andrew G. Malis; [email-masked]; [email-masked]
> *Cc:* Stewart Bryant (stbryant)
> *Subject:* Re: [PWE3] Regarding Cisco's Statement of IPR Related to
> draft-ietf-pwe3-iccp-09****
>
> ** **
>
> Hi Andy,****
>
> ** **
>
> First and foremost we apologize for the late filing, it was an oversight
> on our part. While there is no excuse for the tardiness, we wish to assure
> the WG that no foul play was intended. Re-examining the evolution of the
> document, the procedures related to the IPR were added to the draft in a
> later version ( draft-ietf-pwe3-iccp-03 to be precise) and not as part of
> the initial draft, and this is our best guess as to why we missed filing
> the IPR disclosure earlier, and it only came to our attention when we were
> updating version –09 of the draft, since the patent was allowed in that
> same timeframe.****
>
> ** **
>
> That said, we wish to clarify that the use of the IPR is not mandatory in
> the draft. It is an optional procedure for a specific error scenario.
> Furthermore, the terms of the IPR are no different from any other filed by
> Cisco under 'reasonable non-discriminatory terms'. ****
>
> ** **
>
> Regards,****
>
> Samer****
>
> ** **
>
> *From: *"Andrew G. Malis" <[email-masked]>
> *Date: *Thursday, October 25, 2012 8:34 AM
> *To: *"[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>
> *Cc: *"Stewart Bryant (stbryant)" <[email-masked]>
> *Subject: *[PWE3] Regarding Cisco's Statement of IPR Related to
> draft-ietf-pwe3-iccp-09****
>
> ** **
>
>  To the PWE3 WG and the authors of draft-ietf-pwe3-iccp:
>
> PWE3 participants may have noticed the IPR announcement below.  This leads
> to two important questions:
>
> 1. The two authors of the IPR were also co-authors on the original
> draft-martini-pwe3-iccp, and the patent application was filed almost
> simultaneously with the publication of the original -00 version of the
> draft. This leads to the difficult question of why this IPR wasn't
> disclosed until now, more than four years after the initial filing and
> almost three years from the public publication of the filing.  The chairs
> would like the authors to respond to the lateness of the filing, given the
> many announcements of the IETF's IPR policy, notably in the draft
> boilerplate and in the Note Well, and elsewhere as well.
>
> 2. The chairs would also like to ask the working group if anyone has an
> opinion about how or whether to continue the current WG draft given the
> disclosure of the IPR and the license terms that have been published.
>
> Thanks,
> Andy and Matthew****
>
> ---------- Forwarded message ----------
> From: *IETF Secretariat* <[email-masked]>
> Date: Tue, Oct 23, 2012 at 4:23 PM
> Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to
> draft-ietf-pwe3-iccp-09
> To: [email-masked], [email-masked], [email-masked],
> [email-masked]
> Cc: [email-masked], [email-masked], [email-masked],
> [email-masked]
>
> Dear Ali Sajassi, Luca Martini, Samer Salam, Satoru Matsushima:
>
>  An IPR disclosure that pertains to your Internet-Draft entitled
> "Inter-Chassis
> Communication Protocol for L2VPN PE Redundancy" (draft-ietf-pwe3-iccp) was
> submitted to the IETF Secretariat on 2012-10-23 and has been posted on the
> "IETF
> Page of Intellectual Property Rights Disclosures"
> (https://datatracker.ietf.org/ipr/1898/). The title of the IPR disclosure
> is
> "Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09."");
>
> The IETF Secretariat
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3****
>
> ** **
>
>
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pwe3
>
>

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 5 Nov 2012 21:34:29 +0000

Samer

I read the patent application, and disagree with your interpretation of its scope.

The first and second independent claims are very general,
and claim any mechanism that has a multihomed device speaking with 2 PEs
which exchange messages over an ICCP channel.
This is basically the entire draft.

There is no specification that the PEs are co-located or not, whether the channel is shared or not, etc.

Y(J)S

From: [email-masked] [mailto:[email-masked]] On Behalf Of Samer Salam (ssalam)
Sent: Wednesday, October 31, 2012 17:43
To: Yaakov Stein; [email-masked]; 'Andrew G. Malis'; [email-masked]; [email-masked]
Cc: Stewart Bryant (stbryant)
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi,

To further clarify: two ways of implementing the described procedure were identified in the course of the discussions, one without the IPR and one with. The current draft only captures the latter because it offers better reversion time characteristics (note that failover protection time is comparable for both, it is primarily the reversion time upon recovery that is different). With the approval of the other co-authors, we would be happy to:

Regards,
Samer

From: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 31, 2012 1:06 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Andrew G. Malis'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Wednesday, October 31, 2012 1:06 AM

Adrian,

I support removal of the procedure.

Timely disclosure is required if IPR is "essential" for an implementation to be compliant with an RFC.

Even if the procedure is optional, if it is written up in the RFC it is part of the IETF's definition
of the behavior, and thus when parties choose to implement that option the IPR becomes essential.
This is not the case of IPR being one way of implementing a described procedure.

I think that the IPR holders should support removal of the procedure as well,
as their lack of disclosure could lead to a patent (if granted) being ruled unenforceable.

Y(J)S

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Saturday, October 27, 2012 16:00
To: 'Samer Salam (ssalam)'; 'Andrew G. Malis'; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: 'Stewart Bryant (stbryant)'
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi,

Samer said:

> the use of the IPR is not mandatory in the draft. It is an optional procedure for a specific error scenario.

That makes me wonder whether the WG would like to consider another way of handling this specific error scenario, or even simply to remove the optional procedure.

What do people think?

Thanks,
Adrian

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Samer Salam (ssalam)
Sent: 25 October 2012 17:50
To: Andrew G. Malis; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Stewart Bryant (stbryant)
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi Andy,

First and foremost we apologize for the late filing, it was an oversight on our part. While there is no excuse for the tardiness, we wish to assure the WG that no foul play was intended. Re-examining the evolution of the document, the procedures related to the IPR were added to the draft in a later version ( draft-ietf-pwe3-iccp-03 to be precise) and not as part of the initial draft, and this is our best guess as to why we missed filing the IPR disclosure earlier, and it only came to our attention when we were updating version -09 of the draft, since the patent was allowed in that same timeframe.

That said, we wish to clarify that the use of the IPR is not mandatory in the draft. It is an optional procedure for a specific error scenario. Furthermore, the terms of the IPR are no different from any other filed by Cisco under 'reasonable non-discriminatory terms'.

Regards,
Samer

From: "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, October 25, 2012 8:34 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>
Subject: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

PWE3 participants may have noticed the IPR announcement below.  This leads to two important questions:

1. The two authors of the IPR were also co-authors on the original draft-martini-pwe3-iccp, and the patent application was filed almost simultaneously with the publication of the original -00 version of the draft. This leads to the difficult question of why this IPR wasn't disclosed until now, more than four years after the initial filing and almost three years from the public publication of the filing.  The chairs would like the authors to respond to the lateness of the filing, given the many announcements of the IETF's IPR policy, notably in the draft boilerplate and in the Note Well, and elsewhere as well.

2. The chairs would also like to ask the working group if anyone has an opinion about how or whether to continue the current WG draft given the disclosure of the IPR and the license terms that have been published.

Thanks,
Andy and Matthew
---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

 An IPR disclosure that pertains to your Internet-Draft entitled "Inter-Chassis
Communication Protocol for L2VPN PE Redundancy" (draft-ietf-pwe3-iccp) was
submitted to the IETF Secretariat on 2012-10-23 and has been posted on the "IETF
Page of Intellectual Property Rights Disclosures"
(https://datatracker.ietf.org/ipr/1898/). The title of the IPR disclosure is
"Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09."");

The IETF Secretariat

_______________________________________________
pwe3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pwe3

---

From: "Samer Salam (ssalam)" <[email-masked]>
Date: Mon, 5 Nov 2012 22:08:50 +0000

Hi Yaakov,

The first claim restricts the scope of the IPR to the scenario where the two conditions are met:

  1.  PE is isolated from the core and
  2.  PE sends a message to the dual-homed CE to inform the latter of this condition

I've highlighted the relevant conditions in this snippet of the IPR:

"A method comprising: forwarding traffic received on a first downlink connection with a dual-homed device to an uplink connection with a network core; detecting a failure on the uplink connection with the network core; and in response to detecting the failure, notifying a standby device of the failure and sending a message to the dual-homed device to trigger the dual-homed device to begin forwarding traffic to the network core via a second downlink connection between the standby device and the dual-homed device.

As you know, the ICCP draft covers both PW redundancy as well as AC redundancy for Ethernet Link Aggregation Group. Furthermore, for each redundancy mechanism it covers the following three types of failures:

-Attachment Circuit Failures
- PE Node Failure
- PE Isolation from the core

The IPR concerns only the PE isolation failure for the multi-chassis LAG (mLACP), and in particular only covers the text in the first paragraph of section 9.2.2.4 of the draft. This is the text that we proposed to change per the two suggestions below. The rest of the draft is not impacted by the IPR.

Regards,
Samer

From: Yaakov Stein <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 5, 2012 2:34 PM
To: "Samer Salam (ssalam)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "'Andrew G. Malis'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "Stewart Bryant (stbryant)" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Samer

Y(J)S

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]On Behalf Of Samer Salam (ssalam)
Sent: Wednesday, October 31, 2012 17:43
To: Yaakov Stein; [email-masked]<mailto:[email-masked]>; 'Andrew G. Malis'; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Stewart Bryant (stbryant)
Subject: Re: [PWE3] Regarding Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09

Hi,

Regards,
Samer

Adrian,

Y(J)S

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Adrian Farrel

Hi,

What do people think?

Thanks,
Adrian

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Samer Salam (ssalam)

Hi Andy,

First and foremost we apologize for the late filing, it was an oversight on our part. While there is no excuse for the tardiness, we wish to assure the WG that no foul play was intended. Re-examining the evolution of the document, the procedures related to the IPR were added to the draft in a later version ( draft-ietf-pwe3-iccp-03 to be precise) and not as part of the initial draft, and this is our best guess as to why we missed filing the IPR disclosure earlier, and it only came to our attention when we were updating version –09 of the draft, since the patent was allowed in that same timeframe.

Regards,
Samer

Thanks,
Andy and Matthew
---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

The IETF Secretariat

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 5 Nov 2012 23:07:51 +0000

Samer

I agree that the application only covers uplink failures from PEs towards the network core.
Thus it is not relevant to other failure locations.

Almost any method that desires to protect against such failures needs to detect that uplink failure
(except 1+1 or triangle routing).

Likewise, almost any multichassis method requires telling the multihomed device to send to the other PE.

Y(J)S

Sent: Tuesday, November 06, 2012 00:09

Hi Yaakov,

Regards,
Samer

Samer

Y(J)S

Hi,

Regards,
Samer

Adrian,

Y(J)S

Hi,

What do people think?

Thanks,
Adrian

Hi Andy,

Regards,
Samer

Thanks,
Andy and Matthew
---------- Forwarded message ----------
From: IETF Secretariat <[email-masked]<mailto:[email-masked]>>
Date: Tue, Oct 23, 2012 at 4:23 PM
Subject: [PWE3] IPR Disclosure: Cisco's Statement of IPR Related to draft-ietf-pwe3-iccp-09
To: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>

The IETF Secretariat