Subject: [PWE3] PWE3 VCCV breakout meeting

From: Stewart Bryant <[email-masked]>
Date: Wed, 03 Aug 2005 14:02:20 +0100

These are the minutes of the PWE3 VCCV breakout meeting
that took place at lunch time today.

Corrections from those present and comments from the
list on the proposed resolution are sought.

There were a number of other issues that were raised
at these meeting that were out of scope. Those
issues should be raised on the PWE3 list.

- Stewart

VCCV over IP/RTP Breakout Mtg 3 Aug 2005 @ 1240
===============================================

Present:

Stewart Bryant (Chair)
Bill Stor
Luca martini
Maria Alice
Matthew Bocci
Ron Cohen
Sasha Vainshtein
Scot Weiner
Skip Booth (By Phone)
Tim Frost
Tom Nadeau
Yaakov Stein

Proposals on the Table at Start of Meeting
==========================================

- never include RTP in VCCV
- use ACH
- note that RTP header always starts with 8
etc

or

change order of headers

Discussion
==========

Issue of need to interconnect ip & mpls PWs

Two cases what to do with L2TP and what to do
with UDP/IP

Could change L2TPv3 encap, but UDP problem
remains.

Proposal fix L2TP to be like MPLS and leave
UDP and live with the problems.

UDP has no signalling and is unlikely to be
used for stitching/switching.

Note needs to be added to switching draft
to say that UDP switching to MPLS/L2TP
currently out of scope.

Need to fix statement in VCCV saying that
sub-layer is REQUIRED.

Issue there is one implementation that uses
RTP then CW over L2TP. Needs backwards
compatibility mode.

Proposed Resolution for RTP and CW order for TDM PWs
====================================================

1) L2TP will use MPLS header ordering (i.e. L2TPv3/CW/RTP)

2) VCCV mux will use ACH

3) Main text will describe use of MPLS order.

4) Informational Appendix describing old mode RTP/CW order
    in TDM drafts that are affected.

5) Need new option in RTP AVP for new (MPLS) order IN L2TP

6) Change to VCCV draft to describe the above

7) Need to update TDMoIP, CESoPSN, SATOP to reflect the
    above.

8) SONET draft not affected.

9 In UDP/IP PWs VCCV will not use RTP - RTP header
   will be skipped by noting first nibble = 8.

Sasha noted that he needed to discuss the proposal with
his development team. Others present indicated support
for the proposal.

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Carlos Pignataro <[email-masked]>
Date: Wed, 03 Aug 2005 14:53:01 -0400

Please find one question inline (that may have already come up and been
answered already).

> VCCV over IP/RTP Breakout Mtg 3 Aug 2005 @ 1240

With this order, what is the benefit of hiding the CW presence (or
L2-Specific Sublayer) from the control protocol L2TPv3?
It would seem that for TDM PWs over L2TPv3, defining a TDM-Specific
Sublayer with the same sequencing format as the MPLS CW would achieve
the same results, but also:
o Would free 6 bits from the CW for L2TPv3, since the Length is not
  needed in l2tpv3.
o Would allow identifying and intercepting VCCV messages by inspecting
  Bit 0 of the CW (the same way as described in VCCV draft for other
  L2TPv3 encaps) instead of the first nibble; this in turn:
  - Enables consistent vccv demux for L2TPv3 PWs
  - Frees up another 3 bits.
While:
o Would retain consistent sequencing space.
o Would aware the control protocol of the existence of a CW (or
TDM-Specific Sublayer).

Thanks,

--Carlos.

-- 
--Carlos.
Escalation RTP - cisco Systems

---

From: Scott Wainner <[email-masked]>
Date: Wed, 03 Aug 2005 18:29:04 -0400

>L2-Specific Sublayer) from the control protocol L2TPv3?
I don't think that was what is implied.  L2TPv3 control protocol would 
have to specify that the
MPLS CW would be used for consistency.

>  - Frees up another 3 bits.
I think the intent was for L2TPv3 to NOT do any sequencing support for 
TDM.  In fact, the TDM
sequencing would be a function handled by a highler layer function.

>o Would aware the control protocol of the existence of a CW (or
I still think we're talking about using the first bit of an L2SS (V-bit) 
to identify the presence of a PW-AC or CW for TDMoL2TPv3 ...

---

From: Carlos Pignataro <[email-masked]>
Date: Thu, 04 Aug 2005 08:26:26 -0400

> MPLS CW would be used for consistency.

How? By defining a new L2SS?

> to identify the presence of a PW-AC or CW for TDMoL2TPv3 ... 

I may have missed something, but I understood from the minutes that vccv
was to be discerned by a first nibble of 0001b in the "tdmol2tpv3
payload" (since no l2ss is signaled).

Thanks,

--Carlos.