Subject: [PWE3]fc encap/decap

From: Dong Jixiong <[email-masked]>
Date: Mon, 29 Aug 2005 15:03:51 +0800

Hi, Moran

When mapping fc traffic into PW PDU, we have different encapsulation methods for normal FC frames and FC primitive sequences respectively. For normal FC frames, we use "OSCODE(8bits)+reservered value(24bits)" to encap SOF/EOF. For 
FC primitive sequences, we use "K28.5-CODE(8bits)+DDD(24bits)" to encap them. During receiving fc traffic from PSN, we have to distinguish FC primitive sequences and frames to decap them. We can use the first byte in PWE3 payload to do it. So I suggest K28.5-CODE(8bits) value is different from SOF/EOF OSCODE(8bits)s, such as 0xab, 0x81,etc. and assign this unique value in fc encap pwe3 draft, which can also avoid the future interworking problems.

Regards,
Dong
_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Dong Jixiong <[email-masked]>
Date: Tue, 30 Aug 2005 09:35:31 +0800

Bob,

It refers to fc encap draft(draft-roth-pwe3-fc-encap-00.txt) in PWE3 WG.
You can read it to get the detailed information. Welcome for your comments.

Regards,
Dong
  ----- Original Message ----- 
  From: Robert Snively 
  To: Dong Jixiong 
  Sent: Monday, August 29, 2005 11:46 PM
  Subject: RE: [PWE3]fc encap/decap

  Dong,

  What draft is being referenced in this discussion?

  Does it include both primitive sequences and primitive signals?

  Does it allow for FC-AL-2 loop attachments?

  Bob

------------------------------------------------------------------------------

  From: [email-masked] [mailto:[email-masked]] On Behalf Of Dong Jixiong
  Sent: Monday, August 29, 2005 12:04 AM
  To: Moran Roth
  Cc: pwe3
  Subject: [PWE3]fc encap/decap

  Hi, Moran

  Regards,

  Dong