Subject: RE: [PWE3] PWE3 IANA policy - rough consesnus

From: "Gray, Eric" <[email-masked]>
Date: Tue, 2 Aug 2005 05:04:16 -0400

Mark,

	There are many possible abuses we could be aiming to optimize 
for.  For example, we could use the term "vendor specific" to allow
us to optimize for the type of abuse that makes it difficult for an
organization (like the IEEE) to get something that any mom-and-pop
hamburger joint could get.

--
Eric Gray

--> -----Original Message-----
--> From: Mark Townsley [mailto:[email-masked]]
--> Sent: Tuesday, August 02, 2005 3:58 AM
--> To: Gray, Eric
--> Cc: [email-masked]; Danny McPherson; pwe3; Stewart Bryant
--> Subject: Re: [PWE3] PWE3 IANA policy - rough consesnus
--> 
--> 
--> Gray, Eric wrote:
--> 
--> >Mark,
--> >
--> >	We're cycling on station - again.
--> >
--> >	"Vendor" and "Proprietary" are effectively semantic NULLs
--> >in this context.
--> >  
--> >
--> Actually, the term "vendor-specific" is well known, and has 
--> been used 
--> for other IANA registries and descriptions of type codes in 
--> protocol 
--> specifications. There is both common sense understanding 
--> and precedent 
--> to rely on here.
--> 
--> >	One of my earlier objections to this usage is exactly as
--> >Eric Rosen said - the possibility exists that vendor/proprietary
--> >usage will become a standard (by some definition of the term).
--> >  
--> >
--> Yes, just as it is possible for a vendor to camp on "IETF 
--> Consensus" 
--> space with a proprietary extension and have it become an ad-hoc 
--> standard. As has been said already, there is no protocol 
--> police here. 
--> But just because there isn't, doesn't mean we should abandon all 
--> guidelines.
--> 
--> >Also, if the intent is to somehow distinguish "vendors" from any
--> >other entity, I would challenge your assumption that IANA can 
--> >make this distinction without yet another form of "expert review".
--> >I'm fairly sure that you couldn't make this distinction in fifty 
--> >words or less.
--> >  
--> >
--> In fact, IANA makes this distinction regularly. Honest, in the vast 
--> majority of cases, they know the difference between, say, 
--> "Cisco" and 
--> "IEEE."
--> 
--> Sure, one could incorporate some sub-entity of their SDO 
--> and become a 
--> "vendor" overnight. Perhaps even one with a convincing 
--> enough name to 
--> pull the wool over the eyes of our IANA folks. I think it is 
--> unreasonable to try and optimize for such abuses of the system.
--> 
--> >	FCFS is - I am sure - one of the options allowed as an IANA
--> >assignment policy. Let's use it and stop going around and 
--> >
--> >around
--> >on the issues.
--> >  
--> >
--> Right, I'm not talking about the Policy for the range, I'm 
--> talking about 
--> the label applied to the range.
--> 
--> - Mark
--> 
--> >--
--> >Eric Gray
--> >
--> >--> -----Original Message-----
--> >--> From: [email-masked] 
--> >--> [mailto:[email-masked]]On Behalf Of
--> >--> Mark Townsley
--> >--> Sent: Tuesday, August 02, 2005 3:12 AM
--> >--> To: [email-masked]
--> >--> Cc: [email-masked]; Danny McPherson; pwe3; Stewart Bryant
--> >--> Subject: Re: [PWE3] PWE3 IANA policy - rough consesnus
--> >--> 
--> >--> 
--> >--> 
--> >--> How about (proposed by Thomas earlier):
--> >--> 
--> >--> "reserved for vendor extensions"
--> >--> 
--> >--> I believe IANA knows how to distinguish between a vendor 
--> >--> request and a
--> >--> non-vendor request.
--> >--> 
--> >--> - Mark
--> >--> 
--> >--> Eric W Gray wrote:
--> >--> 
--> >--> > I agree with Eric Rosen on this point.  In addition to 
--> >--> not necessarily 
--> >--> > being an appropriate
--> >--> > distinction, the word "Proprietary" adds no semantic 
--> >--> value given the 
--> >--> > number of  instances
--> >--> > of ideas created by a single individual or organization that 
--> >--> > subsequently become defacto
--> >--> > standards and the fact that "Proprietary" does not 
--> distinguish 
--> >--> > individual/organization types.
--> >--> >
--> >--> > --
--> >--> > Eric G
--> >--> >
--> >--> > Eric Rosen wrote:
--> >--> >
--> >--> >>>0-1024 Expert review
--> >--> >>>1025-4096 Reserved
--> >--> >>>4097- Proprietary - Allocated FCFS by IANA
--> >--> >>>    
--> >--> >>>
--> >--> >>
--> >--> >>Please remove the word "proprietary".  There is no reason 
--> >--> why a codepoint in
--> >--> >>this range would not  be used in a standard.  There is  
--> >--> also no reason why a
--> >--> >>codepoint allocated via expert review would not be 
--> >--> proprietary (i.e., single
--> >--> >>vendor, non-standard). 
--> >--> >>
--> >--> >>
--> >--> >>
--> >--> >>_______________________________________________
--> >--> >>pwe3 mailing list
--> >--> >>[email-masked]
--> >--> >>https://www1.ietf.org/mailman/listinfo/pwe3
--> >--> >>
--> >--> >>
--> >--> >>
--> >--> >>  
--> >--> >>
--> >--> 
--> >--> 
--> >--> _______________________________________________
--> >--> pwe3 mailing list
--> >--> [email-masked]
--> >--> https://www1.ietf.org/mailman/listinfo/pwe3
--> >--> 
--> >
--> >  
--> >
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Mark Townsley <[email-masked]>
Date: Tue, 02 Aug 2005 11:26:16 +0200

>hamburger joint could get.
To use your analogy, I am hearing the WG say that they *want* the 
hamburger shop to have PW types upon request without any review 
(regardless of potential abuses). There is a policy for that, I'm just 
saying that we be up front and say that the values are for hamburger shops.

There are some things that IANA can do, and some things that they 
cannot. They cannot be expert reviewers, but they can tell the 
difference between a vendor and non-vendor (as long as everyone is being 
honest). I would like to let IANA do that for us.

- Mark