Subject: [PWE3] RE: Last Call: 'Encapsulation Methods for Transport of ATM Over M PLS Networks' to Proposed Standard

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 23 Aug 2005 11:15:21 +0300

Luca and all,
I have some questions/comments related to the draft in question:

1. The draft does not explicitly specify which PW types can be
   used with each encapsulation type the only exception being
   ATM AAL5 SDU PW. IMHO this information should be provided
   consistently for ALL encapsulation types defined in the
   draft.

2. Section 13 "ILMI Support" states that if a PE receives an 
   ILMI message from its local CE indicating that a specific 
   VC has been deleted, it sends a status notification to its 
   peer PE, and the latter reacts to this status notification by 
   deleting its matching VC. I have two questions related to this:
   a) Which status value should be used to indicate DELETION
      (as opposed to failure) of a VC? The list of the PW status 
      values defined in draft-ietf-pwe3-iana-allocation-11.txt
      does not seem to contain any suitable ones
   b) Why not to withdraw the PW label mapping for the PW carrying
      a DELETED VC? VC DELETION occurs only as a result of an 
      explicit management operation, so IMHO there is no need to 
      retain the PW label mapping in this case.
   
3. Please note that Section 13 seems to suggest treating
   deletion of a specific VC and failure of the physical interface
   in exactly the same way, i.e. peer PEs should delete all VCs fed
   by the PWs originating in a failed physical port. IMHO:
   a) The behavior of ATM PWs in the case of the physical port
      failure should not depend upon presence or absence of ILMI
   b) Even with ILMI present, failure of the physical port at one
      end of a PW should result in sendding an appropriate AIS
      at the other end.
   Did I miss something here?
   
4. Section 6.1 "ATM N to 1 Cell Mode", bullet (iv) states:

<quote>
   The CLP bit from each cell may be mapped to a corresponding
   marking on the PW PDU. This allows the drop precedence to be
   preserved across the PSN.
<end quote>

   Section 12 "Mapping of ATM and PSN Classes of Service"
   re-formulates the same statement for MPLS networks:

<quote>
   When the PSN is MPLS based, a mapping between the CLP bit and the EXP
   field can be performed to provide visibility of the cell loss
   priority in the MPLS network. 
<end quote>
   
   My question is: Can the mapping indicated above be combined with 
   the cell concatenation defined in Section 6.1, bullet (iii)? 
   (The obvious catch is that cells concatenated in a single
   PW PDU may have different CLP bits:-)

Hopefully these notes will be useful. 
  
Regards,
				Sasha

> -----Original Message-----
> From: The IESG [mailto:[email-masked]]
> Sent: Tuesday, August 23, 2005 4:11 AM
> To: IETF-Announce
> Cc: [email-masked]
> Subject: Last Call: 'Encapsulation Methods for Transport of 
> ATM Over MPLS Networks' to Proposed Standard 
> 
> 
> The IESG has received a request from the Pseudo Wire 
> Emulation Edge to Edge WG to consider the following document:
> 
> - 'Encapsulation Methods for Transport of ATM Over MPLS Networks '
>    <draft-ietf-pwe3-atm-encap-09.txt> as a Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send any comments to the
> [email-masked] or [email-masked] mailing lists by 2005-09-05.
> 
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-ietf-pwe3-atm-encap-09.txt
> 
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ietf-announce
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Shahram Davari <[email-masked]>
Date: Tue, 23 Aug 2005 14:52:17 -0700

No. Figure 7 has also a very different control word than Figure 11. In fact the 4th bit is reserved in Figure 7.

-Shahram   

> From: Prakash Jayaraman [mailto:[email-masked]]
> Sent: Tuesday, August 23, 2005 5:47 PM
> To: Shahram Davari
> Cc: [email-masked]'; IETF-Announce; [email-masked]
> Subject: Re: [PWE3] RE: Last Call: 'Encapsulation Methods for 
> Transport
> of ATM Over M PLS Networks' to Proposed Standard
> 
> 
> Figure-7 appears to be the correct reference.
> 
> - prakash
> 
> Shahram Davari wrote:
> 
> >Hi,
> >
> >Section 10.1: The text related to Figure 11 says:
> >
> >" * T (transport type) bit
> >
> >       Bit (T) of the control word indicates whether the 
> packet contains
> >       an ATM admin cell or an AAL5 payload. If T = 1, the packet
> >       contains an ATM admin cell, encapsulated according to the VCC
> >       cell relay encapsulation, figure 8.
> >"
> >
> >But the control word of Figure 11 and Figure 8 are 
> completely different.
> >I think the reference to cell relay encapsulation should be deleted.
> >
> >Yours,
> >Shahram
> >
> >
> >  
> >
> >>From: [email-masked]
> >>[mailto:[email-masked]]On Behalf Of The IESG
> >>Sent: Monday, August 22, 2005 10:11 PM
> >>To: IETF-Announce
> >>Cc: [email-masked]
> >>Subject: Last Call: 'Encapsulation Methods for Transport of ATM Over
> >>MPLS Networks' to Proposed Standard 
> >>
> >>