Subject: RE: [PWE3] Re: Demultiplexing of VCCV packets in SAToP and CESoPS N

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 2 Aug 2005 10:09:24 +0300

Skip and all,
Please ignore my previous email on this thread.It has been inadvertently
sent BEFORE
any comments have been added. Sorry for inconvenience.

Hopefully this one is WITH the comments.

I have snipped parts of the text to make readiing easier.

Regards,
			Sasha

> -----Original Message-----
> From: Skip Booth [mailto:[email-masked]]
> Sent: Monday, August 01, 2005 3:05 PM
> To: Sasha Vainshtein
> Cc: 'Tnadeau (E-mail) '; 'Yaakov Stein '; [email-masked] '; 
> Alik Shimelmits; Stewart Bryant
> Subject: Re: [PWE3] Re: Demultiplexing of VCCV packets in 
> SAToP and CESoPS N
> 
> 
> 
> 
> Sasha Vainshtein wrote:
> > Skip and all,
> > Stitching between MPLS and L2TP PWs is surely an important goal.
> > However, I think that the existing situation makes it near impossible - 
> > and the TDM PWs are the least complicated part of it!
> > 
> > When it come to Layer 2 PWs (FR, ATM, HDLC, Ethernet), the L2TP and
> > MPLS sequencing schemes differ substantially:
> > - L2TP uses a 24-bit no-gap sequence number space
> > - MPLS uses a 16-bit, skipped-zero one.
> 
> Sure - but there's ways to perform the 16-24 bit conversion, 
> albiet not that
> pretty, you can still do it.  In environments where 
> sequencing is not required, the interworking is pretty straightforward.
>
[Sasha] Of course different sequence number spaces do not represent a
problem
IF you do NOT do any sequencing at all (including possible interest of
the endpoints in lost packets PW packets, e.g. as an indication of the level
of
serivce provided:-). Otherwise the only way to support
16-24 bit conversion would be RE-SEQUENCING (with the stitching point
keeping
a state with two expected sequence numbers, doing two types of in-order
checks,
generating suitable numbers. I'd say that if we agree to do that, reversing
the CW/RTP
order (without tampering with the contents of any of these!) at the
stitching point is peanuts. 
... snipped to the end ...

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Skip Booth <[email-masked]>
Date: Tue, 02 Aug 2005 06:54:46 -0400

> stitching point is peanuts. 

Let's just forget about the 16-24 bit conversion for the sake of this discussion
because I believe we've already agreed that the MPLS CW should be used for
CEMoL2TPv3 applications.  We've already agreed that 0001 represents an inband
VCCV packet.  The only remaining point of contention is the RTP/CW ordering.  By
ordering the RTP header after the MPLS CW for both L2TPv3 and MPLS pseudowires,
we provide a consistent, clear VCCV demux operation which is as future proof as
possible and provides easy support of L2TP to MPLS pseudowire stitching.  There
is no technical reason (that I've seen) for ordering the RTP header before the
CW for L2TPv3, while there appear to be at least a couple of good technical
reasons for ordering it consistently.

-Skip