Subject: RE: [PWE3] PWE3 IANA policy - rough consesnus

From: "Gray, Eric" <[email-masked]>
Date: Tue, 2 Aug 2005 03:24:33 -0400

Mark,

	We're cycling on station - again.

	"Vendor" and "Proprietary" are effectively semantic NULLs
in this context.

	One of my earlier objections to this usage is exactly as
Eric Rosen said - the possibility exists that vendor/proprietary
usage will become a standard (by some definition of the term).
Also, if the intent is to somehow distinguish "vendors" from any
other entity, I would challenge your assumption that IANA can 
make this distinction without yet another form of "expert review".
I'm fairly sure that you couldn't make this distinction in fifty 
words or less.

	FCFS is - I am sure - one of the options allowed as an IANA
assignment policy. Let's use it and stop going around and around
on the issues.

--
Eric Gray

--> -----Original Message-----
--> From: [email-masked] 
--> [mailto:[email-masked]]On Behalf Of
--> Mark Townsley
--> Sent: Tuesday, August 02, 2005 3:12 AM
--> To: [email-masked]
--> Cc: [email-masked]; Danny McPherson; pwe3; Stewart Bryant
--> Subject: Re: [PWE3] PWE3 IANA policy - rough consesnus
--> 
--> 
--> 
--> How about (proposed by Thomas earlier):
--> 
--> "reserved for vendor extensions"
--> 
--> I believe IANA knows how to distinguish between a vendor 
--> request and a
--> non-vendor request.
--> 
--> - Mark
--> 
--> Eric W Gray wrote:
--> 
--> > I agree with Eric Rosen on this point.  In addition to 
--> not necessarily 
--> > being an appropriate
--> > distinction, the word "Proprietary" adds no semantic 
--> value given the 
--> > number of  instances
--> > of ideas created by a single individual or organization that 
--> > subsequently become defacto
--> > standards and the fact that "Proprietary" does not distinguish 
--> > individual/organization types.
--> >
--> > --
--> > Eric G
--> >
--> > Eric Rosen wrote:
--> >
--> >>>0-1024 Expert review
--> >>>1025-4096 Reserved
--> >>>4097- Proprietary - Allocated FCFS by IANA
--> >>>    
--> >>>
--> >>
--> >>Please remove the word "proprietary".  There is no reason 
--> why a codepoint in
--> >>this range would not  be used in a standard.  There is  
--> also no reason why a
--> >>codepoint allocated via expert review would not be 
--> proprietary (i.e., single
--> >>vendor, non-standard). 
--> >>
--> >>
--> >>
--> >>_______________________________________________
--> >>pwe3 mailing list
--> >>[email-masked]
--> >>https://www1.ietf.org/mailman/listinfo/pwe3
--> >>
--> >>
--> >>
--> >>  
--> >>
--> 
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
--> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Mark Townsley <[email-masked]>
Date: Tue, 02 Aug 2005 09:57:39 +0200

>	"Vendor" and "Proprietary" are effectively semantic NULLs
Actually, the term "vendor-specific" is well known, and has been used 
for other IANA registries and descriptions of type codes in protocol 
specifications. There is both common sense understanding and precedent 
to rely on here.

>usage will become a standard (by some definition of the term).
Yes, just as it is possible for a vendor to camp on "IETF Consensus" 
space with a proprietary extension and have it become an ad-hoc 
standard. As has been said already, there is no protocol police here. 
But just because there isn't, doesn't mean we should abandon all 
guidelines.

>I'm fairly sure that you couldn't make this distinction in fifty 
In fact, IANA makes this distinction regularly. Honest, in the vast 
majority of cases, they know the difference between, say, "Cisco" and 
"IEEE."

Sure, one could incorporate some sub-entity of their SDO and become a 
"vendor" overnight. Perhaps even one with a convincing enough name to 
pull the wool over the eyes of our IANA folks. I think it is 
unreasonable to try and optimize for such abuses of the system.

>assignment policy. Let's use it and stop going around and 
>
>around
>on the issues.
>  
>
Right, I'm not talking about the Policy for the range, I'm talking about 
the label applied to the range.

- Mark

---

From: Loa Andersson <[email-masked]>
Date: Tue, 02 Aug 2005 10:45:01 +0200

Here is an example on text from the IANA registry, this is
the language we should use. I strongly suspect that IANA will
do what ever we suggest

"The range for Status Codes is 0x00000000 - 0x3FFFFFFF.
Status Codes in the range 0x00000000 - 0x1FFFFFFF are allocated
through an IETF Consensus action, codes in the range
0x20000000 - 0x3EFFFFFF are allocated as First Come First Served,
and codes in the range 0x3F000000 - 0x3FFFFFFF are reserved for
Private Use."

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                            [email-masked]