Subject: RE: [PWE3] PWE3 IANA policy - rough consesnus

From: Sasha Vainshtein <[email-masked]>
Date: Mon, 1 Aug 2005 17:07:02 +0300

Stewart and all,
I am OK with this.

Regards,
				Sasha

> -----Original Message-----
> From: Stewart Bryant [mailto:[email-masked]]
> Sent: Monday, August 01, 2005 3:36 PM
> To: pwe3
> Cc: W. Mark Townsley; Danny McPherson
> Subject: [PWE3] PWE3 IANA policy - rough consesnus
> 
> 
> 
> It is clear that we cannot get the unanimous agreement
> of the PWE3 WG on the IANA policy issue.
> 
> In order to move forward the chairs need to make a call
> on the rough consensus.
> 
> Taking into account all of the views that have been
> expressed we think that the following is the appropriate
> policy:
> 
>     0-1024    Expert review
> 1025-4096    Reserved
> 4097-        Proprietary - Allocated FCFS by IANA
> 
> - Stewart/Danny
> 
> 
> 
> _______________________________________________
> pwe3 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pwe3
> 

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 2 Aug 2005 05:52:02 -0400

Mark,

	Correct me if I'm wrong, but the common usage for the 
term "Vendor Specific" is that the assignments from "this
space" (the space designated as "vendor specific") is scoped
by a vendor identifier - such as an OUI.  In this sense, the
designation of any space in this case as "Vendor Specific"
would be a mistake.  Hence the "semantic NULL" comment I made
earlier.

	The argument against "proprietary" has also been made,
and is similar.

--
Eric

--> -----Original Message-----
--> From: Mark Townsley [mailto:[email-masked]]
--> Sent: Tuesday, August 02, 2005 3:58 AM
--> To: Gray, Eric
--> Cc: [email-masked]; Danny McPherson; pwe3; Stewart Bryant
--> Subject: Re: [PWE3] PWE3 IANA policy - rough consesnus
--> 
--> 
--> Gray, Eric wrote:
--> 
--> >Mark,
--> >
--> >	We're cycling on station - again.
--> >
--> >	"Vendor" and "Proprietary" are effectively semantic NULLs
--> >in this context.
--> >  
--> >
--> Actually, the term "vendor-specific" is well known, and has 
--> been used 
--> for other IANA registries and descriptions of type codes in 
--> protocol 
--> specifications. There is both common sense understanding 
--> and precedent 
--> to rely on here.
--> 
--> >	One of my earlier objections to this usage is exactly as
--> >Eric Rosen said - the possibility exists that vendor/proprietary
--> >usage will become a standard (by some definition of the term).
--> >  
--> >
--> Yes, just as it is possible for a vendor to camp on "IETF 
--> Consensus" 
--> space with a proprietary extension and have it become an ad-hoc 
--> standard. As has been said already, there is no protocol 
--> police here. 
--> But just because there isn't, doesn't mean we should abandon all 
--> guidelines.
--> 
--> >Also, if the intent is to somehow distinguish "vendors" from any
--> >other entity, I would challenge your assumption that IANA can 
--> >make this distinction without yet another form of "expert review".
--> >I'm fairly sure that you couldn't make this distinction in fifty 
--> >words or less.
--> >  
--> >
--> In fact, IANA makes this distinction regularly. Honest, in the vast 
--> majority of cases, they know the difference between, say, 
--> "Cisco" and 
--> "IEEE."
--> 
--> Sure, one could incorporate some sub-entity of their SDO 
--> and become a 
--> "vendor" overnight. Perhaps even one with a convincing 
--> enough name to 
--> pull the wool over the eyes of our IANA folks. I think it is 
--> unreasonable to try and optimize for such abuses of the system.
--> 
--> >	FCFS is - I am sure - one of the options allowed as an IANA
--> >assignment policy. Let's use it and stop going around and 
--> >
--> >around
--> >on the issues.
--> >  
--> >
--> Right, I'm not talking about the Policy for the range, I'm 
--> talking about 
--> the label applied to the range.
--> 
--> - Mark
--> 
--> >--
--> >Eric Gray
--> >
--> >--> -----Original Message-----
--> >--> From: [email-masked] 
--> >--> [mailto:[email-masked]]On Behalf Of
--> >--> Mark Townsley
--> >--> Sent: Tuesday, August 02, 2005 3:12 AM
--> >--> To: [email-masked]
--> >--> Cc: [email-masked]; Danny McPherson; pwe3; Stewart Bryant
--> >--> Subject: Re: [PWE3] PWE3 IANA policy - rough consesnus
--> >--> 
--> >--> 
--> >--> 
--> >--> How about (proposed by Thomas earlier):
--> >--> 
--> >--> "reserved for vendor extensions"
--> >--> 
--> >--> I believe IANA knows how to distinguish between a vendor 
--> >--> request and a
--> >--> non-vendor request.
--> >--> 
--> >--> - Mark
--> >--> 
--> >--> Eric W Gray wrote:
--> >--> 
--> >--> > I agree with Eric Rosen on this point.  In addition to 
--> >--> not necessarily 
--> >--> > being an appropriate
--> >--> > distinction, the word "Proprietary" adds no semantic 
--> >--> value given the 
--> >--> > number of  instances
--> >--> > of ideas created by a single individual or organization that 
--> >--> > subsequently become defacto
--> >--> > standards and the fact that "Proprietary" does not 
--> distinguish 
--> >--> > individual/organization types.
--> >--> >
--> >--> > --
--> >--> > Eric G
--> >--> >
--> >--> > Eric Rosen wrote:
--> >--> >
--> >--> >>>0-1024 Expert review
--> >--> >>>1025-4096 Reserved
--> >--> >>>4097- Proprietary - Allocated FCFS by IANA
--> >--> >>>    
--> >--> >>>
--> >--> >>
--> >--> >>Please remove the word "proprietary".  There is no reason 
--> >--> why a codepoint in
--> >--> >>this range would not  be used in a standard.  There is  
--> >--> also no reason why a
--> >--> >>codepoint allocated via expert review would not be 
--> >--> proprietary (i.e., single
--> >--> >>vendor, non-standard). 
--> >--> >>
--> >--> >>
--> >--> >>
--> >--> >>_______________________________________________
--> >--> >>pwe3 mailing list
--> >--> >>[email-masked]
--> >--> >>https://www1.ietf.org/mailman/listinfo/pwe3
--> >--> >>
--> >--> >>
--> >--> >>
--> >--> >>  
--> >--> >>
--> >--> 
--> >--> 
--> >--> _______________________________________________
--> >--> pwe3 mailing list
--> >--> [email-masked]
--> >--> https://www1.ietf.org/mailman/listinfo/pwe3
--> >--> 
--> >
--> >  
--> >
-->

---

From: "Gray, Eric" <[email-masked]>
Date: Tue, 2 Aug 2005 05:53:49 -0400

Agree.

--> -----Original Message-----
--> From: [email-masked] 
--> [mailto:[email-masked]]On Behalf Of
--> Stewart Bryant
--> Sent: Monday, August 01, 2005 11:33 AM
--> To: Yaakov Stein
--> Cc: pwe3; W. Mark Townsley; Luca Martini; Danny McPherson
--> Subject: Re: [PWE3] PWE3 IANA policy - rough consesnus
--> 
--> 
--> 
--> 
--> Yaakov Stein wrote:
--> 
--> >>"Pseudo Wire Status" has not been discussed , and is a 
--> small field ...
--> >>so we would have 0 to 16 expert , 16 to 23 reserved , 23 to 
--> >>31 fcfs vendor proprietary ....
--> >>
--> >>
--> >>Is this the detailed WG consensus ?
--> > 
--> > 
--> > No. Both due to the semantics and to the size of the field,
--> > I believe that PW status should be by our allocation only
--> > (no FCFS).
--> > 
--> > Y(J)S
--> > 
--> > 
--> 
--> I agree with Yaakov, any field that small should always be
--> by IETF Consensus.
--> 
--> - Stewart
--> 
--> 
--> 
--> _______________________________________________
--> pwe3 mailing list
--> [email-masked]
--> https://www1.ietf.org/mailman/listinfo/pwe3
-->