Subject: RE: [PWE3] Explicit Routing for MS-PW: Difference in the NetworkVisibility assumption

From: "Chris Metz \(chmetz\)" <[email-masked]>
Date: Wed, 3 Aug 2005 02:21:57 -0400

Hi Sasha-
Agree with your general charaterization of visibility assumptions
related to the signaling protocols in question. The former requires
per-PE hop lookups to route the PW setup to the next-hop S-PE or target
ultimate-PE. The latter includes a complete path vector with some
lookups based on its "looseness".
 
I can also envision a scenario where PW setups use a path vector to
reach the "front door" of a provider network and will then need to "ask"
where the target U-PE is.
 
Chris 

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sasha Vainshtein
	Sent: Tuesday, August 02, 2005 3:19 AM
	To: PWE3 WG (E-mail)
	Subject: [PWE3] Explicit Routing for MS-PW: Difference in the
NetworkVisibility assumption

	Hi all,
	IMHO there is a fundamental difference in the network visibility
assumptions reflectetd in the LDP- and RSVP-TE-based signaling
proposals:

	*	The former assumes that the network visibility of the
U-PE is limited to its Next Hop S-PE (or possibly a small set of Next
Hop S-PEs) 
	*	The latter assumes that U-PE may be fully aware of the
entire set (or a subset) of S-PEs the MS-PW is going to traverse.

	The full/partial path awareness presumption may be valid in
certain circmumstances,but the limited visibility one seems to be a bare
minimum for MS-PW.
	 
	Regards,
	                    Sasha

_______________________________________________
pwe3 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pwe3

---

From: Scott W Brim <[email-masked]>
Date: Wed, 03 Aug 2005 08:51:07 +0200

> lookups based on its "looseness".

Sasha, please clarify "network visibility assumptions".  Regardless of
what signaling method you are using, if there are multiple possible
S-PEs (or whatever they are called), you need to choose one.  That
implies the same "visibility" into the path you want to take.  Let's
distinguish between what goes into a signaling message and the
"network visibility" you need to have discovered (by BGP, PCE,
whatever) in order to know where to send your signaling?

> where the target U-PE is.

Indeed, and a management plane mechanism may have already done the
homework for you.

swb

>  
> Chris  
>  
>  
> 
>     *From:* [email-masked] [mailto:[email-masked]] *On
>     Behalf Of *Sasha Vainshtein
>     *Sent:* Tuesday, August 02, 2005 3:19 AM
>     *To:* PWE3 WG (E-mail)
>     *Subject:* [PWE3] Explicit Routing for MS-PW: Difference in the
>         * The former assumes that the network visibility of the U-PE is
>           limited to its Next Hop S-PE (or possibly a small set of Next
>           Hop S-PEs)
>         * The latter assumes that U-PE may be fully aware of the entire
>           set (or a subset) of S-PEs the MS-PW is going to traverse. 
> 
>     The /full/partial path awareness/ presumption may be valid in
>     certain circmumstances,but the /limited visibility/ one seems to be
>     a bare minimum for MS-PW.
>      
>     Regards,
>                         Sasha
>      
>      
>      
>      
>      
> 
> 
> ------------------------------------------------------------------------
>