Subject: [quicwg/base-drafts] HTTP cross references (PR #4963)

From: Mike Bishop <[email-masked]>
Date: Thu, 10 Mar 2022 10:26:10 -0800

This replaces the frequent references to definition sections noted in #4949 with index entries which are hyperlinked in the HTML output.  As people review, I&#39;d like particular attention on anywhere we think the cross-reference is so critical it needs to be explicit so it appears in the text output as well.

I&#39;ve attempted to keep any cross-references that pointed to a section which is *not* the one the hyperlink would take you to (e.g. Connection Closure is not the definition of the GOAWAY frame).

You can see the hyperlinked output [here](https://quicwg.org/base-drafts/http/xrefs/rfc9114.html).

Fixes #4949.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4963

-- Commit Summary --

  * xrefs for frame, error, and setting names
  * malformed
  * Stream error and connection error
  * Stream types
  * Push ID
  * Remove frame references

-- File Changes --

    M rfc9114.md (163)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4963.patch
https://github.com/quicwg/base-drafts/pull/4963.diff

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4963
You are receiving this because you are subscribed to this thread.

Message ID: &lt;quicwg/base-drafts/pull/[email-masked]&gt;

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Mar 2022 16:05:18 -0800

@martinthomson approved this pull request.

Wonderful.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4963#pullrequestreview-906629720
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4963/review/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Mar 2022 10:54:40 -0700

@MikeBishop pushed 1 commit.

76cf9d275b394cecdf76441135e6710da81b4790  Accomodate plurals

-- 
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4963/files/9085f05ad62533dda46698031f458c3700233c02..76cf9d275b394cecdf76441135e6710da81b4790
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4963/push/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Mar 2022 07:33:28 -0700

Merged #4963 into h3qp_auth48.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4963#event-6335715998
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/pull/4963/issue_event/[email-masked]>