Subject: [quicwg/base-drafts] RFC Editor comment 4 (Issue #4970)

From: Lucas Pardue <[email-masked]>
Date: Fri, 25 Mar 2022 10:40:29 -0700

The repeated "when" clauses in this sentence make it
     difficult to parse.  If our suggestion does not correctly capture
     your intent, could you please rephrase?

Original:
A stream becomes unblocked when the Insert Count becomes
unblocked when the Insert Count becomes greater than or equal to the
Required Insert Count for all encoded field sections the decoder has
started reading from the stream.

Perhaps:
A stream becomes unblocked when the Insert Count becomes
unblocked.  When the Insert Count becomes greater than or equal to the
Required Insert Count for all encoded field sections, the decoder has
started reading from the stream.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4970
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/[email-masked]>

---

From: Mike Bishop <[email-masked]>
Date: Mon, 28 Mar 2022 12:06:53 -0700

It actually looks as though the words "becomes unblocked when the Insert Count" are duplicated, which would make the corrected text:

> A stream becomes unblocked when the Insert Count becomes greater than or equal to the Required Insert Count for all encoded field sections the decoder has started reading from the stream.

That might still be confusing, but the proposed text certainly isn't the right change.

The key point to capture is:

- The decoder has started reading at least one encoded field section from the stream and encountered a Required Insert Count value in some or all of them which exceeds its current Insert Count.
- When the Insert Count is greater than or equal to the RIC value from all of the encoded field sections the decoder has attempted to process, the stream becomes unblocked.

-- 
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4970#issuecomment-1081030653
You are receiving this because you are subscribed to this thread.

Message ID: <quicwg/base-drafts/issues/4970/[email-masked]>