Subject: Stateless reset tweak

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Oct 2017 15:39:24 +1100

https://github.com/quicwg/base-drafts/pull/842

ekr pointed out that handling a stateless reset is a little tricky
because the payload overlaps with the header.   After some discussion
(on #820), we concluded that the easiest way to solve this problem was
to put the token at the very end of the packet.  This makes the packet
more easily identified by clients, because the token is always in the
same place no matter what flags or packet type is used.

Does anyone think that this is a bad idea?  I'd like to integrate this into -07.

---

From: Ian Swett <[email-masked]>
Date: Tue, 10 Oct 2017 08:22:44 -0400

Sounds good to me.

After failed decryption, the end of the packet would be more likely to be
in cache anyway.