Subject: ECN design team wiki

From: Ingemar Johansson S <[email-masked]>
Date: Thu, 12 Oct 2017 06:53:27 +0000

Hi

I created a small ECN wiki. This can perhaps be used as a scratch-book for the design team ?

I started on a list of requirements, some of them are probably botched but it is atleast a first stab at it. Feel free to edit.

https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC

/Ingemar

From: Martin Thomson [mailto:[email-masked]]
Sent: den 11 oktober 2017 23:53
To: quicwg/base-drafts <[email-masked]>
Cc: Ingemar Johansson S <[email-masked]>; Author <[email-masked]>
Subject: Re: [quicwg/base-drafts] Design team for ECN and/or timestamp design team (#856)

Feel free to use the quic@ietf list or the wiki<https://github.com/quicwg/base-drafts/wiki> to coordinate this sort of activity.

—
You are receiving this because you authored the thread.
Reply to this email directly, view it on GitHub<https://github.com/quicwg/base-drafts/issues/856#issuecomment-335960066>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AKOdGG4GhPepFqWmkSKWtCA7micDg9BRks5srTjHgaJpZM4P1eTo>.

---

From: Christian Huitema <[email-masked]>
Date: Thu, 12 Oct 2017 11:03:10 -0700

In the same spirit, I took a crack at time stamps:
https://github.com/quicwg/base-drafts/wiki/Time-stamps-in-QUIC

On 10/11/2017 11:53 PM, Ingemar Johansson S wrote:
> I started on a list of requirements, some of them are probably botched
> but it is atleast a first stab at it. Feel free to edit.
>
>  
>
> *From:* Martin Thomson [mailto:[email-masked]]
> *Sent:* den 11 oktober 2017 23:53
> *To:* quicwg/base-drafts <[email-masked]>
> *Cc:* Ingemar Johansson S <[email-masked]>; Author
> <[email-masked]>
> *Subject:* Re: [quicwg/base-drafts] Design team for ECN and/or
> timestamp design team (#856)
>
>  
>
> Feel free to use the quic@ietf list or the wiki
> <https://github.com/quicwg/base-drafts/wiki> to coordinate this sort
> of activity.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/856#issuecomment-335960066>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKOdGG4GhPepFqWmkSKWtCA7micDg9BRks5srTjHgaJpZM4P1eTo>.
>

-- 
Christian Huitema

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 12 Oct 2017 11:41:16 -0700

Thanks much for setting up the wiki, Ingemar!

On Thu, Oct 12, 2017 at 11:03 AM, Christian Huitema <[email-masked]>
wrote:

> I started on a list of requirements, some of them are probably botched but
> it is atleast a first stab at it. Feel free to edit.
>
>
>
> *From:* Martin Thomson [mailto:[email-masked]
> <[email-masked]>]
> <[email-masked]>
> *Cc:* Ingemar Johansson S <[email-masked]>
> <[email-masked]>; Author <[email-masked]>
> *Subject:* Re: [quicwg/base-drafts] Design team for ECN and/or timestamp
> design team (#856)
>
>
>
> <https://github.com/quicwg/base-drafts/wiki> to coordinate this sort of
> activity.
>
> —

---

From: marcelo bagnulo braun <[email-masked]>
Date: Fri, 13 Oct 2017 09:50:25 +0200

Hi,

Thanks for this.
One question, not sure if this has been discussed or not, is a 
requirement to allow ECT/CE marking of all packet type in a quic 
connection? (including handshake, acks, etc) (i see you have a reference 
to the generalized ECN draft, but it is not really referenced in the 
document)

Regards, marcelo

---

From: Ingemar Johansson S <[email-masked]>
Date: Sun, 15 Oct 2017 19:46:51 +0000

Hi Marcelo

You are correct in your observation that the -03 version indicates that ECN capability exchange (with ECT codepoint set) should take place after the QUIC connection setup. However, I brought up the possibility that this can also take place already at the connection setup at he QUIC WG session at IETF-99. There are some potential benefits with this and Apple´s ECN test result (on TCP) seem to indicate that this is safe.
Based on this, I believe that one should append R.7 in the ECN QUIC wiki with 
"ECN capability exchange MAY take place either at or after QUIC connection setup."  

/Ingemar

> -----Original Message-----
> From: marcelo bagnulo braun [mailto:[email-masked]]
> Sent: den 13 oktober 2017 09:50
> To: Ingemar Johansson S <[email-masked]>; QUIC WG
> <[email-masked]>
> Cc: Ian Swett <[email-masked]>; [email-masked]'
> <[email-masked]>; Mirja Kuehlewind (IETF) <[email-masked]>;
> [email-masked]; Jana Iyengar ([email-masked]) <[email-masked]>; Subir
> Das <[email-masked]>
> Subject: Re: ECN design team wiki
> 
> Hi,
> 
> Thanks for this.
> One question, not sure if this has been discussed or not, is a requirement to
> allow ECT/CE marking of all packet type in a quic connection? (including
> handshake, acks, etc) (i see you have a reference to the generalized ECN
> draft, but it is not really referenced in the
> document)
> 
> Regards, marcelo
> 
> 
> > <https://github.com/quicwg/base-drafts/issues/856#issuecomment-
> 3359600
> > 66>,
> > or mute the thread
> > <https://github.com/notifications/unsubscribe-
> auth/AKOdGG4GhPepFqWmkSKWtCA7micDg9BRks5srTjHgaJpZM4P1eTo>.
> >
>