Subject: Flow control transport parameters are optional

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jul 2018 11:15:27 +1000

Just checking that people are OK with this change.

Marten opened https://github.com/quicwg/base-drafts/pull/1610 which
proposes making the initial_max_data transport parameter optional.
Given that this can be set to 0 anyway, it isn't any more of a footgun
that we already have.  Absent objections, I plan to merge this.

---

From: Tommy Pauly <[email-masked]>
Date: Sun, 29 Jul 2018 20:22:26 -0700

Seems reasonable, given that it has a well-defined default of 0. I imagine most implementations will want to always send this, but there doesn’t seem to be any harm in making it optimal. 

Tommy

> On Jul 29, 2018, at 6:15 PM, Martin Thomson <[email-masked]> wrote:
>