Subject: Big changes in -17

From: Martin Thomson <[email-masked]>
Date: Fri, 26 Oct 2018 10:20:04 +1100

No, that doesn't mean that we're going to be making major changes, but
I did want to draw attention to a few things that seem likely to
happen in -17 in the transport.

I hope that nothing here is a surprise to anyone.

1. Version negotiation.  This was discussed in NY and people seemed to
like the proposed direction.  There is a PR in progress here:
https://github.com/quicwg/base-drafts/pull/1901

2. MAX_STREAMS.  We realized that the accounting for stream limits,
particularly STREAM_ID_BLOCKED, was slightly broken.  Making the frame
consistent with the transport parameter - that is, having a count
rather than a maximum - solves this problem nicely.  PR:
https://github.com/quicwg/base-drafts/pull/1900

3. Renumbering.  With all the changes we've had, we've tried to keep
identifiers stable.  That means we have a fragmented mess.  The
editors plan to renumber frame types and transport parameters to try
to restore some semblance of sanity.

4. The first octet.  We discussed this in NY:
https://github.com/quicwg/wg-materials/blob/master/interim-18-09/minutes.md#first-octet---martin-thomson
and we will have a decision about the spin bit within 2 weeks.  After
that, one of the designs discussed will be implemented.

5. Your last minute changes.  Maybe.  Get them in soon, please.

After that, the list of remaining design issues gets very lean (at
least for the transport draft).  Once we ship -17, the intent is to
raise the bar considerably for changes that aren't clearly bug fixes
or editorial improvements.  The idea is that people can start
deploying -17, so we can all start to learn the hard lessons.
Avoiding gratuitous changes from that point is going to be necessary.

---

From: <[email-masked]>
Date: Mon, 29 Oct 2018 14:26:18 +0100

Hello Martin,

> that, one of the designs discussed will be implemented.

Do I assume correctly that "the designs discussed" are the following three:

  - nothing (no spin bit)
  - spin bit alone
  - spin bit + VEC

Or is there room for other (written) proposals ?

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 29 Oct 2018 12:07:00 -0700

Alexandre,

Are you really asking if an alternative design for the spin-bit(s) can be
proposed now, or am I mis-reading your question?

- jana

On Mon, Oct 29, 2018 at 6:26 AM <[email-masked]> wrote:

> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> pas etre diffuses, exploites ou copies sans autorisation. Si vous avez
> recu ce message par erreur, veuillez le signaler
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;

---

From: <[email-masked]>
Date: Mon, 29 Oct 2018 21:06:46 +0100

I was merely trying to clarify what the plural ("designs") meant, given that in 
NYC it was made clear that nothing but the single spin bit had undergone enough 
privacy analysis (not even the VEC).

On 10/29/2018 08:07 PM, Jana Iyengar wrote:
> On Mon, Oct 29, 2018 at 6:26 AM <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hello Martin,
>

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Oct 2018 09:35:22 +1100

> Or is there room for other (written) proposals ?

You should refer to the email from Lars.  I believe that the approach
they propose only considers "no spin bit" vs. "spin bit alone".

---

From: <[email-masked]>
Date: Tue, 30 Oct 2018 11:20:07 +0100

> they propose only considers "no spin bit" vs. "spin bit alone".

Then, this means that the two reserved bits (0x3 in 1st byte) are out of scope 
for v1, right ?

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Oct 2018 22:05:31 +1100

As our chairs said:

> Note that draft-ietf-quic-spin-exp describes what we commonly call the single-bit spin bit variant. We'd like to confirm that the discussion will be limited to that variant.

I read that as saying that this needs to be confirmed.