Subject: RE: Structuring the BKK spin bit discussion: and manufacturers ?

From: <[email-masked]>
Date: Tue, 30 Oct 2018 09:25:24 +0000

Hi

IMO manufacturers of any sort of devices (router, box, proxy, mobile equipment...) should start sharing their intends too.

Regards
Emile

-----Message d'origine-----
De : QUIC [mailto:[email-masked]] De la part de Lars Eggert
Envoyé : lundi 29 octobre 2018 16:27
À : IETF QUIC WG
Objet : Structuring the BKK spin bit discussion

Hi,

you'll have seen that we've set aside a lengthy slot on the agenda in order to finish the discussion on whether the spin bit (described in draft-ietf-quic-spin-exp) should be included in the first version of QUIC the IETF publishes, and if yes, what shape that inclusion would take.

Note that draft-ietf-quic-spin-exp describes what we commonly call the single-bit spin bit variant. We'd like to confirm that the discussion will be limited to that variant.

Next, we'd like to confirm that the WG believes that it is fit-for purpose, i.e., that if a sufficient number of bits were spinning, operators could obtain the information they need. This also includes confirmation that the privacy aspects of the spin bit proposal are understood and acceptable to the WG.

We'd specifically like to ask client and server implementors with projected sizable deployments to indicate whether they intent to implement and deploy, if the WG decided to include the spin-bit in the spec. We have seen one such statement on the list from Microsoft (thank you!) and would be interested to hear from others, either on the list or during the session in Bangkok.

Finally, if the WG has agreement to include the spin bit in the spec based on the information from and the discussion on the points above, we need to come to consensus on what shape such an inclusion of the spin bit would take, e.g., negotiated extension, conformance requirements (MAY/SHOULD/MUST) for clients and servers, etc.

Please let us know if you have any questions or comments about this approach for structuring the discussion in Bangkok.

Lars and Mark

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 30 Oct 2018 12:27:41 +0200

Hi,

> IMO manufacturers of any sort of devices (router, box, proxy, mobile equipment...) should start sharing their intends too.

certainly, there's no harm in that.

But since it's the QUIC clients that need to spin and the QUIC servers that need to echo, we're specifically interested in the level of implementation interest there.

Lars