Subject: question about QPACK decode framing

From: Brian Swander <[email-masked]>
Date: Wed, 31 Oct 2018 20:57:27 +0000

Is there a way to determine that we are decoding a complete set of headers a priori?   I.e. is the "headers length" encoded anywhere?   Or does decode (control stream) just have to handle the case where we only have a partial header, and we just pend and wait for more data before continuing?

Thanks
bs

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 31 Oct 2018 17:15:18 -0400

Hi Brian,

(I am assuming you're talking about processing the header block.)

The header block is in the HQ "HEADERS" frame which has a length.
Depending on your implementation, you may be able to tell if you
have the complete header block buffered.

  - Dmitri.