Subject: Special TCPM meeting on draft-ietf-quic-recovery

From: Jana Iyengar <[email-masked]>
Date: Sun, 4 Nov 2018 20:16:33 +0700

PSA: For those not paying attention to the TCPM mailing list, the second
TCPM session (Tues, 11:20-12:20, Chitlada 1) is dedicated to a discussion
of QUIC loss detection and congestion control (draft-ietf-quic-recovery).

---

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 6 Nov 2018 02:18:41 +0000

Some differences from TCP that are worth discussing in this meeting:

  1.  Loss recovery epoch. QUIC may reduce cwnd several times on successive losses whereas TCP will keep cwnd constant until (longer) recovery exit or RTO.
  2.  Cwnd not reduced until an RTO is confirmed. In app send limited case, inflight could be very small compared to cwnd. So in QUIC there is potential to send a burst out after a long idle period (with outstanding data) where TCP wouldn’t. The draft claims this is okay to do because RTO may have been a result of RTT increase instead of loss. Is there data to suggest on which side we should err? i.e. data on what are the chances that an RTO is due to an RTT increase versus loss.
  3.  Min timeout for Crypto = 100 msec in absence of RTT samples. I believe the TCP RFC requires a minimum of 1 second in this case.

Another difference is kMinimumWindow = 2 versus 1 in TCP. Ian has said he will do an experiment to test IW = 1 or 2 and then decide the next steps, so IMO no discussion needed in this meeting.

Some more feedback on the draft (not necessarily as a comparison to TCP):

  1.  kUsingTimeLossDetection variable seems superfluous. All it seems to do is control RACK versus ER. It’s not even controlling FACK. Why not always do time based detection including FACK and TLP, and remove ER from the spec? Time based loss detection subsumes ER.
  2.  Immediate ACK on receiving CE = 1. This doesn’t work for DCTCP where ACK should be edge triggered (CE 0 to 1 or 1 to 0 transitions). So this is dependent on congestion control algorithm.

From: QUIC <[email-masked]> On Behalf Of Jana Iyengar
Sent: Sunday, November 4, 2018 5:17 AM
To: QUIC WG <[email-masked]>
Subject: Special TCPM meeting on draft-ietf-quic-recovery

PSA: For those not paying attention to the TCPM mailing list, the second TCPM session (Tues, 11:20-12:20, Chitlada 1) is dedicated to a discussion of QUIC loss detection and congestion control (draft-ietf-quic-recovery).