Subject: Consensus Calls on Recent Transport/TLS Issues (again)

From: Mark Nottingham <[email-masked]>
Date: Fri, 16 Aug 2019 14:18:28 +1000

The following issues have proposals for resolution, and discussion so far seems to support consensus to accept them. If you object, please do so on the issue or in response to this message (changing the Subject appropriately!). Absent any pushback, we'll direct the editors to incorporate them next week.

See <https://github.com/quicwg/base-drafts/projects/5> for the current state of issues in the Late Stage process, itself defined at <https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md>.

* #2869: Stateless Reset packet sizes should not depend on the maximum connection ID length
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2927>

* #2834: Long Header Packets and Routing Connection IDs
   The proposal is to close with no action.

* #2770: If you want a Stateless Reset you need to send a larger packet than before
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2927>

* #2656: Discarding connection state at server on unvalidated client
   The proposal is to make this an editorial issue.

* #2541: Clients cannot abandon Initial packets while server can still send initial close
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2688>

* #2534: ECN text disables ECN too aggressively
  The proposal is: <https://github.com/quicwg/base-drafts/pull/2752>

* #2205: Largest acked in ACK frame MUST NOT decrease
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2752>

* #2151: Where can you send CONNECTION_CLOSE
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2688>

* #2084: Discuss requirement that connection IDs not be correlatable
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2929>

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 26 Aug 2019 17:06:18 +1000

Hearing no pushback, consensus declared.

> On 16 Aug 2019, at 2:18 pm, Mark Nottingham <[email-masked]> wrote:
>