Subject: Fwd: QUIC IETF Draft 2019-07-09 possible error

From: Lars Eggert <[email-masked]>
Date: Mon, 5 Aug 2019 20:03:30 +0300

Redirecting from other list

-- 
Sent from a mobile device; please excuse typos.

Begin forwarded message:

> Resent-From: <[email-masked]>
> From: Daris Nevil <[email-masked]>
> Date: August 1, 2019 at 19:20:35 GMT+3
> Resent-To: [email-masked], [email-masked], [email-masked], [email-masked], [email-masked], [email-masked]
> To: "[email-masked]" <[email-masked]>,  "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> Subject: QUIC IETF Draft 2019-07-09 possible error
> 
> There may be an error in the IETF document draft-ietf-quic-transport-22:
>  
> https://datatracker.ietf.org/doc/draft-ietf-quic-transport/?include_text=1
>  
> The issue begins on page 81 with the packet diagram.  It shows both a “DCID Len(8)” and “SCID Len(8)”.  However, the description of “DCID Len” says it provides the length for both Destination Connection ID as well as Source Connection ID.  In addition, the “DCID Len” description states the Dest/Src lengths may be at most 18 bytes, while the “SCID Len” description says it may be up to 20 bytes.
>  
> This document from June 2019 shows a different Long Header Packet format that contains a single byte for the DCID/SCID lengths.
>  
> https://docs.google.com/document/d/1FcpCJGTDEMblAs-Bm5TYuqhHyUqeWpqrItw2vkMFsdY/edit
>  
> Can you clarify which Long Header Packet format is correct, and explain the possible descrepencies?
>  
> Kind regards,
> Daris A Nevil
> Intrusion Inc
> 214-564-5317 cell
>

---

From: Eric Kinnear <[email-masked]>
Date: Mon, 05 Aug 2019 10:31:25 -0700

See https://github.com/quicwg/base-drafts/issues/2932 <https://github.com/quicwg/base-drafts/issues/2932> where someone else noticed this as well.

This has been updated in the latest editor’s draft
https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#long-header <https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#long-header>
via
https://github.com/quicwg/base-drafts/commit/913370291aa863a847126f7df9f9ab3df7024196 <https://github.com/quicwg/base-drafts/commit/913370291aa863a847126f7df9f9ab3df7024196>

Thanks,
Eric

> On Aug 5, 2019, at 10:03 AM, Lars Eggert <[email-masked]> wrote:
> 
>> Resent-From: <[email-masked] <mailto:[email-masked]>>
>> From: Daris Nevil <[email-masked] <mailto:[email-masked]>>
>> Resent-To: [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>, [email-masked] <mailto:[email-masked]>
>> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>,  "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
>> https://datatracker.ietf.org/doc/draft-ietf-quic-transport/?include_text=1 <https://datatracker.ietf.org/doc/draft-ietf-quic-transport/?include_text=1>
>>  
>> https://docs.google.com/document/d/1FcpCJGTDEMblAs-Bm5TYuqhHyUqeWpqrItw2vkMFsdY/edit <https://docs..google.com/document/d/1FcpCJGTDEMblAs-Bm5TYuqhHyUqeWpqrItw2vkMFsdY/edit>
>>