Subject: Consensus Calls on Recent Transport/TLS Issues

From: Mark Nottingham <[email-masked]>
Date: Wed, 7 Aug 2019 08:48:35 +1000

The following issues have proposals for resolution, and discussion so far seems to support consensus to accept them. If you object, please do so on the issue or in response to this message (changing the Subject appropriately!). Absent any pushback, we'll direct the editors to incorporate them next week.

See <https://github.com/quicwg/base-drafts/projects/5> for the current state of issues in the Late Stage process, itself defined at <https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md>.

* #2170: Embed QUIC version in expansion
   The proposal is to close with no action.

* #2920: Should server TP encryption be a requirement for the cryptographic handshake?
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2921>

* #2842: Does it make sense to try 0-RTT after Retry?
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2852>

* #2840: Does rejecting 0-RTT data prohibit ACKing 0-RTT data?
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2841>

* #2825: Exceeding Max STREAM ID should be a connection error
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2826>

* #2805: Rationalize terminology around transport/application interactions
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2857>

* #2763: Coordinating spin
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2882>

* #2760: NEW_TOKEN should be symmetric
   The proposal is to close with no action (although it may be taken up in post-QUICv1 work)

* #2685: CC state after a change of path?
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2918>

* #2670: Remove ack_delay_exponent TP
   The proposal is to close with no action.

* #2550: Apply GREASE to transport parameters
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2873>

* #2389: Be clearer about the purpose of disable_migration
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2893>

* #2388: Articulate principles for definition of error codes
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2880>

* #2342: Spoofed connection migration as a DoS vector
   The proposal is: <https://github.com/quicwg/base-drafts/pull/2893>

--
Mark Nottingham   https://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 16 Aug 2019 11:04:04 +1000

Hearing no pushback, consensus declared.

> On 7 Aug 2019, at 8:48 am, Mark Nottingham <[email-masked]> wrote:
>

---

From: "Martin Thomson" <[email-masked]>
Date: Fri, 16 Aug 2019 11:27:33 +1000

Thanks Mark.

I have merged all the PRs and closed all the issues.