Subject: [Issue 287] Re: Cmts on ExtAttrs-05

From: Greg Weber <[email-masked]>
Date: Sun, 8 Mar 2009 22:08:44 -0400

On Thu, Nov 6, 2008 at 10:09 PM, Glen Zorn <[email-masked]> wrote:
> Greg Weber [mailto:[email-masked]] writes:
>
> ...
>
>> A couple editorial comments on the current (-05) extended attributes
>> draft:
>>
>> Section 5, under More bit description:
>>    "exceeds 246 octets" -> "exceeds 245 octets"
>
> Fixed.
>
>> Section 5, under Ext-Len description:
>>   ">=3." -> ">=4."
>
> Fixed.
>
>> Figure 3: the second Ext-Type's value:
>>   "(0x00" -> "(0x01)"
>
> Fixed.

I don't think this got fixed correctly in -06.  Now the first byte of
Ext-Type is 0x00, and it should be 0x01.

G

>
>> Figure 4: I think the very last two octet values swapped.
>
> Fixed.
>
>> Figure 4: The third attribute in this figure violates this earlier
>> MUST from section 4:
>
> Yup.  Anybody happen to remember whose idea it was to put that restriction
> in place?
>
>>   "If an Extended Attribute contains more than one TLV then all of the
>> encapsulated
>>   TLVs MUST fit completely within the Extended Attribute."
>>   Not sure if this is a problem with the text or the example -or maybe
>> just wording.
>
>

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/radiusext/>

---

From: Greg Weber <[email-masked]>
Date: Wed, 11 Mar 2009 14:32:29 -0400

I see the issue mentioned below has been fixed in -07, so I think
Issue 287 may be closed.

G