Subject: Status of draft-ietf-radext-tcp-transport-06.txt

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 13 May 2010 12:40:54 +0200

What is the status of draft-ietf-radext-tcp-transport-06.txt after the
IETF Last Call. Do the editors and the shepherd believe that we need a
new version or is it ready for IESG review in the closest telechat?

Dan

--
to unsubscribe send a message to [email-masked] with
the word 'unsubscribe' in a single line as the message text body.
archive: <http://psg.com/lists/radiusext/>

---

From: Alan DeKok <[email-masked]>
Date: Thu, 13 May 2010 12:52:16 +0200

> new version or is it ready for IESG review in the closest telechat?

  There are no pending issues, IIRC.

  The only unpublished changes are the result of the secdir review.  I
believe those can be handled during the RFC editor process.

  Alan DeKok.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 13 May 2010 14:35:22 +0200

Thanks. I will put the document on the agenda of the 5/20 telechat then.

Did you answer the SEC-DIR review? We can already insert the RFC Editor
note if edits are agreed with the reviewer. 

Regards,

Dan

> -----Original Message-----
> From: Alan DeKok [mailto:[email-masked]] 
> Sent: Thursday, May 13, 2010 1:52 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: Status of draft-ietf-radext-tcp-transport-06.txt
> 
> > What is the status of 
> draft-ietf-radext-tcp-transport-06.txt after the 
>   The only unpublished changes are the result of the secdir 
> review.  I believe those can be handled during the RFC editor process.
> 
>   Alan DeKok.
>

---

From: Alan DeKok <[email-masked]>
Date: Thu, 13 May 2010 14:49:48 +0200

> Thanks. I will put the document on the agenda of the 5/20 telechat then.

  OK.

> note if edits are agreed with the reviewer. 

  Yes.  New text suggested for the "Security Considerations" section:

...
Implementors should consult [RTLS] for issues related the security of
RADIUS over TLS, and [RFC5246] for issues related to the security of
the TLS protocol.

Since "bare" TCP does not provide for confidentiality or enable
negotiation of credible ciphersuites, its use is not appropriate for
inter-server communications where strong security is required.  The
use of "bare" TCP transport (i.e., without additional confidentiality
and security) is NOT RECOMMENDED, as there has been little or no
operational experience with it.
...

  The first paragraph is new.  The second is a repeat of text earlier in
the document, which seemed appropriate to re-highlight in this section.

  Alan DeKok.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 13 May 2010 14:54:58 +0200

Should this text be inserted between the second and the third paragraph
in the current Security Considerations section? 

Dan

> Sent: Thursday, May 13, 2010 3:50 PM
> To: Romascanu, Dan (Dan)
> Cc: 'radext mailing list'; [email-masked]
> > Did you answer the SEC-DIR review? We can already insert the RFC 
> > Editor note if edits are agreed with the reviewer.
> 
> Implementors should consult [RTLS] for issues related the 
> security of RADIUS over TLS, and [RFC5246] for issues related 
> to the security of the TLS protocol.
> 
> Since "bare" TCP does not provide for confidentiality or 
> enable negotiation of credible ciphersuites, its use is not 
> appropriate for inter-server communications where strong 
> security is required.  The use of "bare" TCP transport (i.e., 
> without additional confidentiality and security) is NOT 
> RECOMMENDED, as there has been little or no operational 
> experience with it.
> ...
> 
>   The first paragraph is new.  The second is a repeat of text 
> earlier in the document, which seemed appropriate to 
> re-highlight in this section.
> 
>   Alan DeKok.
>

---

From: Alan DeKok <[email-masked]>
Date: Thu, 13 May 2010 15:04:54 +0200

> in the current Security Considerations section? 

  Yes.

  Alan DeKok.