Subject: [radext] NAI draft: consensus on the name "Network" Access Identifier?

From: Stefan Winter <[email-masked]>
Date: Fri, 01 Aug 2014 10:30:29 +0200

Hello,

due to my remote-only presence in the IETF90 meeting, one little point
to discuss fell in the cracks; I'd like to ask now on the list for
opinions because this is the only thing holding back the PROTO write-up
of the NAI draft.

In TRAC issue 176 ( http://tools.ietf.org/wg/radext/trac/ticket/176 ) I
raised the point that the document is currently inconsistent in its use
of the term NAI: some parts stress that the identifier is useful in a
generic context, beyond network access, while other parts define it to
be strictly in a network context.

The inconsistency really should be fixed; the question is in what way:
either the object itself could be renamed to reflect the wider focus; or
the name "Network Access Identifier" could stay, explaining that it's
historically grown and does not intend to limit its use to network
access despite the name.

A few people have already voiced their opinion and an emerging consensus
seems to be that Network Access Identifier is a too well-known term to
change.

I'd like to confirm consensus on the list that this is the way to go.
Please let the list know if you disagree with that course of action by
15 Aug 2014.

Greetings,

Stefan Winter

-- 
Stefan WINTER
Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et
de la Recherche
6, rue Richard Coudenhove-Kalergi
L-1359 Luxembourg

Tel: +352 424409 1
Fax: +352 422473

PGP key updated to 4096 Bit RSA - I will encrypt all mails if the
recipient's key is known to me

http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC0DE6A358A39DC66

---

From: Rhys Smith <[email-masked]>
Date: Fri, 1 Aug 2014 08:56:42 +0000

> I'd like to confirm consensus on the list that this is the way to go.

+1 from me. Keep the name the same but add some text to say that it’s not meant to be used in the network access context only.

Rhys.
--
Dr Rhys Smith
Identity, Access, and Middleware Specialist
Cardiff University & Janet, the UK's research and education network

email: [email-masked] / [email-masked]
GPG: 0x4638C985

---

From: Bernard Aboba <[email-masked]>
Date: Sat, 2 Aug 2014 06:03:20 -0700

Do not change the term.

> On Aug 1, 2014, at 1:30, "Stefan Winter" <[email-masked]> wrote:
> 
> Hello,
> 
> _______________________________________________
> radext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/radext

---

From: Alejandro Perez Mendez <[email-masked]>
Date: Sun, 03 Aug 2014 10:52:36 +0200

> +1 from me. Keep the name the same but add some text to say that it’s not meant to be used in the network access context only.

+1

---

From: <[email-masked]>
Date: Sun, 3 Aug 2014 09:40:19 +0000

No change :-)

Envoyé depuis mon Sony Xperia SP d'Orange

---- Bernard Aboba a écrit ----

Do not change the term.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Sun, 3 Aug 2014 18:11:25 +0000

In 3GPP specs, we use to define new identifiers (e.g. Private User ID in Its) that are  "in the format" of a NAI. So these identifiers have the same format of NAI but are not network access identifiers. I think that this kind of clarification is sufficient to avoid misinterpretation in the semantic.

Lionel

---- Alejandro Perez Mendez a écrit ----

On 1 Aug 2014, at 09:30, Stefan Winter <[email-masked]><mailto:[email-masked]> wrote:

+1

Rhys.

email: [email-masked]<mailto:[email-masked]> / [email-masked]<mailto:[email-masked]>
GPG: 0x4638C985

_______________________________________________
radext mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/radext

---

From: Stefan Paetow <[email-masked]>
Date: Tue, 5 Aug 2014 12:39:16 +0000

> > A few people have already voiced their opinion and an emerging 
> > consensus seems to be that Network Access Identifier is a too 
> > well-known term to change.
> > 
> +1 from me. Keep the name the same but add some text to say that it's not meant to be used in the network access context only.

+1 for Rhys' suggestion. 

Stefan

Janet(UK) is a trading name of Jisc Collections and Janet Limited, a 
not-for-profit company which is registered in England under No. 2881024 
and whose Registered Office is at Lumen House, Library Avenue,
Harwell Oxford, Didcot, Oxfordshire. OX11 0SG. VAT No. 614944238