Subject: [radext] Error-Cause value allocation for draft-ietf-radext-bigger-packets

From: Stefan Winter <[email-masked]>
Date: Mon, 20 Jun 2016 16:18:36 +0200

Hello,

IANA is in the process of completing the allocations of new code points
for the bigger-packets draft.

One of the two, the new Packet Type Protocol-Error, is no problem.

The other one, the new value "Response Too Big" for the Error-Cause
attribute, raises a question that we wanted to let the working group
know about and ask for opinions.

Error-Cause is defined in RFC 5176 with the following ranges:

0xx Reserved
1xx Reserved
2xx Successful Completion [of CoA exchanges]
3xx Reserved
4xx fatal errors commited by the Dynamic Authorization Client
5xx fatal errors commited by the Dynamic Authorization Server

As it happens, bigger-packets is not specific to Dynamic Authorization;
it applies to RADIUS packets in general.

So, the categories of RFC5176 above do not fit well to the
"Response-Too-Big" semantics.

After thinking about this for a bit, the cleanest approach is probably
to define two new categories:

6xx represent fatal errors committed by a RADIUS server
7xx represent fatal errors committed by a RADIUS client

And within those, allocate

601 Response Too Big

If these categories are created, there should be corresponding text in a
new rev of bigger-packets.

Please let the list know how you think about this in the next two weeks.
If noone speaks up against this, we'll continue along this path.

Greetings,

Stefan Winter

-- 
Stefan WINTER
Ingenieur de Recherche
Fondation RESTENA - Réseau Téléinformatique de l'Education Nationale et
de la Recherche
2, avenue de l'Université
L-4365 Esch-sur-Alzette

Tel: +352 424409 1
Fax: +352 422473

PGP key updated to 4096 Bit RSA - I will encrypt all mails if the
recipient's key is known to me

http://pgp.mit.edu:11371/pks/lookup?op=get&search=0xC0DE6A358A39DC66

---

From: Alan DeKok <[email-masked]>
Date: Mon, 20 Jun 2016 10:22:56 -0400

Sounds good to me.  Since allocations for Error-Cause are "expert review", I think we're good to go here, barring any counter-arguments.

> On Jun 20, 2016, at 10:18 AM, Stefan Winter <[email-masked]> wrote:
> 
> Hello,
> 
> <0x8A39DC66.asc>_______________________________________________
> radext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/radext

---

From: Bernard Aboba <[email-masked]>
Date: Mon, 20 Jun 2016 10:30:16 -0400

Sounds good to me too (I'm the Designated Expert).

On Mon, Jun 20, 2016 at 10:22 AM, Alan DeKok <[email-masked]>
wrote:

>   Sounds good to me.  Since allocations for Error-Cause are "expert
> review", I think we're good to go here, barring any counter-arguments.
>
> _______________________________________________
> radext mailing list
> [email-masked]