Subject: Re: (radius) Username/User-Password attributes

From: "Bernard Aboba" <[email-masked]>
Date: Tue, 27 Oct 1998 17:19:52 -0800

The vulnerability depends completely on the shared secret
chosen. If it is an English word, then a dictionary attack
would be very easy to mount. I'm told that English only
has 1.3 bits of entropy/character -- which means that a
20 character password would be the equivalent of a
26 bit key -- which is crackable in seconds.

-----Original Message-----
From: Leonard Cuff <[email-masked]>
To: Dale E. Reed Jr. <[email-masked]>
Cc: [email-masked] <[email-masked]>
Date: Tuesday, October 27, 1998 1:05 PM
Subject: Re: (radius) Username/User-Password attributes

>
>Most of what I know about cryptography comes from browsing in Bruce
Schneier's
>"Applied Cryptography" (so therefore I DON'T consider myself an expert),
but
>as I see it, having a fixed value in the password field (such as
"Ascend-DNIS")
>makes possible the recovery
>of the shared secret by hackers through a "known plaintext" attack.
Basically
>they can snoop the message on the net, then pick shared secrets via any
favorite
>method and keeping running MD5 'till the known plaintext pops out, shazaam
they
>know the shared secret.  RADIUS does have a 128 byte keyspace, but given
the
>reality
>of how people pick their key - short lengths, all printable characters,
>what's the
>vulnerability?
>
>I'd like to have someone who IS a cryptography expert
>comment on the security aspects here.
>
>Leonard
>
>At 05:53 PM 10/23/98 -0700, Dale E. Reed Jr. wrote:
>>Aydin Edguer wrote:
>>>
>>> Yes.  Ascend supports DNIS and CLID authentication (and has for at least
>>> three years).
>>>
>>> Ascend sends the DNIS or CLID information in the Access-Request as the
>>> User-Name attribute along with a standard User-Password.
>>>
>>> For example, if the NAS is configured to use DNIS to pre-authenticate
>>> a call, the number that was dialed would be placed in the User-Name.
>>>
>>> If the number was 5551212, then the User-Name would be "5551212" and
>>> the Password would be "Ascend-DNIS".
>>
>>This is what I prefer to see.  It makes life REALLY easy to diagnose
>>and interpret this.  Just set the username to the same as the
>>
>>> The use of User-Name could be fairly generic between all NAS vendors and
>>> is very easy to implement.  The use of "Ascend-*" as a User-Password is
>>> not generic and most vendors would probably not agree to such a value.
>>> The option on the RADIUS server side would be to ignore the password if
>>> other NAS vendors use a different password.
>>
>>The password really isn't relevant and in most cases is ignored.  It
>>COULD be definable on the NAS for added security, though.
>>
>>> > How many servers will break if they get an Access-Request w/o them?
>>>
>>> Most.  The typical index into the RADIUS user database is the User-Name
>>> attribute.  It is a requirement for Livingston 1.x and Merit 2/3/4.x
>>> RADIUS servers at least.
>>
>>RadiusNT does require it unless Caller-ID Authentication is enabled.
>>
>>--
>>Dale E. Reed Jr.  ([email-masked])
>>_________________________________________________________________
>>       IEA Software, Inc.      |  RadiusNT, Emerald, and NT FAQs
>> Internet Solutions for Today  |   http://www.iea-software.com
>>-
>>To unsubscribe, email [email-masked]' with
>>'unsubscribe ietf-radius' in the body of the message.
>>
>>
>
>-
>To unsubscribe, email [email-masked]' with
>'unsubscribe ietf-radius' in the body of the message.
>

-
To unsubscribe, email [email-masked]' with
'unsubscribe ietf-radius' in the body of the message.

---

From: Paul Krumviede <[email-masked]>
Date: Wed, 28 Oct 1998 06:40:12 -0500

Yes, entropy of English (or most other languages) is quite
low. One can find a collision in MD5 much more quickly than
one can find the shared secret, but if the shared secret is
not recognizable as such finding a collision won't help
much.

Joe Touch had a paper a few years ago on MD5 throughput from
which one might be able to derive an estimate of how long it
would take to brute force attack MD5 (without any pre-computation).

-paul

-