Subject: [RAI] media-policy-dataset: <media-intermediaries>

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 8 Aug 2011 15:07:30 -0400

The current version of draft-ietf-sipping-media-policy-dataset specifies a <media-intermediaries> element with an assortment of child elements to be used in a session information document to specify the various media intermediaries to be used by the various media streams in the session.  (The intermediaries fall into three classes:  RTP relays, TURN servers, and MSRP relays.)  There are some open questions regarding these:

- The XML schema does not allow <media-intermediaries> to appear in session policy documents.  If <media-intermediaries> cannot be affected by session policies, there seems to be no reason to record them in session descriptions.  On the other hand, perhaps we should allow <media-intermediaries> to be specified in session policies.  Would that be useful?

- The current schema does not allow <media-intermediaries> to be specified separately for each stream within a session.  That seems to be an oversight, but perhaps is not a troublesome restriction.

Dale

---

From: Andrew Allen <[email-masked]>
Date: Mon, 8 Aug 2011 20:17:07 +0000

Dale

Yes I think specifying media intermediaries in session policies would be useful.

I can see that during the session setup the network can decide if a relay or other internediary is needed for that session or not. On net sessions may not need intermediaries but off net sessions may well do so.

This could help reduce the number of candidate tests that need to be done with ICE

Does the media policy schema allow the netwok to influence the ICE candidates? It would seem useful for the network to be able to reduce the list of candidates to remove things it knows will not work and to suggest candidates that will work.

Andrew

----- Original Message -----
From: Worley, Dale R (Dale) [mailto:[email-masked]]
Sent: Monday, August 08, 2011 02:07 PM
To: [email-masked] <[email-masked]>
Subject: [RAI] media-policy-dataset: <media-intermediaries>

Dale
_______________________________________________
RAI mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rai

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Wed, 31 Aug 2011 14:54:14 -0400

> From: Andrew Allen [[email-masked]]
> 

Currently, one cannot put media intermediary specifications in
policies.  Although it does not seem that it would be difficult to add
them.

The <fixed-intermediary> would not be useful in a policy, as it can't
be used for more than one media stream.  But <turn-intermediary> and
<msrp-intermediary> could be meaningful in policies.  We would need to
rigidly specify what media streams each specification would apply to.

> I can see that during the session setup the network can decide if a
> relay or other internediary is needed for that session or not. On net
> sessions may not need intermediaries but off net sessions may well do
> so.

If the processing is being done during a particular session setup, we
don't need a policy specification, as the policy server will be
editing the session info document.  The current syntax and semantics
supports that directly.

> Does the media policy schema allow the netwok to influence the ICE
> candidates? It would seem useful for the network to be able to reduce
> the list of candidates to remove things it knows will not work and to
> suggest candidates that will work.

There isn't a media intermediary specification for ICE candidates,
only for TURN servers.  I think to allow the policy server to edit the
ICE candidates, we'd need a way for the session info document to
encode all the information in the a=candidate lines, so that the
server could examine them and add to them.

Dale