Subject: [RAI] media-policy-dataset: "q" attribute

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Mon, 8 Aug 2011 15:07:40 -0400

In several situations, draft-ietf-sipping-media-policy-dataset allows a session policy or session description to apply "q" values to elements of a list, showing which elements are preferred.  However, the SDP generated from a session description allows only very limited specification of preferences, viz., the ordering of the codec numbers shows their preference order.  In this context, the value of a full-fledged "q" attribute is very limited.  Should we keep it or remove it from the design?

Dale

---

From: Andrew Allen <[email-masked]>
Date: Mon, 8 Aug 2011 23:36:21 +0000

Dale,

The session policy work was very much driven by 3GPP requirements. One of these requirements as I recall was to have the policy be able to influence the preferences of codecs made in a offer. It might also be useful to also influence the preference of IP address candidates or security mechanisms (for when media intermediaries are involved).

Currently used mechanism in 3GPP is to order the the codecs in 488 responses with the most preferred codec first.

However just ordering codecs has an issue when multiple policies can be received from different networks (as is the case with session policy). In this case the UA needs to be able to aggregate multiple policies from different networks to form a single policy that is consistent. Using q values gives the UA the ability to determine which is the most preferred codec that suits both networks.

Suppose network A indicates

Allowed:
 G.711: q=0.5
 G.729: q=0.3
 AMR: q=0.2
 
and network B indicates 

Allowed:
 AMR: q=0.9
 G.729: q=0.1
 
The UA can tell that AMR is the better choice.

Therefore I think we should keep the q values.

Andrew

----- Original Message -----
From: Worley, Dale R (Dale) [mailto:[email-masked]]
Sent: Monday, August 08, 2011 02:07 PM
To: [email-masked] <[email-masked]>
Subject: [RAI] media-policy-dataset: "q" attribute

Dale
_______________________________________________
RAI mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/rai

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.