Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

From: "Hahn, Scott" <[email-masked]>
Date: Sat, 1 Dec 2001 22:40:38 -0800

This WG last call for the Framework PIB document
http://www.ietf.org/internet-drafts/draft-ietf-rap-frameworkpib-06.txt
has completed. We have had no dissenting comments on the mailing list and we
intend to advance this document to the AD for review by the IESG.

   Scott Hahn
   Mark Stevens
   WG co-chairs

---

From: "Da Silva, Pedro" <[email-masked]>
Date: Mon, 3 Dec 2001 15:04:36 -0000

Given that last call period is over I presume there was consensus on a few
issues raised recently concerning the frwkIfRoleCombo table.
Could you please provide the resolutions?

The two messages where these issues were raised were:
Sent: Friday, November 16, 2001 2:43 PM
Subject: RE: frameworkpib-06 comments

and 
Sent: Friday, November 23, 2001 11:23 AM
Subject: frwkIfRoleComboTable

cheers,
Pedro

-----Original Message-----
From: Hahn, Scott [mailto:[email-masked]]
Sent: Sunday, December 02, 2001 6:41 AM
To: [email-masked]
Cc: [email-masked]; Mark L. Stevens
Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

   Scott Hahn
   Mark Stevens
   WG co-chairs

-----Original Message-----
From: Hahn, Scott [mailto:[email-masked]]
Sent: Sunday, December 02, 2001 6:41 AM
To: [email-masked]
Cc: [email-masked]; Mark L. Stevens
Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

   Scott Hahn
   Mark Stevens
   WG co-chairs

---

From: "Sahita, Ravi" <[email-masked]>
Date: Tue, 4 Dec 2001 11:22:10 -0800

Pedro,

Regarding the issues, like you proposed, we can
define a base frwkRoleCombo table containing the
basic RoleCombination and IfCapSetName attributes;
and an extension (the frwkIfRoleCombo table) which
contains the IfIndex, IfDirection attributes.

This addresses both issues of having a base rolecombo
table to form other extensions of and having the 
IfDirection in its extension the frwkIfRoleCombo table 
which allows different capability sets in different 
directions to be defined. Does that sound satisfactory?

Ravi

-----Original Message-----
From: Da Silva, Pedro [mailto:[email-masked]] 
Sent: Monday, December 03, 2001 7:05 AM
To: [email-masked]
Subject: RE: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

Given that last call period is over I presume there was consensus on a few
issues raised recently concerning the frwkIfRoleCombo table. Could you
please provide the resolutions?

and 

cheers,
Pedro

-----Original Message-----
From: Hahn, Scott [mailto:[email-masked]]
Sent: Sunday, December 02, 2001 6:41 AM
To: [email-masked]
Cc: [email-masked]; Mark L. Stevens
Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

   Scott Hahn
   Mark Stevens
   WG co-chairs

-----Original Message-----
From: Hahn, Scott [mailto:[email-masked]]
Sent: Sunday, December 02, 2001 6:41 AM
To: [email-masked]
Cc: [email-masked]; Mark L. Stevens
Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

   Scott Hahn
   Mark Stevens
   WG co-chairs

---

From: "Da Silva, Pedro" <[email-masked]>
Date: Wed, 5 Dec 2001 11:43:03 -0000

Ravi,

Yes that sounds great, it goes towards the generic nature of the frwk PIB.

Although I would expect to see the extended tables in the client type PIB
and not in the frwk PIB.
Unless, of course, there are different PIBs defs that need that construct
(e.g. Feedback PIB) and so one could make a case for placing the table in
the frwk PIB. And the frwkIfRoleCombo table certainly falls in that lot...so
no worries.

cheers,
Pedro

-----Original Message-----
From: Sahita, Ravi [mailto:[email-masked]]
Sent: Tuesday, December 04, 2001 7:22 PM
To: 'Da Silva, Pedro'; [email-masked]
Subject: RE: WG Last Call for draft-ietf-rap-frameworkpib-06.txt
concludes

Pedro,

Ravi

-----Original Message-----
From: Da Silva, Pedro [mailto:[email-masked]] 
Sent: Monday, December 03, 2001 7:05 AM
To: [email-masked]
Subject: RE: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

and 

cheers,
Pedro

-----Original Message-----
From: Hahn, Scott [mailto:[email-masked]]
Sent: Sunday, December 02, 2001 6:41 AM
To: [email-masked]
Cc: [email-masked]; Mark L. Stevens
Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

   Scott Hahn
   Mark Stevens
   WG co-chairs

-----Original Message-----
From: Hahn, Scott [mailto:[email-masked]]
Sent: Sunday, December 02, 2001 6:41 AM
To: [email-masked]
Cc: [email-masked]; Mark L. Stevens
Subject: WG Last Call for draft-ietf-rap-frameworkpib-06.txt concludes

   Scott Hahn
   Mark Stevens
   WG co-chairs

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Wed, 05 Dec 2001 12:59:49 -0500

To All:

Here is our (Ravi, Pedro and My) thinkings:
We would change the Framework PIB to:

frwkRoleComboEntry
    PIB-INDEX { frwkRoleComboPrid }
    UNIQUENESS {}
    ::= { frwkRoleComboTable 1 }
FrwkRoleComboEntry ::= SEQUENCE {
    frwkRoleComboPrid InstanceId,
    frwkRoleComboRoles RoleCombination,
    frwkRoleComboCapSetName SnmpAdminString
    }

frwkIfRoleComboEntry
    EXTENDS { frwkRoleComboEntry }
    UNIQUENESS { frwkIfRoleComboIfIndex,
                            frwkRoleComboCapSetName }
    ::= { frwkIfRoleComboTable 1 }
FrwkIfRoleComboEntry ::= SEQUENCE {
    frwkIfRoleComboIfIndex InterfaceIndex
    }

And, in the future, someone can define a new PRC, like:

frwkSlotRoleComboEntry
    EXTENDS { frwkRoleComboEntry }
    UNIQUENESS { frwkSlotRoleComboSlotNumber,
                         frwkRoleComboCapSetName }
    ::= { frwkSlotRoleComboTable 1 }
FrwkSlotRoleComboEntry ::= SEQUENCE {
    frwkSlotRoleComboSlotNumber Unsigned32
    }

We think this will solve the issues Pedro raised and will also allow the
DiffServ PIB to work correctly without any modification.

Please let us know if you have any comments, as the next version of the
draft will be going into IESG.

Thank you very much!
-- Ravi, Pedro, and Kwok --