Subject: COPS Request State

From: Muralidhar S <[email-masked]>
Date: Thu, 27 Dec 2001 10:57:00 +0530

All,

We are working on a SDK for PDP and PEP development. As part of this, we
have
some questions on the cops request state. As part of the SSQ message from
PDP, PEP
sends "all the Request State" for that particular client handle. Can someone
let me know
what does it means when we say "all the Request State"? Does PEP needs to
send
all the Policy Decisions ( PRID, EPD ) that PDP has installed?

Thanks
murali
______________________
WebSpectrum Software Pvt. Ltd,
Jayanagar, Bangalore - 560082
www.wsspl.com
______________________

---

From: "Kulkarni, Amol" <[email-masked]>
Date: Thu, 27 Dec 2001 17:50:53 -0800

Hi Murali,

The PEP only needs to send requests to the PDP. It shouldn't send the
decisions it received. When the PDP gets the requests, it should send the
appropriate decisions to the PEP.

Amol

-----Original Message-----
From: Muralidhar S [mailto:[email-masked]] 
Sent: Wednesday, December 26, 2001 9:27 PM
To: [email-masked]'
Subject: COPS Request State

All,

Thanks
murali
______________________

---

From: Muralidhar S <[email-masked]>
Date: Fri, 28 Dec 2001 09:58:12 +0530

Hi,

Client Handle anyway will be part of the COPS-PR REQ message. I think as
part of
the Request State, PEP needs to send some more details. Section 2.3.1 from
"draft-ietf-rap-frameworkpib-06.txt" is mentioned below.

"2.3.1 Full Request State 
    
   When the PEP wants to send the entire request state to the PDP (for 
   example, in response to a Synchronize State Request from the PDP), 
   the PEP MUST send the incarnation instance with the 
   frwkPibIncarnationFullState attribute set to TRUE. "

But we are not clear as what "the entire request state" is made of? Will it
contain
updated Role-Combination/Capabilities/Limitations etc?

Regards
murali

> From: ??? [mailto:[email-masked]]
> Sent: 2001. December 28. 5:47
> To: Muralidhar S
> Subject: Re: COPS Request State
> 
> 
> I Think that all the request state means the set of 
> all the client-handle that PEP has. 
> 
> regards,
> 
> ----- Original Message ----- 
> From: "Muralidhar S" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, December 27, 2001 2:27 PM