Subject: RE: [Diffserv] parameters section missing from the Diffserv PIB

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Fri, 13 Sep 2002 19:18:41 +0200

> Kwok Ho Chan wrote:
> 
> > Yacine, Jussi:
> > The Diffserv PIB already IMPORT Dscp and IfDirection from different 
> > modules of
> > the Diffserv MIB.  So I did not think there is any issue to 
> > also reused the definitions
> 
> 
> 
> ok for reuse but here we're talking about OIDs...
> my question is: what is the signification of MIB-specific 
> OIDs within a PIB ?
> 
I suspect that you have NOT yet gone to the diffserv MIB to take
a look as to what those OIDs are representing. Once you do that,
I think it should be pretty clear.

Bert
> In the previous versions of the PIB draft, these were identified by 
> PRIDS, they pointed towards a PRC within the same PIB... how does it 
> work now ?
> 
No, this is incorrect. In earlier versions, they were OBJECT IDENTIFIERS
which basically DUPLICATED what was already in the MIB. And because of
that duplication I (in my role of PIB/MIB reviewer) recommended that the
OIDs from the MIB should be re-used.

Bert
> thanks,
> yacine
> 
> 
> > for dsTBParamType and dsIfSchedulerCapsServiceDisc from the 
> Diffserv MIB as
> > advised during IESG review.
> > 
> > The Diffserv PIB's references to the Diffserv MIB are 
> clearly specified as:
> > 
> >    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
> >        SYNTAX      AutonomousType
> >        STATUS      current
> >        DESCRIPTION
> >          "The scheduling discipline for which the set of 
> capabilities
> >          specified in this object apply. Object identifiers 
> for several
> >          general purpose and well-known scheduling disciplines are
> >          shared with and defined in the Diffserv MIB.
> > 
> >          These include diffServSchedulerPriority,
> >          diffServSchedulerWRR, diffServSchedulerWFQ."
> > 
> > and
> > 
> >    dsTBParamType OBJECT-TYPE
> >        SYNTAX       AutonomousType
> >        STATUS       current
> >        DESCRIPTION
> >          "The Metering algorithm associated with the
> >          Token-Bucket parameters.  zeroDotZero indicates this
> >          is unknown.
> >          Standard values for generic algorithms are as follows:
> >          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
> >          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
> >          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
> >          diffServTBParamTswTCM
> > 
> >          These are specified in the Diffserv MIB."
> > 
> > respectively.
> > 
> > I believe the above text is clear.
> > Please advise if improvement can be made.
> > Thanks!
> > -- Kwok --
> > 
> > 
> > At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
> > 
> >> I was wondering about this point:
> >>
> >> how are the OIDs identified in the MIB senseful within the PIB ?
> >>
> >> my understanding is that the PIB is an AUTONOMOUS named data 
> >> structure... in this context, what is the meaning of an OID 
> >> referencing nothing in the PIB itself ?
> >>
> >> thank you for your explanations,
> >> yacine
> >>
> >>
> >>
> >> Wijnen, Bert (Bert) wrote:
> >>
> >>> I think they are the parameters that have been sepcified and 
> >>> identified in the diffserv MIB (RFC3289)
> >>> Thanks,
> >>> Bert
> >>>
> >>>> -----Original Message-----
> >>>> From: Lemponen Jussi [mailto:[email-masked]]
> >>>> Sent: woensdag 11 september 2002 23:02
> >>>> To: [email-masked]
> >>>> Subject: [Diffserv] parameters section missing from the 
> Diffserv PIB
> >>>>
> >>>>
> >>>>
> >>>>
> >>>> Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
> >>>> the parameters section in the PIB itself is missing. The 
> descriptions
> >>>> for attributes dsTBParamType and 
> dsIfSchedulerCapsServiceDisc do still
> >>>> imply that some parameter definitions should be there.
> >>>>
> >>>>
> >>>> Jussi Lemponen
> >>>> Tampere University of Technology
> >>>> Institute of Communications Engineering
> >>>> _______________________________________________
> >>>> diffserv mailing list
> >>>> [email-masked]
> >>>> https://www1.ietf.org/mailman/listinfo/diffserv
> >>>> Archive: 
http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>>
>>> nt/maillist.html
>>> _______________________________________________
>>> diffserv mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/diffserv
>>> Archive: 
>>> http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html 
>>>
>>>
>>
>>
> 
>

---

From: [email-masked]
Date: Mon, 16 Sep 2002 14:25:51 +0200

please see bellow

> I think it should be pretty clear.

I suspect that you suspect easily... let me know if I cant ask questions
about things I dont understand (be sure I looked for answers before
asking on the list).

** example:
diffServTBParamSimpleTokenBucket OID = mib-2.97.3.1
this OID has a meaning in the MIB tree, but it has not in the PIB tree. 
it seems that it's just a pointer towards the MIB and I was wondering
about the conssistency with the PIB namespace.

thank you Kwok for your explanations
yacine