Subject: Re: [Diffserv] parameters section missing from the Diffserv PIB

From: Yacine El Mghazli <[email-masked]>
Date: Thu, 12 Sep 2002 09:31:46 +0200

I was wondering about this point:

how are the OIDs identified in the MIB senseful within the PIB ?

my understanding is that the PIB is an AUTONOMOUS named data 
structure... in this context, what is the meaning of an OID referencing 
nothing in the PIB itself ?

thank you for your explanations,
yacine

Wijnen, Bert (Bert) wrote:

> I think they are the parameters that have been sepcified and identified 
> in the diffserv MIB (RFC3289)
> 
> Thanks,
> Bert 
> 
> 
>>-----Original Message-----
>>From: Lemponen Jussi [mailto:[email-masked]]
>>Sent: woensdag 11 september 2002 23:02
>>To: [email-masked]
>>Subject: [Diffserv] parameters section missing from the Diffserv PIB
>>
>>
>>
>>
>>Reading through draft-ietf-diffserv-pib-09.txt, I noticed that
>>the parameters section in the PIB itself is missing. The descriptions
>>for attributes dsTBParamType and dsIfSchedulerCapsServiceDisc do still
>>imply that some parameter definitions should be there.
>>
>>
>>Jussi Lemponen
>>Tampere University of Technology
>>Institute of Communications Engineering
>>_______________________________________________
>>diffserv mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/diffserv
>>Archive: 
>>http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>
> nt/maillist.html
> _______________________________________________
> diffserv mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/diffserv
> Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
> 
> 
>

---

From: Kwok Ho Chan <[email-masked]>
Date: Thu, 12 Sep 2002 14:39:10 -0400

Yacine, Jussi:
The Diffserv PIB already IMPORT Dscp and IfDirection from different modules of
the Diffserv MIB.  So I did not think there is any issue to also reused the 
definitions
for dsTBParamType and dsIfSchedulerCapsServiceDisc from the Diffserv MIB as
advised during IESG review.

The Diffserv PIB's references to the Diffserv MIB are clearly specified as:

    dsIfSchedulerCapsServiceDisc OBJECT-TYPE
        SYNTAX      AutonomousType
        STATUS      current
        DESCRIPTION
          "The scheduling discipline for which the set of capabilities
          specified in this object apply. Object identifiers for several
          general purpose and well-known scheduling disciplines are
          shared with and defined in the Diffserv MIB.

          These include diffServSchedulerPriority,
          diffServSchedulerWRR, diffServSchedulerWFQ."

and

    dsTBParamType OBJECT-TYPE
        SYNTAX       AutonomousType
        STATUS       current
        DESCRIPTION
          "The Metering algorithm associated with the
          Token-Bucket parameters.  zeroDotZero indicates this
          is unknown.
          Standard values for generic algorithms are as follows:
          diffServTBParamSimpleTokenBucket, diffServTBParamAvgRate,
          diffServTBParamSrTCMBlind, diffServTBParamSrTCMAware,
          diffServTBParamTrTCMBlind, diffServTBParamTrTCMAware,
          diffServTBParamTswTCM

          These are specified in the Diffserv MIB."

respectively.

I believe the above text is clear.
Please advise if improvement can be made.
Thanks!
-- Kwok --

At 09:31 AM 9/12/02 +0200, Yacine El Mghazli wrote:
>my understanding is that the PIB is an AUTONOMOUS named data structure... 
>in this context, what is the meaning of an OID referencing nothing in the 
>PIB itself ?
>
>>http://www.ietf.org/mail-archive/working-groups/diffserv/current/maillist.html
>>
>
>

---

From: Yacine El Mghazli <[email-masked]>
Date: Fri, 13 Sep 2002 09:54:23 +0200

Kwok Ho Chan wrote:

> the Diffserv MIB.  So I did not think there is any issue to also reused 
> the definitions

ok for reuse but here we're talking about OIDs...
my question is: what is the signification of MIB-specific OIDs within a 
PIB ?

in the previous versions of the PIB draft, these were identified by 
PRIDS, they pointed towards a PRC within the same PIB... how does it 
work now ?

thanks,
yacine

>> structure... in this context, what is the meaning of an OID 
>> referencing nothing in the PIB itself ?
>>
>>> I think they are the parameters that have been sepcified and 
>>> identified in the diffserv MIB (RFC3289)
>>> Thanks,
>>> Bert
>>>
>>>> Archive: http://www.ietf.org/mail-archive/working-groups/diffserv/curre
>>>
>>> nt/maillist.html

---

From: Kwok Ho Chan <[email-masked]>
Date: Fri, 13 Sep 2002 13:18:46 -0400

Yacine:
Please see response embedded below.
Thanks!
-- Kwok --

At 09:54 AM 9/13/02 +0200, Yacine El Mghazli wrote:
>my question is: what is the signification of MIB-specific OIDs within a PIB ?

These "OBJECT-IDENTITY" are just constant values used to represent a 
standardized
parameter (more like a global #define in C).  They are just as if 
the  "OBJECT-IDENTITY"
is defined in a PIB.  We are thinking of new PIBs reusing technology 
dependent definitions
in either existing PIBs or MIBs, whenever possible.
Hope this answered your concerns.

>in the previous versions of the PIB draft, these were identified by PRIDS, 
>they pointed towards a PRC within the same PIB... how does it work now ?

In DSPIB-06, IfSchedulerCapsServiceDisc and TBParamType were of type
"OBJECT IDENTIFIER", referencing objects of type "OBJECT-IDENTITY",
for example qosTBParamSimpleTokenBucket and qosSchedulerPriority.

Now they are of type "AutonomousType" which are TCs with syntax of
"OBJECT IDENTIFIER", as defined in RFC 2579 (SNMPv2-TC).
Referencing objects of type "OBJECT-IDENTITY", for example 
diffServTBParamSimpleTokenBucket and diffServSchedulerPriority.

Hence there is no change from the compiler point of view, and no change
from a usage point of view.  This is not related to PRIDS.