Subject: Re: [Rats] [EAT] BOF Preparation

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Tue, 9 Oct 2018 02:00:43 +0000

Hi Hannes, All,

A number of networking vendors have expressed interest in contributing to and implementing the models on the network devices to provide challenge-response as well as unidirectional attestation.  “draft-birkholz-yang-basic-remote-attestation” shows some of this support.

Also commercial implementations of applications exposing the boot integrity of devices exist.  E.g., see:
https://www.cisco.com/c/dam/en/us/td/docs/cloud-systems-management/application-policy-infrastructure-controller-enterprise-module/1-5-x/integrity_verification/release-notes_ver_275/Cisco_IV_App_RN_1_5_0_275.pdf

A standard data model and any protocol extension(s) for interoperability that fits in the existing network operations will be of key value in exposing proof of network device integrity. At Cisco, we are geared up to progress this work.

Thanks,
Shwetha
From: RATS <[email-masked]> on behalf of Hannes Tschofenig <[email-masked]>
Date: Tuesday, October 9, 2018 at 1:13 AM
To: "Diego R. Lopez" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: 'Benjamin Kaduk' <[email-masked]>
Subject: Re: [Rats] [EAT] BOF Preparation

Thanks, Diego. That’s useful input on the scenarios you are looking into.

From: Diego R. Lopez <[email-masked]>
Sent: Sunday, October 7, 2018 6:53 PM
To: Hannes Tschofenig <[email-masked]>; [email-masked]; [email-masked]
Cc: 'Benjamin Kaduk' <[email-masked]>
Subject: Re: [EAT] BOF Preparation

Hi Hannes,

We are interested in using the base technology (whatever is supported in low level software or operating systems) to support attestation of NFV deployments, especially those related with the collaboration of third parties: with universal EPC, and edge computing as the main use cases. And, while is true we are not developing the base software, we are collaborating with academic teams working at the hypervisor and container platform level.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 06/10/2018, 11:08, "Hannes Tschofenig" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Diego,

I guess Telefonica is a user of the technology*. How would leverage the results?

Ciao
Hannes

*: You are not manufacturing chips, developing operating systems, or writing low level software (like firmware) that integrates the discussed attestation technology. Is that correct?

From: Diego R. Lopez <[email-masked]<mailto:[email-masked]>>
Sent: Saturday, October 6, 2018 12:27 AM
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: 'Benjamin Kaduk' <[email-masked]<mailto:[email-masked]>>
Subject: Re: [EAT] BOF Preparation

Hi,

We are interested in fostering attestation technologies able to support and leverage network virtualization techniques (yes, NFV strikes back…), and are in contact with other companies that share the same interest.

I won’t make it to Bangkok, but will be happy to help in anything I can through remote participation.

Be goode,

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
https://www.linkedin.com/in/dr2lopez/

e-mail: [email-masked]<mailto:[email-masked]>
Tel:         +34 913 129 041
Mobile:  +34 682 051 091
----------------------------------

On 05/10/2018, 14:30, "EAT on behalf of Hannes Tschofenig" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Hi Ben, Hi BOF chairs, Hi all,

I have been thinking about how to turn this BoF into a success. I see a few challenges:

There are different items in scope of the work and we (Arm) are interested in contributing to those that relate to the EAT/attestation token work. We are happy to give a presentation about those but I haven’t seen any agenda for the BoF yet. Who is in charge of preparing an agenda? I have seen BoFs fail where the presentations weren’t well aligned or not clearly demonstrating a real-world problem.

At the BoF we will have to demonstrate that there are companies involved who are actually willing to do the heavy lifting to turn this effort into a success. Since there are very different items listed on the proposed charter text I am curious whether there is reasonable support for all of them. I can only speak for our interest in the EAT items and we are working with companies to state their support on the mailing list. But the BoF is likely going to fail if there is only support for a subset of the items. Where are we with the rest and who is reaching out to which part of the industry?

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Jessica Fitzgerald-McKay <[email-masked]>
Date: Tue, 9 Oct 2018 11:41:34 -0400

All,
Wanted to weigh in while we are still scoping this work. I'd be interested
in seeing RATS address solutions that meet supply chain risk and cyber
hygiene use cases. For example, knowing that the device on the network is
the one you are expecting, knowing what it is running and that it's code
has not been modified, being able to compare an expected posture to the
current posture of the device, and so forth. Being able to answer these
questions in a vendor-neutral way is critical for networks with diverse
infrastructure.

Thanks,
Jess

On Mon, Oct 8, 2018 at 10:00 PM Shwetha Bhandari (shwethab) <
[email-masked]> wrote:

> Hi Hannes, All,
>
>
>
> A number of networking vendors have expressed interest in contributing to
> and implementing the models on the network devices to provide
> challenge-response as well as unidirectional attestation.
> “draft-birkholz-yang-basic-remote-attestation” shows some of this support.
>
>
>
> A standard data model and any protocol extension(s) for interoperability
> that fits in the existing network operations will be of key value in
> exposing proof of network device integrity. At Cisco, we are geared up to
> progress this work.
>
>
>
>
>
> Thanks,
>
> Shwetha
>
> *From: *RATS <[email-masked]> on behalf of Hannes Tschofenig <
> [email-masked]>
> *Date: *Tuesday, October 9, 2018 at 1:13 AM
> *To: *"Diego R. Lopez" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> *Cc: *'Benjamin Kaduk' <[email-masked]>
> *Subject: *Re: [Rats] [EAT] BOF Preparation
>
>
>
> *From:* Diego R. Lopez <[email-masked]>
> *Sent:* Sunday, October 7, 2018 6:53 PM
> *To:* Hannes Tschofenig <[email-masked]>; [email-masked];
> [email-masked]
> *Cc:* 'Benjamin Kaduk' <[email-masked]>
> *Subject:* Re: [EAT] BOF Preparation
>
>
>
> Hi Hannes,
>
>
>
> We are interested in using the base technology (whatever is supported in
> low level software or operating systems) to support attestation of NFV
> deployments, especially those related with the collaboration of third
> parties: with universal EPC, and edge computing as the main use cases. And,
> while is true we are not developing the base software, we are collaborating
> with academic teams working at the hypervisor and container platform level.
>
>
>
> Be goode,
>
>
>
> --
>
> e-mail: [email-masked]
>
> Tel:         +34 913 129 041
>
> Mobile:  +34 682 051 091
>
> On 06/10/2018, 11:08, "Hannes Tschofenig" <[email-masked]>
> wrote:
>
>
>
> Hi Diego,
>
>
>
> *: You are not manufacturing chips, developing operating systems, or
> writing low level software (like firmware) that integrates the discussed
> attestation technology. Is that correct?
>
>
>
> *From:* Diego R. Lopez <[email-masked]>
> *Sent:* Saturday, October 6, 2018 12:27 AM
> *To:* Hannes Tschofenig <[email-masked]>; [email-masked];
> [email-masked]
> *Cc:* 'Benjamin Kaduk' <[email-masked]>
> *Subject:* Re: [EAT] BOF Preparation
>
>
>
> Hi,
>
>
>
> We are interested in fostering attestation technologies able to support
> and leverage network virtualization techniques (yes, NFV strikes back…),
> and are in contact with other companies that share the same interest.
>
>
>
> e-mail: [email-masked]
>
> Tel:         +34 913 129 041
>
> Mobile:  +34 682 051 091
>
> On 05/10/2018, 14:30, "EAT on behalf of Hannes Tschofenig" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>
>
> There are different items in scope of the work and we (Arm) are interested
> in contributing to those that relate to the EAT/attestation token work. We
> are happy to give a presentation about those but I haven’t seen any agenda
> for the BoF yet. Who is in charge of preparing an agenda? I have seen BoFs
> fail where the presentations weren’t well aligned or not clearly
> demonstrating a real-world problem.
>
>
>
> At the BoF we will have to demonstrate that there are companies involved
> who are actually willing to do the heavy lifting to turn this effort into a
> success. Since there are very different items listed on the proposed
> charter text I am curious whether there is reasonable support for all of
> them. I can only speak for our interest in the EAT items and we are working
> with companies to state their support on the mailing list. But the BoF is
> likely going to fail if there is only support for a subset of the items.
> Where are we with the rest and who is reaching out to which part of the
> industry?
>
>
>
> Ciao
>
> Hannes
>
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
>
> ------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
>
>
> ------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud de
> la legislación vigente. Si ha recibido este mensaje por error, le rogamos
> que nos lo comunique inmediatamente por esta misma vía y proceda a su
> destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution or
> copying of this communication is strictly prohibited. If you have received
> this transmission in error, do not read it. Please immediately reply to the
> sender that you have received this communication in error and then delete
> it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo
> da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
> indicado, fica notificado de que a leitura, utilização, divulgação e/ou
> cópia sem autorização pode estar proibida em virtude da legislação vigente.
> Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique
> imediatamente por esta mesma via e proceda a sua destruição
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> _______________________________________________
> EAT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/eat
>