Subject: [Rats] Live: https://github.com/ietf-rats-wg

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Fri, 28 Jun 2019 21:24:02 +0000

RATs participants,

The GitHub https://github.com/ietf-rats-wg is now up and live, I’ve uploaded the Virtual meeting minutes and slides there as well as in
https://datatracker.ietf.org/wg/rats/meetings/

We need to get the EAT draft in GitHub so we can start entering issues, but need the Author’s GitHub accounts to include them as members so they can upload the drafts.  There are good instructions and tools in https://github.com/martinthomson/i-d-template
For draft submissions too.

Best, Nancy

---

From: Giridhar Mandyam <[email-masked]>
Date: Sat, 29 Jun 2019 04:28:09 +0000

Thanks Nancy.

Note that EAT already has a GH repo - https://github.com/eat-ietf-wg/eat.  Can we re-use it?

Also note that the current version of EAT is in Kramdown.  I have been unable to find any way to do an automated preview of PR’s for Kramdown.   For that matter, I have not found any automated preview tools for XML2RFC.  But I have not looked that hard, so maybe others in the group can provide guidance.  Unless this can be resolved, my suggestion is that group participants create issues w.r.t. EAT and we hash out the candidate text on the list.  When a consensus is arrived at, then the editors can create the associated PR and close out the issue.  This however puts the onus on the editors to ensure that the PR will seamlessly flow through to creation of valid txt/XML/PDF’s for upload.

-Giri

From: RATS <[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
Sent: Saturday, June 29, 2019 5:24 AM
To: [email-masked]
Subject: [Rats] Live: https://github.com/ietf-rats-wg

CAUTION: This email originated from outside of the organization.
RATs participants,

Best, Nancy

---

From: Michael Richardson <[email-masked]>
Date: Sat, 29 Jun 2019 13:37:19 -0400

> Note that EAT already has a GH repo -
    > https://github.com/eat-ietf-wg/eat.  Can we re-use it?

yes, just got to the bottom of the Settings and Transfer ownership.

    > Also note that the current version of EAT is in Kramdown.  I have been
    > unable to find any way to do an automated preview of PR’s for Kramdown.

What do you mean?
The pull request is going to be in the source format, it won't get formatted
for you.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 29 Jun 2019 18:14:03 +0000

for you.

That can be fixed by setting up continuous integration (CI) builds which result in formatting done for every PR as I recall.  Using Martin's tooling also helps for PR folks to view the content in their build environment before pushing a PR or an update.
https://github.com/martinthomson/i-d-template for Martin's stuff, now part of the IETF and GitHub working group, which has some useful content and pointers at https://github.com/ietf-gitwg/wg-materials/blob/master/TOOLING.md