Subject: [Raw] minutes of call in Oct 18 and info for continuation tomorrow

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 24 Oct 2019 12:44:42 +0000

Dear RAWers,

We had a call last week to prepare for the WG forming BoF. We continue tomorrow, same time, same place:

Tomorrow:
=========

Connection details
------------------

*    Date: October 25, 2019
*    Time: 8-9AM Pacific, 17:00 CEST:
*    Meeting material https://www.dropbox.com/sh/9rj88hf3r3srg03/AABRXxJAyZfORhLbtlStTtIca?dl=0
*    Online minutes taking: https://etherpad.tools.ietf.org/p/raw

Agenda
------

[17:00] Administrivia                                                                               [~5min]
    o    Note-Well, Scribes, Agenda Bashing

[17:10] Summary of last Week                                                              [10min]
    o    Keypoints discussed

[17:20] Problem Statement                                                                     [20min]
    o    Draft Status
    o    differentiators between RAW and DetNet, MANET, CCAMP.
    o    Define Focus / key points for the BoF presentation

[17:40] Organize the WG-forming BoF in Singapore                       [15min]
    o    Poster ?
    o    Agenda

[18:55] AOB                                                                                                [ QS  ]

Minutes of last week:
=================

Agenda
------

[17:00] Administrivia                                                                               [~5min]
    o    Note-Well, Scribes, Agenda Bashing

[17:10] Review / update the docs in progress                                  [10min]
    o    Which drafts and technologies do we have right now?

[17:20] Organize the WG-forming BoF in Singapore                       [25min]
    o    Which presentations in which order by whom?

[18:40] Review the proposed charter                                                 [15min]

[18:55] AOB                                                                                                [ QS  ]

Blue sheets
-----------

* Dave Cavalvanti
* Ethan Grosman
* Rick Taylor
* Georgios Papadopoulos
* Carlos Bernados
* Shahwaiz Afaqui
* Pascal Thubert
* Diego Dujovne
* Jerome Henry

Minute taker
-------------
* Ethan Grossman

Minutes
-------

[17:00] Administrivia                                                    [~5min]
    o   Note-Well, Scribes, Agenda Bashing

         * Won't have a second chance so make it happen this time.
         Rick Taylor, co-chair. Has wireless experience but not DetNet.
         *Pascal: Last time, Requirements and technologies. Charter.
         This time, project to be solved, have the human resources to solve it.
         technology specific vs more general DetNet-like extension for DetNet.
         Going for the latter.
         Rick: Show why RAW needs its own WG vs DetNet, Manet, CCAMP?  Expect questions on this.
         *

[17:10] Review / update the docs in progress                             [10min]
    o    Which drafts and technologies do we have right now?

         *Missing 5G in draft, no text yet. Need someone to cover that.
         Carlos: Use case draft updated since first BOF.
         Pascal: Don't need to spend much time on them this time.
         Rick: Agree, minimize time at details of use cases and technologies.
         Pascal: Carlos will briefly present context, i.e. use cases, why wireless, why reliable/available. Avoid use of "deterministic".
         Goal is to explain what is unique vs wired, e.g. PREOF, OAM
         PREOF for radios more elaborate than wired.
         Pascal: Not too much Requirements
         Rick: Problem statement the most useful for the BOF.
                  Differentiates the work from other WGs e.g. Manet.
         Georgios to present it.
         This is for radio people, who are generally not present in other WGs.
         Pascal: Please review Problem Statement draft most carefully since that will be focus. Particularly identify anything missing from charter.
          Rick: OAM support draft: Agree to put everything we can think of in there, since this will help the attendees to identify any work that is already in progress in other WGs.
          Pascal: Maybe RAW will define work needed from Manet, CCAMP.
          DLEP also relevant.
          Rick: PANRG Path Aware Networking RG (IRTF). Very broad work, end to end path, how to discover. Discussing def of link, e.g. IPv6 over radio is not obvious. We have requirements to fulfill, perhaps they can help with research side.

[17:20] Organize the WG-forming BoF in Singapore                [25min]
    o    Which presentations in which order by whom?
         *
          Rick: Should have 2 hours for this meeting.
          Pascal: Not too much churn at mic. How much time for each topic?
          Rick: Problem statement is most important - spend time on that.
          Pascal: Goal for next week is to refine problem statement draft.
          Note differentiators between RAW and DetNet, Manet, CCAMP.
          DetNet: mostly different people, i.e. not radio people.
          Jerome will be remote. Dave can't attend due to IEEE coming week.
          Would be great to collocate IEEE and IETF meetings on radio topics.
          Overlap with IEEE? Need to define interface between layer 2 and 3.
          Rick: Question: Unclear whether work items are about single radio tech or maintaining paths across heterogeneous layer 2 domains?
          Pascal: Not single homogeneous network. Routing vs forwarding properties? Multi-hop, layer 3. Tech specifics have to be done at layer, but routing can be more agnostic, push to layer 3.
          Need to make clear in problem statement, key differentiator.
          Will ask Dave to come to mic for 5-10 minutes to discuss IEEE work, discuss what should be done at IETF, e.g. Multi-hop, multiple hetero links.
          Dave: Those would be out of scope for 802.11. Focus on MAC, PHY, but not multi-hop, so differentiates. Dave will write up some notes to share on this.
          Can do multi-hop at layer 2, single hop at layer 3.
          Pascal: Discussing charter a good idea at BOF. Online editing of charter during meeting?
          Rick: Likes that idea. Need to take to mailing list, but if can get room to craft something then can run by list afterwards.

18:40] Review the proposed charter                                    [15min]
         *
          Pascal: Charter is at: https://trac.tools.ietf.org/bof/trac/wiki/RAW
          Pascal: Don't want to remove list of technologies - not limited to those.
          Discuss how much time to spend on other topics next week.
          Rick: Milestones, deliverables?
          Pascal: 3 work items defined in Montreal. Is that all? Don't want to boil ocean.
          Opposite is if there is too little, will look like should be handled in other WGs.
          Pascal: So amount of work is important to establish.
          Need to establish we have enough contributors - starting WG is a contract to deliver the work. Show of hands in room - if too few present isn't good. But if offsite do get counted.
          Rick: Need for this in specific industries is important to show. But need the people who need the work to contribute to it.
          Pascal: In DetNet, some people put in use cases but then didn't participate. Has been hard to get Industrial people to come to IETF, they have vertical standards groups but not horizontal like IETF.
          Rick: Same in DLEP - radio manufacturers sitting by and waiting for a result, not contributing.
          Shahwaiz will attend remotely.
          Missing URLLC text, seeking contributions.
          RAW not about computing paths, but some aspects have short time frames which can't be handled by the remote path computation engine. Per-packet decisions. Save energy and BW by not using all possibilities given to us by path computation. Routing can't come back to us to fix path, so must give us options from which we select. So not routing, it is about forwarding, unusual for IETF, need to make clear. Need to discuss OAM and control, since could be source routed decision, this is new. Similarities with ICAN presented at last IETF, but was Internet not wireless, still "unreliable" so somehow analogous.
          1) Problem statement
          2) Technologies covered - don't want get into specifics of each tech, but it is good to identify which techs we can run IP over.
          3) Standards track doc: OAM, even out of band from dest to source. DLEP can help with this.
          4) Standards track doc: recently added: redundancy: which hops should be used, where to control that from? How to inform each hop. Only do source route in this iteration? Will need to determine how much of this to do in RAW.
          Rick: Point 4 is the most important work for RAW. Others could be done in other WGs. Discuss how to turn this into something achieveable - just investigate, experiment? Don't know, will need to discuss with the group. Need to refine this statment. Define enough work but not too much. Better to re-charter than take on too much.
          Rick: But don't discuss re-charter before we even have our first charter.
          Please check over these Etherpad notes.
          These meetings are not the BOF, focus on preparation for BOF.

[18:55] AOB                                                     [ QS  ]

          Thank you Ethan for taking the minutes. : )

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Thu, 24 Oct 2019 14:49:17 +0200

Hi Pascal, all,

Thanks for organizing this. As I mentioned last week this slot is not very
good to me and I'm not sure I'll be able to make it tomorrow. Last week I
managed to move some other stuff from my calendar, but I'm not yet sure
I'll be able to make it this time.

Apologies in advance. I'll check minutes anyway, and we can sync offline if
I don't manage to connect.

Thanks,

Carlos

On Thu, Oct 24, 2019 at 2:45 PM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *    Meeting material
> https://www.dropbox.com/sh/9rj88hf3r3srg03/AABRXxJAyZfORhLbtlStTtIca?dl=0
>
> [17:00]
> Administrivia
>                 [~5min]
> [18:55]
> AOB
> [ QS  ]
> [18:55] AOB
>                                            [ QS  ]
>          Pascal: Carlos will briefly present context, i.e. use cases, why
> wireless, why reliable/available. Avoid use of "deterministic".
>
>          Pascal: Please review Problem Statement draft most carefully
> since that will be focus. Particularly identify anything missing from
> charter..
>
>           Rick: OAM support draft: Agree to put everything we can think of
> in there, since this will help the attendees to identify any work that is
> already in progress in other WGs.
>
>           Rick: PANRG Path Aware Networking RG (IRTF). Very broad work,
> end to end path, how to discover. Discussing def of link, e.g. IPv6 over
> radio is not obvious. We have requirements to fulfill, perhaps they can
> help with research side.
>
>
>
>
>
>
>
>           Note differentiators between RAW and DetNet, Manet, CCAMP..
>
>           Rick: Question: Unclear whether work items are about single
> radio tech or maintaining paths across heterogeneous layer 2 domains?
>
>           Pascal: Not single homogeneous network. Routing vs forwarding
> properties? Multi-hop, layer 3. Tech specifics have to be done at layer,
> but routing can be more agnostic, push to layer 3.
>
>           Will ask Dave to come to mic for 5-10 minutes to discuss IEEE
> work, discuss what should be done at IETF, e.g. Multi-hop, multiple hetero
> links.
>
>           Dave: Those would be out of scope for 802.11. Focus on MAC, PHY,
> but not multi-hop, so differentiates. Dave will write up some notes to
> share on this.
>
>           Rick: Likes that idea. Need to take to mailing list, but if can
> get room to craft something then can run by list afterwards.
>
>
>
>           Pascal: Charter is at:
> https://trac.tools.ietf.org/bof/trac/wiki/RAW
>
>           Need to establish we have enough contributors - starting WG is a
> contract to deliver the work. Show of hands in room - if too few present
> isn't good. But if offsite do get counted.
>
>           Rick: Need for this in specific industries is important to show.
> But need the people who need the work to contribute to it.
>
>           Pascal: In DetNet, some people put in use cases but then didn't
> participate. Has been hard to get Industrial people to come to IETF, they
> have vertical standards groups but not horizontal like IETF.
>
>           RAW not about computing paths, but some aspects have short time
> frames which can't be handled by the remote path computation engine.
> Per-packet decisions. Save energy and BW by not using all possibilities
> given to us by path computation. Routing can't come back to us to fix path,
> so must give us options from which we select. So not routing, it is about
> forwarding, unusual for IETF, need to make clear. Need to discuss OAM and
> control, since could be source routed decision, this is new. Similarities
> with ICAN presented at last IETF, but was Internet not wireless, still
> "unreliable" so somehow analogous.
>
>           1) Problem statement
>
>           2) Technologies covered - don't want get into specifics of each
> tech, but it is good to identify which techs we can run IP over.
>
>           4) Standards track doc: recently added: redundancy: which hops
> should be used, where to control that from? How to inform each hop. Only do
> source route in this iteration? Will need to determine how much of this to
> do in RAW.
>
>           Rick: Point 4 is the most important work for RAW. Others could
> be done in other WGs. Discuss how to turn this into something achieveable -
> just investigate, experiment? Don't know, will need to discuss with the
> group. Need to refine this statment. Define enough work but not too much.
> Better to re-charter than take on too much.
>
> --
> Raw mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/raw
>

-- 
Special Issue "Beyond 5G Evolution":
https://www.mdpi.com/journal/electronics/special_issues/beyond_5g