Subject: [Raw] WG forming BoF approved

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Oct 2019 09:45:53 +0000

Dear all

All hands on the bridge, the WG forming BoF was approved yesterday!

For memory the BoF request is here: https://trac.tools.ietf.org/bof/trac/wiki, inlined below.

And it points at the draft charter ​https://trac.tools.ietf.org/bof/trac/wiki/RAW<https://trac.tools.ietf.org/bof/trac/wiki/RAW>

We have already one chair named for the BoF, Erik Nordmark from IAB. We need to prepare the agenda and reread the proposed charter.

There was some concern that we are not overlapping with IEEE. It would be good to have a couple of slides describing the relationship, Dave and Xavi, if you can help?

All the best

Pascal

RAW BoF request

Name: Reliable and Available Wireless (RAW)

Description: Due to uncontrolled interferences, including the self-induced multipath fading, deterministic networking is difficult to achieve on wireless links. The radio conditions may change -way- faster than a centralized routing paradigm can adapt and reprogram, in particular when the controller is distant and connectivity is slow and limited. RAW separates the routing time scale at which a complex path is recomputed from the forwarding time scale at which the forwarding decision is taken for an individual packet. RAW operates at the forwarded time scale. The RAW problem is to decide, within the redundant solutions that are proposed by the routing, which will be used for each individual packet to provide a DetNet<https://trac.tools.ietf.org/bof/trac/wiki/DetNet> service while minimizing the waste of resources. A RAW solution would consist of a set of protocols that evaluate the media in real time and another that controls the use of redundancy and diversity attributes that are available along the path.

RAW intersects with protocols or practices in development at the IETF as follows:

  *   MANET defines DLEP that can be leveraged at each hop to derive generic radio metrics (e.g., based on LQI, RSSI, queueing delays and ETX) on individual hops
  *   OAM work at DetNet<https://trac.tools.ietf.org/bof/trac/wiki/DetNet> observes the state of MPLS and IPv6 pseudowires in the direction of the traffic. RAW needs feedback that flows on the reverse path and gathers instantaneous values from the radio receivers at each hop to inform back the source and PREOF relays so they can make optimized forwarding decisions. The work named ICAN may be related
  *   SPRING and BIER define in-band signaling that influences the routing when decided at the head-end on the path. There's already one RAW-related draft at BIER, more may follow.
  *   RAW will need new in-band signaling when the decision is distributed, e.g., required chances of reliable delivery to destination within latency. This signaling enables relays to tune retries and replication to be met.
  *   CCAMP defines protocol-independent metrics and parameters (measurement attributes) for describing links and paths that are required for routing and signaling in technology-specific networks. RAW would be a source of requirements for CCAMP to define metrics that are significant to the focus radios.

Status: WG Forming

  *   Responsible AD: Deborah Brungard
  *   BoF proponents: Pascal Thubert <​[email-masked]<mailto:[email-masked]>>, Ethan Grossman <​[email-masked]<mailto:[email-masked]>>, Corinna Schmitt <​[email-masked]<mailto:[email-masked]>>
  *   BoF chairs: Erik Nordmark,TBD
  *   Number of people expected to attend: 100
  *   Length of session (1, 1.5, 2, or 2.5 hours): 2 hours
  *   Conflicts to avoid (whole Areas and/or WGs): 6TiSCH, DetNet<https://trac.tools.ietf.org/bof/trac/wiki/DetNet>, LPWAN, MANET, SPRING, BIER, CCAMP. As IEEE meets the week before, to allow travel time, do not schedule for Monday.

Agenda

  *   Review techs and problem statement
  *   deep dive into the proposed charter, prioritize and focus
  *   time permitting, describe early proposed solutions

Links to the mailing list, draft charter if any, relevant Internet-Drafts, etc.

  *   Mailing List: ​https://www.ietf.org/mailman/listinfo/raw<https://www.ietf.org/mailman/listinfo/raw>
  *   Draft charter: ​https://trac.tools.ietf.org/bof/trac/wiki/RAW<https://trac.tools.ietf.org/bof/trac/wiki/RAW>
  *   Relevant drafts:
     *   Use Cases: ​https://tools.ietf.org/html/draft-bernardos-raw-use-cases<https://tools.ietf.org/html/draft-bernardos-raw-use-cases>
     *   Focus Technologies: ​https://tools.ietf.org/html/draft-thubert-raw-technologies<https://tools.ietf.org/html/draft-thubert-raw-technologies>
     *   Problem statement: ​https://tools.ietf.org/html/draft-pthubert-raw-problem-statement<https://tools.ietf.org/html/draft-pthubert-raw-problem-statement>
     *   Requirements for distributed: ​https://tools.ietf.org/html/draft-papadopoulos-raw-pareo-reqs<https://tools.ietf.org/html/draft-papadopoulos-raw-pareo-reqs>
     *   OAM features for RAW: ​https://tools.ietf.org/html/draft-theoleyre-raw-oam-support<https://tools.ietf.org/html/draft-theoleyre-raw-oam-support>

---

From: "Cavalcanti, Dave" <[email-masked]>
Date: Thu, 10 Oct 2019 16:16:14 +0000

Hi Pascal,

Congratulations of the forming BoF. I’ll be happy to help on the interface/relationship with IEEE and 802.11 more specifically.

Thanks
Dave

From: Raw [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Thursday, October 10, 2019 2:46 AM
To: [email-masked]
Cc: 'Erik Nordmark ([email-masked])' <[email-masked]>
Subject: [Raw] WG forming BoF approved

Dear all

All the best

Pascal

RAW BoF request

Status: WG Forming

Agenda

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 10 Oct 2019 20:20:24 +0000

That’s perfect Dave,

Any chance you attend the BoF in person ?
This is the critical time where the decision to form the group is made. We’ll need to isolate the specific contributions that the IETF can make and demonstrate how we interact constructively with the IEEE thanks to people like you and Jerome.

Many thanks !

Pascal

Le 10 oct. 2019 à 20:58, Cavalcanti, Dave <[email-masked]> a écrit :

Hi Pascal,

Thanks
Dave

Dear all

All the best

Pascal

RAW BoF request

Status: WG Forming

Agenda

--
Raw mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/raw